Copyright and trademark information

The contents of this Documentation are subject to the Public Documentation License, Version 1.0 (the "License"); you may only use this Documentation if you comply with the terms of this License. A copy of the License is available at: http://www.openoffice.org/licenses/PDL.rtf.

The Original Documentation is “OpenOffice.org User Guide for Version 1.1.x”.

Contributor(s): G. Roderick Singleton.

 Portions created by G. Roderick Singleton are Copyright © 2004. All Rights Reserved.

 All trademarks within this guide belong to legitimate owners.

[Note: a copy of the PDL is included in this template and is also available at: http://www.openoffice.org/licenses/PDL.rtf]

Feedback

Please direct any comments or suggestions about this document to: grsingleton@openoffice.org

Acknowledgments

I wish to recognize the Technical Writers of Sun Microsystems for the fine model they have provided for organizing this document.

I wish to thank David Collier-Brown for contributing time and energy in editing each section as they come available and making the overall flow of this document better.

I wish to thank John McCresh for contributing time and energy in making a printed copy available. All proceeds from sale of printed copies goes to support OpenOffice.org.

Modifications and updates

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>[0.8]</td>
<td>[2004-11-13]</td>
<td>[grs: Eighth edition issued for comment]</td>
</tr>
<tr>
<td>[1.0]</td>
<td>[2004-12-26]</td>
<td>[grs: version 1 released]</td>
</tr>
<tr>
<td>[1.1]</td>
<td>[2005-01-07]</td>
<td>[grs: updated to include a TOC limitation]</td>
</tr>
<tr>
<td>[1.2]</td>
<td>[2005-01-26]</td>
<td>[grs: fix some minor formatting]</td>
</tr>
<tr>
<td>[1.3]</td>
<td>[2005-02-09]</td>
<td>[grs: added conditionals in writer tables to writer chapter]</td>
</tr>
<tr>
<td>[1.4]</td>
<td>[2005-02-09]</td>
<td>[grs: added to troubleshooting chapter]</td>
</tr>
<tr>
<td>[1.5]</td>
<td>[2005-04-11]</td>
<td>[grs: Removed index]</td>
</tr>
</tbody>
</table>
Contents

Copyright and trademark information ...................................................................................... i
Feedback .................................................................................................................................. i
Acknowledgments ................................................................................................................ i
Modifications and updates ..................................................................................................... i
Contents .................................................................................................................................. iii
Overview ................................................................................................................................ 1
Using the Guide ....................................................................................................................... 1
Chapter 1: Using OpenOffice.org Help.................................................................................. 3
OpenOffice.org Step-by-Step Help ......................................................................................... 3
Tips .......................................................................................................................................... 4
Turning tips on and off ........................................................................................................... 4
Extended Tips ............................................................................................................................ 4
Turning extended tips on and off .............................................................................................. 4
Help Agent ............................................................................................................................... 4
Turning the Help Agent on and off ............................................................................................. 5
Chapter 2: Working With OpenOffice.org .......................................................................... 7
The User Interface ................................................................................................................... 7
Starting OpenOffice.org .......................................................................................................... 7
The OpenOffice.org Writer Window ....................................................................................... 8
Toolbars in the OpenOffice.org Window ................................................................................. 8
The Title Bar ............................................................................................................................ 8
The Menu Bar ........................................................................................................................... 9
The Toolbars ............................................................................................................................ 9
Using Floating Toolbars ......................................................................................................... 11
The document window ............................................................................................................. 11
Docking windows ..................................................................................................................... 11
Opening and Saving Documents ............................................................................................. 13
Opening Documents ............................................................................................................... 13
The Templates and Documents dialogue ................................................................................ 14
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Saving Documents</td>
<td>16</td>
</tr>
<tr>
<td>Changing the Work Directory</td>
<td>17</td>
</tr>
<tr>
<td>Saving Documents Automatically</td>
<td>17</td>
</tr>
<tr>
<td>Backup a File Automatically</td>
<td>17</td>
</tr>
<tr>
<td>Saving Files Automatically Every ’n’ Minutes</td>
<td>17</td>
</tr>
<tr>
<td>Properties</td>
<td>18</td>
</tr>
<tr>
<td>OpenOffice.org File Formats</td>
<td>19</td>
</tr>
<tr>
<td>XML file format names</td>
<td>19</td>
</tr>
<tr>
<td>OpenOffice.org XML file structure</td>
<td>20</td>
</tr>
<tr>
<td>Definition of the XML formats</td>
<td>21</td>
</tr>
<tr>
<td>Sending Documents as E-Mail</td>
<td>22</td>
</tr>
<tr>
<td>Printing Documents</td>
<td>23</td>
</tr>
<tr>
<td>Displaying Print Previews</td>
<td>24</td>
</tr>
<tr>
<td>Reduced Printing of Documents</td>
<td>25</td>
</tr>
<tr>
<td>To print two pages beside one another on one sheet of paper</td>
<td>25</td>
</tr>
<tr>
<td>Printing in Black and White</td>
<td>25</td>
</tr>
<tr>
<td>Printing text and graphics in black and white</td>
<td>25</td>
</tr>
<tr>
<td>Printing in black and white in Impress and Draw</td>
<td>25</td>
</tr>
<tr>
<td>Printing only text in black and white</td>
<td>26</td>
</tr>
<tr>
<td>Printing all text documents with black and white text</td>
<td>26</td>
</tr>
<tr>
<td>Printing the current text document with black and white text</td>
<td>26</td>
</tr>
<tr>
<td>Printing Brochures</td>
<td>26</td>
</tr>
<tr>
<td>Spellcheck</td>
<td>27</td>
</tr>
<tr>
<td>Automatic Spellcheck</td>
<td>27</td>
</tr>
<tr>
<td>Checking Multilingual Texts</td>
<td>28</td>
</tr>
<tr>
<td>Starting the Spellcheck</td>
<td>30</td>
</tr>
<tr>
<td>Excluding Text From the Spellcheck</td>
<td>30</td>
</tr>
<tr>
<td>Using Automatic Functions</td>
<td>31</td>
</tr>
<tr>
<td>Using AutoCorrect and AutoFormat</td>
<td>31</td>
</tr>
<tr>
<td>Turning off URL Recognition by AutoCorrect</td>
<td>33</td>
</tr>
<tr>
<td>Undo URL recognition</td>
<td>33</td>
</tr>
</tbody>
</table>
Turn off URL recognition .................................................................................................................. 33
Other AutoCorrect functions ............................................................................................................. 33
Creating a Letter Template With the AutoPilot .................................................................................. 35
Find & Replace .................................................................................................................................. 36
Finding a Word in Text ....................................................................................................................... 36
Searching for Whole Words Only ...................................................................................................... 37
  Match Case ....................................................................................................................................... 37
Searching for Text With Wildcards ...................................................................................................... 37
Searching Backward ............................................................................................................................. 38
Current Selection Only ....................................................................................................................... 38
Searching for Styles ............................................................................................................................. 38
Searching for Attributes ...................................................................................................................... 38
Searching for Special Formats ........................................................................................................... 39
Similarity Search ................................................................................................................................. 39
List of Regular Expressions ................................................................................................................. 39

Chapter 3: Managing Text Documents With Writer ........................................................................ 41
The OpenOffice.org Writer Functions ............................................................................................... 41
  Writing ............................................................................................................................................... 41
  Designing and Structuring .................................................................................................................. 41
Desktop Publishing with OpenOffice.org Writer .............................................................................. 42
Calculations .......................................................................................................................................... 42
  Creating Drawings .............................................................................................................................. 42
  Inserting Graphics .............................................................................................................................. 42
Customizable Program Interface ......................................................................................................... 42
  Drag&Drop .......................................................................................................................................... 42
Extensive Help Functions .................................................................................................................... 42
The OpenOffice.org Writer Window .................................................................................................... 43
  Windows® of OpenOffice.org Writer ............................................................................................... 43
Entering and Formatting Text .............................................................................................................. 44
  Entering New Text .............................................................................................................................. 44
  To enter new text: ............................................................................................................................... 44
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line breaks</td>
<td>44</td>
</tr>
<tr>
<td>Automatic correction</td>
<td>44</td>
</tr>
<tr>
<td>Word completion</td>
<td>44</td>
</tr>
<tr>
<td>Inserting Text</td>
<td>44</td>
</tr>
<tr>
<td>Switching Between Insert Mode and Overwrite Mode</td>
<td>45</td>
</tr>
<tr>
<td>Using the keyboard</td>
<td>45</td>
</tr>
<tr>
<td>Using the mouse</td>
<td>45</td>
</tr>
<tr>
<td>Entering Text Anywhere on a Page</td>
<td>45</td>
</tr>
<tr>
<td>Selecting and Deleting Text</td>
<td>46</td>
</tr>
<tr>
<td>Deleting characters</td>
<td>46</td>
</tr>
<tr>
<td>Deleting text</td>
<td>46</td>
</tr>
<tr>
<td>Selecting text to delete with the mouse</td>
<td>46</td>
</tr>
<tr>
<td>Selecting text to delete with the keyboard</td>
<td>46</td>
</tr>
<tr>
<td>Deleting non-adjacent pieces of text</td>
<td>46</td>
</tr>
<tr>
<td>Setting the Viewing Zoom Factor</td>
<td>47</td>
</tr>
<tr>
<td>Keyboard Navigating and Selection in Writer</td>
<td>47</td>
</tr>
<tr>
<td>Inserting Special Characters</td>
<td>47</td>
</tr>
<tr>
<td>Inserting Protected Spaces, Hyphens and Conditional Separators</td>
<td>48</td>
</tr>
<tr>
<td>Non-breaking spaces</td>
<td>48</td>
</tr>
<tr>
<td>Non-breaking hyphen</td>
<td>48</td>
</tr>
<tr>
<td>Hyphen, em-dash and en-dash</td>
<td>48</td>
</tr>
<tr>
<td>Manual Hyphenation</td>
<td>48</td>
</tr>
<tr>
<td>Emphasizing Text</td>
<td>49</td>
</tr>
<tr>
<td>Changing the colour of Text</td>
<td>49</td>
</tr>
<tr>
<td>Rotating Text</td>
<td>49</td>
</tr>
<tr>
<td>Defining Borders</td>
<td>50</td>
</tr>
<tr>
<td>Choose Format from the menu bar, Borders tab page</td>
<td>50</td>
</tr>
<tr>
<td>Use the Borders floating toolbar with Tables</td>
<td>52</td>
</tr>
<tr>
<td>Superscripts and Subscripts</td>
<td>54</td>
</tr>
<tr>
<td>Making text superscript/subscript while typing</td>
<td>54</td>
</tr>
<tr>
<td>Applying subscripts/superscripts retrospectively</td>
<td>55</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Templates and Styles</td>
<td>77</td>
</tr>
<tr>
<td>Creating New Styles From Selection</td>
<td>78</td>
</tr>
<tr>
<td>New Style from Selection</td>
<td>78</td>
</tr>
<tr>
<td>Transferring Formats With Fill Format Mode</td>
<td>79</td>
</tr>
<tr>
<td>Updating Styles From Selection</td>
<td>79</td>
</tr>
<tr>
<td>This is how to update a Style:</td>
<td>79</td>
</tr>
<tr>
<td>Style can also be updated by using drag and drop:</td>
<td>79</td>
</tr>
<tr>
<td>Copying Styles into Documents</td>
<td>79</td>
</tr>
<tr>
<td>Entering and Formatting Text Automatically</td>
<td>81</td>
</tr>
<tr>
<td>Disabling the AutoCorrect Function</td>
<td>81</td>
</tr>
<tr>
<td>ASCII Quotation marks are replaced with Custom Quotes</td>
<td>81</td>
</tr>
<tr>
<td>Sentences always begin with a capital letter</td>
<td>81</td>
</tr>
<tr>
<td>Three identical characters will become a whole line</td>
<td>81</td>
</tr>
<tr>
<td>Automatic Spellcheck</td>
<td>81</td>
</tr>
<tr>
<td>To exclude words from the spellcheck</td>
<td>82</td>
</tr>
<tr>
<td>Using AutoText</td>
<td>83</td>
</tr>
<tr>
<td>Defining AutoText</td>
<td>84</td>
</tr>
<tr>
<td>Using AutoText in Networks</td>
<td>85</td>
</tr>
<tr>
<td>Printing AutoText</td>
<td>85</td>
</tr>
<tr>
<td>AutoText With AutoComplete</td>
<td>86</td>
</tr>
<tr>
<td>Exceptions in AutoCorrect</td>
<td>86</td>
</tr>
<tr>
<td>Example</td>
<td>86</td>
</tr>
<tr>
<td>Moving Text, Drawing Lines</td>
<td>87</td>
</tr>
<tr>
<td>Inserting, Editing and Linking Text Frames</td>
<td>87</td>
</tr>
<tr>
<td>Inserting Text Frames</td>
<td>87</td>
</tr>
<tr>
<td>Editing Text Frames</td>
<td>88</td>
</tr>
<tr>
<td>Linking Text Frames</td>
<td>88</td>
</tr>
<tr>
<td>Using Text Animation</td>
<td>90</td>
</tr>
<tr>
<td>Drawing Lines in Text</td>
<td>93</td>
</tr>
<tr>
<td>Editing Text With FontWork</td>
<td>94</td>
</tr>
<tr>
<td>Aligning Text With Lines</td>
<td>96</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Aligning text on a free form line</td>
<td>96</td>
</tr>
<tr>
<td>Aligning text with straight lines</td>
<td>96</td>
</tr>
<tr>
<td>The Navigator</td>
<td>97</td>
</tr>
<tr>
<td>Jumping From One Object to Another in Text</td>
<td>97</td>
</tr>
<tr>
<td>Jumping From One Reminder to Another</td>
<td>98</td>
</tr>
<tr>
<td>Jumping to a Specific Page</td>
<td>98</td>
</tr>
<tr>
<td>Other Navigator Features</td>
<td>99</td>
</tr>
<tr>
<td>Indexes and Tables of Contents in Writer</td>
<td>100</td>
</tr>
<tr>
<td>Defining Index/Table of Contents Entries</td>
<td>100</td>
</tr>
<tr>
<td>Editing or Deleting Index and Table Entries</td>
<td>101</td>
</tr>
<tr>
<td>Creating a Table of Contents</td>
<td>101</td>
</tr>
<tr>
<td>Creating Alphabetical Indexes</td>
<td>102</td>
</tr>
<tr>
<td>Using a Concordance File</td>
<td>103</td>
</tr>
<tr>
<td>Creating User-Defined Indexes</td>
<td>103</td>
</tr>
<tr>
<td>Creating Bibliographies</td>
<td>104</td>
</tr>
<tr>
<td>Updating, Editing and Deleting Indexes and Tables of Contents</td>
<td>105</td>
</tr>
<tr>
<td>Editing the Format of an Index/Table of Contents</td>
<td>106</td>
</tr>
<tr>
<td>Indexes Covering Multiple Documents</td>
<td>106</td>
</tr>
<tr>
<td>Headings and Numbering</td>
<td>107</td>
</tr>
<tr>
<td>Numbering and Numbering Styles</td>
<td>107</td>
</tr>
<tr>
<td>Turning Bullets On and Off</td>
<td>107</td>
</tr>
<tr>
<td>Turning Numbering On and Off</td>
<td>108</td>
</tr>
<tr>
<td>Example numbered list with sublevels</td>
<td>109</td>
</tr>
<tr>
<td>Outline Numbering</td>
<td>109</td>
</tr>
<tr>
<td>Automatic Numbering/Bullets</td>
<td>110</td>
</tr>
<tr>
<td>Numbering Illustrations by Chapters</td>
<td>111</td>
</tr>
<tr>
<td>Defining Number Ranges</td>
<td>111</td>
</tr>
<tr>
<td>Using Master Documents and Subdocuments</td>
<td>113</td>
</tr>
<tr>
<td>Importing Lists From Other Text Programs</td>
<td>116</td>
</tr>
<tr>
<td>Changing Numbering via the Keyboard</td>
<td>116</td>
</tr>
<tr>
<td>Interrupting and Continuing Numbering</td>
<td>117</td>
</tr>
</tbody>
</table>
Delete the automatic numbering .......................................................... 117
Formatting the paragraph .................................................................. 117
Continuing numbering with a new starting value ............................... 117
Numbering Lines .............................................................................. 118
Line Numbering for All Paragraphs ...................................................... 118
Line Numbering for Particular Paragraphs .......................................... 118
Tables in Text .................................................................................... 119
Inserting Tables ................................................................................ 119
Inserting an empty table using the mouse: ........................................... 119
Inserting an empty table via the Insert menu or floating toolbar : ........ 119
Inserting from OpenOffice.org Calc with the clipboard ...................... 119
Inserting from OpenOffice.org Calc using drag-and-drop .................. 120
Deleting Tables .................................................................................. 120
Inserting Paragraphs Before Tables at Start of Page ......................... 121
Formatting Tables in Text Documents ................................................ 121
Calculating in Text Documents .......................................................... 123
Formulas in Text Documents .............................................................. 123
Formula Options ................................................................................ 123
Basic Calculation Functions ................................................................ 123
Basic Functions in the Submenu ........................................................ 123
Operators .......................................................................................... 124
Statistical Functions ......................................................................... 124
Trigonometric Functions ..................................................................... 125
More Defined Values ......................................................................... 125
Calculating in Text ............................................................................. 125
Calculating With Formulas Located in Text ......................................... 126
Conditional Text ............................................................................... 127
An Example of Defining and using conditional .................................... 127
Defining a conditional variable: .......................................................... 127
Defining a condition and the conditional text: ...................................... 128
Displaying the conditional text: ........................................................... 129
Contents

Calculating in Text Document Tables ................................................................. 130
To display the conditional text: ................................................................. 131
Calculating in Text Document Tables ................................................................. 132
Calculating Across Multiple Tables ............................................................... 133
Calculating Cell Totals in Tables ...................................................................... 133
Merging and Splitting Cells ............................................................................... 134
  Merging Cells in OpenOffice.org Writer ......................................................... 134
  Splitting Cells in OpenOffice.org Writer ........................................................ 134
  Merging Cells in OpenOffice.org Calc .......................................................... 134
  Canceling the merging of cells in OpenOffice.org Calc ................................ 134
Inserting or Deleting Rows/Columns Using the Keyboard .................................. 134
Repeating Several Heading Rows in Tables ...................................................... 135
Enlarging and Reducing Cells in Text Tables .................................................... 135
Adapting Table Widths ...................................................................................... 136
Copying Calc Sheet Areas to Text Documents ................................................ 136
Images, Drawings, Clipart and FontWork .......................................................... 138
Positioning Objects .......................................................................................... 138
Captions and Number Ranges ........................................................................... 139
  Defining Captions ......................................................................................... 139
  Editing or deleting captions ........................................................................... 139
  Inserting an object in a number range ............................................................ 139
Numbering Illustrations by Chapters ................................................................. 140
Inserting Graphics ............................................................................................ 140
  Inserting Graphics via dialogue ..................................................................... 140
  Inserting Graphics From OpenOffice.org Draw or Impress .......................... 141
  Inserting Graphics via Drag and Drop From the Gallery .............................. 141
  Inserting Graphics With a Scanner ............................................................... 141
Inserting a Chart From OpenOffice.org Calc .................................................... 142
  Dragging and Dropping a Copy of the Chart ................................................. 142
  Charts with Linked Data ................................................................................ 142
  Inserting Decorative Horizontal Lines ......................................................... 143

OpenOffice.org User Guide
## Contents

Headers, Footers and Footnotes ................................................................................. 144

Some Notes Concerning Headers and Footers ......................................................... 145

Inserting Page Numbers in Footers ......................................................................... 145

Inserting Chapter Information in Headers ............................................................... 145

Defining Different Headers ....................................................................................... 147

Inserting Page Numbers of Continuation Pages ...................................................... 147

Inserting Lines Under Headers ................................................................................ 148

Footnotes and Endnotes .......................................................................................... 149

Inserting and Editing Footnotes .............................................................................. 149

  Inserting a footnote via an icon ............................................................................. 150

  Inserting a footnote via a dialogue ...................................................................... 150

  Tips for Working with Footnotes ...................................................................... 150

Spacing Between Footnotes ..................................................................................... 150

Spellcheck, Dictionaries, Hyphenation ................................................................. 152

  Controlling the Spellcheck via dialogue .............................................................. 152

  Automatic Spellcheck ......................................................................................... 153

    To exclude words from the spellcheck .............................................................. 153

  Removing Words From User-Defined Dictionaries ........................................... 153

Hyphenation ............................................................................................................. 153

  Automatic hyphenation ....................................................................................... 154

  Manual Hyphenation ......................................................................................... 154

Thesaurus .................................................................................................................. 155

Form Letters, Business Cards and Labels ................................................................. 157

Creating Form Letters .......................................................................................... 157

  Brief Instructions (For Quick Results) ................................................................. 157

  Fixed and Variable Fields ................................................................................... 157

Creating and Printing Labels and Business Cards .................................................... 159

  Designing Business Cards via dialogue .............................................................. 159

  Designing Labels and Business Cards ............................................................... 160

  Printing Labels With Serial Numbers .............................................................. 160

  Printing Address Labels .................................................................................... 161
Contents

Examining and Extrapolating Data ......................................................................................... 179
What-If Calculations .............................................................................................................. 179
Importing and Exporting Data ............................................................................................... 180
   Importing into Calc ........................................................................................................... 180
   Exporting from Calc .......................................................................................................... 181
Referencing Data in Networks and the Internet .................................................................... 181
The Calc Window .................................................................................................................. 182
Structure of a Spreadsheet ..................................................................................................... 182
Rows and Columns ................................................................................................................ 183
Multiple Sheets in a Document .............................................................................................. 184
   Inserting Sheets ............................................................................................................... 184
   Renaming Sheets ............................................................................................................. 184
Values and Formulas as Cell Contents .................................................................................. 185
   Calculating in Spreadsheets ............................................................................................ 185
   Using Built-in Functions .................................................................................................. 187
   A Short Description of What Cells Can Contain .............................................................. 188
Text ......................................................................................................................................... 188
Numbers ................................................................................................................................. 190
Calculating With Formulas .................................................................................................... 193
Calculating With Dates and Times ......................................................................................... 194
Inserting and Editing Notes ................................................................................................. 195
Handling Multiple Sheets ..................................................................................................... 196
   Displaying Multiple Sheets .............................................................................................. 196
   Working With Multiple Sheets ......................................................................................... 196
   Printing Spreadsheets ....................................................................................................... 197
Formatting a Spreadsheet ..................................................................................................... 198
Formatting Numbers ............................................................................................................. 198
   Dates ................................................................................................................................. 198
Formatting Cells and Sheets ................................................................................................. 199
Using AutoFormat for Tables ............................................................................................... 199
Layout of Spreadsheets ........................................................................................................ 200
Designing Spreadsheets Clearly........................................................................................................200
Formatting Text in a Spreadsheet........................................................................................................201
Formatting Numbers in a Spreadsheet................................................................................................201
Formatting Borders and Backgrounds for Cells and Pages..............................................................201
Addressing Cells..................................................................................................................................202
Addresses and References, Absolute and Relative..............................................................................202
  Relative Addressing..........................................................................................................................202
  Absolute Addressing........................................................................................................................202
  When to Use Relative and Absolute References.........................................................................202
Addressing by Name............................................................................................................................204
Recognizing Names as Addressing......................................................................................................204
Only Copy Visible Cells.........................................................................................................................205
Referencing a Cell in Another Document..........................................................................................206
Using References in Formulas...............................................................................................................207
  References to Other Sheets..............................................................................................................208
Using Charts........................................................................................................................................210
  Editing Chart Titles..........................................................................................................................213
  Editing Chart Legends......................................................................................................................213
  Adding Texture to Chart Bars..........................................................................................................214
  Editing Chart Axis............................................................................................................................214
Database Functions in Calc..................................................................................................................215
  Defining Database Ranges...............................................................................................................215
  Creating Records in a Spreadsheet.................................................................................................215
  Defining Database Ranges...............................................................................................................217
  Sorting Database Ranges..................................................................................................................217
  Filtering Database Ranges.................................................................................................................218
  Grouping Database Ranges and Calculating Subtotals.................................................................220
Transferring Data From a Data Source to a Spreadsheet..................................................................221
  Opening a Database File in Calc...................................................................................................221
  Dragging and Dropping Copies into Spreadsheets......................................................................222
Evaluating Data With Calc.....................................................................................................................224
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>DataPilot.......................................................................................................................... 224</td>
</tr>
<tr>
<td>What use is the DataPilot?................................................................................................. 225</td>
</tr>
<tr>
<td>Creating DataPilot Tables.............................................................................................. 225</td>
</tr>
<tr>
<td>Selecting DataPilot Output Ranges................................................................................... 227</td>
</tr>
<tr>
<td>Editing DataPilot Tables.................................................................................................... 227</td>
</tr>
<tr>
<td>Filtering DataPilot Tables................................................................................................ 227</td>
</tr>
<tr>
<td>Updating DataPilot Tables............................................................................................... 227</td>
</tr>
<tr>
<td>Deleting DataPilot Tables.................................................................................................. 227</td>
</tr>
<tr>
<td>Consolidating Data............................................................................................................ 228</td>
</tr>
<tr>
<td>Applying Goal Seek........................................................................................................... 230</td>
</tr>
<tr>
<td>Naming Cells...................................................................................................................... 230</td>
</tr>
<tr>
<td>Start Goal Seek................................................................................................................ 231</td>
</tr>
<tr>
<td>Applying Multiple Operations.......................................................................................... 231</td>
</tr>
<tr>
<td>Multiple Operations in Columns or Rows........................................................................ 231</td>
</tr>
<tr>
<td>Examples.............................................................................................................................. 231</td>
</tr>
<tr>
<td>Calculating With One Formula and One Variable.......................................................... 232</td>
</tr>
<tr>
<td>Calculating with Several Formulas Simultaneously....................................................... 232</td>
</tr>
<tr>
<td>Multiple Operations Across Rows and Columns............................................................. 232</td>
</tr>
<tr>
<td>Calculating with Two Variables....................................................................................... 233</td>
</tr>
<tr>
<td>Using Scenarios................................................................................................................ 234</td>
</tr>
<tr>
<td>Using Ready-Made Scenarios............................................................................................ 234</td>
</tr>
<tr>
<td>Creating Personal Scenarios............................................................................................ 234</td>
</tr>
<tr>
<td>Validity of Cell Contents.................................................................................................. 236</td>
</tr>
<tr>
<td>Using Cell Contents Validity............................................................................................. 236</td>
</tr>
<tr>
<td>Sample macro:.................................................................................................................... 238</td>
</tr>
<tr>
<td>Printing or Exporting Spreadsheets.................................................................................. 239</td>
</tr>
<tr>
<td>Printing Sheet Details....................................................................................................... 239</td>
</tr>
<tr>
<td>Defining Number of Pages for Printing........................................................................... 239</td>
</tr>
<tr>
<td>Printing Sheets in Landscape Format............................................................................... 240</td>
</tr>
<tr>
<td>Printing Rows or Columns on Every Page....................................................................... 240</td>
</tr>
<tr>
<td>Saving and Opening Sheets in HTML............................................................................... 242</td>
</tr>
<tr>
<td>Topic</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Defining Background colours</td>
</tr>
<tr>
<td>Switching Page Styles</td>
</tr>
<tr>
<td>Presentation Styles</td>
</tr>
<tr>
<td>Using Outline View</td>
</tr>
<tr>
<td>Slide Transitions, Effects and Animation</td>
</tr>
<tr>
<td>Automatic Slide Transition</td>
</tr>
<tr>
<td>Effects for Objects</td>
</tr>
<tr>
<td>Selecting Hidden Objects</td>
</tr>
<tr>
<td>Individual Presentations</td>
</tr>
<tr>
<td>Exporting, Printing and Presenting</td>
</tr>
<tr>
<td>Printing a Presentation Slide</td>
</tr>
<tr>
<td>Exporting Presentations as Web Pages</td>
</tr>
<tr>
<td>Exchanging Data via the Clipboard</td>
</tr>
<tr>
<td>Creating a Business Report</td>
</tr>
<tr>
<td>Creating a Business Report in Presentation Form</td>
</tr>
<tr>
<td>Entering Text in the Outline View</td>
</tr>
<tr>
<td>Changing the Slide Layout</td>
</tr>
<tr>
<td>Designing Slides</td>
</tr>
<tr>
<td>Creating a Slide Show</td>
</tr>
<tr>
<td>Defining or Changing Slide Order</td>
</tr>
<tr>
<td>Creating Cross-Fade Effects</td>
</tr>
<tr>
<td>Starting Presentations</td>
</tr>
<tr>
<td>Working with Connectors</td>
</tr>
<tr>
<td>&quot;Edge to Edge” Connectors</td>
</tr>
<tr>
<td>&quot;Middle to Middle” Connectors</td>
</tr>
<tr>
<td>Editing Connectors</td>
</tr>
<tr>
<td>Using a Snap Grid</td>
</tr>
<tr>
<td>Editing Glue Points</td>
</tr>
<tr>
<td>Hints and Tips for a Successful Presentation</td>
</tr>
<tr>
<td>Using the Mouse as a Pointer</td>
</tr>
<tr>
<td>Changing Bullet Symbols in Outline View</td>
</tr>
</tbody>
</table>
Inserting, Deleting and Renaming Slides ................................................................. 281
Creating and Printing Handouts ......................................................................... 282
Organizing and Printing Notes ........................................................................... 282
Using the Navigator ............................................................................................... 283
Edit Jump Targets ................................................................................................ 283
Modifying Object Size .......................................................................................... 283
Creating Additional Objects .................................................................................. 283
Changing Font and Font Size ................................................................................ 283
Modifying colours .................................................................................................. 283
Chapter 6: Creating Drawings with Draw ............................................................ 285
OpenOffice.org Draw Functions ............................................................................ 285
Creating and Publishing Vector Graphics ............................................................ 285
Creating 3D Objects .............................................................................................. 285
Manage Organization Charts ................................................................................ 285
Drawing .................................................................................................................. 285
Export ..................................................................................................................... 286
Construct ............................................................................................................... 286
Integrate ................................................................................................................. 286
The OpenOffice.org Draw Window ......................................................................... 287
Toolbars and Windows® in OpenOffice.org Draw .............................................. 287
Drawing Rectangles and Ellipses and Entering Text ............................................ 288
Rotating and Resizing Objects .............................................................................. 290
Arranging and Aligning Objects ........................................................................... 291
Arranging Objects ............................................................................................... 291
Aligning Objects .................................................................................................. 291
Drawing Sectors and Segments .......................................................................... 292
Entering Text ......................................................................................................... 293
Normal Text .......................................................................................................... 293
Fitting Text to Frames .......................................................................................... 293
Callouts .................................................................................................................. 294
Converting Text Into 3D ...................................................................................... 294
Contents

Drawing, Editing and Converting ................................................................. 295
  Curves and Objects .............................................................................. 295
    Drawing Curves ................................................................................. 295
  Editing Curves ...................................................................................... 296
  Vectorizing Bitmaps ............................................................................ 297
  Converting Text Characters to Curves .................................................. 298
  Converting to Curves, Polygons, 3D ..................................................... 299
Working With Objects ............................................................................ 302
  Duplicating Objects ............................................................................ 302
  Cross-Fading Between Two Objects ................................................... 303
    Grouping Objects ............................................................................. 304
    Entering Groups ............................................................................... 304
    Exiting Groups ................................................................................ 304
    Navigating Between Objects of a Group .......................................... 305
Combining Objects and Constructing Shapes ......................................... 306
  Combining Objects ............................................................................ 306
  Constructing Shapes .......................................................................... 306
    Shapes - Merge ............................................................................... 307
    Shapes - Subtract ........................................................................... 307
Graphic Objects in Drawings and Presentations .................................... 308
  Inserting Bitmaps ............................................................................. 308
  Editing Bitmaps ................................................................................ 308
    Applying Text to Bitmaps ................................................................. 308
  Saving Bitmaps .................................................................................. 309
Working With colours ............................................................................ 311
  The colour Bar .................................................................................. 311
  Defining Custom colours .................................................................. 312
  Replacing colours using the Eyedropper ......................................... 314
Gradients and Patterns for Objects and Background ................................ 316
  Defining Gradients ........................................................................... 316
  Defining a custom colour Gradient .................................................. 316
# Contents

- Interactively Defining a colour Gradient ................................................................. 317
- Organizing the Attribute Tables ................................................................................. 318
- 3D Globe ..................................................................................................................... 319
- Creating Texture on a 3D Object ................................................................................ 319
- Using Illumination ....................................................................................................... 321
- More 3d Effects ............................................................................................................ 321
  - 3D Effects: Favorites ................................................................................................. 321
  - 3D Effects: Geometry .............................................................................................. 322
  - 3D Effects: Shading .................................................................................................. 322
  - 3D Effects: Illumination ......................................................................................... 323
  - 3D Effects: Textures and Material ........................................................................... 323
- Designing 3D Objects From Font Characters ............................................................ 324
  - First Step: ................................................................................................................ 324
  - Second Step: ............................................................................................................ 325
  - Third Step: ............................................................................................................... 326
  - Fourth Step: ............................................................................................................. 328
  - Fifth Step: ................................................................................................................ 329
- Using a Grid ................................................................................................................ 331
- Mechanical or Construction Drawings ......................................................................... 332
  - Creating a Construction Plan .................................................................................. 333
    - Using Snap Lines ................................................................................................ 337
    - Using Dimension Lines ....................................................................................... 337
  - Working With Multiple Layers ............................................................................... 338
    - Using One colour per Layer ................................................................................. 338
- Chapter 7: Databases and Data Sources ..................................................................... 340
  - Registering a Data Source ....................................................................................... 340
    - AddressBooks ...................................................................................................... 342
      - Registering an AddressBook .............................................................................. 342
      - Using the AutoPilot to import an AddressBook .................................................. 342
      - Manually Registering an Existing Address Book ............................................... 342
      - System Address Book as Data Source ............................................................... 344
Contents

Inserting an object as a link ................................................................. 365
Inserting an object as a background graphic ......................................... 365
Inserting an object as a texture (pattern) for another object ...................... 365
Copying Graphics From the Gallery ................................................... 365
Inserting Graphics From a Document in the Gallery ............................. 365
Copying Graphics Between Documents ............................................. 366
Copying Draw Objects into Other Documents ..................................... 366
Inserting a Draw object in a text document ...................................... 367
Inserting a Draw object in a spreadsheet ........................................ 367
Drag and Drop With the Data Source View ......................................... 368
Using data in a text document ......................................................... 368
Applying data to a table document .................................................. 368
Inserting controls in a text form ....................................................... 368
Copying Sheet Areas to Text Documents ............................................ 369
Inserting Data From Spreadsheets .................................................... 369
Inserting Data From Text Documents .............................................. 369
Copying Text Using Drag and Drop .................................................. 370
Revision Marking Function ................................................................ 371
Recording and Displaying Changes ................................................... 371
Accepting or Rejecting Changes ....................................................... 372
Comparing Versions of a Document .................................................. 373
Merging Versions ............................................................................. 373
Recording Changes .......................................................................... 373
Version Management ......................................................................... 374
Protecting Contents in OpenOffice.org .............................................. 375
Protecting All Documents When Saving ............................................. 375
Turning on protection ....................................................................... 375
Turning off protection ..................................................................... 375
Protecting Revision Marking ............................................................ 375
Turning on revision protection ........................................................ 375
Turning off revision protection ....................................................... 375
Contents

Layout .................................................................................................................................398
Alignment ...........................................................................................................................399
Examples ...............................................................................................................................400
Chapter 12: Troubleshooting Common Problems ..........................................................402

Error Message contains “Get Storage: "No Content"” .........................................................402
Under Windows® ................................................................................................................402
  Multi-user installations: ....................................................................................................402
  Single-user installations: ..................................................................................................402
UNIX systems ...................................................................................................................403
Outline numbering is not retained after a save: .................................................................403
How get the page count to not count a title page? (How do I offset the page count?) ......404
What to do when your document prints or exports to pdf with blank pages after a page break… 404

Public Documentation License, Version 1.0 ....................................................................406
Overview

This, the OpenOffice.org User's Guide, attempts to provide answers to questions about working with OpenOffice.org. It is focused on OpenOffice.org 1.1.x releases but, it should be useful with 1.9 and 2.0 releases. Differences between 1.1.x and these later releases are boxed.

In addition, use of the OpenOffice.org Help facility is also covered. Through Help, users can get detailed answers to all questions at any time by pressing (F1), opening the Help menu or clicking the Help buttons. More information on using OpenOffice.org Help can be found in Chapter 1, Working with OpenOffice.org.

Other sources of support are available through the users@openoffice.org mailing list, OOforum via the Internet, the OpenOffice.org support newsgroups provided by gmoe.org and the latest news about OpenOffice.org at www.openoffice.org.

Using the Guide

This User's Guide is designed for users who are already familiar with the basic functions of their computer. Where there are differences in certain functions between supported operating systems, these differences are explained. If functions described here are not available on a particular platform, this is a system-related limitation caused by the platform in use.
Chapter 1: Using OpenOffice.org Help

Different kinds of help are available in OpenOffice.org.

- Step-by-step instructions with full references via the Contents and Index selections of OpenOffice.org Help
- Help Tips that pop up next to the mouse pointer
- Extended tips with more detailed explanations than provided with Tips

OpenOffice.org Step-by-Step Help

To access Help, use the Help menu item or click the Help buttons in the individual dialogues.
OpenOffice.org Help is context-sensitive. This means that, when Help is opened in Writer it is specific to Writer. Similarly, to get help about Calc, either first open a spreadsheet and only then look for help, or select Help for the specific module from the pull-down list at the top of the Help window. The pull-down list at the top of the Help window sets the selected module as the current section for searching.

**Tips**

**Tips** are defaulted to being on at installation and it is recommended that this feature should always be switched on (in the Help menu, **Tips** should be checked). With **Tips** activated one can, for example, let the mouse pointer rest on an icon so that its name is displayed. Tips may also be seen in many other places in OpenOffice.org. For example, when scrolling through a table, the tip shows the row or column.

**Turning tips on and off**

Select Help > **Tips** to enable or disable this feature.

**Extended Tips**

Switch on the **Extended Tips** during the first few weeks of OpenOffice.org usage. Enabling this fun gives a brief description of each item on the screen when the mouse pointer is hovered over the item for a moment.

**Turning extended tips on and off**

Choose Help > **Extended Tips** to turn extended tips on and off. The command is checked when the **Extended Tips** function is switched on.

Press Shift+F1 to turn Extended Tips on temporarily. The pointer turns into the Extended Tips pointer. Now see the Extended Tips for any element on the screen as the mouse pointer is moved. As soon as the mouse is clicked or a key pressed, the pointer returns to the normal mouse pointer.

**Help Agent**

When certain actions are performed in OpenOffice.org, the Help Agent automatically appears. This is a small window in a corner of the document.

The Help Agent normally remains visible for 30 seconds. When clicked, it is replaced by a help window providing some helpful advice about the current topic. If a Help Agent dealing with the same topic is repeatedly ignored or closed instead of being clicked, it does appear again for this topic. Resetting the Help Agent restores it to the way it was when OpenOffice.org was first installed.
Turning the Help Agent on and off

1. Choose **Help - Help** Agent to have the Help Agent appear. If the command is checked, the Help Agent is automatically displayed when certain actions are performed in OpenOffice.org.

2. By accessing **Tools > Options > OpenOffice.org > General** from the main toolbar, activate, reset the Help Agent and set its display duration.
Chapter 2: Working With OpenOffice.org

OpenOffice.org is reasonably intuitive but is sufficiently different to other suites that a period of familiarization required before use is fluid and effective. This chapter starts with a general explanation of the most common control features in OpenOffice.org, such as toolbars, floating toolbars and dockable windows. This is followed by information on functions that can be used in most of the program modules of OpenOffice.org.

The User Interface
OpenOffice.org provides not only the usual control elements found in other applications, such as menus and icons, but a host of other special features besides. For example, many of the special OpenOffice.org features can be accessed via a context menu, opened by right-clicking on the selected objects. Other user-friendly functions are available by dragging and dropping with the mouse.

Starting OpenOffice.org
Under Windows®, once the program is installed (see the separate setup guide that is part of the download image and is on most CDs), the OpenOffice.org group should be on the Windows® Start menu under Programs. Under *NIX, its location depends upon where it is installed and which window manager is used; however, under Gnome and KDE, the OpenOffice.org group may be found in the Main menu. To create a blank text document in Writer, click Text Document. For a blank spreadsheet in Calc, click Spreadsheet, and so on.

NOTE: Under Windows®, the OpenOffice.org Quickstarter should be in the Windows® task bar. The icon may be double-clicked or right-clicked to open its context menu. Right-clicking Quickstarter opens a submenu from which a new, blank document can be opened. Double-click Quickstarter to open the Templates and Documents dialogue.
The OpenOffice.org Writer Window

A text document is displayed and edited in the Writer window. Spreadsheet, presentations or drawings are displayed in very similar windows, except the menus and icons change automatically depending on the context.

Toolbars in the OpenOffice.org Window

The Title Bar

The title bar shows the name of the program, OpenOffice.org, and usually the file name of the current document. If a document title is entered in File > Properties > Description, this title is displayed rather than the file name.
The Menu Bar

At the top of the OpenOffice.org window, immediately under the title bar, is the menu bar. Point with the mouse to a command on the menu bar and press the left mouse button. The menu opens, allowing one to choose a command from the submenu by clicking it. The menu bar can also be accessed from the keyboard, by pressing the Alt key. The menus are organized into basic functions. The Edit menu, for example, provides the functions needed to edit the current document (cut, copy, paste, undo changes and so on), while the View menu has functions that allow control of the view of the elements displayed on the screen. In other words, the commands, used for editing, viewing, sequencing, formatting and printing, etcetera a document or its contents, can only be used when the document is open and active, where active, in this case, means that the document has to be in front of any others on the screen. If the commands should correspond to an object in the document, then that object has to be selected. In addition, the menus are context sensitive., This means that only those menu commands that are relevant to the current work will be available. For example, if the cursor is located in a text document, then only the text editing menu commands are available. Likewise, if graphics are selected in a document, then only the menu commands that can be used to edit graphics will be available. The other inactive menu items are hidden. By choosing Tools > Options > OpenOffice.org > View, one can select the Inactive menu entries field and then see the inactive menu items as gray entries in menus.

OpenOffice.org lets the user change and customize the menu bar the way as desired. Many of the toolbars and the status bar may so be modified to suit personal requirements.

The Toolbars

Below the menu bar is the function bar. This bar contains icons for several important commands and functions that can be used in OpenOffice.org to open a document, export to PDF, undo and redo, access the navigator, stylist or gallery or print the current document.

Immediately above the horizontal ruler is the object bar. This offers features that are always appropriate to the current context such as alignment, font styles, lists and indenting. For example, if a piece of normal text is selected, one will see different icons from those within a text table. Further, when dealing with tables, the object bar may be toggled with this icon, which may found at the far right of the object bar.

On the left edge of the document is the main toolbar. This varies depending on the document type (text, spreadsheet, presentation, drawing or formula).

Other toolbars such as the option bar and colour bar will be described later.

It is easy to change the position of the toolbars. For example, if the position of the main toolbar should be on the right edge of the document instead of on the left, simply hold down the control key, Ctrl, and drag it there. Changing the order of the icons on a bar, is also simply done by dragging each icon to the new location while simultaneously pressing the Ctrl and Alt keys.

Note: under Windows®, one only needs to use (Alt).
Some icons have small triangles to indicate that there are more functions available. These are called **floating toolbars**. When a long click is applied to these icons, a new window opens giving access to all those features associated with that icon. Short clicks deliver different behavior than a long click but give the same functionality.
Using Floating Toolbars

When editing a text document, the **Insert** icon is at the top of the main toolbar. Do a long click on this icon. This opens a floating toolbar containing further icons.

![Floating Toolbar](image)

The user now has a few choices to make: either to click the icon to activate the feature, or to grab the window by its title bar and drag it away from the main toolbar while holding down the left mouse button (Remember to first release the mouse button that was clicked to open the popup otherwise the title bar cannot be grabbed with the mouse). Notice that the icon, that was used previously, is still there. If one now clicks the **Insert Graphics** icon, notice that this icon has replaced the original icon a the top of the main toolbar. Use a short click to open the directly visible function and a longer click to reopen the floating toolbar.

The document window

At the top left hand edge of the document window are the toolbars that are needed for work, and that these vary depending on the document type and context. At the bottom edge is the status bar. The status bar contains different fields displaying information appropriate to the type of document. Some of these fields give access to special functions, either by double-clicking or by opening the relevant context menu. For more detailed explanations, refer to **Help**.

Docking windows

Some tools in OpenOffice.org open in popups that are dockable, such as the **Stylist**, the **Navigator** and the **Gallery**. These windows may be re-sized or docked on one of the edges of the OpenOffice.org window. On each edge several windows may be docked on top of or alongside each other; then, by moving the border lines, the relative proportions of the window can be changed. To undock and re-dock, double-click in the window while pressing **Ctrl-Doble-click** in a vacant area of the window. For example, in the Stylist double-click a gray part of the window, that is, next to the icons. This action can hide or unhide the window with the arrow button. The second button switches between a locked and floating state. In the floating state, the window floats above the workplace so that the windows below it are partially covered. Switch to the locked state to display the docked window next to the workplace. If the window is docked to the left of the workplace, the following buttons appear depending on the state:
Unhide

A hidden window can be un-hidden (shown) by clicking the arrow button.

Hide

Click the arrow button to hide a window.

Lock

Click this button to lock a floating window.

Floating

Click this button to change a locked window to a floating window.

On any window edge where another window is docked there are two buttons which allow the window to unhidden, hidden or locked.

• Unhide a docked window by clicking the window border. By doing so, the AutoHide function becomes active. Hiding is then automatic.

Grab a window by the title bar or by a vacant area and move it across the screen. Hold down the Ctrl key while moving it to dock the window to the edges.

Another window may also be docked adjacent to one which is already docked. Users can also choose to have them one on top of the other or side by side. As a window is moved, note that an outline displays showing where the window will dock and how big it will be.
Opening and Saving Documents

There are multiple methods of loading or opening documents. For example, by using the File > Open dialogue, the Open icon on the Function Bar or the File > New > dialogue.

Opening Documents

To open an existing document that was saved on the hard drive or on a removable disk, there are three possibilities. Either choose File > Open, click the Open File icon on the function bar, or use the Ctrl+O shortcut keys.

In each case, the Open dialogue is displayed.

![Open dialogue](image)

This dialogue is described in detail in the OpenOffice.org Help. However, here are a few tips:

1. Change the size of the dialogue by dragging the borders of the dialogue with the mouse.
2. Click the Default Directory icon to go straight to one's work directory. To define a work directory, choose Tools > Options > OpenOffice.org > Paths.
3. Long-click or short-click the Up One Level icon. A short click takes the user one directory higher. A long click opens a submenu with a choice of superordinate directories.
4. To only see files containing a certain name, enter the name with wildcards in the File name pull-down list and press Enter. If *.txt, for example, is used only the files having .txt at the end of their names will be displayed. If s* is used, all names beginning with the letter s will be displayed.
Documents may be opened with write-protection enabled. To edit a read-only document, click the **Edit File** icon on the function bar.

**NOTE:** Under Windows®, a system dialogue is automatically displayed when opening and saving OpenOffice.org documents. Choose **Tools > Options >OpenOffice.org > General** and check **Use OpenOffice.org dialogues.** This enables a user to be presented with the OpenOffice.org dialogues shown in this guide.

## The Templates and Documents dialogue

The **Templates and Documents** dialogue can be regarded as a kind of command center for OpenOffice.org documents. It provides easy access to a user's work directory and to any supplied sample documents. Here find all document templates - both the supplied ones and any personally created ones. To open the dialogue, choose **File > New > Templates and Documents** or press **Shift+Ctrl+N**. In Windows®, double-click the OpenOffice.org Quickstarter icon on the task bar.

![Templates and Documents dialogue](image)

The dialogue offers the following areas, which can be selected by clicking one of the offerings in the shortcut bar on the left:

- **New Document** - A way to create a new, empty document from a set of prepared templates.
- **Templates** - Choose from the many ready-to-use document templates.
• **My Documents** - A quick route to the documents in a work directory. A work directory may be defined by selecting **Tools > Options > OpenOffice.org > Paths** and entering the path required for **My Documents**.

• **Samples** – This is an empty folder when installed; however, some examples may be downloaded from [http://documentation.openoffice.org/Samples_Templates/User/template/index.html](http://documentation.openoffice.org/Samples_Templates/User/template/index.html). (See New Document for example templates)
Saving Documents

Saving the current document can be done in three ways, using File > Save command, the Save Document icon on the function bar, or just press Ctrl+S.

For a first time save, use File > Save as. A dialogue box pops up to allow choosing where to store the file.

With File > Save as, one assigns the document a name whereas the other two options save without asking for the file to be named. Therefore, using the Save as feature is especially important when saving files for the first time. For the most part, choose any name desired (limited only by the restrictions imposed by the operating system). When the document is to be opened later, find it under that name.

Save documents regularly as work progresses. The simplest way is to save the current document by pressing Ctrl-S. This replaces the document on the data medium with the current document.

Note: An untitled documents must be given a unique name for AutoSave to obey the settings in Tools > Options > Load and Save > General. Disabling AutoSave is not recommended.
Changing the Work Directory
When the Open dialogue comes up, the work directory is displayed. The user can change from this directory as follows:

1. Select **Tools > Options > OpenOffice.org > Paths**.
2. Double-click **My Documents** to open the edit dialogue.
3. In the **Select Path** dialogue, enter the work directory wanted and click **Select**.
4. Close with **OK**.

Likewise, other directories can be selected using the same method. For example, to display a different default directory for inserting graphics, change the path for the entry **Graphics**.

Saving Documents Automatically

Backup a File Automatically
To create a backup copy of a document every time a document is saved:

1. Select **Tools > Options > Load/Save > General**.
2. Check **Always create backup copy**.

If the current document is saved, using the same path and file name with which it was first opened, using File > Save or Ctrl+S, the old version will be overwritten by the new version.

If the **Always create backup copy** is checked, the old version is first copied to the backup directory.

- The default backup directory is `~/OpenOffice.org<release>/user/backup`
  
  Change this, as described above, in **Tools > Options > OpenOffice.org > Paths > Backups** entry.

- The backup copy retains the same name as the document, but the extension is changed to `.bak`. If the backup folder already contains such a file, it is overwritten without warning!

Saving Files Automatically Every 'n' Minutes

1. Select **Tools > Options > Load/Save > General**.
2. Check **AutoSave every** and select the time interval in the listbox.
3. Check **Prompt to save** to ensure one is asked prior to saving the document.

OpenOffice.org will draw a progress bar at the bottom when saving a file. However, this can result in a sudden beep while attempting to enter text which indicates that Writer is not accepting input.

Using this feature is the equivalent to saving the current document as manually pressing Ctrl+S.

If the document was saved previously, the old version will be overwritten by the current version.
Note: If both checkboxes Always create backup copy and AutoSave every are checked, the file will be overwritten every 'n' minutes. At the same time, the backup copy will be replaced by the last version.

Properties

File > Properties records and collects statistics and other data on a document. For example, the template from which is was created, the author, user-entered data et cetera. Also not that information that is entered under File > Properties, such as the name of the author, date created, word and character counts et cetera, are not encrypted at any time.

Note: If no template is listed, then either no default template was set or the template was altered and, the next time the document was opened, someone declined to update the document. If the document isn't updated after a template change, then the link to the template is permanently broken.
OpenOffice.org File Formats

OpenOffice.org uses an XML file format as the default for saving and opening documents.

**XML file format names**

In saving and opening OpenOffice.org documents if no other file type is selected, OpenOffice.org uses the following XML formats:

<table>
<thead>
<tr>
<th>Application File</th>
<th>extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenOffice.org Writer</td>
<td>*.sxw</td>
</tr>
<tr>
<td>OpenOffice.org Writer templates</td>
<td>*.stw</td>
</tr>
<tr>
<td>OpenOffice.org Calc</td>
<td>*.sxc</td>
</tr>
<tr>
<td>OpenOffice.org Calc templates</td>
<td>*.stc</td>
</tr>
<tr>
<td>OpenOffice.org Impress</td>
<td>*.sxi</td>
</tr>
<tr>
<td>OpenOffice.org Impress templates</td>
<td>*.sti</td>
</tr>
<tr>
<td>OpenOffice.org Draw</td>
<td>*.sxd</td>
</tr>
<tr>
<td>OpenOffice.org Draw templates</td>
<td>*.std</td>
</tr>
<tr>
<td>OpenOffice.org Math</td>
<td>*.sxm</td>
</tr>
<tr>
<td>Master documents</td>
<td>*.sxg</td>
</tr>
</tbody>
</table>

These file name extensions permit reasonable differentiation when searching though a lot of files of different file types in a directory. Since these are compressed XML files, it should be evident that these must first be unpacked before being manipulated, for example, by a text editor.

**Note:** If a user wants to work permanently with another file format, define this as the default. Select Tools > Options > Load/Save > General for alternative file formats that can be selected for each OpenOffice.org document type.
OpenOffice.org XML file structure

The OpenOffice.org XML file formats are compressed and packed using ZIP. Use an unpacking program, such as WinZip on Windows® or unzip on *NIX, to unpack the contents of an XML file. The structure is similar to the following illustration.

<table>
<thead>
<tr>
<th>Archive: example.sxw</th>
<th>Length</th>
<th>Method</th>
<th>Size</th>
<th>Ratio</th>
<th>Date</th>
<th>Time</th>
<th>CRC-32</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>30</td>
<td>Stored</td>
<td>30</td>
<td>0.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>3931a5e1</td>
<td>mimetype</td>
</tr>
<tr>
<td></td>
<td>4260</td>
<td>Stored</td>
<td>4260</td>
<td>0.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>a10af03b</td>
<td>Pictures/100010DA222DD884.gif</td>
</tr>
<tr>
<td></td>
<td>9022</td>
<td>Defl:N</td>
<td>2147</td>
<td>76.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>cd8d5105</td>
<td>content.xml</td>
</tr>
<tr>
<td></td>
<td>2447</td>
<td>Defl:N</td>
<td>954</td>
<td>61.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>08c57cab</td>
<td>Basic/~AutoPilot/Create.xml</td>
</tr>
<tr>
<td></td>
<td>1586</td>
<td>Defl:N</td>
<td>642</td>
<td>60.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>55c931dc</td>
<td>Basic/~AutoPilot/Save.xml</td>
</tr>
<tr>
<td></td>
<td>389</td>
<td>Defl:N</td>
<td>223</td>
<td>43.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>756d8953</td>
<td>Basic/~AutoPilot/script-lb.xml</td>
</tr>
<tr>
<td></td>
<td>287</td>
<td>Defl:N</td>
<td>193</td>
<td>33.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>528021b8</td>
<td>Basic/Standard/script-lb.xml</td>
</tr>
<tr>
<td></td>
<td>405</td>
<td>Defl:N</td>
<td>225</td>
<td>44.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>95c3869e</td>
<td>Basic/script-loc.xml</td>
</tr>
<tr>
<td></td>
<td>59152</td>
<td>Defl:N</td>
<td>5041</td>
<td>92.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>e86699c4</td>
<td>styles.xml</td>
</tr>
<tr>
<td></td>
<td>1381</td>
<td>Stored</td>
<td>1381</td>
<td>0.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>70e3c0fc</td>
<td>meta.xml</td>
</tr>
<tr>
<td></td>
<td>6841</td>
<td>Defl:N</td>
<td>1230</td>
<td>82.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>0d922df6</td>
<td>settings.xml</td>
</tr>
<tr>
<td></td>
<td>1602</td>
<td>Defl:N</td>
<td>349</td>
<td>78.00%</td>
<td>05/15/04</td>
<td>15:25</td>
<td>8e61970e</td>
<td>META-INF/manifest.xml</td>
</tr>
</tbody>
</table>

**Note:** Under Windows®, output should be similar to the above.

- The text content of the document is located in `content.xml`. This file can be viewed with, for example, a pure text editor.

  By default, `content.xml` is stored without indents or any other type of formatting so that the time needed for saving and opening is minimized. By selecting **Tools > Options > Load/Save > General** this procedure can be changed so that the lines saved are structured in a more human readable format.

- `meta.xml` contains the meta information on the document, which is entered via **File > Properties**.

  In documents saved with security, `meta.xml` remains unsecured.

- `settings.xml` contains further information on settings for this document, for example on the printer, on the recording of changes, the associated data sources and so on.

- `styles.xml` retains the styles defined for the document. For example, these can be seen in the stylist.

  **meta-inf/manifest.xml** file describes the structure of the XML file.
Additional files can be contained in the packed file format. For example, Graphics can be found in the **Pictures** subdirectory, Basic code in the **Basic** subdirectory and linked Basic libraries are found in further subdirectories of **Basic**.

**Definition of the XML formats**

The DTD (Document Type Description) files can be found in $HOME/OpenOffice.org<release>/share/dtd.

*Note that the formats are subject to certain licenses. Notes on the licenses are found at the start of the DTD files. More detailed information can be found on the OpenOffice.org website.*
Sending Documents as E-Mail

Working in OpenOffice.org, one can send the current document as an e-mail attachment providing that the default e-mail program up is set up correctly.

**Note:** To set up this feature, select **Tools > Options > OpenOffice.org > External Programs** and configure the programs to use.

1. Choose **File > Send > Document as E-mail**.
2. When the e-mail composer window appears, enter a recipient, subject and any text and send the e-mail.
Printing Documents

Upon creating a document, normally one will want to print it out on paper for distribution.

Print the current document either directly to a printer, or “to file”. When printing to a file, all the information that would otherwise be sent to the printer is initially written to a file. On another computer, the file can then be copied directly to the printer connected to it.

**Note:** OpenOffice.org Writer always formats documents so that they are printed as well as possible with the selected printer. Therefore, always define a default printer, even if there is no available printer.

Click the **Print File** icon on the function bar to print the current document without the intervention of a dialogue.

To retain finer control of printing, either select **File > Print**, or use the keyboard shortcut Ctrl+P.

In the **File > Print** dialogue, select a specific printer (if there is more than one installed printer). Under Print range, determine how many pages to print (or only certain pages), and how many copies are wanted.
In addition to the general printing options already mentioned, one can choose special printer options for the different document types in OpenOffice.org using additional dialogues that allow the user to control the way the contents or the pages of the document are printed. Define these printer options for the current print job by clicking the **Options** button in the **Print** dialogue. Select **Tools > Options > (name of document type) > Print** to create a general definition for normal use.

**Note:** There are many different printers with widely varying properties. The printing functions differ according to the operating system, printer driver and printer model used. The selected printer defines the width and height of the characters, and hence also the line and page breaks. OpenOffice.org **Writer** and **Calc** always format the pages in the way they will appear when printed.

**Displaying Print Previews**

Before printing out a document, reviewing how the printed document will appear on paper is often a good idea. OpenOffice.org offers a **Print Preview** feature for this purpose thereby allowing adjustment of margin widths, optimization of page breaks et cetera.

1. Switch to the document for preview.
2. Select **File > Page Preview**.
   - Use the icons on the object bar to zoom in or out.
3. Use the arrow keys or object bar icons to scroll through the pages of the document and check how they will appear in print.
**Reduced Printing of Documents**

To get a reduced printout of a text document, choose **File > Page Preview**. Here, decide whether to have two, four or any number of pages beside and on top of each other.

**To print two pages beside one another on one sheet of paper**

1. Choose **File > Page Preview**.
2. Locate the Page Preview icon. If there are more or fewer pages than desired, long click the icon to the right of the grayed out **Page Preview: Two Pages** on the object bar and select the number of pages needed for previewing.
3. Click on the **Print page view** icon.
   Clicking the **Print options page view** icon opens a dialogue where one can enter settings for reduced printing.
4. Click **OK** to confirm.

**Printing in Black and White**

If there is a colour printer installed but printing should be restricted to black and white only, use one of the following options:

**Printing text and graphics in black and white**

1. Select **File > Print**. This opens the **Print** dialogue.
2. Click on **Properties**. This opens the properties dialogue for the printer.
3. Choose the option to print in black and white. For further information, refer to the help for the printer or read the printer manual.
4. Confirm the Properties dialogue and click **OK** in the **Print** dialogue.
5. The current document will be printed in black and white.

**Printing in black and white in Impress and Draw**

1. Choose **Tools > Options > Presentation** or **Tools > Options > Drawing**, as appropriate.
2. Then choose **Print**.
3. Under **Quality** select either **Grayscale** or **Black & white** and click **OK**. From now on, **all** presentations or drawings will be printed without colour. For eliminating colour printing of the **current** printing process, select the option in **File > Print > Options**.
   Selecting the **Default** quality option allows documents to be printed in colour again later on.

   **Grayscale** converts everything to a maximum of 256 gradations from black to white.

   **Black & White** converts everything into the two values black and white.
Printing only text in black and white

In Writer, the user can choose to print colour-formatted text in black and white. This can be specified either for all text documents to be printed subsequently, or only for a printing process of the current text document.

Printing all text documents with black and white text

2. Then choose Print.
3. Under Contents mark Print black and click OK.

All text documents or HTML documents will from now on be printed with black text.

Printing the current text document with black and white text

1. Choose File > Print. This opens the Print dialogue.
2. Click the Options button. This opens the Printer Options dialogue.
3. Under Contents mark Print black and click OK.

The text document or HTML document now being printed will be printed in black text.

Printing Brochures

OpenOffice.org text documents consisting of more than one page can be printed automatically as a brochure. Two pages of a text document will be reduced in size and printed next to each other on a page in landscape (horizontal) orientation. Both sides of the page will be printed (most printers require that users take out the paper after the first half of the printing process and feed it in again with the blank side of the page facing upward). OpenOffice.org will automatically print the pages so that they can be read as a brochure. OpenOffice.org automatically arranges the pages in such a way that the text can be read continuously by laying the pages together, fold them in the center and stapling them in the fold.

- To make a brochure using the current document, select File > Print. In the dialogue that opens, click the Options button. Check the Brochure checkbox.
Spellcheck

OpenOffice.org has an automatic spellcheck which can be active while typing, or activated manually.

Automatic Spellcheck

The automatic spellcheck that works while typing in text can be turned on and off by clicking the AutoSpellcheck on/off icon on the main toolbar. With automatic checking enabled, words recognized as incorrect are highlighted with a wavy red underline.

Incorrect words are recognized as incorrect if all the following conditions are met:

• a spellcheck module is installed for the language of the word,
• this module is enabled,
• the word is not found in the installed dictionaries.
• the word is not in any active user dictionary.

Users can create any number of custom/user dictionaries.

Create a user dictionary by selecting Tools > Options > Language Settings > Writing Aids.
As text is proofread, the wavy red underlines draw attention to possible spelling mistakes. Of course, Spellcheck will not catch spelling mistakes that form other recognizable words (such as “fun” instead of “run”). As long as the automatic spellcheck is activated, the red markings can be seen on the screen but are not printed.

The easiest way to correct a red-underlined word is to right-click it. This opens a context menu that offers several alternative words to choose from. Click one of the alternatives and the red-underlined word will be replaced with the alternative. Where a red-underlined word should be included in a user dictionary, because it is correctly typed, use the context menu. When a red-underlined word is replaced with a suggestion from the spellcheck via the context menu, working with a document is made much easier to deal with frequent typing errors.

Upon clicking the suggestion, OpenOffice.org not only replaces the red-underlined word with the suggestion selected, it also remembers this replacement while the document is open. If the same typing error is made again, Spellcheck automatically replaces the mistyped word with the word that replaced it previously.

**Checking Multilingual Texts**

OpenOffice.org Writer can manage spellchecking (plus thesaurus and hyphenation) in multiple languages (33 at the time of writing). The OpenOffice.org setup program offers this via “Custom Installation” and, after installation via the “Modify” option in setup, where one can choose which language modules to install.

Select the language of an entire text document with Tools > Options > Language Settings > Languages. If it applies to the user's needs, check For the current document only. For all paragraphs formatted with the same Paragraph Style, apply a language via the Paragraph Style. A language can be defined for individual words via Character Styles, or directly with Format > Character.
In **Tools > Options > Language Settings > Writing Aids**, check the option **Check in All Languages**. Now, the spellcheck will take all installed languages into account. Words that are correctly typed in any of the installed languages are regarded as correctly typed, irrespective of their language attribute. In multilingual texts, the automatic checking that was enabled by clicking the icon on the main toolbar, offers another facility as well. In the context menu of a red-underlined word that is recognized as incorrect, specify that the word or the whole paragraph is one of the other installed languages. The language of the underlined characters or all characters of the paragraph is automatically assigned as a character format.
Starting the Spellcheck
To check the entire text for spelling mistakes in the “classic” way (i.e. letting the Spellcheck
go through the whole document on its own), go to the Tools menu and choose Spelling >
Check. The Spellcheck dialogue will only appear if there are words in a text unknown to the
Spellcheck. The various options to be seen in the Spellcheck dialogue are described in detail
in the OpenOffice.org Help. In the Spellcheck dialogue, if an unrecognized word is included
in a user dictionary, the user can also define the permitted hyphens for the automatic
hyphenation. Enter the hyphens in the word as an equals sign (=).

Note: placing an equals sign at the end of the word means that this word will not be automatically hyphenated.

Excluding Text From the Spellcheck
If certain areas, words or tables should not be spellchecked because they are, say, in a foreign
language for which there is no installed module, then specify "Unknown" as the language to
be checked by Spellcheck. Do this by either using direct formatting by selecting the text and
then choosing Format > Character > Font or by modifying the corresponding Style for
the text (e.g. open the context menu and choose Edit Paragraph Style...).
Using Automatic Functions

OpenOffice.org has all kinds of intelligent assistants to help, all of which have names beginning with “auto”.

The section introduces a few of these auto-functions. For detailed explanations, refer to the OpenOffice.org Help.

Using AutoCorrect and AutoFormat

OpenOffice.org can either format documents while typing or afterward, plus correct typing errors. AutoFormat and AutoCorrect will work while typing, thereby letting the user draft documents much more efficiently. Here are a couple of examples.

- AutoCorrect is useful if one often makes the same typing errors. For example, if one tends to capitalize not only the first letter of some words but also the second, simply select the AutoCorrect function that corrects mistakes of this sort while typing.

- AutoFormat formats texts. One AutoFormat feature automatically will detect paragraphs beginning with a hyphen followed by a tab or space, and reformat the paragraph as a bullet point. The automatic bulleted is then applied to any paragraphs that follow as well. Automatic bulleted ends when there is no text is entered in a new paragraph is completed by only pressing Return.

In text documents, AutoFormat can be toggled on and off by selecting Format > AutoFormat. In the popup, check the While Typing command so that AutoFormat works while typing. Writer can automatically format the whole document or the current selection at a later time, check the menu command Apply. Selecting the Apply and Edit Changes command from the sub-menu let's the user see all document changes made via AutoFormat. Users then have the choice of accepting or rejecting all changes or reviewing each change separately.

One may also select and set the options in Tools > AutoCorrect/AutoFormat. AutoCorrect offers many options that can selectively turned on and off. Some of these offer different methods for formatting while typing and post-processing. The Replace and Exceptions lists are language dependent. OpenOffice.org first searches in the list of the language of the text, then the list for the higher ranking language family, and finally in all installed languages (For example, first in "English (US)", then in "English", then in "All Languages").
The following graphic shows the various functions available in this dialogue. A detailed explanation of each function is given in OpenOffice.org Help.

In addition to the functions shown here, one can also select Custom Quotes. This means that all quotation marks entered as a simple computer character with Shift+2 are automatically turned into correct typographer's quotes. Users can choose the characters to be used for this purpose.
Turning off URL Recognition by AutoCorrect

When text is entered, OpenOffice.org automatically recognizes a word that may be a URL and replaces the word with a hyperlink. OpenOffice.org formats the hyperlink with direct font attributes (colour and underline) the properties of which are obtained from certain Character Styles.

If OpenOffice.org should not automatically recognize URLs while typing, turn off this feature using one of the following methods.

**Undo URL recognition**

1. Press Ctrl+Z to undo text that has been automatically converted into a hyperlink.
2. Select the hyperlink and choose **Format > Default** if this conversion is not noticed until later.

**Turn off URL recognition**

1. Load a document of the type in which URL recognition is to be modified. For example, if modifying URL recognition for text documents, open a text document.
2. In OpenOffice.org Writer select **Tools > AutoCorrect/AutoFormat** or **AutoCorrect ...** for other modules.
3. In the **AutoCorrect** dialogue, choose the **Options** tab.
4. Deselect **URL Recognition**, so that words will no longer be automatically replaced with hyperlinks.

   In Writer there are two checkboxes in front of **URL Recognition**. The field in the first column is for modifying in a post-edit session while the field in the second column enables AutoCorrect to make the corrections while typing.

**Other AutoCorrect functions**

The **AutoCorrect > Replace** tab has a default list of items that will be automatically replaced provided that **Use replacement table** on the **Options** tab page is checked. One can add all of their most frequent typos to this list and have AutoCorrect replace them with the right text. Also use this feature to enter special characters or phrases that are keyboard intensive to do normally. For example, type `(C)`, this is immediately turned into the copyright symbol.

**Note:** The fonts supplied with OpenOffice.org include the Euro symbol. If working with other fonts, one can easily insert the Euro symbol from another font using AutoCorrect. When working in a text document, choose **Insert > Special Character**. Look for the Euro symbol and click **OK**.

Enter in the **Abbreviation** text box `€u`, for example. The **Text only** box should not be marked. Click **New**. Now close the dialogue. As soon as the `€u` is entered followed by a space or at the end of a sentence, a Euro symbol will be inserted.

On the **Exceptions** tab, enter any exceptions for the two types of automatic correction:
- Assuming the **Replace** option is enabled to automatically start each sentence with a capital (uppercase) letter, and “e.g.” is entered and is followed by a lowercase “d” then the “d” would be capitalized. So to compensate for this behaviour, enter “e.g.” into the **Exception** list to prevent this type of correction.

- Again, assuming the **Replace** option is enabled to automatically convert the second of two capital letters at the beginning of a word to a lowercase letter, enter any exceptions that are correctly written with two capital letters, such as PC and CD.

These exceptions can also be automatically included by selecting the **Autoinclude** checkboxes on the **Exceptions** tab. When this feature is enabled and one then uses an idiom in the text that is automatically corrected but which should not be corrected, immediately press Ctrl+Z. Doing this not only undoes the automatic “correction”, but also sees to it that this particular “correction” will not be made automatically again in the session.

**AutoCorrect** can also be used to replace one word or abbreviation with something more appropriate. For example, “ASAP” with the text “as soon as possible”; however, the OpenOffice.org **AutoText** function is a better choice for doing this.
Creating a Letter Template With the AutoPilot

If one is writing a personal letter, the AutoPilot and standard AutoTexts are not essential, but in formal business correspondence these aids can save a lot of time and make work much easier.

**Note:** To produce a standard letter, have a look at the supplied templates. Simply press the shortcut keys **Shift+Ctrl+N** or choose **File > New > Templates and Documents**.

Start the AutoPilot with the **File > AutoPilot > Letter** menu command.

Treat this section as a tutorial to using OpenOffice.org **Autopilot**. In order to get the most from the following, it is recommended that one accept all the defaults provided without changing them, and then print the result. Of course, one could click on the **Create** button immediately, but as part of the tutorial process and to familiarize oneself with this function, click **Next** on each dialogue page, so that every page is seen at least once during the learning process.

Examine each of the AutoPilot pages while going through the process of creating a letter template. Enter data or modify options on each page as necessary. Each page allows modifications according to each user's preferences including sender and recipient addresses, both of which can also be entered manually. Predefined elements will appear but users have the final say on what to include in their letter.

For example, sender information is automatically taken from the personal details that each user enters at the time of installation. These details may be changed at any time by selecting **Tools > Options > OpenOffice.org > User Data** and entering new information or editing existing details.

While one may, there is no need to go through all the steps of the AutoPilot each time one wants to write a letter. Although the AutoPilot does produce a document that can immediately be filled in, printed, and sent, using the AutoPilot is really meant to help create customized templates.
The AutoPilot creates a template which can be edited and then used as a customized template for all letters. This ensures that correspondence has a consistent format. This also applies to the other types of documents which can also be created with the AutoPilot (e.g. faxes).

Thanks to the AutoPilot, one doesn't have to start from scratch but can use preexisting texts when creating custom templates, whether for business letters, faxes, memos, or other documents.

Find & Replace

When working with a computer it is often useful to be able to locate certain pieces of text quickly. The Find function in OpenOffice.org Writer, Calc, Impress and Draw is the tool to use for this purpose. Find can also locate variations in the given search term or limit the search to certain places in the document, such as the beginning of a word or the end of a paragraph.

Text strings found in the text can be replaced by other strings with or without confirmation, although sometimes manual editing is still necessary where, for example, there are deviations in gender found in other languages.

Finding a Word in Text

Let's say the word “Holland” is read or written somewhere in a long text and, now, there is a need to return to that point in the text, but its location is not remembered. When this happens, activate the Find function with Ctrl+F. Enter the string one wants to find in the Search for field and press Enter.
OpenOffice.org starts searching from the current cursor position towards the end of the document. Upon reaching the end of the document, a new dialogue appears asking whether or not to continue the search at the beginning of the document. Click the Enter key to confirm. If the text string is found, it is highlighted.

The Find & Replace dialogue can remain open without interfering with text entry and it can be moved to any place on the screen. However, when it is closed, it remembers the previously entered strings so they do not need to be reentered for the next search, but can be selected from the list box.

One very useful feature is the multi-selection facility Find All. For example, setting every occurrence of the word “bold” in the text to bold type that was read (or written) To accomplish this task, enter bold in the Search for field and then click Find All. All occurrences are now selected, and simply, click the Bold icon \textbf{} in the text object bar to format all occurrences to bold.

The dialogue graphic above illustrates that there are several ways of expanding or restricting searches by combining selections from the Options group box and the buttons. Examples for each option are described below.

**Searching for Whole Words Only**
Select the Whole words only option to find whole words that match the searched for word. For instance, if the word “in” is entered as the search term in the Search for field, all instances of “in,” or “In,” as stand-alone words in the text will be found. Words like “bin” or “chin” will not be found if this checkbox is selected. If searching using regular expressions or for Styles, do not select this option.

**Match Case**
When this checkbox is selected, the search is case-sensitive to uppercase and lowercase letters. So if searching for “in,” it will be found, but not the word “In,” Combine a Match case search with the Whole words only option as needed.

**Searching for Text With Wildcards**
1. Start Find by selecting Edit > Find & Replace dialogue or use Ctrl+F.
2. Check the Regular expressions box.
3. Enter the search term with the desired wildcards and click Find.

Regular expressions are shown in a form that should be familiar to Unix command line users:

- The wildcard for any number of a given character is the character itself followed by an asterisk.
  
  Example: Enter “Hawai*” in the Search for field. This means than any number of “i ’s” may follow “Hawa”. Thus the words “Hawai” and “Hawaii” will be found.

- The wildcard for a single character is the period or dot. This is equivalent to the wildcard ‘?’ in file names.
• The wildcard for several characters in succession is '.*' (period and asterisk). This is equivalent to the wildcard '*' in file names.

• A paragraph end can be found with the dollar sign ($), and the first character at the beginning of a paragraph with the string '\n' (caret and period).

• Regular expressions may only be searched within paragraphs.

There are many other wildcards that can be used that are listed in OpenOffice.org Help with a search term of “Regular expression”.

**Searching Backward**

When locating a specific word, in a particular part of a long text, that is often used, it's likely the word will be entered in the Search for field and then each extraneous location skipped by repeatedly clicking the Find button. Since it is possible that Find may be clicked once too often by mistake, select Backward and click again on Find to return to the location of the previously found item.

**Current Selection Only**

Select the Current selection only option to limit the search rather than causing the entire document to be searched. The search will be restricted to the lines that are highlighted in the document. If text is selected before activating the Find command, the search will automatically take place only within that selected range.

**Searching for Styles**

Quickly reformat all or part of a text using this feature. For example, text formatted with the Style “Heading 2” can be replaced with the Style “Heading 3.” Select the Paragraph Style in the list box under Search for. Then select the new Paragraph Style in the Replace with field. Start the replacement process with the Replace button. All matching styles found in the text will be displayed in sequence. The user can decide each time whether or not to do the single replacement, replace all matching styles found in the text, or to cancel the process.

**Searching for Attributes**

Select Attributes to open a dialogue from which to select those text attributes to be employed to search within a document. OpenOffice.org then finds all attributes that differ from the format of the Paragraph Style. For example, in this dialogue, if the Font Weight checkbox is selected, the program can find all words that have a heavier font than normal. These could be words that have has the Bold attribute applied, either through direct or indirect formatting, or that have been highlighted with a font previously defined as a bold font, such as ones containing the words "Bold" or "Black" in their name. By default, Find searches only for direct attributes. However, after searching for the attributes, one may enable the Including Styles checkbox in the groups section of the Find & Replace dialogue where Search for Styles was previously. Then, the search extends from the direct attributes we selected previously to include indirect attributes, such as those set with styles.
Searching for Special Formats

By clicking the Format button, one opens a dialogue from which to select the specific formats in the search. For example, if one has manually centered a few lines in the text, find them using the options of Format in the Find & Replace dialogue. Now let's say that the found attribute must be replaced with another, to do this take the following steps:

1. Position the cursor in the Replace with field.
2. Click the Format button.
3. Choose the replacement attribute.

The chosen attributes are listed under the Search for and Replace with fields. If no replacement is indicated for the attribute found in the text, the default settings are automatically applied.

Similarity Search

This function seeks not only for the search term, but also for similarly typed words. As needed, fine-tune the degree of similarity by clicking the button immediately to the right of the “Similarity search” checkbox.

List of Regular Expressions

This list is also in Help but is included here as a convenience. Regular expressions are a very powerful tool in searches and replacements. There are may tutorials on their general use on the Internet.

<table>
<thead>
<tr>
<th>Character</th>
<th>Result/Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>.</td>
<td>Represents any single character. The search term &quot;sh.\rt&quot; finds both &quot;shirt&quot; and &quot;short&quot;.</td>
</tr>
<tr>
<td>^</td>
<td>Using ^Peter will find this search term only if it appears at the beginning of a paragraph. Special characters (for example, blank spaces and character-anchored frames) at the beginning of a paragraph are ignored.</td>
</tr>
<tr>
<td>$</td>
<td>Only finds the search term if it appears at the end of a paragraph. For example, if one searches for, say, Peter at the end of a paragraph, enter Peter$ in the Search for box. Special characters (for example, blank spaces and character-anchored frames) at the end of a paragraph are ignored.</td>
</tr>
<tr>
<td>^$</td>
<td>Enter ^$ in the Search for box to find empty paragraphs.</td>
</tr>
<tr>
<td>*</td>
<td>Represents any number of characters. For example, &quot;Ab*e&quot; finds &quot;Ac&quot;, &quot;Abc&quot;, &quot;Abbe&quot;, &quot;Abbe&quot;, and so on.</td>
</tr>
<tr>
<td>+</td>
<td>The character before this symbol must appear at least once: &quot;AX.+4&quot; finds &quot;AX 4&quot;, but not &quot;AX4&quot;. The longest possible text within the paragraph is always found. If the paragraph contains the text AX 4 AX4, the search finds the first A to the last 4.</td>
</tr>
<tr>
<td>?</td>
<td>Finds words that include the characters that come before the character that is in front of the &quot;. For example, &quot;Texts?&quot; finds the words &quot;Texts&quot; and &quot;Text&quot;.</td>
</tr>
<tr>
<td>\</td>
<td>Only finds the character (no numbers) that you specify. For example, if you search for \C, only \C is found.</td>
</tr>
<tr>
<td>Character</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td><code>\n</code></td>
<td>Finds a hard row break that was inserted with Shift+Enter. To change row breaks into paragraph breaks, enter <code>\n</code> in the <strong>Search for</strong> and <strong>Replace with</strong> boxes, and then click the <strong>Replace all</strong> button.</td>
</tr>
<tr>
<td><code>\t</code></td>
<td>Finds a tab space. You can also use this expression in the <strong>Replace with</strong> box.</td>
</tr>
<tr>
<td><code>\&gt;</code></td>
<td>Only finds the search term if it appears at the end of a word. For example, &quot;book&gt;&quot; finds &quot;checkbook&quot;, but not &quot;bookmark&quot;.</td>
</tr>
<tr>
<td><code>\&lt;</code></td>
<td>Only finds the search term if it appears at the beginning of a word. For example, &quot;&gt;book&quot; finds &quot;bookmark&quot;, but not &quot;checkbook&quot;.</td>
</tr>
<tr>
<td><code>^S</code></td>
<td>Searches for empty paragraphs.</td>
</tr>
<tr>
<td><code>^.</code></td>
<td>Searches for the first character of a paragraph.</td>
</tr>
<tr>
<td><code>&amp;</code></td>
<td>Use this character in the <strong>Replace with</strong> box to add the characters that you enter to the search criteria when a replacement is made. For example, if you enter &quot;window&quot; in the <strong>Search for</strong> box and &quot;&amp;frame&quot; in the <strong>Replace with</strong> box, the word “window frame” is replaced with &quot;window frame&quot;. You can also enter a “&amp;” in the <strong>Replace with</strong> box to modify the <strong>Attributes</strong> or a different <strong>Format</strong> of the search criteria you entered in the <strong>Search for</strong> box.</td>
</tr>
<tr>
<td><code>[abc123]</code></td>
<td>Finds the characters that are between the brackets.</td>
</tr>
<tr>
<td><code>[a-e]</code></td>
<td>Finds the characters that are between a and e.</td>
</tr>
<tr>
<td><code>[a-eh-x]</code></td>
<td>Finds the characters that are between a-e and h-x.</td>
</tr>
<tr>
<td><code>[^a-s]</code></td>
<td>Finds all characters except for a-s.</td>
</tr>
<tr>
<td><code>\xXXXX</code></td>
<td>Finds a special character based on its four-digit hexadecimal code (XXXX). The code for the special character depends on the font used. You can view the codes by choosing <strong>Insert - Special Character</strong>.</td>
</tr>
<tr>
<td>`</td>
<td>`</td>
</tr>
<tr>
<td><code>{2}</code></td>
<td>Defines the number of times that the character in front of the opening bracket occurs. For example, &quot;tre{2}&quot; finds &quot;tree&quot;.</td>
</tr>
<tr>
<td><code>{1,2}</code></td>
<td>Defines the number of times that the character in front of the opening bracket can occur. For example, &quot;tre{1,2}&quot; finds both &quot;tree&quot; and &quot;treated&quot;.</td>
</tr>
<tr>
<td><code>(</code></td>
<td>Defines the characters inside the brackets as a reference. You can then refer to the first reference in the current expression with &quot;\1&quot;, to the second reference with &quot;\2&quot;, and so on. For example, if your text contains the number 13487889 and you search using the regular expression (8)\1\1, &quot;8788&quot; is found.</td>
</tr>
<tr>
<td><code>[:digit:]?</code></td>
<td>Finds a single digit number. To find a number with more than one digit, use <code>[:digit:]*</code>.</td>
</tr>
<tr>
<td><code>[:space:]?</code></td>
<td>Finds white space such as spaces and tabs.</td>
</tr>
<tr>
<td><code>[:print:]?</code></td>
<td>Finds printable characters.</td>
</tr>
<tr>
<td><code>[:cntrl:]?</code></td>
<td>Finds nonprinting characters.</td>
</tr>
<tr>
<td><code>[:alnum:]?</code></td>
<td>Finds alphanumeric characters (numbers and text characters).</td>
</tr>
<tr>
<td><code>[:alpha:]?</code></td>
<td>Finds alphabetic characters.</td>
</tr>
<tr>
<td><code>[:lower:]?</code></td>
<td>Finds lowercase characters if <strong>Match case</strong> is selected in the <strong>Options</strong> area.</td>
</tr>
<tr>
<td><code>[:upper:]?</code></td>
<td>Finds uppercase characters if <strong>Match case</strong> is selected in the **Options area.</td>
</tr>
</tbody>
</table>
Chapter 3: Managing Text Documents With Writer

In this chapter, the user will learn about the OpenOffice.org word processing module, called Writer. Starting with the basics, it will introduce the more sophisticated functions and, lastly provide an explanation of some of the templates and sample documents that are part of the distribution.

Remember to examine other chapters in the guide for other important information on working in Writer:

- Usage of menus, windows, floating toolbars et cetera is described in Chapter 1.
- Information about customizing the user interface of OpenOffice.org, working with data sources, e.g. for form letters, and about the revision marking function is contained in a separate chapter “Advanced Techniques”.

The OpenOffice.org Writer Functions

This section contains a brief overview of the functionality and capabilities of OpenOffice.org Writer.

Writing
Writer helps users to create all sorts of written documents. One can produce personal letters, form letters, brochures, faxes, and even professional manuals. Documents that are used often can be saved as templates, for example, an invoice form. The spellcheck and thesaurus functions are at one's disposal. If desired, have the AutoCorrect and hyphenation functions active while typing.

There is no restriction to the length of a text document in OpenOffice.org. Use the Navigator to move around easily and quickly within the document. OpenOffice.org Writer comes with a variety of templates for almost every purpose. Also users can create their own using the AutoPilot.

Designing and Structuring
OpenOffice.org offers a wide variety of options to design documents. Use the Stylist to create, assign and modify styles for paragraphs, individual characters, frames and pages. In addition, the Navigator can help create structured texts and also allows modification of the structure, for instance, by shifting paragraphs from one position to another.

Additionally, various indexes and tables can be created in text documents. One can define the structure and appearance of the indexes and tables according to individual needs. Live hyperlinks and bookmarks allow jumping directly to the corresponding items in the text.
Desktop Publishing with OpenOffice.org Writer

OpenOffice.org Writer contains numerous functions to assist in creating perfectly styled documents. Text can be formatted multi-columnar, and have text frames, graphics, tables, etc. integrated into it. The text frames can be linked all over the place, even beyond page limits to create a newspaper format. Functions such as making lines register-true, flow of contours through and around graphics, and defining of characters, paragraphs and tables in any colour complement the tools to lend documents a professional look.

Calculations

Text documents in OpenOffice.org have an integrated calculation function that helps one to execute sophisticated calculations or logical links. Tables in a text document can easily be created in order to perform calculations.

Creating Drawings

Draw, vector drawing tool, lets users create drawings, graphics, legends, et cetera directly in text documents.

Inserting Graphics

Pictures with different formats can be inserted into a text document, including graphics with a JPG or GIF format. The most common formats can be edited directly in a text document with the image editor. In addition, the Gallery provides a collection of clipart graphics organized by theme.

Customizable Program Interface

The design of OpenOffice.org's program interface is such that each user can configure it according to individual preferences. The various windows (Stylist, Navigator, et cetera) can be positioned as floating windows anywhere on the screen and some can be docked to an edge. Visible icons and menus can be customized as well.

Drag&Drop

The drag-and-drop feature enables users to work even more quickly and efficiently with text documents in OpenOffice.org. For instance, one can drag graphics directly from the Gallery into an active document.

Extensive Help Functions

The program provides an extensive Help function which serves as a reference guide to the program elements in OpenOffice.org as well as includes a variety of instructions for simple and complex tasks.
Chapter 3: Managing Text Documents With Writer

The OpenOffice.org Writer Window

Windows® of OpenOffice.org Writer

The above graphic shows the various windows and toolbars available for use in managing documents and where their associated icons are located. For clarity, the windows, listed counter-clockwise, are Insert floating toolbar, Insert Fields “submenu, Insert Object floating toolbar, Form Functions floating toolbar, Draw Functions floating toolbar, Navigation Window, Navigator Window and Stylist Window.
Chapter 3: Managing Text Documents With Writer

Entering and Formatting Text

There is no prescribed sequence in which to work. One can enter text and, let us say, underline it or italicize it while typing or choose to do this later. Users can also decide whether or not to split a section of text into two columns immediately or to delay the action. Text never has to be deleted and retyped simply because formatting needs changing.

Basically, to edit text, first select it and then choose the relevant command, such as the one to format the text in italics. There are several ways of selecting text, for example, using the arrow keys whilst holding down the Shift key, or with the mouse whilst keeping the mouse button depressed. Often there are different ways of choosing a command, for example, with a menu command, with a toolbar icon or with shortcut keys.

Entering New Text

To enter new text:

1. Open an existing text document or create a new one.
2. Enter text using the keyboard.
   
   When special characters, such as the copyright symbol or accented characters that are not available on the keyboard are to be entered, select Insert > Special Character and chose what is needed from the table.
3. Press Enter to begin a new paragraph.

Line breaks

Users never need to worry about line breaks as the software inserts these automatically. Only press Enter at the point to start a new paragraph.

Automatic correction

OpenOffice.org Writer includes a configurable auto-correction tool that can make various corrections while typing. For example, automatically capitalizing the start of every sentence.

Word completion

The automatic word completion function helps when entering text. For example, let's say, there's an often used long word. In this case, Writer suggests a word it recognizes as matching what has been typed so far. If the suggestion is what is wanted, Press Enter (or define another key) to accept it.

Inserting Text

1. Open an existing document.
2. Place the cursor at the point where text is to be added using either the mouse or the arrow keys, and enter the new text.

Insert mode is enabled by default, thus any text, following the insertion point, is shifted as new text is entered. To overwrite the existing text at this point, select Overwrite mode by clicking the INSRT field in the status bar as shown below.
Switching Between Insert Mode and Overwrite Mode

Using the keyboard:
If the keyboard has an Ins key, press it to toggle between overwrite mode and insert mode. The current mode is displayed on the status bar.

Using the mouse:
On the status bar, click in the fourth field from the left, which indicates the current mode, to switch to the other mode:

- **INSRT**
  Insert mode is enabled. The text cursor is a blinking vertical line. Click in the field to enable overwrite mode.

- **OVER**
  Overwrite mode is enabled. The text cursor is a blinking block. Click in the field to enable insert mode.

Default layout of the status bar:

![Status Bar Layout](image)

Note: the area that is clicked to change from insert to overwrite

After clicking

![Status Bar Layout](image)

Entering Text Anywhere on a Page
Writer enables one to enter text at any position within the type area in the text document. This is the direct cursor function:

Click the **Direct Cursor on/off** icon on the main toolbar. Clicking the icon turns the direct cursor on and off. When the icon appears pressed, the direct cursor is enabled.

Click on a free space in the text document. The shape of the mouse pointer shows how the text that is entered will be aligned.

```
Align Left  Center  Align Right
```

Enter the text. OpenOffice.org automatically inserts the requisite number of blank lines, tabs and spaces.

![Cursor Shapes](image)
Selecting and Deleting Text

Some basic steps to start.

Deleting characters

- To delete one character to the left of the cursor, press Backspace (above the Enter key).
- To delete one character to the right of the cursor, press the Delete key (may be labeled Del).

Deleting text

Selecting text to delete with the mouse

1. Left-click to set the cursor on the first character to be deleted.
2. Keeping the mouse button depressed, drag the pointer to the last character to be deleted. The characters will be highlighted.
3. Release the mouse button.
4. Press the Delete key to delete the selected text.

Selecting text to delete with the keyboard

1. Use the arrow keys to go to the first character to be deleted.
2. Hold down the Shift key.
3. Using the arrow keys, move the cursor to just after the last character to be deleted.
4. Release the Shift key. The text is highlighted.
5. Press the Delete key to delete the selected text.

Note: To put the selected text into the clipboard for use later or to put elsewhere in the document, press Ctrl+X rather than Delete. This “cuts” out the text and places it on the clipboard. To paste it back in, wherever and as often as desired, “press Ctrl+V when the cursor is set to the correct location.

Deleting non-adjacent pieces of text.

1. Press Ctrl and keep it pressed.
2. Left-click “to set the cursor at the first character of the first piece of text to be deleted.
3. Press the left mouse button and drag the pointer to the last character of the text to be deleted.
4. Release the mouse button and the Ctrl key.
5. Repeat steps 1 to 4 for each piece of text to be deleted.
6. Press the **Delete** key to delete the selected text.

**Setting the Viewing Zoom Factor**

By right-clicking in the area shown above, the user can select the display Zoom factor for the document. The optimal setting is particularly useful when the Stylist or Navigator are docked and opened, off and on, during a session in that the full width page of text is always displayed.

**Keyboard Navigating and Selection in Writer**

Navigating and selection using the keyboard is done using the arrow keys. One can also use **Home**, **End**, **PgUp** and **PgDn**. Certain keys have different functions depending on whether they are simply pressed or are used in combination with the **Ctrl** key. The following table provides an overview of the keys used for navigation.

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>+Ctrl key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right/left arrow keys</td>
<td>Go one character to the left or right</td>
<td>Go one word to the left or right</td>
</tr>
<tr>
<td>Up/down arrow keys</td>
<td>Go one line up or down</td>
<td>Move the current paragraph up or down</td>
</tr>
<tr>
<td>Home</td>
<td>Go to the beginning of the current line</td>
<td>Go to the beginning of the document</td>
</tr>
<tr>
<td>Home In a table</td>
<td>Go to the beginning of the current cell</td>
<td>1. Go to the beginning of the current cell 2. Go to the beginning of the table 3. Go to the beginning of the document</td>
</tr>
<tr>
<td>End</td>
<td>Go to the end of the current row</td>
<td>Go to the end of the document</td>
</tr>
<tr>
<td>End In a table</td>
<td>Go to the end of the current cell</td>
<td>1. Go to the end of the current cell 2. Go to the end of the table 3. Go to the end of the document</td>
</tr>
<tr>
<td>PgUp</td>
<td>Scroll one page up the screen</td>
<td>Switch to the header and back</td>
</tr>
<tr>
<td>PgDn</td>
<td>Scroll one page down the screen</td>
<td>Switch to the footer and back</td>
</tr>
</tbody>
</table>

**Inserting Special Characters**

This is how to insert special characters (such as check marks, boxes, telephone symbols etc.) in text:

- Select **Insert > Special Characters**, go view the selection of characters available.

- In the large selection field select the desired character or more than one by clicking with the mouse or by navigating by keyboard in succession. The characters are displayed at the bottom of the dialogue box. Upon closing the dialogue with **OK**, all displayed characters in the selected font are inserted in the current document at the cursor.
• If a special character is required in any text input field (such as in the URL field of the function bar or in the input fields in the Find&Replace dialogue), press Shift+Ctrl+S to pop up the Special Characters dialogue.

Inserting Protected Spaces, Hyphens and Conditional Separators

Non-breaking spaces
To prevent two words from being separated at the end of a line, press the Ctrl key while “typing” the space between the words. This is important, for example, between a title and the person’s name.

Non-breaking hyphen
An example of a non-breaking hyphen would be in a company name such as A-Z. Obviously having A– appear at the end of a line and Z at the beginning of the next line is not usually desired. To solve this problem, press Shift+Ctrl+ minus sign. In other words, hold down the Shift and Ctrl keys and press the minus key.

Hyphen, em-dash and en-dash
To enter longer dashes, add the character sequences and replacement under Tools > AutoCorrect/AutoFormat > Replace.

NOTE: There is a Replace dashes under the Options tab but be aware that this selection is for creating paragraph borders when a sequence of three hyphens or three equals signs are entered these are replaced by a single line border and a double line border respectively.

Here is a method to use:

1. Open a text document and place the cursor in a convenient location.
2. Use the Special Character dialogue to find the long (em) dash to use and insert it in the document.
3. Copy the character.
4. Open Tools > AutoCorrect/AutoFormat > Replace.
5. Paste the dash character into the With field
6. Enter the desired character sequence into the Replace field. For example, two hyphens (--) to trigger the replacement.

Now there is a shortcut that defined that automatically replaces the user-defined input sequence with the optional dash selected. This dash can also be in another font.

Manual Hyphenation
Although OpenOffice.org offers automatic hyphenation by entering a separator inside a word, users can override this feature by entering Ctrl+ minus. Thus the word can be hyphenated at the end of the line regardless of the state automatic hyphenation for this paragraph.
Emphasizing Text
There are many ways of emphasizing text in a special way. Here are some of them:

- Use the icons in the Object bar for regular Formatting needs. For example, change the text to bold or to another font style, change the text colour and background, or center the text.

- Whole paragraph can be emphasized using borders. Place the cursor in the paragraph that is to be emphasized, right-click to its context menu and select Paragraph, then click on, for example, the Borders tab. At this point, a border may be selected to frame the paragraph, and also with shadow shading, if desired. If necessary the distance between the border and the paragraph text can be adjusted under Spacing to contents.

- Using a Text Frame, provides the following possibilities:
  a) Text can receive a border
  b) Text can be placed outside of the text margin on the side of the page.
  c) Text frames can be linked when text should flow from one frame to another.

- Choose Format > Paragraph > Background to apply a background colour to the paragraph.

- Use the Draw Text “function: Open the Draw function toolbar (on the main toolbar), select the Text icon, drag open a frame and enter the text. This text can be positioned as desired, which includes rotating at various angles, or curving and slanting the text with the help of Format > FontWork.

Changing the colour of Text
Click the Font colour icon in Writer and other modules, and keep the mouse button pressed to obtain a floating toolbar from which to choose a colour from the range of colours.

Font colour icon. Note the colour is shown in the bar at the bottom.

When using a short-click with no text selected, the mouse pointer changes its appearance to a watering can. Drag this watering can symbol while keeping the mouse key pressed, across the target text area. This text area now takes on the selected colour. The function remains active for as long as the icon is active (looks depressed), or until simply clicking without dragging, or until the (ESC) key is pressed.

Rotating Text
Text can be rotated by entering it into a text frame as follows:
Open the Draw Functions floating toolbar on the main toolbar.

On the floating toolbar, click on the Text icon. The mouse pointer changes to a '+' which indicates that a text frame may defined and opened.

Open up a text frame, release the mouse button and type in any text.

Click on the edge of the text frame. Now see the Draw Object Bar, which contains the Object Rotation Mode icon. Click on it.

Now, if one clicks on one of the handles in the corners of the text frame and drag the mouse, the whole text frame turns with the text.

From the context menu of the Text Frame, a user can start the Position and Size dialogue by selecting the Rotation tab. This allows the precise angle of rotation to be defined numerically.

**Defining Borders**

Borders of pages, paragraphs, tables and other objects can be defined in two places:

- Choose Format > (object name) > Borders where <object name> is page or paragraph.
- In tables, use the Borders floating toolbar on the object bar.

**Choose Format from the menu bar, Borders tab page**

To set a border, select Format > Page > Borders or Format > Paragraph > Borders which opens the following dialogue:
On the left of the dialogue panel is the Line arrangement group. Notice that the four outer edges of the User-defined area are marked with small angles. To edit an outer margin, click in the appropriate position between the small angles. Above this area are four predefined Default borders which may also be used.

In both cases, the selected border elements will be indicated by black triangles. Now now choose a line style or a colour, it will be applied to the selected part of the border.

**Note:** If an empty line is selected in the preview, that is to say, if, one of the three conditions “Line”, “Gray Line” and “No Line”, The condition “No Line” appears, This means that the relevant part of the border will be deleted.

Clicking repeatedly on an element in the **Borders** dialogue switches between three alternative modes:

- The element is displayed as a line
  - Clicking **OK** will apply the format to the element.
  - The element is displayed as a thick black line
  - If **OK** is clicked, the object remains unchanged.
The element is displayed as a line Clicking OK will apply the format to the element.

The element is not displayed Clicking OK deletes the element.

**Use the Borders floating toolbar with Tables**

Suppose the following table border is required for a document:

<table>
<thead>
<tr>
<th>Country</th>
<th>Berlin</th>
<th>New York</th>
<th>London</th>
</tr>
</thead>
<tbody>
<tr>
<td>River</td>
<td>Germany</td>
<td>USA</td>
<td>Great Britain</td>
</tr>
<tr>
<td></td>
<td>Spree</td>
<td>Hudson</td>
<td>Thames</td>
</tr>
<tr>
<td>Population</td>
<td>&gt; 3 Million Citizens</td>
<td>&gt; 7 Million Citizens</td>
<td>&gt; 6 Million Citizens</td>
</tr>
</tbody>
</table>

1. Place the cursor at the position in the document where the table is to be inserted.
2. Choose **Insert > Table** to open the **Insert Table** dialogue, and insert a table of the required size, e.g. 4 columns and 3 rows.
3. Select the whole table by pressing Ctrl+A twice, then click the **Borders** icon on the object bar. On the floating toolbar click the icon at top left, which means “No Border”.

![Borders toolbar](image)
4. Now, with the mouse, select the whole of the first row, open the context menu and choose Table to open the Table Format dialogue.

5. Open the Borders tab page.

6. In the line field select the required line thickness, e.g. 2.50 pt.

7. First select full bordering from the Defaults

8. In the large Line arrangement field, click once in the area between the two top angles (see illustration) to remove the top line and then on OK.

9. Now select the second row of the table and again open the Table Format dialogue by choosing Table in the context menu.

10. Under Line arrangement, click the areas between the two bottom angles (see illustration) to remove the bottom line between the rows and then on OK.

10. Now select the third row of the table and again open the Table Format dialogue by choosing Table in the context menu.

10. Under Line arrangement, click the areas between the two top angles (see illustration) to remove the top line between the rows and then on OK.

11. In the Style field select the required line thickness and click OK.

11. Now the table is finished.
Superscripts and Subscripts
Users have the following options for superscripting or subscripting text:

1. Use the keyboard shortcuts Ctrl+Shift+P and Ctrl+Shift+B.
2. Choose Format > Character > Position.
3. Add the icons for these to the text object bar as follows:
   a) Select Tools - Configure, click on the Toolbars tab, and then click Customize.
   b) In the Toolbars box, select the Text Object Toolbar.
   c) Locate Superscript and Subscript in the Buttons in use list and select them by checking the box next to their names. Use Move Up and Move Down to put them where needed.
   d) Click OK. Icons now appear on the text object bar.

Making text superscript/subscript while typing
Suppose one wants to type 1 $m^2$ (superscript 2):

1. Type the character “m”.
2. Press Ctrl+Shift+P. Ctrl+Shift+P is the keyboard shortcut for superscript text.
3. Type the 2.
4. Press the keyboard shortcut, Ctrl+Shift+P, again to disable superscripting.
   Note: At the end of a paragraph, an easier way to disable superscripting is to press the right arrow key once.
5. Continue entering the text.

Suppose that entering H2O with a subscript 2 is wanted:

1. Type the H.
2. Press Ctrl+Shift+B. Ctrl+Shift+B is the keyboard shortcut for subscript text, Ctrl+Shift+P for superscript text.
3. Type the 2.
4. Press the keyboard shortcut again.
   There is an even easier way when the cursor is at the end of a paragraph: Press the right arrow key once.
5. Type the 0.
Applying subscripts/superscripts retrospectively

Let's say that while proofing text, the text H2O needs to altered to include a subscripted “2” giving \(\text{H}_2\text{O}\). To do so, use either the key shortcut method, described above, or use this method method via the menu command:

1. Highlight the character that should be in subscript/superscript. For example, select the 2.
2. Choose Format > Character. This opens the Character dialogue.
3. Click the Position tab.
4. Select Subscript and click OK.

The 2 now appears in subscript.

Writing in Uppercase or Lowercase

Writer has the following methods for re-formatting text in uppercase or lowercase.

- To display in uppercase: Highlight the text and choose Format > Character > Font Effects tab, and under Effects select Capitals.
- Displaying in lowercase: Highlight the text and choose Format > Character > Font Effects tab, and under Effects select Lowercase.
- Converting to uppercase: Highlight text, then choose Format > Case/Characters > Uppercase or right-click and make the same selection from the popup menu.
- Converting to lowercase: Highlight text, then choose Format > Case/Characters > Lowercase or right-click and make the same selection from the popup menu.

Moving Text Sections in Documents

1. Select the text that to be moved.
2. Place the mouse pointer in the selected text, then press the mouse button and keep it pressed.
3. Drag the mouse until a symbol appears next to the pointer, indicating that the selected area will be moved. In addition, a gray text cursor moves with the mouse pointer, indicating where the selection is to be inserted.

<table>
<thead>
<tr>
<th>Mouse Pointer Shape</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="move.png" alt="Moving" /></td>
<td>Moving</td>
</tr>
<tr>
<td><img src="copy.png" alt="Copying" /></td>
<td>Copying</td>
</tr>
<tr>
<td><img src="link.png" alt="Creating a link" /></td>
<td>Creating a link</td>
</tr>
</tbody>
</table>
To copy the text, rather than move, it, press Ctrl while performing the actions described above. As shown, the action is indicated by a plus sign next to the mouse pointer. One can press and release the Ctrl key as often as needed — the action applies to the condition prevailing at the time the mouse button was released.

**Resetting Font Attributes While Typing**

Users may apply direct formatting while typing text and later decide to reset all formatting and continue entering text using the default format. Text is entered using direct character formatting, to reset the formatting to default, press the right arrow key once which causes the prior text to revert to the default Paragraph Style. Now, continue entering text at the end of the current paragraph.

**Example procedure for resetting Font Attributes**

Suppose one wants to type the words “bold italic”, and set the last two words to bold italic while typing. First type **Enter this in**, then click on the **Bold** and **Italic** icons on the Object Bar followed by entering **bold italic**. To continue with normal setting,, simply press the right arrow key once and finish the paragraph. This is simpler than clicking on the two icons again.

**Chapters in Navigator**

In long documents, use the Navigator to obtain an overview and change the sequence of chapters or their level in the hierarchy of chapters and sub-chapters. The only condition is that “Heading” Paragraph Styles must be applied to the chapter headings (or enter the Paragraph Styles are chosen for headings under **Tools > Outline Numbering**).

To dock the Navigator window:

- Hold down Ctrl and double-click on the gray area at the edge of the Navigator, for example, next to or below the icons.

  This docks the Navigator against the side of the window, or turns it back to a variable window whose size and position can be selected and sized by dragging and dropping with the mouse. The size and position are automatically remembered. Double-click to switch between docked and variable Navigator windows.
the document.

**Quick Formatting Using the Adjacent Paragraph Format**

When there are two consecutive paragraphs with different paragraph formats that should be formatted the same way, do it quickly with the following method:

a) Delete the paragraph mark between two paragraphs.

b) Press Enter.

Both paragraphs now have the same format with the same Style.

---

**Note:** to see paragraph marks, enable View > Non printing Characters

Delete paragraph marks in the following two ways:

1. Go the end of the first paragraph and press the Delete (Del) key. This action merges the second paragraph into the first (known as “deleting to the right”). To turn the text back into two paragraphs, Press the Enter key twice and the second paragraph has the same format as the first.

2. Go to the beginning of the second paragraph and press Backspace (usually above the Enter key). the second paragraph merges with the first paragraph but keeps its format (known as “deleting to the left”). Pressing Enter creates two paragraphs but both have the format of the second paragraph.

**Using Sections**

Sections in OpenOffice.org Writer text documents isolate blocks of text for special purposes. One example their use in Writer is in preparing complete documents using Master documents. Another is in preparing contracts from a set of fixed codicils.

The following are the ways that sections can be incorporated in a Writer document:

- Sections of text that have a different number of columns than the master text.
• Sections protected from further editing.
• Sections that are only to be shown under certain circumstances or hidden.
• Sections that are to be inserted into a document as files or parts of files.
• Sections that can be incorporated into other text documents via DDE

A section must consist of at least one paragraph. When selected text is defined as a section, it automatically ends with a paragraph break.

Another text document may be inserted as a section within a text document. A section from another text document can also be inserted as a section. Sections can be linked, within a single document, to other locations. To insert a new paragraph immediately before or after a section, place the cursor at the very beginning or end of the section and press Alt+Enter.
Sections and Columns

- **Multicolumn section:** A section can contain other sections. This feature allows the user, for example, to create a two-column section on a page of text, and then create a three-column section within that section.

**Multicolumn page:** The page format (Format > Page > Columns), which always applies to all pages with the current Page Style, is independent of the sections.

**Multicolumn frame:** Frames containing columns of text may be inserted. These can be moved freely around the page (from main toolbar, long-click to open Insert floating toolbar, click Insert frame icon). For these frames, for example, one can select that the text in the frame be positioned a certain distance from the edge of the frame (Choose Format > Frame > Wrap).

Inserting Sections

1. Place the cursor at the point to insert the new section, or select the text that is to form a new section.
2. Choose Insert > Section. In the dialogue, define other settings for the section.
3. Click Insert.

Other documents or sections from other documents can be inserted. In this case, Links must be checked. Enter a file name in the text box, or click “…” to search for a file. Select a named section of the document in the Section pull-down list.

When opening a document that contains linked sections, a popup asks the user to update these sections. If the answer is yes, the current versions of the linked sections will be updated.

Under Windows®, the DDE method can be used to keep inserted sections up to date with the current status of the original files. Sections can also be used as files in HTML documents. The inserted sections are automatically updated when OpenOffice.org loads the relevant HTML document again. Web browsers show the content of the sections as at the time the content was saved as an HTML document.

Editing Sections

Edit the sections in the text document by choosing Format > Sections. This dialogue allows the user to protect sections, unprotected sections, reveal hidden sections, change the conditions and remove sections; that is turn them back into normal text.
Formatting Text With and Without Styles

Plain text can be too bland unless one applies visual effects to it, such as giving overall structure to the text, emphasizing individual words, quotations or references or breaking up solid areas of text. Thus the user should consider giving special formatting to sections of text.

Direct Formatting or Formatting With Styles

When working with Writer, choose between direct formatting and formatting with Styles. to apply text attributes such as bold, italics, font type and font size.

Apply direct format by directly setting a certain attribute(s) to the selected text area. For example, clicking the Bold icon on the text object bar directly applies the bold format to a selected text area or to subsequent characters at the cursor while typing. Direct formatting is more appropriate for one time use. If, for example, to make a word bold, just position the cursor in the word and click the Bold icon. This works quickly and intuitively.

Styles, on the other hand, apply attributes to text in an indirect manner. A Style is a labelled collection of default settings that format text. Indirect formatting, with the help of Styles, is much preferable when formatting lengthy documents in a uniform fashion. Styles do require some advance preparation. First create the Style, then apply the Style to the text. Both tasks are best done using the Stylist.

By way of example, let's assume that each of the headings is formatted with a 24 point Helvetica font but this now needs to be changed in all the headings to a 20 point Times font and in bold. Doing this manually requires time and patience; however, had the format been defined as a Style, say with the name “Head1”, that was applied to the headings in the document, one could simply modify the “Head1” Style, and all headings would be automatically changed to match the new settings.
Chapter 3: Managing Text Documents With Writer

The Style Concept in OpenOffice.org

Styles for characters, paragraphs, frames, numbered lists and pages (or cells in tables) are always saved with the document. If wanted, one can copy the Styles of one document to another document and choose whether or not to overwrite (replace) Styles of the same name.

One nice feature of OpenOffice.org is that one can turn any document, including the Character, Paragraph, Frame, Numbering and Page Styles it contains, into a template. When a new document based on this template is opened, all those Styles are available to the user.

OpenOffice.org come with predefined Styles for all document types. Thus, when a new text document is opened using File > New > Text Document, a new, blank document is opened with these fixed settings. One may add or modify the styles used with a document as work progresses and, if desired, this document can be turned into a default template “by saving it via File “-> Templates > Save. Any Styles that are custom defined and are contained in the default template will then apply to all new documents created with this template.

The Styles in the Stylist

Open the Stylist by choosing the Stylist command from the Format menu or by pressing F11 or by clicking the icon on the function bar. All the Stylist functions are explained in OpenOffice.org Help.

At the top of the Stylist are icons for selecting the Style type to display. These are, from left to right: Paragraph, Character, Frame, Page, Numbering Styles, Fill Format Mode, New Style from Selection and Update Style.

The scrolling frame of the Stylist lists those available styles in the active Style category that is specified in the list box at the bottom of the Stylist window.

For example, in the graphic below, the word “Automatic” is selected in the list box. Writer offers the Styles that make sense in that context. To see all the Styles of a Style type, select “All Styles” from the list box.

Paragraph Styles

Select Paragraph Styles, if it is not already selected, by clicking the Paragraph Styles icon in the Stylist. The list of Paragraph Styles appears.
Double-click an entry in the list of Paragraph Styles. The paragraph in which the cursor is positioned will now be formatted with that Paragraph Style. Double-click in the Stylist on another Paragraph Style, and the formatting of the current paragraph changes accordingly.

To format a paragraph as a heading, follow this procedure:
1. Type the line to be formatted as a heading and press the Enter key.
2. Set the cursor in that line.
3. Open the Stylist. For example, by pressing the F11 key.
4. Double-click the Paragraph Style “Heading 1”.

This one paragraph now has the paragraph format “Heading 1”. If one wants to know which attributes are included in this paragraph format, click “Heading 1” in the Stylist, then right-click to open the context menu. Then choose Modify to open the Paragraph Style: Heading 1 dialogue, which tells everything about the properties of this Paragraph Style.

When one decides not to modify this Paragraph Style, simply close the dialogue by clicking the Cancel button. But, this Paragraph Style should define the corresponding modifications then close the dialogue with the OK button. These modified settings will now apply to all paragraphs (old and new) having the “Heading 1”

Paragraph Style.
Changes can also be applied to all Paragraph Styles that are derived from the Paragraph Style “Heading 1”. The Paragraph Styles “Heading 1” to “Heading 10” are all hierarchically derived from the Paragraph Style “Heading”. By selecting “Hierarchical” from the list box at the bottom, one can immediately see where a selected Style fits in the hierarchy of styles. Simply put, the style immediately higher up is the one from which the style is derived and the following one, which is derived from the custom style.
By way of example, if one changes the left indent to 2.54 cm (1 inch) in the Paragraph Style “Heading”, for example, that this will change the left indent for all Paragraph Styles “Heading 1” to ”Heading 10” to 2.54 cm. Changes that users make directly in one of the Style dialogues have priority over the properties “inherited” from higher-ranking Styles. Right click on a style and open it with Modify to get the Paragraph Styles dialogue “and then choose the Organize tab. If the Linked with listbox is checked, one will see from which Style the selected Style is derived.
Character Styles

In the following illustration, the Stylist displays a list of available Character Styles. These Styles do not modify the whole paragraph, but only the single word in which the cursor is currently positioned or a selected text range.

Use or modify the supplied Styles, or define custom Styles and use those. The best way is to start by selecting a Style from the Stylist (with a single click), which may then be used as the starting point for creating a custom Style. One, then, merely has to enter the properties that are different from the selected Style since the other properties are “inherited” from the parent Style.

The following table describes the base Styles and the various attributes available.

<table>
<thead>
<tr>
<th>Style Type</th>
<th>Attribute Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paragraph</td>
<td>Styles Indents and Spacing, Alignment, Hyphenation, Tabs, Font, Language, Initials</td>
</tr>
<tr>
<td>Character Styles</td>
<td>Font, Font Size, Language</td>
</tr>
<tr>
<td>Frame Styles</td>
<td>Position, Anchoring, Borders</td>
</tr>
<tr>
<td>Page Styles</td>
<td>Header, Footer, Margins, Columns</td>
</tr>
<tr>
<td>Numbering Styles</td>
<td>Numbering Type, Outline, Bullets, Assigning Numbering Styles</td>
</tr>
</tbody>
</table>

Hierarchical Styles

Styles can be hierarchically linked to each other. Thus, one defined Style can be derived from another with the result that the new Style contains only the differences from the “basic” Style. This is convenient, if later one changes the “basic” Style, to have all text with the derived Style also updated accordingly.
For example, start with the Paragraph Style “default”. It uses the font “Times New Roman” in “12” point to create a Style called “indented text” where the only addition is a left indent with no other changes. Later, the user decides to change the font in “text body” and then the font is automatically changed in the “indented text” Style as well.

Sticking with this example, if one redefined the left indentation in the “default”, it would have no effect on the paragraphs formatted with “indented text” because, in the hierarchy, the more closely associated format always has priority.

**Numbering Styles**

Simple bulleting and numbering in a document can be easily set using from the icons on the Writer object bar. Likewise, the icons for bold, italic et cetera. can be used to assign direct formatting that is not already part of the Style. The Stylist, too, offers various Numbering Styles that may be applied by double-clicking the name of the Style.

For more control of numbering in a document, use **Format > Numbering/Bullets** which offers several other options that may be more suitable and which can be used to create custom styles.

**Creating New Character Styles or Paragraph Styles**

Creating a new Style on the basis of an existing Style is a straightforward process. The following is a step-by-step procedure with which to start:

a) First of all, apply new, direct formatting to any characters or any paragraph, which will become the Style. To do this, either use the text object bar or open the **Format** menu and choose **Character** or **Paragraph**.

b) Select the text or paragraph containing the new formatting. For words or paragraphs, simply position the cursor in the respective word or paragraph.

c) At the top of the Stylist, click the **Paragraph Styles** icon to create a new Paragraph Style. Likewise, click the **Character Styles** icon to create a new Character Style.

d) At the top of the Stylist, click **New Style from Selection**. This opens the **Create Style** dialogue.

e) Enter a name for the new Style and click **OK**.

As can be seen in the Stylist, a new Style has been created in the “Custom Styles” group making it available for use for indirect formatting in documents.

A user may also create a new Style without using an existing Style as the starting point. Here is a method by which to create a new paragraph style.

a) In the Stylist, choose Paragraph Style by clicking its icon. (the one farthest to the left in the Stylist bar.)

b) Call the context menu of the Stylist (click right mouse button).

c) Choose **New**…

d) Enter the data for the desired Style
Chapter 3: Managing Text Documents With Writer

e) close the dialogue with **OK**.

Yet another example shows how to define a Paragraph Style for a subtitle and assumes there are several subtitles in the text that are candidates for formatting with a custom Paragraph Style.

1. Position the cursor in a paragraph in the text that to format with the new Paragraph Style.
2. Apply a Paragraph Style to the paragraph as an initial format. This way one does not need to define all of the attributes oneself. For example, double-click on the “Heading 1” Paragraph Style in the Stylist.
3. The paragraph is now formatted as “Heading 1.”
4. Highlight the entire paragraph. It will appear highlighted.
5. Modify the type of characters by selecting an italic font in the **Character** dialogue (Choose **Format > Character > Font**) or by clicking the **Italics** icon on the text object bar.
6. In the Stylist, click on the **New Style by Example** icon and enter a name for the new Style in the dialogue box, for example, “Head1”
7. Click **OK**.
8. Now apply the new “Head1” Paragraph Style by placing the cursor in the paragraph and double-clicking the “Head1” style name in the Stylist.

Where the desired Style already exists in a document, select and apply it from the **Apply Style** pull-down list on the object bar.

**Creating Document Templates**

For any user-defined Paragraph or Character Styles to be available in other documents, first create a template. It is best if one uses a current document so that the template will contain all the Styles wanted and needed. The following steps will help create a new template:

1. Have the documents open. If desired, delete all text from the current document, leaving only the Styles.
2. Call the menu command **File > Templates > Save**.
3. In the dialogue **Document Templates**, select the category into which to save the template. In the **New Template** text field, enter the name for the template.
4. click **OK** to complete the process of creating a template.

With the template saved, the next time when **File > New > Templates and Documents** is used to select a template for creating a document, this template will selectable from those available. All the user-defined Text and Paragraph Styles will then be available for the new document.
The Advantages of the Stylist

From the preceding instructions users now know how to apply the Styles in the Stylist to “text, how to apply custom Styles and how to create a template that uses these custom styles. This gives an advantage in that Styles do not have to be redefined every time. Plus one can apply Styles from one text document to another text document by selecting “Format > Styles > Load”. In this way, the desired formatting can be applied to the document quickly and easily. But the Stylist offers still more possibilities.

Formatting Multiple Paragraphs

In the work described above, the same Paragraph Style “Heading 1” was applied to each of several paragraphs. The Stylist can save a lot of time on this task:

1. In the Stylist, select the Style that should be applied on multiple paragraphs by clicking the Style once.
2. At the top of the Stylist, click on the Fill Format Mode icon. The mouse pointer changes to a symbol indicating this mode as soon as it moves back into the document.
3. Click once on every paragraph in the text to which to apply the selected Style.
4. Finally, to switch off this mode, click the Fill Format Mode icon again or press the Escape key.

Changing a Style the Easy Way

The section provides a scenario for making a style change quick and easy. To start one has used the custom Style made in the previous sections to format a document with the new “Head1” Style. However, later, the user may decide that it would look better if the headings were spaced with slightly wider gaps between the letters. The following gives the steps to making this change:

1. Locate the longest heading formatted with the “Head1” Style “in the document and click three times in that heading to select the entire line.
2. Make the desired changes. To lock the character spacing, use this method:
   a) choose Format > Character, or choose Character from the context menu for the selected line.
   b) In the Character dialogue, click the Position tab and in the Spacing list box select “Expanded”. In the spin button, increase the spacing to make the heading wider.
   c) Close the dialogue with OK.
3. Now additional direct formatting has been on one of the headings formatted with the Style “Head1”. All direct and Style formatting should now be added to the “Head1” Paragraph Style. This Style is still selected in the Stylist.
4. At the top of the Stylist, click the Update Style icon. All headings formatted with “Head1” will be automatically reformatted with the modified Style.
Chapter 3: Managing Text Documents With Writer

Styles can also be configured to adapt to any changes automatically. In the properties dialogue for the Style, click the Organizer tab and mark Auto-Update. This allows users to change the formatting of, say, a paragraph formatted with this Style “and have the formatting of all other paragraphs with the same Style “be automatically changed as well.

Page Styles and Page Numbers

Often text documents are created without a page number on the title page but with lowercase or uppercase roman numerals on the pages of the Table of Contents (one does not know how many yet), and to start numbering the rest of the pages with Arabic numerals.

*Note: Different Page Styles are the OpenOffice.org Writer equivalent of “section changes” in other text programs.*

Page numbers are better located in footers or headers rather than in the running text, to ensure that they do not change their position when text is inserted or deleted. The steps below show how to do this:

1. Create a new Page Style
2. Apply the new Page Style
3. Edit the Page Style
4. Use the footer Paragraph Style to format page numbers.

*Note: Do not use the Offset box under Insert > Fields > Other > Document tab to change the page number of a page. The offset is only used, for example, at the end of a page to display the number of the next page, i.e. to offset the display; it does not change the page number itself.*

The manually entered page number (in contrast to the automatically numbered page numbers) is an attribute of that particular page. This property is set as direct formatting in the first paragraph of that page.

Create Page Styles

1. Open the document in which to enter or change the page numbers or begin with a new text document, although users will need to first enter some text and page breaks to be able to follow the steps described here.
2. Open the Stylist. 
3. Select the Page Styles view in the Stylist.
4. Call up the context menu of one of the Page Styles and select the New... command.

One will now see the Page Style dialogue with the Organizer tab page. The cursor will be blinking in the Name text box in which to enter the name of the first new Page Style.

5. Enter Title Page and press the Enter key. The properties of the new Page Styles can be changed later.
6. In the context menu of the Stylist click the **New...** command again and define the Page Style with the name “**Table of contents**”.

7. Repeat the whole procedure again for the new **Main text** Page Style. Of course, the names used here are only meant as examples. In a real situation, one would naturally enter the names of choice.

With the completion of the above steps, there should now be three new Styles that have been created.

1. Place the cursor on the first page of the document. Double-click the **Title page** entry in the Stylist.

So, now the first page is assigned this Page Style. To confirm this, one will see the name **Title page** in the **Page Style** field on the status bar below. By the way, users can also edit (double-click) and assign existing Page Styles via the context menu of the **Page Style** field on the status bar.

If, however, one now scrolls through the pages of the document, it may be noticed that the **Title page** Page Style has been applied to every page. If all the pages had been defined by the **Standard** Page Style, they are now all defined by the new Style. Page Styles always apply to all preceding as well as following pages, unless a page break occurs with a change of Page Style.

On the **Organizer** tab page, if a Next Style for a Page Style is entered, this means that after a page break (whether it is entered manually or occurs automatically) the Next Style will be taken as the Page Style. In the example described here, for the Page Style **Title page** one can select the Next Style **Table of Contents**. The **Table of Contents** Page Style is then always applied to the next page after the title page. This saves a user from having to go through the procedure described below involving the **Manual Break** dialogue.

**Note:** Always choose the **Table of Contents** Page Style as the Next Style to follow the **Table of Contents**, since no one can be sure the number of pages that the Table of Contents will require.

2. Now place the cursor at the beginning of the page where the Table of Contents should begin. Go ahead and enter a manual page break with a change of Page Styles.

3. Select **Insert > Manual Break**. The **Insert Break** dialogue appears.
4. Select as **Type** the **Page break** option. In the list box select the **Table of Contents** Page Style which will then begin at this point in the document.

5. Click **OK**.

6. Place the cursor at the beginning of the first line in the main text.

7. **Choose Insert > Manual Break.** The **Insert Break** dialogue appears.

8. Select as **Type** the **Page break** option. In the pull-down list, select the **Main text** Page Style, which should be applied after this point. Mark the **Change page number** check box and select the new page number 1.

9. Now click **OK**.

**Note:** For headers or footers to contain different contents on the right and left sides, just uncheck the **Same content left/right** check box under **Format > Page > Footer.**
Under **Format > Page > Page**, one can select the **page layout** “mirrored”. This lets the user define an inner and an outer margin for the text. The left and right pages of the main text often have different Page Styles so that, for example, the left pages have a header, but the right ones do not. There are already **Left page** and **Right page** Page Styles provided for use; so use these instead of **Main text**. The first page of the main text is page 1 and contains the **Right page** Style; assign the **Left page** Style as the Next Style and vice versa. These Styles can be assigned to the corresponding pages in the Stylist context menu with the **Modify** command. On the **Organizer** tab page, choose the Next Style.

**Caution:** There is an active issue that inserts blank pages where one least expects them. If this is a problem, please use the workaround at page 404

**Editing Page Styles**

The new **Main text** Page Style “can have a page number in the middle of the footer. To make is so, do the following:

1. Select **Main Text** in the Stylist, right click to open the context menu and select **Modify**.
2. The paragraph Style dialogue window and display the “definitions for **Main Text**.
3. Click the **Footer** tab.
4. Check the “**Footer on** box.
5. Click **OK** which places an empty footer on the document page.
6. Click the mouse cursor in it to enter data.
7. Choose **Insert > Field > Page Number**. If **View > Field > Shadings** is enabled, the page number appears in a gray field otherwise with no shading.
8. To have “Page” precede the page number, place the cursor in front of the field and enter “Page”.
9. Click the **Center** icon on the object bar to center the current paragraph.
10. The appearance of the footer and its contents are now defined.

**Page Breaks as Paragraph Formats**

In the first paragraph of the main text, direct paragraph formatting was automatically applied, determining that the text automatically begins on the new Page 1. This will also apply if no text exists after the manual break on the new page. To check this for the first paragraph after the manual break, choose **Paragraph...** from the context menu (not **Edit Paragraph Style**, since this is a direct formatting attribute for a paragraph).
If a particular paragraph should be on a new page with a new Page Style, then that would be a property of that particular paragraph. Assign this property under **Format > Paragraph > Text Flow**.

**Changing the Format of Page Numbers**

Page numbers may be specified as either direct or as a property of the Page Style just like other text attributes. Using direct formatting, however, should only be employed in a few instances. When direct formatting, one edits the the field directly as follows:

1. Double-click the field with the page number. The **Edit Fields: Document** dialogue opens.
2. Select the desired field format.

3. Click OK.

Better than the direct formatting method, just described, is to make the page number format a property of the Page Style as explained below:

1. Open the context menu on the page and select Page. Then the user will see, for example, the Page Style: default dialogue. Instead of “default”, the title bar of the dialogue contains the name of the current Page Style.

2. Go to the Page tab.

3. In the Numbering pull-down list, determine how the numbering should appear on all pages with this Style.

4. Close the dialogue with OK.

5. Now select the As Page Style format for the field which shows the page number (see the description of direct formats above).

Users may change other properties in the footer, such as the font, by editing the Footer Paragraph Style so that the changes will apply to all footers.

- Place the cursor in the footer. Call the context menu and choose Edit Paragraph Style.

Increasing the spacing of the footer from the text above is also a format attribute of the Page Style:

1. Select the Page Style in the Stylist wanted.
2. Right click and select the **Modify...** command in the context menu.

3. In the **Page Style** dialogue set the desired width and height of the footer.

**Page Styles Summary**

Unlike assigning a Character Style or Paragraph Style, where one first selects the text then double-clicks in the Stylist on the name of the Style to apply the chosen style, applying Page Styles is different.

A Page Style is always a property of the first paragraph of a page whether or not this the first paragraph of the current page or the first paragraph of a previous page. However, not every first paragraph has the **Page Style** attribute. Since this is the case, OpenOffice.org Writer searches for the Page Style attribute of the current page by starting at the current cursor position and continues to search towards the beginning of the document, checking each first paragraph of a page to locate a Page Style as attribute.

To change from one Page Style to another, use the context menu of the field in the Status bar which displays the current Page Style.

Upon right clicking on this field, one gets a popup containing a list of page styles, select the Page style wanted for this page and Writer searches backwards until the first paragraph at the beginning of a page has been found. This paragraph is now be given the newly selected Page Style and this Style will be applied from this point up to the end of the document or until a new first paragraph containing another Page Style is found.
Defining default Templates

Whenever users finds that they are forever changing the formatting of new documents to suit “requirements, it is time to use a separate template. In Writer, this is known as the default template. If the user chooses, this default template can be set so that every time a new text document is opened and this is the template that is employed upon selecting File > New > Text Document. The following demonstrates one way that this can be done:

1. Create or open a document that contains the user's favorite Styles and formatting.
2. Delete the text of the document, as “desired, so that only the Styles and other settings remain.
3. Save the document as template by choosing File > Templates > Save. Doing so saves the document as a template in $HOME/OpenOffice.org<release>/user/template under *NIX and, under Windows®, %HOME%\OpenOffice.org<release>\user\template. This is the user's Default template directory.
4. Select File > Templates > Organize.
5. In the left list box of templates, double-click “default”. The name of the default template that was saved will appear. Click the name.
6. Open the context menu and choose Set as default Template. Close the dialogue. This template will now be used as the default template.
Chapter 3: Managing Text Documents With Writer

Templates and Styles

OpenOffice.org templates are files that one can use as base for creating personal, custom documents, in the manner of a road map. Templates can contain text, logos, other graphic objects and other constructs. Also, every template contains a set of Styles that are viewable in the Stylist. For each document type (text, table, drawing, presentation etc.), a single template file “is defined, called a default template (file). This template is always used as the default when, for example, create a new (usually empty) document with File > New.

Nearly every document type has its own template. Lists of the different templates for text documents can be found in the OpenOffice.org Help about text documents as can those that that apply to drawings, presentations and spreadsheets.

Select Format > Styles > Catalog to open a dialogue which shows the different Styles for the current document. For example, if one opened a text document and called this command, the dialogue will look like this:

![Paragraph Styles dialog](image)

Just as in the Stylist, the type of Styles can be selected from this list box, the Styles belonging to this type modified, custom Styles deleted and new Styles created. However, by clicking Organizer, a dialogue appears with contents similar to the following illustration:
Use this dialogue to copy the Styles contained in a particular template or in a particular document individually to another document. Look at the illustration. As can be seen double-clicking the name of a folder in the left window shows all the templates contained in that folder below it. Double-clicking one of these files causes the two categories Styles and Configuration to appear. Once again, double-click to open a list of the objects contained. But in the case of a document one only sees the Styles that are actually used in that document.

When dragging and dropping elements from one dialogue page to the other, “the mouse pointer shows the location to which the content may be dragged. Either the mouse pointer is a circle with a line through it, in which case the content cannot be moved to that place, or the mouse pointer has an insert line that marks the place where the content will be moved to when “the mouse button is released.

**Creating New Styles From Selections**

Create a new Style by copying an existing Style, as follows:

1. Open the Stylist.
2. In the document, select formatted text or a paragraph that has the format from which to create the new Style.
3. Click the icon on the Stylist function bar.

**New Style from Selection**

New Styles can also be created from a selection by dragging and dropping it:

1. Select the type of Style to be made by clicking the corresponding icon at the top of the Stylist (e.g. Paragraph, Character, Frame, Page or Numbering).
2. Select that part of the paragraph, text or object form which to form the new Style.
3. Drag this to the main Stylist area and release the mouse button over a free area when the insertion line is no longer visible.
Transferring Formats With Fill Format Mode

Applying a new Style in Fill Format Mode:

1. Open the Stylist.
2. In the Stylist, select the Style to copy.
3. Click the Fill Format Mode icon.
4. Position the watering can cursor on the object to which to apply the Style selected.
5. Press the mouse button.

**Note:** There is an exception to this procedure: when applying a Character Style in the Fill Format Mode, select the character with the mouse (watering can) while holding down the mouse button instead of only clicking.

To quit the fill format mode, click the icon again or press Esc.

**Warning:** If the watering can icon is activated, a right-click anywhere in the document undoes the last watering can action. Be careful not to accidentally right-click and thus undo actions that should be kept.

Updating Styles From Selections

**This is how to update a Style:**

1. Open the Stylist.
2. In the document, select a formatted text or paragraph with the format to adopt as a Style.
3. In the Stylist, select the Style to update (single-click, do not double-click!)
4. In the Stylist, click on the Update Style icon:

**Style can also be updated by using drag and drop:**

1. Select the Style to be updated in the Stylist.
2. Select the section of paragraph text, the format of which is to be used to update the Style selected in the Stylist.
3. Drag the text into the main Stylist area and release the mouse button when the insertion line is seen above an entry.

With this procedure, the Paragraph Style directly above the insertion line is given the new format.

Copying Styles into Documents

Load the Styles from another document into the current document.

Choose Format > Styles > Load to select a document. Choose whether to apply Paragraph Styles and Character Styles, Frame Styles, Page Styles or Numbering Styles and whether the original Styles should be overwritten in the current document with the new ones.

In the dialogue, click the From File button to start a dialogue in which one can make a selection like under File > New > Templates and Documents.
Chapter 3: Managing Text Documents With Writer

**Entering and Formatting Text Automatically**

This section deals with certain automatic functions that in entering and formatting text.

**Disabling the AutoCorrect Function**

Writer has functions that are defaulted to correct many common typing errors; however, this behaviour may not always be desirable. Any automatic correction can be reversed immediately after it is made by pressing (Ctrl+Z)

Below is a description of the places in OpenOffice.org where one can disable automatic corrections (and re-enable them):

**ASCII Quotation marks are replaced with Custom Quotes**

1. Open a text document.
2. Choose **Tools > AutoCorrect/AutoFormat**.
3. Click on the **Custom Quotes** tab. Uncheck **Replace**.

**Sentences always begin with a capital letter**

1. Open a text document.
2. Choose **Tools > AutoCorrect/AutoFormat**.
3. Click on the **Options** tab. Unmark **Capitalize first letter of every sentence**.

A word is replaced with another word

1. Open a text document.
2. Choose **Tools > AutoCorrect/AutoFormat**.
3. Click on the **Replace** tab. Look for the word pair and delete it.

**Three identical characters will become a whole line**

When three of the following characters ( > _ = * ~ #) are entered at the start of a new paragraph and **Enter** is pressed, a page-wide line of various thickness results:

1. Open a text document.
2. Choose **Tools > AutoCorrect/AutoFormat**.
3. Go to the **Options** tab. Uncheck the **Apply border** check box if this automatic conversion should no longer occur. The line is a border of the previous paragraph. Choose **Format > Paragraph** to edit or delete it.

**Automatic Spellcheck**

- From within a text document, click the **AutoSpellcheck on/off** icon on the main toolbar. All words marked as incorrect by the spellchecker will then be underlined in red.
• Click on words underlined in this way with the right mouse button. A context menu then appears.

• The context menu often provides a list of suggested words, one of which one may click to select it. The suggested word then replaces the word underlined in red.

If the wrongly typed word is replaced using the AutoCorrect function in the context menu, the word pair will be entered in the AutoCorrect replacement table. To call up this table, choose Tools > AutoCorrect/AutoFormat > Replace tab.

If the word underlined in red is correct, it can be stored in a custom dictionary using the Add command.

To exclude words from the spellcheck:

1. Select the words.
2. Open the context menu of one of the words.
3. Choose Character.
5. Now select the language [None].
Using AutoText

Writer contains an AutoText function which helps users to use shortcuts and abbreviations to add expanded strings to letters, faxes or any other OpenOffice.org documents.

To insert AutoText do the following:

- Enter the shortcut for an AutoText item and press the F3 key.

  There is a set of predefined AutoText blocks already in existence. For example, enter DT and press the F3 key to insert a dummy text which can be used to check the look of a page filled with text (and other objects). Likewise entering FN and pressing F3 will insert an OpenOffice.org Math formula that is sequentially numbered at the right page margin.

- Choose Edit > AutoText.

  The AutoText dialogue contains a number of AutoTexts. As can be seen, AutoTexts can even contain graphics and tables.

Long-click on the Edit AutoText icon on the main toolbar and select an AutoText category as shown below:
Use the left mouse button to select the AutoText for insertion. Upon releasing the mouse button, the text is inserted in the text at the cursor position.

![Image of AutoText dialog box]

Note: Use the AutoComplete function in a similar manner. Directions for doing this function are found in Help.

**Defining AutoText**

Write the desired text. It may contain formatting and embedded graphics. Select the text. Now, click briefly on the **AutoText** icon in the Main Toolbar. In the large list box, select the category (e.g. 'default'), assign a name for the new text component in the text box and correct the abbreviation if necessary. Now save the text component via **AutoText > New** and close the dialogue.
Using AutoText in Networks

AutoTexts from can be used from different directories. An example would be in a typical
OpenOffice.org network installation:

Read-only “company AutoTexts” could be in a directory on the server and user-defined
AutoTexts in a user's own files. Both are read and used while typing.

- Choose Tools > Options -OpenOffice.org > Paths. Double-click AutoText.

Two paths are entered here. The first path will take the selected AutoTexts from the server
installation while the second path takes the AutoTexts from the user directory. When two
AutoTexts from the different directories have the same name, OpenOffice.org uses the
AutoText from the user directory.

Printing AutoTexts

To print a list of all AutoTexts, run the AutoText macro from the OpenOffice.org Basic
Gimmicks library. This macro lists all AutoText names and shortcuts in a new text document.

1. Select Tools > Macros > Macro >
2. Double-click “Gimmicks” in the right list of the Macro dialogue.
3. Select “AutoText”
4. Click Run.
AutoText With AutoComplete

To enable AutoCompletion of selections in the AutoText dialogue, check **Display remainder of name as suggestion while typing**.

![AutoText Dialogue](image)

So while typing, enter a word in the text that exists as an AutoText name, this sequence is recognized after the third matching letter is typed and a **Help** tip appears containing the whole name of the AutoText entry. If the offering is acceptable, press **Enter** to insert the AutoText.

**Note:** **Help** tip sometime contain several AutoText names that begin the same way, use **Ctrl-Tab** to scroll forwards and **Shift-Ctrl-Tab** to scroll backwards through the list to select the text wanted.

Exceptions in AutoCorrect

Should AutoCorrect correct a word that is entered but this correction is not wanted, “restore the original word by using the **Undo** function. This action will also add the word to the list of exceptions in AutoCorrect proving that **AutoInclude** is checked in the **AutoCorrect** dialogue. (By default it is checked.)

**Example**

By default, AutoCorrect automatically corrects two capitals at the start of a word. However, in the case of product names and other similar texts, two initial capitals may exactly what is needed.

Suppose there's a new product called “**Est**”. Under normal settings, AutoCorrect automatically changes this to “**Est**”; however, by pressing the **Ctrl-Z** key sequence “the automatic replacement is reversed (undo) “and the word “**Est**” is automatically added to the list of exceptions in the **AutoCorrect** dialogue.

**Note:** See also the functions for automatic numbering of headings in **Help**.
Moving Text, Drawing Lines

Making text look as good as it as reads is likely something desired. To achieve this, users can customize its appearance for maximum impact.

Inserting, Editing and Linking Text Frames

A text frame is a bounded area that can contain text, graphics and other objects and be placed anywhere on a page; for example, to make columns for a newsletter.

Linking the content of a frame to another, let's the text flow backward and forward between them.

Click the edge of any text frame to select it and eight handles appear, four of which are located in the corners and one in the middle of each side.

Inserting Text Frames

Existing text into a may be put into a frame or an empty frame opened into which text can be added later. Following these steps to create a frame. If using existing text, highlight the text for the frame then proceed as shown below:

1. Long-click the Insert icon on the main toolbar and open its floating toolbar.

2. On the Insert floating toolbar, press the mouse button on the Insert frame manually icon to open the column preview.

3. In the preview move the mouse point to select the desired number of columns.

4. With the crosshair cursor, create a selection frame to define the new location and area for the paragraph. Press the Escape key to cancel frame formation.

Any text that was highlighted is now automatically deleted from the normal, continuous text and inserted into the text frame.
Editing Text Frames

Select a text frame by clicking on one of its edges. Once selected, a user can drag and drop to change its position by grabbing an edge and thus move the whole frame. If one does the same action using one of the handles, the size of the frame changes. So, dragging a handle on one of the sides enlarges or compresses the text frame in one direction only, whereas dragging a corner handle enlarges or reduces it in two dimensions.

Right clicking within a selected frame popups the context menu. Th options in this menu allow one to make further adjustments.

As seen in the above graphic, a number of selections can be made. For example, choose “Alignment” which positions the frame relative to other frames, drawing objects, graphics et cetera. Use the Wrap submenu to choose if normal text should wrap around the frame, wrap on one of the sides or not wrap at all. Selecting Frame in the context menu is the same as choosing Format > Frame from the menu bar and opens a dialogue that gives access to managing all properties of the frame.

The contents and functions available for use in text frames are the same as in text documents and can contain pictures, multiple columns, tables, drawings et cetera.

Linking Text Frames

Several text frames may be linked to each other “over different pages of a document. The text “automatically flows from one to the next.

1. In order to create a link, click the edge of the frame to be linked. Eight handles appear around the edges.
2. Click the Link icon on the object bar.
3. Click the frame that is to be linked.

When a linked frame is selected, any existing links are indicated by a connecting line.
Note: The height of a frame that is linked with a subsequent frame is automatically fixed. The height is no longer automatically adapted to the content of the frame. Only the height of the last frame of a chain can be adapted to the text content.

Click the **Link** of the object bar when a frame is selected and the cursor changes. The cursor can display as one of two icons: a chain with an arrow when two frames can be linked by clicking, or a chain with a stop sign when linking is not possible where the cursor is positioned. A note is displayed in the status bar in each case, for example, why linking is possible or not possible.

Note: Linking is only possible from one frame to the next. That means that a frame that is already linked to a frame cannot be linked to another frame which follows. Therefore, the link icon cannot be activated if a frame already has a next link. Also, two frames can only be unlinked with the **Unlink Frames** icon from the first frame.

Linking of frames cannot happen under the following conditions:

- The target is not empty. Automatically captioned frames are not considered empty and, thus, can not be the target of a link.
- The target already has a previous link.
- Source and target are in different sections. For example, one frame is in a header and the other frame is in a footer.
- The source already has a next link.
- Source and target are the same.
- Closed chains or chains from the inside out or from the outside in are also not permissible. The latter is the case if a frame is inserted into another frame and these must be linked with each other.
Using Text Animation

Writer's Text Animation feature enables composition of applications with coloured, animated text. For example, for a simple web site. The following step-by-step procedure shows how to do it:

1. Open a new, blank OpenOffice.org Writer document.
2. Select Format > Page to select a background for the whole page.
3. Open the Draw Functions floating toolbar from the main toolbar.
4. Click the Rectangle icon.
5. Create a rectangle in the center of the page.

6. Open the context menu for the selected drawing object by right clicking in the rectangle.
7. Choose the Area command to assign a colour or pattern to the area inside the rectangle.
8. On the left side of the Area tab page, select the option Gradients and choose e.g. “gradient 4”.
9. Close the dialogue with OK.
10. Open the context menu once more.
11. Select the **Line**... command to define the border properties of the rectangle and choose a colour and a width.

![Image of Line dialog]

12. Close the dialogue with **OK**.

13. Double-click in the middle of the rectangle and enter any text regardless whether the text extends beyond the width of the rectangle or not.

14. Click again on the border of the rectangle in order to select it.

15. Open the context menu and select **Text**.

16. In the **Text** dialogue, click the **Text Animation** tab.

17. Under **Text Animation**, select **Effects**

18. Select the pull-down list the option “Scroll Through”.

19. On the **Text** tab page, set the distance from the left and right borders. (The border of a frame goes half inside and half outside.)

20. Click **OK**.

21. Now undo selection of the rectangle by clicking on another place in the document. In a moment the text animation will start to run.

22. To alter the size of the animated text, select the rectangle again and double-click in the center. Now select the text and apply a larger font size.
23. A suitable text colour can also be chosen by opening the context menu and choosing \textbf{Character}.

\textbf{Note:} Enlarge or reduce the page view either by choosing \textit{View} > \textit{Zoom} or via the context menu of the scale field on the status bar. If the screen display is to be refreshed, press \textit{Shift}+\textit{Ctrl}+\textit{R}. 
**Drawing Lines in Text**

Any lines that are incorporated in a document can have attributes defined, such as the angle, width, colour, et cetera, however the user chooses.

- Create a horizontal line suitable, for example, for a website, by applying the preset Paragraph Style **Horizontal Line**. Place the cursor on a blank line and double-click the **Horizontal Line** Style in the Stylist. If the entry for horizontal lines is not visible in the list of Paragraph Styles, switch the view in the Stylist from “Automatic” to “All Styles”.

- Draw a line above, beside or below a paragraph by choosing **Format - Paragraph > Borders**. This function is explained in detail in the OpenOffice.org Help.

- To personally define the line attributes and direction, use the **Line** drawing object as follows:
  1. On the main toolbar, long-click the **Show Draw Functions** icon to open the **Draw Functions** floating toolbar.
  2. Click the **Line** icon. The mouse pointer changes to a cross-hair symbol with a line beside it.
  3. In a document, locate where the line should begin, click, hold down the mouse button and drag to the point where to end the line. Holding down the **Shift** key, restricts drawing to horizontal, vertical, and diagonal lines only.
  4. Release the mouse button once the line has the desired direction and length.
  5. To draw more lines, repeat steps 2 and 3.
  6. End this function by pressing the **Esc** key or by clicking the **Selection** icon from the **Draw Functions** floating toolbar.
  7. Once all lines are complete, select all of the lines at the same time by clicking each line while holding down the **Shift** key. By using this multiple selection method, one can assign all of them a common colour, width or any other attribute as needed.

**Note:** If these lines or other draw objects are exported in a text document to HTML, Be aware that such objects "are not defined as part of the Internet page description language HTML and are therefore not exported directly into HTML format but "are exported as graphics."
Editing Text With FontWork

The **FontWork** program module is used for graphical text effects in a similar manner to the WordArt® function available with Microsoft Office. If this functionality is needed, here is the procedure to follow:

1. Open the **Drawing Functions** floating toolbar from the Main toolbar.
2. Select the **Text** icon.
3. Draw a text frame on the page.
4. Enter the “text, for example “**FontWork”**.
5. Choose **Format > FontWork**. This opens the **FontWork** window, from which to select the desired effects:

![FontWork window](image)

6. Click the upper-left icon with the semicircle to display the text as a curve.
7. Click **Vertical** in the Shadow options. Specify 0.10 inches for the x-axis shadow distance. The text should now appear similar to the illustration.

8. Since the first and last letters may not be easy to see, insert two blank spaces before and after the text. double-click the text, edit it, and then click outside the object.

9. Selecting the **FontWork** object causes eight handles appear which can be used to change the size and shape of an object. For example, drag one of the handles in the desired direction.

10. Finished **FontWorks** objects can be copied to the clipboard and so pasted into other documents for modification, sizing or other attributes.
Aligning Text With Lines

Aligning text on a free form line
1. Draw a free form line using the free form line function on the Draw Functions floating toolbar.
2. Double-click on the line.
3. Enter the desired text or copy it from the clipboard.
5. Click for example on the Rotate icon.

Aligning text with straight lines
Slanting text so that it follows an angle from one point on the text page to another point uses a similar procedure to aligning text on a free form line. Here's how:
1. Using the draw functions, draw a straight line from one point to another.
2. In the list box on the object bar, select the line style “Invisible”.
3. Double-click on the line, which is now invisible (but the two ends may still be seen).
4. Double-click exactly between them.
5. Enter the text.
6. Click outside the line object.
The Navigator

The Navigator is another important feature of OpenOffice.org that, along with the Stylist, that helps manage formatted documents.

Activate the Navigator by clicking the corresponding item in the Edit menu.

In particular, the Navigator helps one to navigate, or move accurately, to the parts of a document required and provides detailed information about the content of the document in an understandable manner.

In text documents, the Navigator provides complete lists of all heading, graphics, “tables et cetera in a document. Simple navigation, such as going straight to a specific place in a document, only requires double-clicking the desired entry in the Header list. Besides simple navigation, the Navigator can do much more in assisting users to manage documents. For example, a document is structured using headings, through the Navigator, a user can change the sequence and hierarchical levels of whole chapters and sub-chapters quite easily by clicking the appropriate icons in the Navigator.

The Navigator can be docked to the edge of a window by dragging its title bar while pressing the Ctrl key. Undocking the window is easily done by pressing Ctrl and double-clicking in a vacant area of the Navigator.

Jumping From One Object to Another in Text

Clicking the Navigation icon at the top of the Navigator opens a “mini navigator”.

---

OpenOffice.org User Guide
Chapter 3: Managing Text Documents With Writer

This Navigation panel has functions to allow movement in a document from, say, one graphic object to the next one or to the previous one. To enable this feature, first grab the the blue title bar of the navigation floating toolbar and drag it to a position outside of the Navigator. Now the arrow icons will be visible at the right side. Just click the "Graphics" icon and then either the Previous graphic or Next graphic arrows. This also works for tables, frames, sections, and so on. A plus sign in front of one of the entries indicates that there are corresponding objects in the selected document and that the list of the objects of this type can be shown by clicking the plus sign or double-clicking the entry. Double-click one of the object names to display it in the document and move the cursor to that position.

Another way to access the ““mini navigator” can be found in the vertical scroll bar at the bottom right-hand side of the document window. As when accessing Navigation from the Navigator, click the object type to which to jump “and then click one of the arrow icons to go to the previous or next object of this type in a document.

When the Navigator double arrows in the scroll bar appear black, a user can move through the document page-by-page. Likewise, if the arrows appear blue, one can search to each object of the same category that has been selected in the Navigator (for example, to each table or bookmark, and so on). Similarly to the main section of the Navigator, there are icons for Headings, OLE objects, Hyperlinks, References, et cetera.

Names of any of the elements in the Navigator can be easily modified: The context menu for that name (right-click the name) provides the command for renaming.

**Jumping From One Reminder to Another**

Use the Navigator to set temporary reminders that stay in effect until the document is closed. This is handy if looking up or adding something later as it makes it easy to move between particular locations in the document. For example:

1. Position the cursor where to set a reminder.
2. Click the Set Reminder icon in the Navigator. The reminder will not be visible in the document.
3. When jumping to a reminder, select the Reminder entry in the ““mini Navigator”” and one can now move through the reminders by clicking the Previous and Next arrows.

**Jumping to a Specific Page**

Moving quickly to particular pages in long documents is easy even if the Navigator is not opened or docked. Double-click the current page number on the status bar, and the Navigator opens. Double-clicking the display field on the status bar closes “the Navigator. “However, if the Navigator is docked, these “actions close and dock window.

Enter the number of the target page number into the spin button at the top of the Navigator panel. Once the page number is selected or entered, press Enter and the cursor is automatically placed on that page.
A keyboard shortcut, Ctrl+Shift+F5, opens the Navigator when it is inactive and moves the cursor to the spin box where the desired page number may be directly entered. In the case where the Navigator is docked, this key sequence simply places the cursor in the spin box. Now press the Enter key to go directly to the chosen page.

**Note:** Changing to a new page does not need to done with the cursor. Enter a page number in the Navigator spin box and wait one or two seconds and the respective page will appear. By entering another number, that page ‘appears. The cursor is placed on the page only by pressing the Enter key.

**Other Navigator Features**

When one wants to know about the objects in a document, the Navigator can be very helpful, particularly in longer documents. For example, there is an HTML page open, the Navigator tells at a glance which hyperlinks the page contains including any hidden hyperlinks. However, hidden hyperlinks will be without reference text.

Use the **Content View** of the Navigator to help organize and rearrange whole chapters with their sub-chapters, so long as these have been formatted with one of the chapter numbering Styles. For detailed instructions, refer to the OpenOffice.org Help.
**Indexes and Tables of Contents in Writer**

Writer documents can contain any number of predefined or user-defined indexes. For example, users can have a table of contents, alphabetical index, illustration index and/or bibliography. There are some limitations:

1. Additional styles cannot be hyperlinked. This is true for all 1.1.x releases. The reason for this missing feature (or concept bug, whatever one may call it...) has been correctly described by Laurent Godard in Issue Tracker, 3356.

2. Default settings for indices may not be what is needed for a document and should be checked.

**Defining Index/Table of Contents Entries**

The first step in preparing indexes, such as a table of contents or other index, is to determine which entries in the document should be included.

First define entries for the index(es) as entries in the document in the following manner:

1. Select the word or words in the document which are to be listed in the index. Several words can be selected by holding down the Shift key if they are listed one after the other, or by holding down the Ctrl key if they are spaced apart. When selecting a single word, simply position the cursor in the word — it does not need to be highlighted.

2. Enter the selected words in an index by choosing Insert > Indexes and Tables > Entries. If a different term to appear in the index, enter it in the Entry field. For example, one could enter “dictionary, defining”, whereas only the word “dictionary” appears in the text.

To define all similar words in a text as entries, select Insert - Indexes and Tables > Entry and check Apply to all similar texts.

To include the words in a separate index with a name of one's choice, click on the New User-defined Index icon in the Insert Index Entry dialogue. This opens a dialogue in which to enter a name for the index. This name later appears as the title of the index. The title of an index can be changed without the content of the index changing.
Editing or Deleting Index and Table Entries

All defined index entries are shaded gray in the document for easy recognition but, which is never be printed. If display of the shaded entries on-screen is unwanted, switch the highlighting on or off using View > Field Shadings.

1. To edit an entry, place the cursor immediately before or inside it.
2. Then choose Edit > Index Entry.
3. Alter the text in the Entry text box as needed.
4. Click on the Delete button to delete this entry from the list.

If the displayed text of the entry is “modified, the altered text is inserted into the generated index. Only a thin gray mark in the document remains where the entry was. To edit an entry such as this, place the cursor directly after the thin mark and choose Edit > Index Entry.

Use the arrow buttons in the Edit Index Entry dialogue to switch to the next or previous entry of the same index type.

Creating a Table of Contents

1. Place the cursor at the location at which to create the table of contents.
2. Choose Insert > Indexes and Tables > Indexes and Tables. The Insert Index/Table dialogue appears. Click the Index/Table tab and select “Table of Contents” as Type (the first time this dialogue is started, this tab page and type are already selected).
3. Click on OK to create the table of contents from the headings and entries already defined.
4. To insert additional paragraphs of another Paragraph Style into the table of contents, check Additional Styles
5. Click the icon next to the box to open the dialogue
6. Define the Paragraph Styles that are also to appear in the table of contents and the level they are to be shown.

When changing headings, rearranging their sequence or inserting new chapters, remember “to update the table of contents as follows:

- Place the cursor in the Table of Contents.
- Right click to active the context menu
- Select Update Index/Table.
- Select Tools > Update > All Indexes and Tables to update all the indexes and tables of contents in a document.

Creating Alphabetical Indexes
1. Place the cursor in which to create the index.
2. Select Insert > Indexes and Tables > Indexes and Tables.
   The Insert Index/Table dialogue appears.

3. On the Index/Table tab, select “Alphabetical Index” in Type.
4. Click OK to generate the alphabetical key word index using the default settings.

There are several options that can enhance the usability of any index. e.g. To highlight “letters under which entries exist as subtitles (“alphabetical delimiter” in the Entries tab), to allow case-sensitivity to be taken into account when sorting and much more.

Editing the Paragraph Styles in the Stylist is the best method for changing the formatting of the individual lines in the index as all direct formatting is overwritten at the next update.
Using a Concordance File

A concordance file is a variation of an index in that it provides exact references to words in the document and permits cross-referencing and sub-indexing. Thus a concordance file contains a number of key words and information as to how these words are to be seen in an index.

1. Choose Insert > Indexes and Tables > Indexes and Tables.
2. On the Index/Table tab page, select the type Alphabetical Index.
3. Mark the Concordance file check box.

Click the File button to select whether to open, create, or edit a concordance file. Further information on the structure of the concordance file can be found in OpenOffice.org Help.

Creating User-Defined Indexes

Users can create as many user-defined indexes as needed.

Open Insert > Indexes and Tables > Entry
Select User-defined from the Index list box

1. Click the New User-Defined Index icon in the dialogue
2. Name the new index.
3. Click OK
4. Add entries for this new index.
5. Finally create the index in the document:
   a) Position the cursor on the place where the user-defined index is to be created.
   b) Choose Insert > Indexes and Tables > Indexes and Tables.... to open the dialogue Insert Index/Table.
   c) Select the “user-defined” type in the Index/Table tab. If the user-defined index has been given a name, select this name from the Type list box.
d) Give the index a title

e) Check the **Styles** box

f) Click the “icon

g) Choose one of the Styles that is used in the document from which to generate the index of all paragraphs having the corresponding Style.

h) Mark the other check boxes under **Create from** to create the index from all the objects of a certain type.

i) Assign names to the objects in the **Options** tab of the corresponding property dialogue.

j) Click **OK** to generate the index from marked entries.

**Creating Bibliographies**

Bibliography entries are often in the form of: “Smith [Smith 1995] has also carried out research on this matter” or similar so that “the reader knows that more detailed information can be found in the bibliography under “Smith 1995” with the full name of the author, title of the book, publisher, date of publication and a myriad of other possible terms.

Decide what details should appear in the bibliography and then use **Insert > Indexes and Tables > Indexes and Tables** “with a **Type of Bibliography** to define how the entries will look when displayed.

Select **Tools > Bibliography Database** to open the bibliography database. Examine the columns and find one labeled **Type** then use different entries for magazine articles than for entries concerning books. For this reason the bibliography database is divided into different **types** of sources of literature. A new record can be inserted in the **Insert Bibliography Entry** (by clicking the **New** button), but these “ad hoc” records will be saved only in the current document, not in the Bibliography Database, and then only if “the relevant new entry is actually inserted.
1. To insert the bibliography entries into the text, position the cursor in the text where the entry is to appear and then choose Insert > Indexes and Tables > Bibliography Entry. The following dialogue will appear:

![Insert Bibliography Entry dialog]

2. First decide whether to select the entry from the records contained in the bibliography database or from the entries that are contained in the current document (and which can differ from entries of the same name in the bibliography database). An entry in the document content can be identical to an entry in the Bibliography Database. The entry in the document has precedence.

3. If the required entry already exists as a data record select it in the list box Short name and click Insert. If the desired entry does not yet exist, create a new entry. If the New button is used to do this, one can define a new record, but this will only be recognized in the current document.

   If the record should be included in the bibliography database, choose Tools - Bibliography Database, enter the new record and then insert the bibliography database entry in the document.

### Updating, Editing and Deleting Indexes and Tables of Contents

Indices and Table of Contents are snapshots of what is present at the time they are created. Obviously there are occasions when these need updating, editing or deleting. The following instructions give the steps needed to accomplish any of the above tasks.

1. Place the cursor in the index/table and right click to call the context menu.

2. Select the desired command:
a) Update Index/Table
b) Delete Index/Table
c) Edit Index/Table
d) Edit Paragraph Style

**Note:** (d) Edit Index/Table is only available if Insert > Indexes and Tables > Indexes and Tables > “Index/Table” > “Protected from manual changes” is selected. This is because, by default, indices and tables of contents are protected from changes.

### Editing the Format of an Index/Table of Contents

The Entries tab on the Insert > Indexes and Tables > Indexes and Tables dialogue permits editing the format of an index. In this tab, alter the way in which entries, tab stops and page numbers are arranged et cetera. Using the Styles tab, assign other Paragraph Styles. For detailed instructions, refer to the OpenOffice.org Help.

Hyperlinks can be automatically assigned to the entries in the table of contents using the following method:

1. Go to the Entries tab page,
2. Place the cursor in the structure row before the entry <E #>
3. Click the Hyperlink button, then place the cursor after <E> and click Hyperlink again.

Where the list is a table of contents for the document, click a hyperlink to go straight to the first occurrence; however, the table of contents must be generated from headings.

### Indexes Covering Multiple Documents

There are several ways of creating an index covering multiple documents:

- Create an index in each individual document, then copy the indexes into a document and post-edit them.
- A more elegant solution is to select each individual index as a section (Insert > Section) and insert these sections in a common index document as a link.
- If one is working with a master document, common indexes are possible across all sub-documents.

More information about master documents can be found later in this manual.
Chapter 3: Managing Text Documents With Writer

Headings and Numbering

Most text documents benefit from use of headings and numbering. Writer provides “automatic functions that help the user manage the structure and formatting of documents via headings and numbering.

Numbering and Numbering Styles

Numbering in a document may be applied either as direct formatting or by using a Style, in the same manner as is done with other paragraph attributes such as “Justified” or “Line Spacing”. The icons on the numbering object bar and the options in the Format > Numbering/Bullets dialogue apply direct formatting. Direct formatting is also applied when automatic numbering is used via the AutoFormat/AutoCorrect function.

Note: The AutoNumbering of AutoCorrect is not applied to the Styles listed in the Stylist under “Special Styles”.

A Numbering Style can be applied as part of certain Paragraph Styles or applied directly to the paragraphs. With the former case, one can take advantage of the paragraph formatting system for numbering as well. Changing a Numbering Style ensures that all numbering created with this Style will be automatically reformatted. The Numbering Styles are described in the OpenOffice.org Help.

Turning Bullets On and Off

Bullets may be turned on and off in a document. The following is one method to turn a bulleted list on and off:

1. Place the cursor in a paragraph to be marked with a bullet symbol, or select a number of paragraphs.

2. Click on the Bullets on/off icon on the Text Object Bar. The paragraph or paragraphs will be formatted as a bulleted list.

3. In an existing bulleted list, if one clicks the Bullets on/off icon, the paragraphs will turn back into normal text.

4. In a bulleted list, clicking on the icon at the far right of the object bar changes the Text Object Bar to the Numbering Object Bar which contains icons for moving and rearranging numbered paragraphs. By opening the context menu on the object bar, users can also select which bar to display.
One can select further settings for the bulleted list in which the cursor is positioned with the **Format > Numbering/Bullets** dialogue.

- Choose different bullet symbols under **Format > Numbering/Bullets > Options** by clicking on the button with three dots. This opens the **Special Characters** dialogue but only if **Bullet** was selected in the **Numbering** pull-down list.

**Turning Numbering On and Off**

Turning numbering on and off can be accomplished as follows:

1. Highlight the paragraphs to be numbered or returned to normal text.

2. Click on the **Numbering on/off** icon on the Text Object Bar. The paragraphs are formatted as a numbered list or, with an existing numbered list, the paragraphs will turn back into normal text.

Numbered lists are best controlled in the same manner as bulleted lists, i.e. with the icons on the Numbering Object Bar. When a numbered list is moved down a level, the subordinate numbered list at this level starts from one again. Using the **Show sublevels** box in **Format > Numbering/Bullets > Options**, select which previous levels should be included in the numbered list.
**Example numbered list with sublevels:**

1. Line one
2. and line two
   1. and a sub level of line 2

The above list is not numbered as fully as it might be but serves as an example. Normally the full number of the last line should indicate the sublevel as 2.1 as well. To do this apply **Format > Numbering/Bullets > Outline** to that level. This will be reflected in **Format > Numbering/Bullets > Options**.

**Outline Numbering**

Choose **Tools > Outline Numbering** to number headings automatically. By default, the Paragraph Style “Heading 1” is assigned to the highest level of **Outline Numbering**.

For custom Paragraph Styles “that should be used, apply these styles in this dialogue on each individual level.

![Outline Numbering Dialogue Box](image)

**Note:** If a Numbering Style is selected from the **Number pull-down list**, then all paragraphs in a document that have the “Heading 1” format will have consecutive numbers placed in front of them.

With respect to custom style s where there is, currently, a Paragraph Style “Head1” that is used for headings at level 1.

1. In the **Level** list box select 1
2. In the **Paragraph Style** pull-down list select **Head1**.

3. Click **OK**.

Now, all paragraphs to which **Head1** is applied will be listed in the Navigator under “Headings”.

Remember that chapters can be rearranged the in the Navigator (see the section on the Navigator) when changing their order or their placing in the hierarchy. Using this feature also updates the numbering.

Click on one of the icons **Promote Chapter**, **Demote Chapter**, **Promote Level** and **Demote Level**,

or

- Move the chapter heading in the Navigator using the mouse.

The result is that numbering of all affected chapters is adjusted automatically.

**Automatic Numbering/Bullets**

Writer also automatically recognizes bullets and numbering during entry if **Format > AutoFormat > While Typing** was previously chosen. Numbering that uses Roman numerals is also recognized and continued.

*Note: A list can start with any value: e.g., it does not have to begin with I.*

A step-by-step example with Roman numerals:

1. Enter **I.** (with a period after it), also followed by a space and text. A right parenthesis may also be used as a substitute for a period.

2. Press the **Enter** key to create a new paragraph.

3. The new paragraph will begin with **II.**, i.e., the Roman numeral for two.

4. Enter some text, press the **Enter** key and the next paragraph will begin with **III**.

5. Repeat as needed.

Roman numbering can begin with any numeral desired, For example, with **i.** (corresponds to 101), which will be followed by **ii.** (102) et cetera.
Numbering Illustrations by Chapters

Numbering illustrations by chapter, so that illustrations are labeled “Illustration 1.1”, “Illustration 1.2”, and so on in the first chapter and “Illustration 2.1”, “Illustration 2.2”, et cetera. in the second, is easily done. Use the following procedure to do this:

1. Organize a document in chapters.
2. Choose Tools > Outline Numbering to number the chapter headings that are formatted. For example, where there is the Paragraph Style “Heading 1”, select the ”Heading 1” Style from the Paragraph Style list box and the option “1, 2, 3…” from the Number list box below it.
3. Select the first illustration for numbering.
4. Choose Insert > Caption....
5. In the dialogue that appears, select Illustration as the category and Arabic (1 2 3) as the numbering. Caption text can also be entered in this dialogue.
6. Click Options.
7. Specify the chapter numbering in the Number Range Options dialogue. For example, select option “1” under Level and specify the separator wanted for chapter numbering.
8. Click OK.
9. In the Caption dialogue, click OK. The illustrations are now numbered by chapters.
10. Repeat 1-7 for all other illustrations in the document.

Numbering now occurs automatically: All illustrations within one chapter level are numbered appropriately “and the chapter level numbering wanted can be changed in the Number Range Options dialogue.

NOTE: Choose Tools > Options > Text Document > General, and under Caption mark the Automatic check box. When the button next to Object selection is clicked, the Caption dialogue appears. Here one can, for example, determine that all illustrations in text documents from now on receive captions automatically.

Defining Number Ranges

Define separate number ranges, or sequences to number each group of elements in a document that belong together. For example, notes, warning messages, quotations, et cetera. The following procedure shows how to do this:

1. For example, type “Note Number” in front of the first note.
2. Choose Insert > Fields > Other....
3. On the Variables tab page, select the “Number Range” field.
4. For the Name, enter “Note.”
5. Click Insert
6. Close the dialogue.
This “Note” number range enables users to automatically number all the notes in a document. In the field **Value**, select a new initial value for the entire number range. This is useful when dealing with a document in a series of connected documents.

Number ranges and captions can be restarted with each chapter. In the **Caption** and **Fields** dialogues users can choose the chapter level at which to begin renumbering.
Using Master Documents and Subdocuments

A new empty master document is created by choosing File > New > Master Document, or creating a master document from an existing document by choosing File > Send > Create Master Document.

Note: Existing master documents have the extension ".sxg", thus distinguishing a master document from "normal" Writer documents in the Open File dialogue.

Open a master document by choosing File > New > Master Document and the new master document is opened as an empty text document. Providing that the Navigator is not docked and collapsed, the Navigator opens immediately in global mode.
The Navigator provides the functions needed for navigating and editing a master document.

![Paragraph Style: Heading 1](image)

Double-click a document in the **Navigator** to load it for editing. Now the user can either enter text, such as headings, or insert subdocuments, by clicking the icon **Insert** and choosing the desired entry **Text** or **File**. A new document “can also be inserted a by a long click on the icon to get the context list and selecting **New** document whereupon one “first enters the name and path for the document and then continues on to write the new document and save it.

**Paragraph Styles** that the user defines and uses in the subdocuments are automatically adopted in the master document. If the master document is saved afterwards, these Styles will be available everywhere in the master document. The Styles defined in the master document have priority over Styles with the same name in subdocuments.

**Note:** When using master documents, use the same template as a base for all subdocuments and the master document itself. As a new Style is needed in the document, simply add it to the document template and reload the master document so that the new Style can be applied to all documents automatically.

Use Page Styles to ensure that all subdocuments always start on a new page (i.e. always on a new right page). There is a built-in Page Style called “Right page” that could, for example, be linked to the Paragraph Style “Header 1”. For example, by assigning a page break to the Paragraph Style “Header 1”, every “Header 1” will always be at the top of a right page. If the **Next Style** is assigned to the Page Style “Right page” select “Left page” instead and vice versa.
Chapter 3: Managing Text Documents With Writer

If the cursor is positioned in a text in the master document, the entry Text is shaded gray because consecutive texts are always combined to one single text. New text can be inserted between individual inserted documents. The new documents or texts are always inserted above the current entry. However, one can easily change their order with Drag&Drop or with the icons Move down and Move up.

Documents are inserted in the master document as protected areas. That means these documents cannot normally be edited within the master document but it is possible to navigate through the document with the cursor and read them.

All indexes are created directly in the master document and, automatically, include all subdocuments.

When one or more subdocuments are changed after creating an index, the indexes in the master document should also be updated. To do this, click the icon Update (as shown to the left) on the Navigator for master documents and select the entries to be updated from the submenu. Likewise, references work in a Master Document and its subdocuments, in the same manner as in subdocuments themselves “when these are defined in the documents involved. For example, if figures in a subdocument are numbered from “Figure 1” to “Figure 10”, figures in the next subdocument can numbered starting at “Figure 11”).

A Master document, together with all its parts, can be saved as a combined OpenOffice.org Writer document. To do so, do the following:

1. In the Navigator, click the Toggle icon.
2. In the Navigator list, double-click "Sections".
3. Right-click a section name and choose Edit.
4. Select all of the sections in the Section list, and then click Remove.
5. Click OK.
6. Choose the command File > Export, and select “the normal OpenOffice.org Writer text format (swx) in the list box File type.

Printing a master document with all subdocuments, texts, and indexes is the same as printing any other OpenOffice.org document. Simply use the print direct icon on the Function bar or via File > Print dialogue.

To check if a link exists for a single subdocument or all subdocuments, position the mouse pointer in the Navigator on the corresponding entry. The path information for the original document appears in a small popup window. Should the file is no longer be found at the original path, a warning File not found is shown along with the original path and the entry is displayed in red in the Navigator.
Importing Lists From Other Text Programs

Word processors internally organize bulleted and numbered lists in a unique manner, such as using special fonts or graphics that may not be available in OpenOffice.org. So, should OpenOffice.org import foreign text and present this information incorrectly, use the following steps to overcome these import problems:

1. Import the document from the other application (File > Open and then the Files of type list box). Where bullets are not applied correctly, use the other application to try saving the document another export format, such as in RTF format, and then import this new document.

2. Use the Find & Replace dialogue.
   a) Select the string of characters which now appears at the start of each list and copy to the clipboard. This could be, for example, an asterisk (*) followed by a tab.
   b) Start Find & Replace.
   c) Insert the contents of the clipboard in the Search for field (Ctrl+v).

   Note: To ensure that the search text is only found at the start of the paragraph by inserting a caret (^) before the search text and checking the Regular expressions box.

   d) Click on Find All. To select all imported lists “but do “not close the Find & Replace dialogue at this time.
   e) Click on the Bullets on/off icon on the Object Bar to convert all the imported lists to OpenOffice.org lists.
   f) Back in the Find & Replace dialogue, click on Replace All. Since the Replace with field is empty, all selected strings will be deleted. For example, the asterisk * and tab, used above, will disappear.
   g) In the Numbering/Bullets dialogue define the type of bullets for bulleted lists.

Changing Numbering via the Keyboard

- To move the numbering down a level in the hierarchy (or further to the right), place the cursor at the beginning of the numbered paragraph and press the Tab key.
- Press Shift and Tab together to move an indented bulleted or numbered list up one level (to the left).
- To insert a tab stop at the beginning of a numbered line, press (Ctrl+Tab).
Interrupting and Continuing Numbering

Sometimes, with a series of automatically numbered paragraphs, there is one paragraph that must not have a number as the following example demonstrates:

1. First paragraph.
2. Paragraph two.
   An unnumbered paragraph.
3. Paragraph number three.

To do this, choose from the following methods:

**Delete the automatic numbering**
1. Select all paragraphs 1 to 4 and click on the Numbering on/off icon.
2. Place the cursor before the first character of the third paragraph.
3. Press the Backspace key to delete one character to the left.

**Note:** The paragraph remains indented but loses its number. The fourth character now has the number 3. This method also produces the desired result after saving in HTML format.

**Formatting the paragraph**
1. Select all paragraphs 1 to 4 and click on the Numbering on/off icon.
2. Place the cursor in the third paragraph.
3. Click again on the Numbering on/off icon.

As can be seen from above this is method used to produce example text where the third paragraph loses its number and its indentation. However, with HTML format, the interruption creates two separately numbered lists.

**Continuing numbering with a new starting value**
1. Number paragraphs 1 and 2 with the Numbering on/off icon.
2. Place the cursor in the fourth paragraph.
3. Choose Format > Numbering/Bullets and go to the Options tab.
4. In the Numbering pull-down list select “1, 2, 3 . . .”. In the Start at spin box select the starting value – in this case 3.
5. Click OK.
Numbering Lines

When lines are to be numbered within a document, select line numbering properties wanted under Tools > Line Numbering. The user can decide, for the whole of the document, whether blank lines should be counted as well, and whether lines in text frames should likewise be counted. Decide the intervals at which lines are numbered and insert separators between these intervals to identify a particular line number. The line numbering appears on the screen and is printed.

Other line numbering properties can be applied to the paragraph (Format > Paragraph > Numbering) or to the Paragraph Style. Doing it this way ensures greater flexibility, as one can exclude a paragraph from the line numbering or restart the numbering at a paragraph with any value.

**Line Numbering for All Paragraphs**

2. Check the Show Numbering check box.

This “numbers all the paragraphs in the document.

**Line Numbering for Particular Paragraphs**

1. Enable the line numbering for all paragraphs as described above.
2. Open the Stylist and click the Default Paragraph Style.
3. Right-click to open the context menu.
4. Click Modify to open the Paragraph Style: Default dialogue.
5. Select the Numbering tab.
6. Uncheck Include this paragraph in line numbering. As all Paragraph Styles are derived from the default Style, no paragraph will be numbered unless a subordinate Paragraph Style exists and was modified accordingly.
7. In the document, highlight all the paragraphs that are to be numbered.
8. Select Format > Paragraph > Numbering, check the Include this paragraph in line numbering check box.
9. Click OK when done.
Tables in Text

Tables and spreadsheets can be entered in text documents. Choose either to insert a table or to import spreadsheets from Calc which one does by dragging and dropping from “the sheet or from a data source view.

Inserting Tables

There are a number of ways to insert tables in text documents:

**Inserting an empty table using the mouse:**

1. Place the cursor at the position in the text where to insert the table.
2. Point with the mouse to the **Insert table** icon on the **Insert** floating toolbar.
3. Press the mouse button and move the mouse down and to the right until the required numbers of rows and columns appear in the preview area under the icon.
4. Release the mouse button. (To abort the process, before releasing the button move the mouse up or to the left until the word **Cancel** appears in the preview area.)

**Inserting an empty table via the Insert menu or floating toolbar:**

1. Place the cursor at the position in the text where to insert the table.
2. Select **Insert > Table** from the Function toolbar or click briefly on the **Insert Table** icon on the **Insert** floating toolbar. Either opens the **Insert Table** dialogue.

**Inserting from OpenOffice.org Calc with the clipboard**

1. Open the text document and the Calc document from which to insert a range of cells.
2. Select a range of cells from the spreadsheet. Copy it to the clipboard, for example with Ctrl+c.
3. Switch to the text document. There are now various options for inserting the range of cells:

   - Use the “normal” command **Edit > Paste** or Ctrl+V to insert the range of cells as an OLE object. Double-click on the OLE object in order to edit it with Calc tools and commands. Click outside the object to quit edit mode.
Chapter 3: Managing Text Documents With Writer

- Choose **Edit > Paste Special** to open the **Paste Special** dialogue which has several options from which to choose. The same options can also be found on the submenu of the **Paste** icon on the Function Bar:

<table>
<thead>
<tr>
<th>Options</th>
<th>Is inserted as...</th>
</tr>
</thead>
<tbody>
<tr>
<td>“OpenOffice.org Calc Spreadsheet” or “Star Embed Source”</td>
<td>OLE object — as with <strong>Ctrl</strong>(V) or drag-and-drop</td>
</tr>
<tr>
<td>GDIMetaFile</td>
<td>Graphic</td>
</tr>
<tr>
<td>Bitmap</td>
<td>Graphic</td>
</tr>
<tr>
<td>HTML HTML table</td>
<td>Unformatted text Text only, tab stops as separators</td>
</tr>
<tr>
<td>Formatted text [RTF]</td>
<td>Text table</td>
</tr>
<tr>
<td>DDE link (only under Windows®)</td>
<td>Table structure and contents, without formatting. With updating.</td>
</tr>
</tbody>
</table>

**Inserting from OpenOffice.org Calc using drag-and-drop**

Open the text document and the Calc document from which to insert a range of cells.

1. Highlight the range of cells from the spreadsheet that should be in the document.

2. Click in this selected range of cells and hold down the mouse button.

3. Wait a moment until the cursor changes.

4. Without releasing the mouse button, drag the selected range of cells into the text document. Should the text document not be visible, first move the mouse pointer to the text document icon on the task bar and wait a moment until the text document opens. In the text document, a gray insertion cursor follows the mouse pointer to the location of where the table is to be placed.

5. Release the mouse button when the gray insertion cursor is at the location where the table is to be inserted.

**Deleting Tables**

When deleting a whole table from a text document, the user has the following options:

1. By paragraph:
   a) Select from the end of the paragraph before the table to the start of the paragraph after the table.
   b) Press **Del** or **Backspace**.

2. By table:
   a) Place the cursor in the table.
   b) select all cells, for example by pressing **Ctrl+a**
   c) open the context menu.
   d) select **Row > Delete**.
Chapter 3: Managing Text Documents With Writer

**Note:** This method also works at the beginning or end of a document.

**Inserting Paragraphs Before Tables at Start of Page**
Occasionally a table get inserted at the very beginning of a text document or immediately after a fixed page break, and now text must be inserted before this table. This is not difficult but how to do it can be puzzling. Here's how:

1. Place the cursor in the first cell of the table, right at the start of any content in that cell.
2. Press Enter which moves the “table down a line.”
3. Place the cursor in this (empty) line.
4. Press Delete to remove it from the table leaving space in which to type.

**Formatting Tables in Text Documents**
A new table inserted into a text document can have the default format which means that the first row has the Paragraph Style “Table Heading,” and all other rows will have the “Table Contents” Style. Text entered in the first row will automatically be bolded and centered. The section describes various formatting options that can be used to determine the overall appearance of a table.

With tables in text documents, the first thing to note is that not all cells must be sized according to the general grid of rows and columns. Easily merge neighboring cells into a single cell, or split individual cells horizontally or vertically. There are icons on the table object bar, called Merge Cells and Split Cells, which can be used or use Format > Cells > Merge. This gives great flexibility in formatting any table.

In the Table Format dialogue, decide on the formatting attributes for a table. Open this dialogue either with the menu command Format > Table or the Table command in the context menu.

To change the table background, for example, proceed as follows:

1. Select the cells to which to assign a background colour.
2. Now, either choose Format > Table or click Table in the context menu of the selected cells.
3. In the Table Format dialogue, click the Background tab.

Notice the two list boxes at the top of the dialogue. In the left box, choose a colour or graphics as the background. In the right box, define whether to apply the background to the selected cells, the whole row, or the entire table. Cell formatting takes priority over row formatting.

4. Click OK upon making a choice.
5. Tables can be designed with even greater impact using thematically appropriate backgrounds. While background colours and graphics are always inserted behind text and values in a table, graphics and other objects can also be inserted into the table.

1. Set the cursor in the cell where the object is to appear.
2. To insert graphics, choose Insert > Graphics > From File.
3. In the Insert Graphics dialogue, select the desired graphics file.
4. Click Open.
5. Click on the inserted graphic object and select the Graphics command from the context menu (or double-click on the graphic object). In the Graphic dialogue, various settings can be defined for the graphic and its function in the document. For example, define how text is to wrap around which will determine if the text should flow around, through or beside the graphic object. Users can also set a hyperlink which can be loaded whenever the graphic object in the text document is clicked. Furthermore, a graphic object can be linked to a macro and in so doing, assign various events to it. One could, for example, use this capability to program certain functions, such as having a sound played when the mouse pointer touches the graphic object.
Calculating in Text Documents

Formulas in Text Documents
Pressing F2 while the cursor is in a text table open the Formula bar. Clicking the icon opens a submenu, from which one can insert a formula into the cell of a table by putting the cursor either in the cell in the table or at the position in the document at which the result should appear.

The formula appears in the input line. To specify a range of cells in a table, select the desired cells with the mouse. The corresponding cell references also appear in the input line. Enter additional parameters, as necessary, and click Apply to confirm the entry. A formula can also be entered directly, if the appropriate syntax is known. This is necessary, for example, in the Insert Fields and Edit Fields dialogs.

Formula Options

Basic Calculation Functions

<table>
<thead>
<tr>
<th>Operation</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Addition</td>
<td>+</td>
<td>Calculates the total.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>&lt;A1&gt; + 8</code></td>
</tr>
<tr>
<td>Subtraction</td>
<td>-</td>
<td>Calculates the difference.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>10 - &lt;B5&gt;</code></td>
</tr>
<tr>
<td>Multiplication</td>
<td>MUL or *</td>
<td>Calculates the product.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>7 MUL 9</code></td>
</tr>
<tr>
<td>Division</td>
<td>DIV or /</td>
<td>Calculates the quotient.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>100 DIV 15</code></td>
</tr>
</tbody>
</table>

Basic Functions in the Submenu

<table>
<thead>
<tr>
<th>Function</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>SUM</td>
<td>Calculates the sum of the selected cells.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>SUM &lt;A2:C2&gt; displays the sum of the values in cells A2 to C2</code></td>
</tr>
<tr>
<td>Round</td>
<td>ROUND</td>
<td>Rounds a number to the specified decimal places.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>15.678 ROUND 2 displays 15.68</code></td>
</tr>
<tr>
<td>Percent</td>
<td>PHD</td>
<td>Calculates a percentage</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>10 + 15 PHD displays 10.15</code></td>
</tr>
<tr>
<td>Square Root</td>
<td>SQRT</td>
<td>Calculates the square root.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>SQRT 25 displays 5.00</code></td>
</tr>
<tr>
<td>Power</td>
<td>POW</td>
<td>Calculates the power of a number.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example: <code>2 POW 8 displays 256.00</code></td>
</tr>
</tbody>
</table>
Operators

Various operators may be inserted in a formula. Choose from the following functions:

| List Separator |  | Separates the elements in a list. Example of using a list: MIN 10|20|50|<C6>|<A2:B6>|20 |
|---------------|---|------------------------------------------------------------------|
| Equal         | EQ or == | Checks if selected values are equal. If they are unequal, the result is zero, otherwise 1 (true) appears. Example: <A1> EQ 2 displays 1, if the content of A1 equals 2. |
| Not Equal     | NEQ or != | Tests for inequality between selected values. Example: <A1> NEQ 2 displays 0 (wrong), if the content of A1 equals 2. |
| Less than or Equal | LEQ | Tests for values less than or equal to a specified value. Example: <A1> LEQ 2 displays 1 (true), if the content of A1 is less than or equal to 2. |
| Greater than or Equal | GEQ | Tests for values greater than or equal to a specified value Example: <A1> GEQ 2 displays 1 (true), if the content of A1 is greater than or equal to 2. |
| Less          | L | Tests for values less than a specified value Example: <A1> L 2 displays 1 (true), if the content of A1 is less than 2. |
| Greater       | G | Tests for values greater than a specified value Example: <A1> G 2 displays 1 (true), if the content of A1 is greater than 2. |
| Boolean Or    | OR | Tests for values matching the Boolean OR Example: 0 OR 0 displays 0 (false), anything else results in 1 (true) |
| Boolean X Or | XOR | Tests for values matching the Boolean exclusive OR Example: 1 XOR 0 displays 1 (true) |
| Boolean And   | AND | Tests for values matching the Boolean AND Example: 1 AND 2 displays 1 (true) |
| Boolean Not   | NOT | Tests for values matching the Boolean NOT Example: NOT 1 (true) displays 0 (false) |

Statistical Functions

Choose from the following statistical functions:

| Mean | MEAN | Calculates the arithmetic mean of the values in an area or a list. Example: MEAN 10|30|20 displays 20 |
|------|------|----------------------------------------------------------------------------------|
| Minimum Value | MIN | Calculates the minimum value in an area or a list. Example: MIN 10|30|20 displays 10 |
| Maximum Value | MAX | Calculates the maximum value in an area or a list. Example: MAX 10|30|20 displays 30.00 |
Trigonometric Functions

Choose from the following trigonometric functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Symbol</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sine</td>
<td>SIN</td>
<td>Calculates the sine in radians</td>
<td>SIN (PI/2)</td>
</tr>
<tr>
<td>Cosine</td>
<td>COS</td>
<td>Calculates the cosine in radians.</td>
<td>COS 1</td>
</tr>
<tr>
<td>Tangent</td>
<td>TAN</td>
<td>Calculates the tangent in radians.</td>
<td>TAN &lt;A1&gt;</td>
</tr>
<tr>
<td>Arc Sine</td>
<td>ASIN</td>
<td>Calculates the arc sine in radians.</td>
<td>ASIN 1</td>
</tr>
<tr>
<td>Arc Cosine</td>
<td>ACOS</td>
<td>Calculates the arc cosine in radians.</td>
<td>ACOS 1</td>
</tr>
<tr>
<td>Arc Tangent</td>
<td>ATAN</td>
<td>Calculates the arc tangent in radians.</td>
<td>ATAN 1</td>
</tr>
</tbody>
</table>

More Defined Values

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>PI</td>
<td>Pi</td>
<td>3.1415...</td>
</tr>
<tr>
<td>E</td>
<td>Euler's constant</td>
<td>2.7182...</td>
</tr>
<tr>
<td>TRUE</td>
<td>True</td>
<td>not equal to 0</td>
</tr>
<tr>
<td>FALSE</td>
<td>False</td>
<td>0</td>
</tr>
</tbody>
</table>

Calculating in Text

1. Place the cursor at the position in the text where the calculation result should appear.
2. Press (F2) to display the Formula bar.
3. Enter the desired formula, for example (4+6)*100.
4. Press Enter or click on Apply to insert the result.

Use the Formula icon to perform more complex calculations. Clicking on this icon opens a branched submenu from which to select a formula. The formulas are placed on the formula bar at the cursor position, and users are free to switch between inputting formulas and values from the keyboard and via the Formula icon.

As an example of a more complex calculation to be performed in a text, suppose we want to calculate the mean value of three figures.

1. Display the Formula bar with (F2).
2. Open the submenu of the Formula icon.
3. Choose “Median” from the statistical functions. The input field will display ”=median.”
4. Enter the first number and then a vertical bar (|) as the list separator.

5. Enter the second number, another separator and then the third number. The input field may now show, for example, “=median 12|22|34.”

6. Press Enter, to inset the result as a field in the text.

7. Double-click on the field to edit it.

**Calculating With Formulas Located in Text**

If the text already has a formula, the result can be entered into the text without using the Formula bar as follows:

1. Select the calculation formula in the text. This text must not contain anything other than figures, arithmetic operators and any currency symbols.
   
   Example: 12 + 24 * 2

2. Press Ctrl and the plus sign (Ctrl +), or choose Tools > Calculation. The calculation result will be stored on the clipboard.

3. Set the cursor at the point where the result of the calculation is to be inserted.

4. Press Ctrl+V, or choose Edit > Insert.

In this example, the result, 60, is inserted. If the formula is still selected at the time of insertion, the result replaces the formula.
Conditional Text
Fields can be used in a document to display text when a condition that is met. For example, one can define the conditional text that is displayed in a series of reminder letters.

Setting up conditional text in this example is a two-part process. First create a variable, and then create the condition.

![Conditional Text Screen](image)

An Example of Defining and using conditional
Using conditionals in a text document is a two part exercise. The following sections provide a method that can be used.

Defining a conditional variable:
The first part of the example is defining a variable for the condition statement.
1. Type “Reminder” in the document, and then add space.
2. Select Insert > Fields > Other.
3. Click the Variables tab.
4. Click “Set variable” in the Type list.
5. Type a name for the variable in the Name box, for example “Reminder”.
6. Click “Text” in the Format list.
7. Enter “1” in the Value box,

8. Click Insert.

To display integers, click the “~1234” format.

**Defining a condition and the conditional text:**

The second part of the example is to define the condition that must be met, and to insert a place holder for displaying the conditional text in the document.

1. Place the cursor where the conditional text is to be inserted in the text.

2. Choose Insert > Fields > Other.

3. Click the Functions tab.

4. Click “Conditional text” in the Type list.

5. Type Reminder EQ "3" in the Condition box. In other words, the conditional text will be displayed when the variable in the field that was defined in the first part of this example is equal to three.

The quotation marks enclosing the number 3 indicate that the variable, defined in the first part of this example is a text string. See above for a list of operators that can be used when defining a condition.
6. Type the text that you want to display when the condition is met in the **Then** box. There is no limit to the length of the text that you can enter. If you want, you can even copy and paste a paragraph into this box.

7. Click **Insert**, and then click **Close**.

**Displaying the conditional text:**

In this example, the conditional text is displayed when the value of the conditional variable is equal to 3.

1. Place the cursor in front of the field that was defined in the first part of this example.
2. Choose **Edit > Fields**.
3. Replace the number in the **Value** box with "3".
4. Click **Close**.
5. If the field does not automatically update, press **F9**.
Calculating in Text Document Tables

OpenOffice.org Writer tables can also have calculations and these can extend beyond the current table. In this case, the table name serves as a clear table identifier.

For example, there are two tables, labeled Table 1 and Table 2, in which the first cell of Table1 must be multiplied by the first cell of Table2 and the product returned in cell A2 of the current table. Here's how:

1. position the cursor in cell A2 in the current table and enter “=<Table1.A1> *
   <Table2.A1>

2. The product is presented inPlace the cursor where you want to insert the conditional text in your text.
   1. Choose Insert - Fields - Other, and then click the Functions tab.
   2. Click "Conditional text" in the Type list.

Type Reminder EQ "3" in the Condition box. In other words, the conditional text will be displayed when the variable in the field that you defined in the first part of this example is equal to three. The quotation marks enclosing the number 3 indicates that the variable that you defined in the first part of this example is a text string. For a list of operators that you can use when defining your condition, see the Related Topics section of this page. Type the text that you want to display when the condition is met in the Then box. There is no limit to the length of the text that you can enter. If you want, you can even copy and paste a paragraph into this box.
Click **Insert**, and then click **Close**.

**To display the conditional text:**

In this example, the conditional text is displayed when the value of the conditional variable is equal to 3.

6. Place your cursor in front of the field that you defined in the first part of this example, and then choose **Edit - Fields**.

7. Replace the number in the **Value** box with "3", and then click **Close**.

8. If the field does not automatically update, press F9.
Calculating in Text Document Tables

OpenOffice.org Writer tables can also have calculations and these can extend beyond the current table. In this case, the table name serves as a clear table identifier.

For example, there are two tables, labeled Table 1 and Table 2, in which the first cell of Table 1 must be multiplied by the first cell of Table 2 and the product returned in cell A2 of the current table. Here's how:

3. position the cursor in cell A2 in the current table and enter “=Table1.A1 * Table2.A1"

4. The product is presented in Table 1.A2.

**Note:** With the help of the Navigation Bar one can navigate quickly and easily between the table formulas in the document.

If a table formula refers to an invalid table cell, a “**Faulty expression**” is displayed in the cell. Invalid table cells are either deleted cells or those which are themselves faulty.

Addition is similar. Thus to add cells B1:B10 from Table 1 and present the sum in a single-cell in Table 2, which should already exist somewhere in the text, do the following:

1. Create the text and Table 1.
2. Enter the text where the sum is to appear.
3. Insert a frame (**Insert** > **Frame** menu command).
   a) In the **Frame** dialogue select the character to be used as an anchor.
   b) Deselect the border.
   c) Deselect the frame by clicking outside it.

**Note:** When entering text in the frame, click in the very center of the frame. The frame should not be selected, but the text cursor should be inside the frame.

   d) Insert the single-cell table inside the frame “using **Insert** > **Table**.
   e) Select a row and a column
   f) Click **OK**.
   g) The cursor is positioned in Table 2.

   h) Define the mathematical formula by entering an equal sign at which point, the Calculation Bar will be displayed. The formula for calculating the total of cells B1 to B10 is: **=Table1.B1:B10**

5. Highlight the cells in Table 1 to be summed. Do this by keeping the mouse button pressed as the pointer is dragged from the first to the last cell being summed.

6. Close the mathematical formula by clicking the **Accept** icon on the Calculation Bar. The result of the calculation will be seen in Table 2.
7. If there are changes in the cells being summed, update the result by pressing function key (F9).

**Note:** Instead of first inserting the border and then inserting a table inside the border, start by inserting a single-cell table, then select the whole of this cell - the only way to do this is with the shortcut keys (Ctrl+a) and then click on the Insert > Frame icon. The border automatically surrounds the table (incidentally, this also works with any section of text). Now set the anchor to character; cut the whole table to the clipboard and paste it where it should go, remove the borders from the frame and table and apply further settings.

**Calculating Across Multiple Tables**

Calculations in any text document, where there are more than one table which contains data required for calculation, can be done in OpenOffice.org Writer. For example:

- Insert two tables each with several rows and columns.
- Enter a few figures in the tables, but leave at least one cell empty.

The tables should be automatically named “Table1” and “Table2”. If one chooses, each table can be given a different name (Format > Table, Table tab, text box Name) using only letters and numbers for naming.

1. Position the cursor in an empty cell.
2. Press F2 to display the Formula bar.
3. As an example, enter SUM.
4. Individually click the cells containing figures in both tables that are part of the calculation. After each click, enter a plus sign (+) from the keyboard, and continue to the next cell containing a figure.
5. Finally, click the Apply icon on the Formula Bar. For example, if adding up the first two rows of each table and showing the total in Table2, the formula is =sum<Table1.A1>+<A1>.

**Calculating Cell Totals in Tables**

1. Insert a table with multiple rows (Insert > Table) into a new text document.
2. Enter a series of numbers into a column, one number per row, leaving the last cell of the column empty.
3. Place the cursor in the last empty cell of the column.
4. Click the Sum icon in the Table object bar.
5. The Formula bar appears, and a formula indicates the cells of the column to be added. The cells are separated by a vertical bar (|).
6. Press the Enter key to confirm, or click Apply in the Formula bar. The sum will appear in the last cell.
When numbers are changed in the table, the sum is automatically be updated. If, for example, formatting the numbers as currency, select the cells and choose **Number Format** from the context menu. The **Number Format** dialogue appears, where the user can choose a new format.

**Merging and Splitting Cells**

One can select adjacent cells together, then merge them into a single cell. Conversely, a large cell that has been created by merging single cells can be divided back into individual cells.

The commands are different in OpenOffice.org Writer and Calc.

**Merging Cells in OpenOffice.org Writer**

1. Highlight all the cells to be included in the merged cell.
2. Select **Format > Cell > Merge**.

**Splitting Cells in OpenOffice.org Writer**

1. Set the cursor in the cell to be split.
2. Select **Format > Cell > Split**.

A dialogue allows splitting the cell into two or more cells, horizontally or vertically.

**Merging Cells in OpenOffice.org Calc**

1. Highlight all the cells to be included in the merged cell.
2. Select **Format > Merge Cells > Define**.

**Canceling the merging of cells in OpenOffice.org Calc**

1. Set the cursor in the cell to be split.
2. Select **Format > Merge Cells > Remove**.

**Inserting or Deleting Rows/Columns Using the Keyboard**

The following methods describe how to insert and delete rows and columns using the keyboard:

- To insert a new column or row:
  1. Ensure the table is in insert mode by pressing **Alt+Ins** for at least three seconds.
  2. During these three seconds, press the relevant arrow key to insert a new row or column to the right or left, above or below the current row or column.
  3. Hold down the **Ctrl** key as well as the arrow key to split the adjacent cell.

- To delete a column or row:
  1. Switch the table to the delete mode for tables by pressing **Alt+Del** for at least three seconds.
2. During these three seconds, press the relevant cursor key to delete a row or column to the right or left, above or below the current row or column.

3. Hold down the **Ctrl** key as well as the arrow key, to merge the current cell with the adjacent cell into one cell.

**Repeating Several Heading Rows in Tables**

If automatically repeating more than one row within a table following a page break, this is how to do it:

1. Select the first table row.

2. Open the context menu and choose **Cell > Split**.
   a) In the **Split Cells** dialogue, select the “horizontal” direction.
   b) Enter the number of rows that are to be repeated
   c) confirm with “**OK**”.

All rows at the beginning of a table that is created in this manner will now be repeated after a page break.

**Enlarging and Reducing Cells in Text Tables**

The width and height of rows and columns are changeable using the keyboard, by dragging and dropping with the mouse or by commands in the context menu. Column widths can also be changed numerically via a dialogue.

Rows and columns can also be evenly distributed with the icons on the **Optimize** floating toolbar on the Table Object Bar.

Rows and columns can also be modified either in the table directly, or with the aid of the rulers. If the mouse pointer is rested on a vertical dividing line in the table, the pointer appears as a separator symbol, and one can simply drag the dividing line to the desired position. (The user may need to click once outside the table before this procedure will work.) The dividing lines on the ruler can be moved in the same way.

When the keyboard is used to enlarge and reduce a table, always hold down the **Alt** key while pressing one of the four arrow keys. The current column or row is enlarged or reduced by whatever amount is set under **Tools - Options > Text Document > Table > “Keyboard handling.** Rows and columns are handled separately.

The current row or column is enlarged or reduced at its right-hand or lower edge. If ones presses the **Shift** key as well as **Alt**, the left-hand or upper edge will be moved. Here are two examples that expect that the cursor is set somewhere in the middle of a medium to large text table:

1. Hold down the **Alt** key, and press the right arrow key. The current column is expanded by the amount specified **Tools > Options > Text Document > Table.** The left edge of the column remains fixed while the right edge moves.
2. Now, hold down the Alt key together with the Shift key and press the right arrow key. The right edge will remain fixed while the left edge will move to the right, thereby reducing the column.

The height of the rows can be adjusted in the same way. However, since the rows are preset to a minimum height, one must first increase their size before the result is obvious.

By pressing the Ctrl key during the process, the enlargement or reduction will apply only to the active cell rather than to the entire row or column. The proportions of the table remain fixed.

**Adapting Table Widths**

The display attributes of a table are defined by the settings under Tools > Options > Text Documents > Tables. Users can also click the icons in the Table object bar to switch between the attributes Fixed, Fixed/Proportional, and Variable.

- **Behavior of rows/columns — Fixed** means, for example, that if one cell is made wider the adjacent cell will become narrower. Other cells will not be affected, and the overall width of the table stays the same.

- **Behavior of rows/columns — Fixed and Proportional** means that all adjacent cells become proportionally narrower. In other words, wide cells will shrink more than narrow ones. Again, table width remains constant.

- **Behavior of rows/columns — Variable** means that the width of the entire table is variable. Whenever an individual cell is made wider, the entire width of the table expands as well.

When inserting or deleting (cells, rows or columns), the table mode decides how the neighboring cells, rows or columns should behave. In the table mode, new rows and columns are only inserted in a fixed way if there is sufficient space.

**Copying Calc Sheet Areas to Text Documents**

1. Open both the text document and the spreadsheet.

2. Select the sheet area to copy.

3. Point to the selected area and press the left mouse button. Keep the mouse button pressed for a moment, then drag the area into the text document.

   **Note:** When the documents are not visible next to each other, first drag the mouse pointer to the destination document button. Continue to hold down the mouse button and the document, addressed in this fashion, is displayed and one can move the mouse pointer within the document.

4. Once the cursor is located in the place where to insert the sheet area, release the mouse button. The sheet area is inserted as an OLE object.

5. the OLE object can be selected and edited at any time.

6. To edit the OLE object, simply double-click on it.
Alternatively, select the object and choose **Edit > Object > Edit** or choose **Edit** from the context menu. The object is edited in its own frame within the text document, but the icons and menu commands needed for spreadsheets are displayed.

7. Select **Open** to open the source document of the OLE object.
Images, Drawings, Clipart and FontWork

Images, graphics, drawings and clipart can be inserted in the text document, or can be distorted text using FontWork.

Positioning Objects

There are various ways of anchoring the objects on a text page, such as graphics and text frames. The following describes the various options, based on the example of a frame:

<table>
<thead>
<tr>
<th>Anchoring</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>as a Character</td>
<td>Frames are placed in the document like any other character, hence, they have an impact on the line size of the line and the line break.</td>
</tr>
<tr>
<td>to Character</td>
<td>Frame is with its X and Y coordinates associated to a character, for example, in the X direction always to the margin and in the Y direction always to the height of the character (marginal frame). The frame should be set at “Flow”.</td>
</tr>
<tr>
<td>to Paragraph</td>
<td>Frame is associated to a paragraph, changes its position with the paragraph.</td>
</tr>
<tr>
<td>on the Page</td>
<td>Frame has always the same position in relation to the page margins.</td>
</tr>
<tr>
<td>on Frame</td>
<td>Frame is inside the superior frame in a fixed position.</td>
</tr>
</tbody>
</table>

The position in relation to the anchor can be chosen through various possibilities. For example, it is possible to set the frame on a fixed position in relation to a page margin, to a paragraph margin, to a text area, etc.

The frame position on even pages can be automatically mirrored, so that a fixed position in relation to the right side of the page produces a corresponding position on the left side of the page. For example, a graphic can always be positioned inside the outer edge of pages. Where the graphic is, say, an arrow pointing to the text, it is a good idea to mirror this automatically on even pages too. To do this, use the Mirror on even pages option on the Type tab of the Graphics dialogue (choose Format > Graphics).
Captions and Number Ranges

In text documents one can create separate, continuously numbered captions for figures, tables and drawing objects.

Users can also define as many separate number ranges as desired. The captions are linked to the figures, tables or drawing objects in a frame. Select the frame when the object is moved.

Defining Captions

1. Select the figure or the object or place the cursor in the table that requires a caption.
2. Open the Caption dialogue with the command Insert > Caption.
3. The dialogue shows a preview of how the caption will look. Further text can be inserted in the Caption field.
4. Click OK.

Note: If one would like to place a tab stop between the automatic captions (e.g., “Figure 1”) and the additional text, can be inserted it in the document later. Press Ctrl+Tab to insert a tab stop at the beginning of a paragraph.

The paragraph format of an automatically applied caption is obtained from the Paragraph Style “Illustration”, “Table”, “Drawing” or “Text”. All of these Paragraph Styles are derived from the “Caption” Paragraph Style. So if all captions always are to appear in green, for example, simply modify the “Caption” Paragraph Style accordingly in the Stylist. To examine this, switch the Stylist to the “All Styles” view or to the hierarchical view.

Editing or deleting captions

A caption is normal text which is placed together with an object in a common frame.

- Edit the caption text just like normal text.
- Delete the caption text just like normal text.

Inserting an object in a number range

Suppose the document contains illustrations as linked graphics, and these are labeled in a number range called “Illustration”. Now the user wants to add a drawing obtained with the drawing tools as a further illustration. Extend the automatic number range “Illustration” as follows:

1. Below the additional illustration, insert a new line and apply the Paragraph Style “Illustration.”
2. Open the Fields dialogue. Pressing Ctrl+F2 is one way.
3. On the Variables tab select the Type “Number range”. Under Selection select “Illustration”.
4. Click Insert
5. Close the dialogue box.
If illustrations are moved with their captions by hand so that the sequence changes, it may be necessary to update the numbers by pressing F9.

**Numbering Illustrations by Chapters**

Numbering illustrations by chapter, so that illustrations are labeled “Illustration 1.1”, “Illustration 1.2”, etc. in the first chapter and “Illustration 2.1”, “Illustration 2.2”, et cetera. in the second is often useful. Here's how to proceed:

1. Organize the document by chapters if this is not already done. Select **Tools > Outline Numbering** to number the chapter headings that are formatted, for example, with the Paragraph Style “Heading 1”. Select the "Heading 1” Style from the Paragraph Style list box and the option “1, 2, 3, ..” from the **Number** list box below it.

2. Select the first illustration to number.

3. Select **Insert > Caption....**

4. In the dialogue that appears, select ion as the category and Arabic (1 2 3) as the numbering. Caption text can also be entered in this dialogue.

5. Click **Options.** Specify the chapter numbering in the **Number Range Options** dialogue. For this example, select option “1” under **Level** and specify the separator wanted for chapter-wise numbering.

6. Click **OK.**

7. In the **Caption** dialogue, click **OK.** The illustrations are now numbered by chapters.

Do the same for all other illustrations in the document. The numbering occurs automatically: All illustrations within one chapter level are numbered, and the user can enter at which chapter level to switch the numbering in the **Number Range Options** dialogue.

**NOTE:** Choose **Tools > Options > Text Document > General**, and under **Caption** mark the **Automatic** check box. When the button next to **Object selection** is clicked, the **Caption** dialogue appears. This is where one can, for example, determine that from now on all illustrations in text documents receive a caption automatically.

**Inserting Graphics**

Graphic objects can be inserted in a text document in several ways. The following sections describe the most useful.

**Inserting Graphics via dialogue**

1. Set the cursor at the position in the document where to insert the graphic.

2. Choose **Insert > Graphics > From File.** The dialogue **Insert Graphics** will appear.

3. Select the desired graphic and click on **Open.**

By default, graphics are inserted with its alignment centered above the current paragraph.
Inserting Graphics From OpenOffice.org Draw or Impress

Graphic objects can be copied and inserted from one document to another by dragging and dropping the object. When publishing a document, it is important to get permission from the creator of the object so as to keep within the copyright laws that may affect usage.

1. Open the document in which to insert the graphic object.
2. Open the document from which to copy the graphic object.
   
   Note: While pressing the Alt key, click the graphic object. This selects the object without activating a hyperlink that may be connected to it.

3. Keep the mouse button pressed and wait a moment while the object is copied to the clipboard.
4. Drag the graphic object into the other document.
   
   Note: When the documents are not visible next to each other, first drag the mouse pointer to the destination document button. Continue to hold down the mouse button and the document, addressed in this fashion, is displayed and the mouse pointer may be moved within the document.

5. Release the mouse button as soon as the gray text cursor is at the position to insert the copy of the graphic object.

If the object is connected to a hyperlink and the method, outlined in the note above, is not used, the hyperlink will be inserted instead of the graphic object. Graphics inserted from a webpage are generally linked to the remote web site. Use Edit > Links if you wish to embed the graphic in the document.

Inserting Graphics via Drag and Drop From the Gallery

Drag and drop a graphic object from the gallery into a text document, spreadsheet or presentation to insert the graphic object. When a graphic object is released directly on a drawing object, the following rules apply:

- When dragging and dropping an object, without pressing a key there is no other sign next to the mouse pointer, only the drawing attributes are transferred from the Gallery and applied to the drawing object over which the user releases the mouse button.
- When dragging and dropping, while pressing the Ctrl key a plus sign appears next to the mouse pointer and the graphic object is inserted as an object.
- When dragging and dropping while pressing the Shift and Ctrl keys, a linking arrow is seen next to the mouse pointer and the drawing object is replaced by the object from the Gallery. The position and size of the object that is replaced remains valid for the new graphic.

Inserting Graphics With a Scanner

To carry out scanning in Writer, a scanner with appropriate driver software must be installed on the local system. (Under Windows®, OpenOffice.org supports the TWAIN standard while, under Unix, OpenOffice.org supports the SANE standard.)
1. Set the cursor at the position in the document where the graphic is to be inserted.
2. Select **Insert > Graphics > Scan.**
   The submenu contains a command to open a dialogue for selecting the scanning source.
3. From the submenu, select the command to request scanning.
   The scanner driver opens a window in which to follow the scanner manufacturer's instructions.
4. Once the scanning process is completed, the image is inserted in the document.

**Inserting a Chart From OpenOffice.org Calc**

**Dragging and Dropping a Copy of the Chart**

1. Open the OpenOffice.org Writer document into which the chart will be inserted.
2. Open the OpenOffice.org Calc document containing the chart.
3. Select the chart with a single click. Eight handles will appear around the chart.
   If one accidentally double-clicks the chart, it will be put in the edit mode, indicated by a gray border. To exit the edit mode, single-click outside the chart.
4. Drag the chart into the OpenOffice.org Writer document.

**Note:** If the Writer document is not visible, first arrange the windows appropriately. If the operating system or windows manager provides a task bar, drag the chart to the Writer button on the task bar; hold that position for a moment while the Writer window opens in the foreground and then drop it in the now visible document.

5. In the Writer document, position the chart or modify the scale as one would any object.
6. To later modify the chart data, double-click and edit it.

**Charts with Linked Data**

If a chart depends on data in a Calc document and this data changes, a chart inserted by the above method is not automatically “updated. To keep the chart and the data up-to-date, do as follows:

1. In the Calc document, copy the cell range from which the chart is created.
2. In the Writer document, long-click the **Insert Object** icon on the main toolbar to open the submenu.
3. Select **Insert OLE Object.**
   The data is now in a table in the Writer document and is always linked via OLE to the source data in the Calc document. (Note DDE is related to OLE and is handled as part of the implementation.)
4. Position the cursor in the table.
5. Long-click the **Insert Objects** icon on the main toolbar to open the floating toolbar...
6. Click the **Insert Chart** icon.

**Inserting Decorative Horizontal Lines**

Choose **Insert > Horizontal Line** to open a dialogue for selecting decorative lines.

The lines are graphics anchored to the current paragraph and centered between the margins. These lines may also be found in a Gallery theme. If one wants to continue using a line from the Internet, add it to the relevant theme in the Gallery. The line can then be selected from this dialogue.
Headers, Footers and Footnotes

![Diagram of the Fields window in Writer]
Some Notes Concerning Headers and Footers

Headers and footers are always linked to the Page Style. All pages with the same Page Style automatically have the same headers and footers. By using Fields in the headers and footers, one can insert variable content in a text document, such as page numbers and chapter headings.

Headers and footers are also available for HTML Writer documents. However, because headers and footers are not provided in the HTML definition, they are exported as special tags and are correctly interpreted again upon loading an Writer HTML page. Thus, web browsers show the content of the header or footer as the text which was there at the time of the HTML export while Writer inserts the fields again and updates these as and when necessary. (Author and sender, on the other hand, are only inserted as fields if the user, is the author or was the last one to modify the document.) Headers and footers are exported in HTML documents if they are enabled in On-line Layout mode.

- For other differences in the content of headers and footers, it is best to create different Page Styles and apply these to the pages.
- Choose Insert > Header or Insert > Footer to select the Page Style in which to insert or remove headers or footers.
- Format > Page may also be chosen to start a dialogue that allows selecting headers or footers for the current Page Style. Here find a check box Same content left/right. If this is not marked, format different headers and footers on the left sides than on the right sides.

Note: If one only wants to assign a single page a different header, the user could also insert a text box to cover the header text. Anchor the frame to the page, and assign the "Wrap Through" option and the background colour “White.”

Inserting Page Numbers in Footers

1. Insert a footer. Choose Insert > Footer and select, from the submenu, the Page Style desired for the footer. The cursor now appears in the footer.

2. Choose Insert > Fields > Page Numbers. The page number appears as a field in the footer.

3. Select the page number and click on the Centered icon on the object bar. Should the footer text to be in the form “Page 9 of 12”, do as follows: “
   a) Type the word “Page” before the field and “ of ” after the field.
   b) Choose Insert > Fields > Page Count.

Inserting Chapter Information in Headers

Fields containing the file name, date, time, chapter headings, et cetera can be inserted into a header.

1. Enter text in a document and apply the style “Heading 1” to chapter headings.

2. Activate the header for the document (Format > Page > Header or Insert > Header).

3. Click within the header to position the cursor in it.
4. Type “Chapter: ”
5. Select the **Insert > Fields > Other** “command.
   a) In the **Fields** dialogue:

   ![Fields dialogue](image)

   b) Select the **Document** tab
   c) Type **Chapter**, 
   d) Format **Chapter name**. Where the header to contain paragraphs formatted with **Heading2** instead of **Heading1**, enter a 2 under **Layer**.
   e) Click **Insert** to add the desired information to the header, and then close the dialogue box.
   f) Now every page of the document will automatically display the chosen chapter heading in the header.
   g) Other information can be inserted into a header in the same manner. Find other menu commands under **Insert > Fields**. Choose from **Date**, **Time**, **Page Numbers**, **Page Count**, **Subject**, **Title** and **Author**. Additional field commands can be selected or defined under **Other**.
**Defining Different Headers**

A defined header and footer will appear in all pages that have the same Page Style. However, different header for the first page or for even and odd-numbered pages are often needed. For example, one may want the name of the chapter to appear on the left (even) pages and the name of the first subchapter to appear on the right (odd) pages. Since headers are a property of the Page Styles, users need to define two different Page Styles and apply them to the respective pages. There are preset Styles for First page, Left page and Right page, which can be adapted to one's specific needs.

Take the Page Style for left pages, this style might have different inner and outer margins, while the style for right pages has a mirror image of those margins. If different headers and footers are not needed, simply choose a mirrored page layout (under Page Layout in the tab Page).

Switching between odd and even Page Styles and between First Page and Left Pages can be done automatically by defining the Next Style. If one defines the Page Style with Next Style and apply the new Page Style to the first page, then OpenOffice.org will automatically apply the correct Page Styles to the continuation pages. Here is a method:

1. Open a new text document.
2. Click the Page Styles icon in the Stylist.
3. Choose the Style First Page to use as the basis for a custom Page Style.
4. Open the context menu and choose New.
5. In the Page Styles dialogue, go to the tab Organizer.
   a) Give the Page Style a name, such as “Page1,” and
   b) define “Left Page” as the Next Style.
6. For the “Left Page” define “Right Page” as the Next Style, and for the “Right Page,” choose “Left Page.”

**Inserting Page Numbers of Continuation Pages**

Footers are inserted using Insert > Footer. After creating the footer, set the cursor in it “and select Insert > Fields > Other... Choose the Document tab and under “Type” select ”Page”, under “Select” select “Next page” and under “Format”, select “As Page Style”. Finally click Fields to insert the field command in the footer of the current document.

The document will display the “page number of the next page, with the exception of the last page.
If the word “Page” should also appear in front of the page number, insert another field of the same type but with another format: Set the cursor in front of the field that just inserted in the document and call the Fields dialogue. Again, select a field of the “Page” type, under Select, select “Next page” and under “Format”, select “Text”. In the Value text box, enter the text to be displayed if a next page exists in the document. Enter “Continue on page” (note the space at the end!) and click Insert.

Of course, one can also enter instead of “Continue on page”, something else. For example, “.../”, to indicate the number of the next page.

Inserting Lines Under Headers
Adjust the appearance of the header directly in the header itself. For example, by clicking on an existing header, users can format the text individually or as a whole paragraph. Additional attributes are available in the Format > Page dialogue in the tab Header.

Selecting the Header tab permits defining a document header for the first time. Mark Header on. When the dialogue is closed by clicking on OK, a header is created which can then be filled out in the document.

- Click the More button on the Header tab to choose additional settings for the border and background of a header.
• Draw a line under the header by going to the Borders tab. Under Line arrangement click between the two lower angle marks at the bottom of the rectangle. This tab page can also be used to define the style of the line and the distance between the header text and the line.

**Footnotes and Endnotes**

Footnotes in a text document can be displayed at the bottom of a page (or column where there is more than one column) or at the end of a document. The settings are defined by choosing Tools > Footnotes. The following information is also valid for endnotes. Endnotes are footnotes that appear collectively at the end of a document instead of at the foot of each page.

One can jump from a footnote anchor in the document to the footnote text quite easily by clicking on the footnote anchor. Press PgUp to return from the footnote to the text.

- The footnote format can be changed by modifying the Paragraph Style “Footnote,” which is automatically applied to all footnotes in a document.
- To delete a footnote, simply delete the footnote mark in the text and the footnote text is automatically deleted as well.

**Inserting and Editing Footnotes**

Footnotes can be inserted in two ways: via an icon or via a dialogue.
Inserting a footnote via an icon
1. Set the cursor at the point where the footnote anchor should appear.
2. Open the Insert floating toolbar on the main toolbar.
3. Click on the Insert Footnote Directly icon.

Inserting a footnote via a dialogue
1. Set the cursor in the document at the point where the footnote anchor should appear.
2. Select Insert > Footnote to open the Insert Footnote dialogue.

When inserting a footnote using the icon, footnote numbering is automatic. The Insert Footnote dialogue on the other hand allows individual settings for the footnote.

Tips for Working with Footnotes
- Click in the text of a footnote to allow editing or modification.
- Press PgUp to jump from the footnote area to the footnote anchor in the text.

Place the cursor in a document immediately before the footnote character of a previously inserted footnote to edit its properties and choose Edit > Footnote or double-click immediately before the footnote character.

When defining general settings applied automatically to footnotes in the document, select Tools > Footnotes to open the Footnote Settings dialogue.

- Format footnotes with Page Setup by choosing Format > Page... > Footnote.

In multicolumn pages, the footnote is inserted in the column where the footnote anchor is located.

Users can also use the mouse to jump from the footnote anchor to the footnote. The mouse pointer changes its appearance as soon as it is over the footnote anchor.

Spacing Between Footnotes
If a bigger distance between the different footnotes or endnotes is wanted, one can add an invisible (white) line as the lower border to the corresponding paragraph format:
1. Set the cursor in a footnote.
2. Open the Stylist.
3. Click on the footnote Paragraph Style to be modified.
4. Open the context menu
5. Select Modify.
6. On the Borders tab page, select a top and a bottom line and give them both the colour white.
7. In the Spacing to contents area, uncheck Synchronize.
8. Increase/decrease the value of the upper or lower spacing.
9. Click OK.
Spellcheck, Dictionaries, Hyphenation

Controlling the Spellcheck via dialogue

Sometimes “choosing Tools > Spellcheck > Check or pressing F7 in a document where “there are no unknown words results in no dialogue appearing. Therefore it is necessary that one enters a deliberately misspelled or unknown word.

![Spellcheck dialog box]

Normally the Spellcheck dialogue appears when called manually via the menu or by pressing F7. Selecting text before calling the dialogue and then checking the spelling only in the text that is selected can be an advantage. The Spellcheck dialogue is described in detail in Help. A manually initiated spellcheck always begins at the cursor position, unless the text was selected (in which case it begins at the beginning of the selected text and ends at its end). When the spellcheck does not begin at the beginning of the document or if the end of the document is reached during the checking process, a dialogue appears asking confirmation that checking continue checking at the beginning of the document.

The system always searches first through the selected user-defined dictionaries and, if the word is not found there, it searches through the main dictionary. Should the word not be there either, the dialogue, shown above, is displayed and which allows the user to replace the "word. Type it correctly in the Word field or select a word from the list of Suggestions, and click on Replace.

The word in the Word text box can be permanently added to the user-defined dictionary. First, select the Dictionary pull-down list. Then, click Add.

When replacing a word in the Word field with another word, one can check this other word by clicking on the Check Word button.
If needed, all unknown words in a text can be automatically entered in the active user-defined dictionary. For instructions, refer to OpenOffice.org Help.

**Automatic Spellcheck**

- From within a text document, click the AutoSpellcheck on/off icon on the main toolbar. All words marked as incorrect by the spellchecker will then be underlined in red.
- Right click on words underlined in this way and a context menu appears.
- The context menu often provides a list of suggested words, one of which may be clicked “to select it. The suggested word then replaces the word underlined in red.

If a wrongly typed word using the AutoCorrect function is replaced in the context menu, the word pair is entered in the AutoCorrect replacement table. To call up this table, choose Tools > AutoCorrect/AutoFormat > Replace tab.

If the word underlined in red is correct, one can place it in a custom dictionary using the Add command.

**To exclude words from the spellcheck:**

1. Select the words.
2. Open the context menu of one of the words.
3. Select Character.
4. Select the Format > Character > Font tab.
5. Select the language [None].

**Removing Words From User-Defined Dictionaries**

1. Choose Tools > Options > Language Settings > Writing Aids tab.
2. Select the user-defined dictionary and click Edit.
3. Now the Edit User-Defined Dictionary dialogue appears allowing the user to search through an alphabetic list.
4. Select the word
5. Click Delete.

**Hyphenation**

Hyphenation in text documents either can either be done automatically or manually.

- Automatic hyphenation is an attribute of paragraphs and Paragraph Styles. This means that one can switch the hyphenation on or off for a paragraph or for a paragraph format and select its properties.
- Manual hyphenation gives individual control, but can be tedious.
Automatic hyphenation

In OpenOffice.org, automatic hyphenation is turned off by default. The following steps are useful for enabling hyphenation on an “as needed” basis:

1. For one or more selected paragraphs, open the context menu and select paragraph.
2. For all paragraphs formatted with a certain Paragraph Style, open the context menu in one of the paragraphs and select Edit Paragraph Style.
   a) In the next dialogue, click on the Text Flow tab.
   b) Under Hyphenation, check off Automatically.
3. To enable hyphenation in all paragraphs, edit the parent Paragraph Style of all derived “Paragraph Styles.
   a) In the next dialogue, click on the Text Flow tab.
   b) Under Hyphenation, check off Automatically.

To enable automatic hyphenation without queries, select Tools > Options > Language Settings > Writing Aids > Options and select Hyphenation without inquiry.

Manual Hyphenation

- For manual hyphenation, place the cursor at the point where the word should be separated and press Ctrl and -. The word will be separated if it is possible, even if automatic hyphenation is turned off for the paragraph.

If a hyphen is entered directly, Writer will not apply the automatic hyphenation for that word. Let's assume the word “Antarctica” would be hyphenated: An-tarcti-ca, but this should be: Ant-arc-ti-ca. Enter all three hyphens manually (directly), including the one between “i” and “ca” as is used in automatic hyphenation.

There is a quick way to prevent a particular word from being affected by the hyphenation (or spellcheck) functionality:

- Select the word and choose Format > Character. On the Font tab select Language None.

If a word want should be permanently set to prevent automatic hyphenation such that it will never be separated, place it in an active user-defined dictionary with an equals sign after it:

1. Choose Tools > Options > Language Settings > Writing Aids.
2. Select a User-defined dictionary.
3. Click the Edit button. Where there is no user-defined dictionary, as yet, create one by clicking the New button.
4. In the Edit Custom Dictionary dialogue, enter the word. e.g., "Companyname=" (without quotation marks)
5. Click Close to close the dialogue.
6. Click OK

Now, the word “Companyname” will never be hyphenated.
Selecting **Tools > Hyphenation** “avoids searching manually through the text in order to find words to hyphenate. This starts the following dialogue which shows all words that could be hyphenated with the current line break, one after the other.

![Hyphenation Dialog](image)

The syllable at which the word could best be hyphenated at the current line break is highlighted. In the case where the word to be hyphenated should have the hyphen at an earlier place in the word, use the left arrow button to move the highlighting to the left. Click on **Hyphenate** to hyphenate the word at the highlighted place and the next word that could be hyphenated is displayed.

When the spellcheck recognizes the word, the default hyphens are displayed as well.

**Thesaurus**

The OpenOffice.org thesaurus provides a means to look up words that may be used instead of the highlighted word.

![Thesaurus Dialog](image)

1. Highlight the word in the text for which an alternative is desired from the thesaurus. For example, the word, clean.

2. Select **Tools > Thesaurus** or press **Ctrl+F7**.
3. In the dialogue which then appears, scroll down the two lower list boxes until a suitable word is found. If the dialogue is closed by clicking on OK, the selected word is replaced by the word in the Replace field.

Note: Not all languages have a thesaurus to accompany an installed dictionary.

When looking for alternatives for a word in another language for which a thesaurus is installed, for example an English word,

1. Select the word in the text
2. call up the thesaurus.
3. Click on the Language button to switch to “English (UK)” or “English (US)”, in order to select British or North American spelling.
4. Then click on Search.

If English language attributes are applied to the English words in the text (Format > Character, Font tab, Language list box), then the spellcheck, thesaurus and hyphenation will automatically be in this language. One can assign a language to Paragraph Styles in the same way.
Form Letters, Business Cards and Labels

Write form letters, design business cards and produce labels — “all from data obtained from a data source or that is sequentially numbered.

Creating Form Letters

To aid in creating form letters, the following section first gives some brief instructions and then detailed instructions.

Brief Instructions (For Quick Results)

1. Register an address data source in OpenOffice.org, if not done previously.

Instructions may be found with the search term “address book” in Help.

2. File > AutoPilot > Letter to open the dialogue.

3. Setup the template.

4. Select the addresses for the form letter, or enter them manually.

Click Create. Writer can now create the form letter.

Fixed and Variable Fields

*Fixed* fields are fields which are filled out only once, i.e., when the field is inserted into the document. For example, if writing an invoice based on an invoice template, use a *fixed* date. By doing so when setting up the invoice document, the field position will contain the current date and will not change later on. That is, the date of the invoice is determined only once.
Chapter 3: Managing Text Documents With Writer

On the other hand, a variable date is updated every time the document is opened and printed. A manual update of the fields (i.e. with the F9 key) sets the actual date in the field entered as Variable date.

If, for example, when inserting a date as a field in a form letter, the user must decide if it is to be inserted as a fixed or as variable date:

- Where the date should never change; that is, as if the date is typed in directly (without a field), select a fixed date format. The advantage to using a fixed date field means that the form letter “can be saved as a template. Using this templates to create a new form letter based on that template will have the date will automatically updated to today’s date.

- By selecting a variable date, the date will be updated every time the document is opened or printed.

Apart from the date, there are various other fields which can also be used in a form letter. The most important fields are the ones which determine where the different elements of the recipient's address are to be placed. These fields have a direct connection to the database table which contains the address list. A field will be inserted in the form letter for each data field, such as name, street, city, et cetera. When printing, Writer inserts the desired data fields in the fields from each record. In most cases, create the form letter template.

1. File > AutoPilot > Letter to open the dialogue.
2. Setup the template.
3. Select the database containing the addresses for the form letter.
4. Set the fields as directed by the AutoPilot
5. With each dialogue, select the features needed.

6. Click Create to add this document to the templates and to open a Writer session to complete the body.

7. If the body text will be used in the future, use File > Template > Save and overwrite the initial instance of the template.

Having done this, this template may be used for other form letters:

1. Select Tools > Mail Merge to start the process of creating a form document based on the template just created. The letter based on this template will be displayed and already contain the fields for the address, date, sender, et cetera.

2. Choose From a template in the Mail Merge dialogue.

3. Press F4 to open the data source for the current document.

4. Select the records necessary for use in the form letter by clicking the row headers at the left in the data source view. Press the Shift key and/or the Ctrl key to make a selection. To print a form letter for all the records in the table, click the empty field above the row headers to select all records.

5. Edit to suit personal requirements.

6. Save the document.

7. Now click the Mail Merge icon on the database bar at the top of the data source view. The Form Letter dialogue appears, where two choices are offered, to save as file(s) or print. One can also choose to print selected records, all records or a particular range. If printing a range, for example, records 1 to 5, ensure that the numbers follow the order displayed in the data source view.

To sort or filter records in the data source view, by click the respective icons on the database bar. For example, to sort all records according to postal code, place the cursor in the POSTAL CODE (ZIP) field of any record and click Sort Ascending. Now the form letter is all ready to go!

**Note:** If a completely new document containing the necessary form letter fields is being created, use drag and drop to do so: Open the text document and press F4 to show the desired database table. Point to a column header and, holding down the mouse button, drag it into the document. The field for inserting this item from this database table is automatically placed in the document.

### Creating and Printing Labels and Business Cards

#### Designing Business Cards via dialogue

Choose File > New > Business Cards to open a dialogue with several tabs which helps design the look of business cards. These are generally fairly simple “which may or may not be what is wanted.”
Designing Labels and Business Cards

Using File > New > Labels for designing business cards, as business cards may be regarded as a simplified, special kind of label, is often the best method. Like labels, all business cards are the same and, as labels, can be filled with different contents, graphics, data obtained from a database, or they can be marked with serial numbers.

1. Select File > New > Labels to open the Labels dialogue.

2. On the Labels tab, under Format, define the label format.

   Writer contains many formats of commercially available sheets for labels, badges, business cards etc. User-defined formats can also be added.

3. On the Labels tab, under Inscription, choose what to write on the labels.

   This often involves database fields, so that the labels can be printed with varying content, when sending “Form Letters” for example. But it is equally possible to have the same text printed on every label.

   Use the pull-down lists to select the database and table from which the data fields are obtained. Click on the big arrow to transfer the selected data field into the inscription area. Press Enter to insert a line break. Entering spaces and any other fixed text is also possible.

   Using the Format tab, define custom label formats, not covered by the predefined formats. To be able to do this, the label type on the Labels tab must be set to “User-defined”. On the Options tab, specify whether all labels or only certain ones are to be created.

4. Enable Synchronize contents check box on the Options tab. If this is checked, only one (the top left label) has to be entered and edited while the remainder will be repeated identically.

5. Upon clicking New Document, a small window opens with the Synchronize Labels button. Enter the first label. When the Synchronize Labels button is clicked, the current individual label is copied to all the other labels on the sheet.

6. Click on New Document to create a new document with the settings that have been entered.

7. Print the new document.

Printing Labels With Serial Numbers

Printing lottery tickets or entry tickets with serial numbers on them is quite easy. “This is how to do it:

1. Select File > New > Labels. This opens the Labels dialogue.

2. On the Labels tab, under Format, select the format in which to print.

3. Tickets, label tags or rolls are available from specialist suppliers and are often made from stiff paper with tear-off perforations, or as self-adhesive labels on a backing material.

4. To define a custom format, select the Format tab.
5. Check **Synchronize contents**.
6. Click on **New Document**.
7. A new document is now created, divided up as wanted. only the top left label needs to be edited and, when satisfied, “press **Synchronize labels** to make all labels appear the same. This button is only visible if **Synchronize contents** is checked on the **Options** tab.

8. Enter the desired text in the top left label and format the contents.
9. Serial numbering can be applied by inserting a field.
10. Place the cursor at the point where the number should appear.
11. Press Ctrl+F2 or choose **Insert - Fields > Other**.
   a) In the **Fields** dialogue, go to the **Variables** tab.
   b) Select the type **Set variable**, if it is not already marked.
   c) In the **Name** box, enter a name for the counting variable, for example **Number**.
   d) To increment the variable from one label to the next by 1, enter the following formula in the **Value** text box: **Number+1**.
   e) Click **Insert**, then close the **Fields** dialogue.
12. Click **Synchronize Labels**.
13. Now save and print the finished document.

**Printing Address Labels**
When printing address stickers for form letters that do not fit in window envelopes, do the following:
1. Select **File > New > Labels** to open the **Labels** dialogue.
2. Select the format of the label sheets that will be printed from the dropdown menu. Remember to check **Synchronize contents** on the **Options** tab.
3. Click on **New Document** to close the dialogue.

4. When the label document open, invoke the data source view by pressing the F4 key.

5. Click the tack icon at the edge of the data source view to avoid having it cover the first label.

6. In the data source view, select the address data source table.

7. Drag the data fields needed for the Address individually into the top left label. For example, click on the column header NAME and, keeping the mouse button depressed, drag it into the label. This inserts a field.

8. Put the fields in order to complete the address in the first label at top left.

9. Place the cursor at the last text position (after the last field) in the first label.

10. Open the **Fields** dialogue by pressing the shortcut keys Ctrl+F2.

11. Choose the **Database** tab.

   a) Select the type **Next record**,

   b) Click on **Insert**

   c) Click **Close**.

12. Now synchronize the labels by clicking the **Synchronize** button in the small window.

13. In the data source view, select the records that will printed on the labels, by clicking on the row headers to the left. Use the Shift or Ctrl key in the usual way to select several records at the same time.

14. On the **database bar**, click the **Data in Fields** icon.  

15. Now save and/or print the label document.

---

**Avoiding Blank Paragraphs**

Sometime fields in a form letter can be empty and a blank line is printed. For example, there is a field named **COMPANY** that should appear in the recipient field, but for some records this field is . To prevent these empty fields from being included do the following:

1. Place the cursor in the text document before the form letter field **COMPANY**.

2. Choose **Insert > Fields > Other** to open the **Fields** dialogue.

3. On the **Functions** tab select the type **Hidden Paragraph**.

4. In the **Condition** field, enter the following text (without quotation marks):

   ```
   not (Company)
   ```
Now the COMPANY line will not be printed, and the rest of the lines will be moved upward if the COMPANY database field is empty.
Newsletters

In this section, learn how to create a newsletter/newspaper as a text document. This is useful for creating newsletters for a company or club, or in celebration of a special event. Currently OpenOffice.org does not have a resident newsletter template but there is a nice one that works available from http://ooextras.sourceforge.net/ and this is one used in this section.

To install the template after downloading, do the following:

1. Open the template in OpenOffice.org Writer.
2. Select File > Templates > Save
3. Choose where to save the template. Default is probably best as no special permissions are needed.
4. Name the template
5. Click OK

Voila, there is now newsletter template ready for use.
Creating a Newsletter From a Template

In the File menu choose New > Templates and Documents. Locate and double-click to open the Newspaper Template.

The document contains several useful elements that could be of good use of in a newsletter. It contains, for example, an automatic page numbering system and a field with the fixed date. One can now enter text and position graphic objects.

Modify the existing heading as needed and insert any graphics.

A few other texts highlighted in gray are variables, which modifiable.

When the document is completed, save and print it.

Edit the template (File > Templates > Edit) for any personalization and layout changes.

Creating Page Styles

Where a page must include not only text but also several larger graphics, create a separate Page Style for this purpose.

1. Open the Stylist and click the Page Styles icon.
2. From the context menu, select the command New to open the Page Styles dialogue.
3. In the tab Organize, assign a descriptive Name for the Style.
4. Next, click the Page tab and define the page format and margins.
5. Check Register-true and choose the reference Paragraph Style Text Body.

Note: If the register-true option is activate, the baselines of all paragraphs with the Text Body Style will be exactly aligned so that they are at the same position in each column and on each page in relation to the page. With double-side printing, the baselines of the register-true paragraph will have the same position. Normally use the Paragraph Style used to create the actual text. To define another Paragraph Style as register-true, call up the properties dialogue of that Paragraph Style. Call it up, for example, in the Stylist via the context menu of that particular Paragraph Style, select the Modify command. On the Indents and Spacing tab, in the field under Register-true, select Activate.

Editing Headers

To edit a header, click in the header field in the document. With the context menu (Page), activate the Page Styles dialogue. Select the Headers tab and click Options. In the Borders/Background dialogue, choose a background colour and click OK, then confirm the following dialogue as well.

Editing Columns

To change the number of columns or create a dividing line between columns, activate the Page Styles dialogue via the Page context menu.

Click on the Columns tab. Change the number of columns in the spin box Amount, and modify the distance between the columns in the spin box Spacing. Make sure that the Automatic Width field is selected.
To create a dividing line, select a narrow line from the Line list box under Separator, set the Height to 75%, and define the position as Centered. Finally, click OK to close the dialogue.

To place headings or subheadings that are more than a column wide into a multi-column text, try putting them in a text frame. The text frame can be freely scaled and positioned on the page. Insert a frame using the Insert Frame icon on the Insert floating toolbar. Text frames can may also have borders, but this is not always necessary.

**Editing Paragraph Styles**

1. Click the Paragraph Styles icon in the Stylist and select the Paragraph Style to be modified.

2. Select the Modify command from the context menu, call up the Paragraph Styles dialogue. In this dialogue, there are several tabs with various settings and options.

Experiment with font effects, for example drop caps. Click the respective tab and select Show Drop Caps. Drop caps may even be assigned a Style in the Character Styles list box under Contents.

**Note:** Newsletters or newspapers require a variety of main headings, subheadings, and text wraps to make it easier to read. In the Paragraph Styles dialogue of the Stylist context menu, it would thus be a good idea to create several appropriate Paragraph Styles (go to the Stylist > context menu > click New...).
Chapter 3: Managing Text Documents With Writer

Working with Frames

A frame positioned over one or more columns can give the newspaper a less crowded, more interesting appearance. Such a frame can contain text, graphics, or even a chart.

![Insert icon on main toolbar and floating toolbar](image)

Click the Insert icon on the main toolbar and from the floating toolbar, select the Insert frame manually icon. The mouse pointer changes to a small cross that is dragged to open a frame and position it over one or more columns in the document.

Formatting a Frame

Put the cursor in the frame (deselect the frame first, then click inside it) and enter any text or graphics. The appearance and properties of the frame can, of course, be modified at any time. Select the frame by clicking it, call up the context menu and click Frame... A dialogue with several tabs will appear which allows, for example, one to apply a coloured shadow to the frame via the Borders tab.

Anchoring Frames

In the Frame dialogue, click the Type tab and select the type of anchor under the heading Anchor to. If the frame is to always remain on the same page — which is important for a table of contents, for example, — select Page. For the frame to flow with the text, e.g., for small symbols which always appear in the margin accompanying a certain word in the text, select To Character. Or, in flowing text, the frame should move with the text as a character, select As Character. Select Paragraph to anchor a frame to a specific paragraph.

The type of anchor can also be specified from the context menu. Alternatively, click the Change Anchor icon in the Object bar to quickly change the anchor.

Defining a Frame Wrap

Open the Frame dialogue (context menu > Frame) to define the frame wrap and click the Wrap tab. Select the desired wrap style, and under Spacing, define the spacing between the frame and text. Finally, select the option First Paragraph.

The First Paragraph field (or the menu command in the context menu) ensures that when a graphic is positioned between two paragraphs, only the first paragraph wraps around the picture.
Defining a Wrap Region

Making a newsletter more attractive with objects or graphics is a goal that is easily achieved by having the text flow around an object. Simply draw a Polygon using the Polygon icon in the Show Draw Functions floating toolbar. Place the polygon over the text and assign the text the Wrap > Contour with its context menu.

A wrap contour to 3D objects can also be defined. Create a 3D object with OpenOffice.org Draw, copy it to the clipboard and paste it into the text document. Open the context menu of the inserted object and choose Wrap > Contour. In the context menu of an object with a wrap contour is the Wrap > Edit Contour command. This command calls the Contour Editor from which manually reediting the automatic contour is possible. Refer to the instructions in Help.

Linking Frames and Facilitating Text Flow

If the text should be continued in the same manner as in a newspaper, i.e. from a frame on page 1 to, say, a frame on page 4, and where the text flow from frame to frame must be done automatically, use linked frames.

Create two (or more) frames by opening the Insert floating toolbar, clicking Insert Frame, then select the first frame (click the border of the frame).

Click the Link Frames icon on the object bar. Now, click the second frame.

To enter text in the linked frames, position the cursor in the first frame and type in text or insert it from the clipboard.

Note: If certain text from a document is to flow in linked frames, first put the text cursor in the first frame (first click the normal text to cancel the frame selection and then click the frame).

Now decide if the text should be a copy in the frame or if it should keep a link to the original document (in this case it would always return to the actual stand of the original document). If the text is only to be copied, choose the command menu Insert > File.
If the text is a section linked to another file choose Insert > Section. In the Insert Sections dialogue that appears, click Link and select the file wanted with the ... button. Finally, click the Insert button.

**Using coloured or Graphic Backgrounds**

To assign a coloured background to a paragraph, place the cursor in that paragraph and click the Background colour icon in the Object bar. A floating colour palette appears from which the desired colour is selected by clicking it once.

*Note: When frequent use of a background colour for certain paragraphs is used, it is best to create a Paragraph Style for this purpose.*

A background can be a graphic image rather than a colour. The background graphic image is assigned to a paragraph either via the Paragraph Style (in that case, all paragraphs based on this Style will have the same graphic background), or use Format > Paragraph.... to edit it. Click the Background tab and in the list box As select “graphics” in order to pick out an appropriate graphic image.

**Creating a Table of Contents**

Tables of contents can be created manually; however, if the contents are altered, the table of contents must be manually updated, as well. It is much more convenient (and time-saving) to have the program create a table of contents automatically.

1. With the text entered, creating a table of contents on the front page of the newspaper or newsletter may be in order. To do so, follow these steps:
   a) Draw a frame manually on the front page,
b) Select To Page as anchor.
c) Press the Escape key to set the cursor in the frame.

2. Open the Insert Index/Table dialogue (choose Insert > Indexes and Tables > Indexes and Tables).

3. On the Index/Table tab page.

4. Select “Table of Contents” as Type,

5. Enter an appropriate heading, e.g., “In this issue...” in the Title field.

Ensure that one of heading Paragraph Styles is assigned so that chapter numbering may be determined for the headings. These are determined by the Styles under Tools > Chapter Numbering. The predefined Paragraph Styles are “Heading1” through “Heading10”.

If the table of contents should use the headings in the document, specify the desired outline structure using the Evaluate up to level spin box.

If other, customized Paragraph Styles for the headings have been defined, these can also be incorporated “into the table of contents. To do so, go to the Insert Index/Table dialogue, click the Index/table tab and in the Create from area, mark the Additional Styles check box. Click the button to the right of the check box. The Assign Styles dialogue will appear.

This is where the level of the Style is assigned, in the table of contents, for each Style used in the document.
Choose more settings on the **Entries** and **Styles** tab pages and Click **OK** to create the table of contents.

Once the newsletter or newspaper is finished, save and print it.
Further Information

Using Automatic Hyphenation

When working with columns, it makes sense to activate automatic hyphenation for every Paragraph Style (do so by calling up the context menu of the Stylist and clicking Modify... to access the Paragraph Style dialogue > click the Text Flow tab). Enter a “3” for Characters at line end and Characters at line begin to ensure that hyphenated words have at least three characters at the beginning or end of a line. For text alignment in columns, choose Justify on the Alignment tab.
Letters With Envelopes

With OpenOffice.org Writer, a letter can be written in no time. These instructions show “how easy it is.

There are two really easy ways “to get a result:

- Use a letter template,

or

- Use the AutoPilot to create a custom tailored letter template.

Using a Ready-Made Letter Template

1. Press Shift+Ctrl+N to open the Templates and Documents dialogue:

2. Select a template.

3. Enter the details required for the various wildcards, such as the salutation.

4. Type in the remaining text.

Templates include the user data that was entered in Tools > Options > OpenOffice.org > User Data and which may be modified at any time.

Creating a Letter Template Using the AutoPilot

1. Start the AutoPilot by selecting File > AutoPilot.

2. Click Letter in the submenu to see the first page of the AutoPilot for Letters.
3. Select **Personal Letter**.

4. click **Next** to bring up a second page with additional options appears.

5. Choose the option **No Logo**.

6. click **Next**. A dialogue will appear in which one can enter the sender details.

7. The sender address is displayed at this point. Thus, under **Show sender?** select **Yes**.

8. Click the symbol **top right** in the **Position and size** area.

9. Click **Next**.

**Note:** If the input field does not contain a sender, the program will lack the necessary details. In this case, click **Cancel**, open the **User Data** tab (in **Tools > Options > OpenOffice.org**) and enter the necessary data. After that, re-open the AutoPilot and carry on as described up to this point. Sender details may also be entered directly in the input field of the AutoPilot; however, these details are not currently entered in **Tools > Options > OpenOffice.org > User Data**, this process for every must be repeated with new template created with the AutoPilot.

10. Continue to click **Next** until reaching the page with the footer options.

11. Deactivate the check box **Footer on**

12. Click **Next** twice.

13. Enter the name of the template in the **Name** field. If necessary, enter any additional information in the **Info** field. (The template will be stored in the template folder under the name chosen.)

14. Click **Next**.

15. Enter the printer trays if different paper trays are “to be used for the first and subsequent pages. This is especially practical when the only the first page is to be on letterhead paper.

16. The last step is to click **Create**.

After clicking the **Create** button, OpenOffice.org creates a document template and places it in the template folder. At the same time, a new, unnamed document appears on the screen, that has been generated as a copy from this template.

Now start entering text and then save and print the document. However, if one would like to keep on working on the layout of the document template or create an envelope for it, close the new document without saving it.

**Creating an Envelope**

This section contains a description of how to create a template for an envelope after completing a letter template plus some tips on how to continue polishing template design.

As the envelope should be saved together with its template, open the letter template.

1. Select **File > Templates > Edit**.
2. Locate the letter template wanted and open it. The templates are found in the OpenOffice.org directory user/template in the user's home directory. (Path names may vary with different releases.)

3. Go to the Insert menu

4. Select Envelope. A dialogue of the same name appears.

![Envelope Dialogue]

5. On the tab pages Envelope and Format, specify the envelope format and the position of the addresses of the sender and addressee on the envelope. Use the Printer tab page to define appropriate print options.

**Inserting an Envelope into a Document**

Click on the Insert button in the Envelope dialogue. The envelope will be inserted above the first page of the active document. (In this case, before the first page of the personal letter template)

To continue editing the envelope (for instance, to change the format again), open the Page Style: Envelope dialogue (in the context menu of the envelope click Page... and select the Page tab).
**Adjusting the Printer for the Printout**

Printing envelopes depends very much on the type of printer used. Some printers require a special cassette, while others have a multi-purpose tray that can feed envelopes. If in doubt, consult the manual for the printer.

Specify any print options in the **Page Style: Envelope** dialogue. To open this dialogue, click an empty spot on the envelope, open the context menu, and select **Page...**. Then select the **Page** tab. Define the desired settings under **Paper Format**.

Check **File > Print ... > Properties** to ensure that the printer knows the size of the envelope being used. When this step is skipped, printing of an envelope becomes unpredictable.

**Applying Various Fonts**

Modify the Paragraph Style to permanently change the font size and style for all paragraphs with that particular paragraph format. First, position the cursor in the text that to be modified and select the command **Edit Paragraph Style** in the context menu.

The **Paragraph Style** dialogue opens, with various tabs. Click on the **Font** tab and specify the type, size, and style of the font.

```
Note: If one wants to emphasize a particular passage in a letter, simply select the text and click the **Bold** or **Italic** icon. To format only a single word, simply place the cursor anywhere in the word and click **Bold** or **Italic**.
```

Make any other necessary changes, then click the **Save Document** icon and close the document template.

```
Note: When creating a template, remember not to type a text for a particular letter. The main purpose of a template is to define the general layout of a document. Use the documents based on the template to add text for a letter.
```

**Creating and Printing a Letter With an Envelope**

With the creation of a customized template for personal letters, write and print a letter.

1. Select **File > New > Templates and Documents**.
2. In the dialogue select the template.
3. click **OK**. OpenOffice.org creates a document based on the template without changing the template itself no matter of the modifications to the document.
4. Enter the text of the letter in the document.
5. Check if the addressee information on the envelope is correct.
6. If this document is to be printed or edited later on, save it and enter a name.
7. Place an envelope in the printer.
8. Select the command **File > Print** and print page 1, which is the envelope.
9. Place normal letter paper in the printer, select the command **File > Print** again.
10. Print the second page. If the letter has more than one page of text, specify which pages to print under **Pages**.
Summary
Create documents from templates, select File > New > Templates and Documents, choose the template wanted and click Open. To edit a template, choose File > Templates, click Edit and select the template.
Chapter 4: Spreadsheets in Calc

Calc is the powerful spreadsheet program of the OpenOffice.org program. It provides the functions necessary for professional use with financial and statistical functions as well as database functions and much more.

Overview of the Functions in Calc

This section contains a short overview of some important functions and capabilities of Calc.

Calculating

Calc works primarily as a spreadsheet program. i.e. it provides a spreadsheet containing cells into which text, digits and formulas can be entered and, from these, calculate simple and complex results. Calc, like the other components of OpenOffice.org, has numerous automatic functions to ease usage.

While Calc provides all the basic calculation types, it also has numerous calculation methods that can be entered interactively via the AutoPilot: Functions. In addition, it allows entering text and flexibly arranging cells, so forms can be comfortably styled, filled in, calculated and printed.

Database Functions

Data that can be summarized into records, such as addresses, inventory levels, customer orders or similar, can also be managed by Calc. Even if there are no calculations, Calc can quickly sort a database range and search the data for specific characteristics, such as maximum or minimum values.

In addition, a sheet in Calc can serve as a data source for creating form letters and reports with OpenOffice.org Writer.

Arranging Data

Data can be organized in easy-to-read lists. With just a few mouse-clicks, the view can be reorganized to show or hide certain data ranges, format ranges according to special conditions, or calculate subtotals and totals.

Examining and Extrapolating Data

The data in Calc tables can be examined in detail in many different ways. Calc is useful for creating term papers because it supports many statistical functions such as regression analysis. And for daily calculations at work, the integrated financial functions are helpful, because they can be used to print detailed tables of current credits and loans and other data.

What-If Calculations

Results of changes made to one factor of calculations composed of several factors can be views immediately. For example, see how changing the period in a loan calculation affects the interest rates or repayment amounts. Furthermore, larger tables are made manageable by using different predefined scenarios.

Dynamic Charts
Calc has a charting function that can display spreadsheet data graphically by selecting the data to be displayed and clicking the **Insert Chart** icon. Drag open a frame at the required position, define specific chart settings in the dialogue that appears. The chart is inserted at the selected position and, when the source data is modified, is be dynamically updated.

**Importing and Exporting Data**

Data from other spreadsheets programs can be imported, edited in Calc and, output in different export formats.

Users are presented with a dialogue similar to the following when they select Text CSV as the file type when the input file uses a character to separate the fields (tab in this example):

**Importing into Calc**
Where the input file is in fixed width fields, check the Fixed width box and set the column widths in the measurement bar as shown below:

![Text import dialog]

**Exporting from Calc**

Usually, one would simply use the Save as dialogue. Other export options, such as PDF are also available in the same manner as for Writer or the other OpenOffice.org modules.

**Referencing Data in Networks and the Internet**

Rather than being restricted to having only a fixed value or formula that refers to other cells in the sheet, each Calc cell can also contain a reference to contents in other documents. The documents referred to do not have to exist on the local computer, they can also be stored on a network or anywhere in the Internet.
The Calc Window

Structure of a Spreadsheet

A spreadsheet is made up of individual sheets. Each sheet contains various cells, arranged in rows and columns. Each cell can contain either an arithmetic formula, text or value (of virtually any length).

A calculation can be entered directly as a mathematical formula. For example, $=4 + 5$. But the main reason for using a spreadsheet is that its formulas can refer to other cells. An example of such a mathematical formula might be $=\text{SUM (A1 : A8)}$. This calculates the sum of the values in cells A1 through A8 and enters the result in the cell containing the formula. Additional formulas may also be entered in cells A1 through A8, each referring to other cells and their contents, and so on. As one can see, this allows calculation of extremely complex relationships.
A new spreadsheet is opened with the command **File > New > Spreadsheet.** Initially it is named “Untitled1” and remains with that name until saved under a different name. Look at the new, still empty document for the several typical elements, that are discussed in the following sections.

**Rows and Columns**

On a spreadsheet, rows are numbered from 1 to 32000 and the columns are designated with the letters A through Z, AA through AZ, and so on; the last column is labeled with the letters IV. Each cell on the sheet can be uniquely referenced by row and column. For example, cell A1 is the first cell in the upper left corner of the sheet.

These numbers and letters appear along the edge of the window. The row header contains the row numbers, and the column header names the columns. Clicking on one of these areas, selects the entire row or column. To select the entire sheet, click on the unlabeled button at the intersection of the row and column headers at the top left.

Enter some text in cell A1. As text is typed, notice that the text appears both in the cell and in the input line of the formula bar. Continue typing to see that more text can be added than appears to fit in the cell.

In fact, any cell can accommodate text longer than a cell. The whole length of the text is displayed and printed, provided the adjacent cells to the right are empty. If the cell to the right is not empty, a small triangle on the right hand edge of the first cell appears, indicating that the cell contains more text than can be displayed.

**Note:** Turn off these triangles by choosing **Tools > Options > Spreadsheet > View** and unchecking the **Text overflow box.**

When a number cannot be displayed in a cell because it is too long, or due to the formatting, e.g., currency format, ###” is displayed. In this case, increase the column width. Set the width to optimal” by simply double-clicking the right divider in the column header.

Use all the usual functions to edit text. Notice, however, that the right and left arrow keys will replace the cell cursor if **Entry mode** (by clicking in a cell and entering characters) is enabled. Double-clicking or pressing the F2 key or clicking in the entry row, enters the **Edit mode.** The left and right arrow keys now replace the text cursor. Upon pressing the **Enter** key, the text in cell A1 is finished and the cursor automatically moves to cell A2. The active cell is always the one with the cell cursor and that is where entries and changes are made.
Multiple Sheets in a Document
At the lower edge of the spreadsheet document there are tabs for switching among the various sheets of a document. A new, empty spreadsheet initially contains three sheets, each titled SheetX” where X stands for the numbers 1 through 3).

Inserting Sheets
1. Using the mouse, put the pointer in one of the sheet tabs at the bottom of the window.
2. Right click to open the Context menu for the commands governing editing sheets.

3. Choosing the Insert command, opens the Insert sheet dialogue.
4. Select the position and quantity of sheets to be inserted
5. Click OK.

Renaming Sheets
1. Right click the tab of the sheet for renaming, e.g. Sheet1”.
2. Open the context menu and choose the Rename command.
3. A dialogue box appears in which to enter a new name.
4. Enter a new name for the sheet
5. click OK.

6. Alternatively hold down the Alt-key and click on any sheet name and enter the new name directly. As an alternative, this feature may or not work with the installed window manager.

**Note:** The name of a sheet may consist only of letters and numbers. Spaces are also permitted.

The name of a sheet is independent of the name of the spreadsheet. Enter the spreadsheet name when saving it for the first time as a file. The document can contain up to 256 individual sheets, each of which, can have different names.
Values and Formulas as Cell Contents

Individual cells can contain text, numbers, dates or formulas. Cell contents are very easily specified or modified and these may be updated at any time by recalculating the formulas with current data.

Values in spreadsheets mean numbers, dates, times and results of formulas. Emphasize values by marking Value Highlighting in the View menu.

If desired, check this option in Tools > Options > Spreadsheet > View, in which case this function will apply permanently for the current document and all documents created in the future (other, already existing documents retain their settings). If this function is enabled, numbers and dates are automatically shown in blue, and values in cells containing formulas in light green. Text remains in black. If Value Highlighting is not marked, users are free to choose the colours and other formatting of the content of their spreadsheets.

Text can be entered in a cell even if it appears to be too long for the cell. Now try entering a very long whole number. If the number is too long to fit in the cell, the overflow indicator ###. By double clicking the right hand edge of the heading of this column, the column is automatically set to the optimal width.

The box at the bottom right in the status bar always displays helpful information. In a spreadsheet, this box can be used to permanently display the sum of all selected cells. Other values may also be displayed, such as the maximum value of all selected cells. Use the context menu to change the value displayed in this field. In case of an error in the spreadsheet, this field will also display an error message.

Calculating in Spreadsheets

The following demonstrates a simple percentage calculation that can be done in a spreadsheet:

1. Position the cursor in cell A3.
2. Enter the number 150 and
3. press the Enter key. The cursor then moves down to cell A4.
4. Enter the number 16 in cell A4.
5. Press the Tab key this time rather than the Enter key and the cursor moves to the right to cell B4.
6. Enter the following in cell B4:

\[=A3 * A4 / 100\]

When input is started with an equals sign, this indicates that a formula is being entered and the formula will be seen in the input line of the formula bar.

7. Press **Enter** to finish the formula.

8. The result of the calculation is (16 percent of 150) in cell B4.

9. Click on cell A3, enter 200.

10. Press the **Enter key**, at which time, the calculation result is automatically adjusted.

11. Click on cell B4.

12. Click at the end of the formula in the input line of the Formula bar.

13. The blinking text cursor indicates a new entry can be made.

14. Add “+ A3” (without the quotation marks) to the formula.

15. Press the **Enter key**.

16. The newly calculated value of the formula appears in cell B4: the previous 16 percent of A3 plus the contents of A3.

These steps introduce the most important steps in working with spreadsheets: creating and entering formulas, entering data (text and numbers), obtaining results, modifying source data or formulas, and how to view results of new data or formulas.

Besides the four basic arithmetic operations, there are other operators, nested brackets and many other functions. The **AutoPilot: Functions** button is a useful aid when inputting functions.
Using Built-in Functions

Calc has many built-in functions, one of which convert Euro dollars to another currency, such as the US dollar. The following provides an example of using functions to achieve a goal.

Note: A list of functions is available from Help > Contents > Index > Search term > function list; Calc.

1. Enter a formula (e.g. =4+5 or =A3*A4/100) in a cell.
2. Press the “Enter” key.
3. The result of the calculation appears in the cell.

However, functions can also be entered in a formula. An example could be =SIN(1), which will give a result of sine of one (rounded to two decimal places).

1. Calc has several other functions, too, and additional functions can be added using StarBasic or AddIns. Help has a section outlining how to do this. In most cases though, the standard functions provided in the program are sufficient for most requirements. The function with the Syntax CONVERT(arguments) is shown here as an example that will convert a sum of US$ 100 into Euros by entering the following formula in a cell:

   =CONVERT(100; "USD"; "EUR")

The result will be the number of Euros per 100 US dollars. The value for conversion is always stated first within the parentheses. It can be entered directly, as shown, or by reference. If the amount is, for example, in cell D2, enter D2 in the formula as the first part of the function.

The remaining parameters of the function name the unit of the amount and the unit into which it is to be converted. All three parts of the function are separated from each other by semicolons.

Thus, using the formula =CONVERT(50; "EUR"; "USD"), displays the number of US dollars that is the equivalent of 50 Euro dollars. To try this, proceed as follows:

   In an new spreadsheet, enter in column D, from D2 to D20 a number of USD sums

1. Designate column E from E2 to E20 as the cells in which the same sums in Euro dollars must appear.
2. Click in cell E2.
3. Enter =CONVERT(
4. Click in cell D2. D2 is now defined as the first part of the function. The cursor remains at D2 in the formula.
5. Enter "USD"; "EUR". i.e. enter the text with both semicolons and the quotation marks.
6. Press the Enter key.
7. This completes the entire formula which now reads

   =CONVERT(D2; "USD"; "EUR").
8. Cell E2 will contain the result of the calculation.

9. Click cell E2, then the small filled square in the bottom right hand corner of cell E2 and, pressing the left mouse button, drag down to cell E20.

10. Release the mouse button there.

11. The formula is now copied from E2 to E20. And all references have been automatically adapted so that they always refer to the neighboring cell on the left.

**A Short Description of What Cells Can Contain**

The previous examples show that cells can accommodate different elements. These are described below.

**Text**

Text in a cell can be formatted and edited with most of the functions available in a text document. For example, to select a word, double-click the word either in the input line or in a cell. If a different font or other attribute from the text object bar is needed, the modifications apply only to the selected word.

- Pressing the Ctrl+Enter keys inserts a manual line break. This shortcut only works directly in the cell, not in the input line.

When text must break automatically at the right border of the cell, proceed as follows:

1. Select all cells in which the text should break at the right border:

2. In **Format > Cell > Alignment**

3. Check the **Line break** field

4. Click **OK**.

Calculations are possible even in text. For example, enter text in cell A1 and more text in A2. In cell A3, insert the formula =CONCATENATE(A1;A2) which will concatenate the two texts, in other words, to string them together.

Numbers may also be entered in the Text format. Format the desired cells as Text (open the context menu of the cell, by right clicking, and choose **Format Cells > Category > Numbers > Text**), and enter numbers in the cells. These will be interpreted as text. The display of these numbers is left-justified just like normal text; however, calculations with numbers in text format are not possible.
If normal numbers have first been entered in cells and the format of the cells has been later changed to Text, these numbers remain normal numbers and will not be converted. Only numbers entered later or numbers which are then edited become text numbers.

To enter a number directly as text, enter an apostrophe (') first, for example for years in column headings '1999, '2000 and '2001. The apostrophe will be not visible in the cell, as it only signals that the entry is text. This can be useful when entering numbers, such as a telephone number or ZIP code, that begins with a zero (0) since a zero (0) at the start of a sequence of digits is removed in normal number formats.
**Numbers**

While numbers are displayed in various ways, internally these always remain numeric. For example, ‘1’ and ‘1.0’ are the same.

Enter the number 12345.6789, for example, and the number will appear in the sheet with only two decimal places, i.e. 12345.68. Nonetheless, the exact number with all four decimal places is kept by the program.

Fractional numbers can also be entered in a cell and used for calculation:

1. Enter 0 1/5 in a cell.
2. Press the Enter key and, in the input line, will be the value 0.2. This will be used for the calculation providing that the cell format is number. Calc does recognize fractions and will automatically use 1/5 and display this.

However, if 0 1/2 is entered, AutoCorrect replaces the three characters 1, / and 2 with a single character. Likewise with 1/4 and 3/4. This replacement is defined in the Tools > AutoCorrect/AutoFormat > Replace tab.

If multi digit fractions such as 1/10 are needed, change the cell format to the fraction view (Context menu of the Cell, choose Format cells). Fractions such as 12/31 or 12/32 may be entered; however, the fractions are automatically scaled down so that, in the last example, 3/8 is displayed.

Select other display options by choosing Format > Cells. All the defined formats are lists on the Numbers tab. A preview shows how the result will look. In this dialogue, define personal formats, that can then be applied to numbers or other content of a spreadsheets.

There are various ways to enter integers starting with a zero:

- Enter the number as text. The easiest way is to enter the number starting with an apostrophe (for example, '0987). The apostrophe will not be entered in the cell and the number will be formatted as text. Because it is in text format, no calculations are possible.
- Format a cell with a number format such as \0000. This format can be assigned in the Format code box under Format > Cells... > Numbers tab and defines the cell display as always put a zero first and then the integer, having at least three places, and filled with zeros at the left if less than three digits.

Entire columns, (with numbers in text format i.e. in the form of 000123) can be turned into real numbers again (without zeros in front of them, i.e. in the form of 123) as follows:

1. Select the column in which the digits are found in text format. Set the cell format in that column as Number.
2. Call up Edit > Find & Replace
3. In the **Search for** box, enter `^[0-9]`
4. In the **Replace with** box enter: &
5. Check **Regular expressions**
6. Check **Current selection only**
7. Click **Replace All**
   
   Cells in the Currency Format

In Calc numbers can have any currency format. Clicking the **Currency** icon in the object list formats the number and the cell is given the default currency format as set in OpenOffice.org under **Tools > Options - Language Settings > Languages**.

Without currency formats, the international exchange of Calc documents could lead to misunderstandings. For example, an Calc document is loaded by a user who uses a different default currency format.
In Calc, users can define a number, formatted as “1,234.50 €”, to remain in Euro dollars in another country and does not changed to the local currency. Use the Cell Attributes dialogue to influence the currency format (Choose Format > Cells > Numbers tab) by two country settings. In the Language list box select the basic setting for currency symbol, decimal and thousands separators. In the Format list box select any deviations from the currency symbol of the format defined by the language.

- If, for example, the language is set to Default and the locale is set as German, the currency format will be 1.234,00 € and, per the locale definition, a point is used before the thousand digits and a comma before the decimal places. Now select the subordinate currency format $ English (US) from in the Format list box, to get the following format:$ 1.234,00. Note that the separators remain the same and that only the currency symbol is changed and converted. The underlying Format of the notation remains the same as it is set in the locale setting.
Calculating With Formulas

All formulas begin with an equals sign. Formulas may contain numbers or text, and other data is also possible such as format details, that specify how the numbers are to be formatted. Naturally the formulas will also contain arithmetic operators, logic operators or function starts.

When using the basic arithmetic signs (+, -, *, /) in formulae, remember that using the Multiplication and Division before Addition and Subtraction rule. Instead of writing =SUM(A1:B1) it’s better to write =A1+B1.

Parentheses are also useful for grouping. For example, the result of the formula =1+2*3 means something different than = (1+2) * 3.

Here are some typical Calc formulas:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>=A1+10</td>
<td>Displays the contents of cell A1 plus 10.</td>
</tr>
<tr>
<td>=A1*16%</td>
<td>Displays 16% of the contents of A1.</td>
</tr>
<tr>
<td>=A1 * A2</td>
<td>Displays the result of the multiplication of A1 and A2</td>
</tr>
<tr>
<td>=ROUND(A1;1)</td>
<td>Rounds the contents in cell A1 to one decimal place.</td>
</tr>
<tr>
<td>=EFFECTIVE(5%;12)</td>
<td>Calculates the effective interest at 5% annually with 12 payments.</td>
</tr>
<tr>
<td>=B8-SUM(B10:B14)</td>
<td>Calculates the sum of the cells B10 to B14 minus the value of B8.</td>
</tr>
<tr>
<td>=SUM(B8;SUM(B10:B14))</td>
<td>Calculates the sum of cells B10 to B14 and adds the value to B8.</td>
</tr>
</tbody>
</table>

It is also possible to nest functions in formulas, as shown in the example. Functions may also be nested within functions. For example, instead of simply =ROUND(A1;1), calculate and round a sine function using =ROUND(SIN(A1);2). Use the Function AutoPilot to help form nested functions.
Calculating With Dates and Times

In spreadsheets users can do more than just display dates and times (both taken from the internal clock of the computer). Calculations can also be made with dates and times. For instance, to find out exactly one's age in seconds or hours, follow these steps:

1. Open a new spreadsheet.
2. Enter a date in cell A1, e.g. a birthday, such as: 1/3/48.
3. Enter the following formula in cell A3: =NOW()-A1
4. Press Enter or click the Accept icon on the formula bar (✓). The result appears in date format.
5. Right-click this cell (i.e. bring up its context menu) since the exercise is to see the difference between two dates as a number of days, the format of cell A3 should be set as a number.
6. Select Format Cells....
7. The Cell Attributes dialogue appears.
   1. On the Numbers tab, the Number category will appear highlighted. The format is set to General which causes, among other things, the result of calculations containing date entries to also be displayed as a date.
   2. Set the number format to -1,234, for example.
   3. Press OK to close the dialogue.
8. Cell A3 will now contain the number of days between today's date and the specified date.
9. Experiment with some additional formulas:
   1. in A4 enter =A3*24 to calculate the hours.
   2. in A5 enter =A4*60 for the minutes.
   3. in A6 enter =A5*60 for seconds.
4. Press the Enter key after each formula.

The time since the birthday will be calculated and displayed in the various units. The values are calculated as of the exact moment when the last formula was entered and confirmed by pressing the Enter key. This value is not automatically updated, although NOW continuously changes, of course. In the Tools menu, the menu item Cell Contents > AutoCalculate is normally active; however, automatic calculation does not apply to the function NOW. Consider that, if it were, the computer would use all its resources updating the sheet.

When spreadsheets contain a very large amount of data or very complicated formulas that may be modified before viewing the calculation results, it may be prudent to cancel or disable the automatic calculation function. Calculation time naturally becomes longer as the complexity and size of a spreadsheet increases.

**Inserting and Editing Notes**

A note may be assigned to each cell by choosing Insert > Note. All notes are indicated by a small red square, the note indicator, in the cell. Notes made visible whenever the mouse pointer is over the cell, provided Help > Tips or Extended Tips is active.

- For a selected cell, choose Show Note from the context menu of the cell. Doing so keeps the note visible until the Show Note command is deactivated from the context menu.

- To edit a permanently visible note, just click in it. When the entire text of the note is deleted, then the note itself is deleted.

- Another way to delete a note is by choosing Edit > Delete Contents, or calling the same dialogue with the Delete key.

- Select Tools > Options > Spreadsheet - View to show or hide the note indicator by checking or unchecking the Note indicator box.
**Handling Multiple Sheets**

Spreadsheet are not limited to just one sheet. In fact, several sheets laid on top of each other. Each sheet has its own unique name displayed on the sheet tab at the bottom of the window.

Additional sheets can be appended to a document or inserted in front of the current sheet. Activate the context menu of a sheet tab and choose the corresponding command. Choose **Rename** in the context menu to modify the name of a sheet.

**Displaying Multiple Sheets**

Use these navigation buttons to display the sheet tabs of all the available sheets. Click the button on the far right of this group to move to the the last sheet tab to see its name. To display the sheet itself, click on the name.

When there is insufficient space to display the sheet tabs on the lower window border, increase it by moving the separator bar between the tab bar and the horizontal scrolling bar with the mouse button. Keep the mouse button pressed and drag to the right. Remember this shares the available space between the sheet tabs and horizontal scroll bar.

**Working With Multiple Sheets**

Each sheet of a spreadsheet is completely independent of the other sheets in a spreadsheet document. However the same data can be incorporated into several sheets. For example, the same data should be inserted at the same location in the first three sheets. To do so, select all three sheets together and enter the data in only one of the sheets.

Selecting several sheets together, is simply a matter of clicking the sheet tabs of the sheets in question while pressing the **Ctrl** key. All selected sheets will now have white sheet tabs, instead of the gray sheet tabs of the unselected sheets. To undo the selection of a sheet, click its sheet tab again whilst pressing the **Ctrl** key. Clicking the sheet tab of the current sheet while pressing the **Shift** key, ensures that only this one is selected.

Calc includes the name of the sheet in the reference when assigning sheet references. Thus, instead of referring to $A$1, Calc refers to $Sheet1.A1$ which makes multi-sheet referencing easy and straightforward as shown in the examples below.

- To address the first cell from both **Sheet1** and **Sheet2** in a single reference, for example, summarize, the 3D formula will read =SUM(Sheet1.A1:Sheet2.A1). The sum function has one addend here, namely, the range from **Sheet 1.A1** to **Sheet 2.A1**. In this range there are two cells (as long as no more cells are included between **Sheet 1** and **Sheet 2**). The simple formula (not a 3D formula) would only list two addends: =SUM(Sheet1.A1;Sheet2.A1).
• To include any subsequently inserted sheets found between Sheet 1 and Sheet 2, the formula would then be \( = \text{SUM(Sheet1.A1:Sheet2.B2)} \).

The full address of a cell also contains the complete path and file name of the spreadsheet document. So, in its full form, the reference to cell A1 in Sheet1 of the document name.sxc could be "file:///home/username/name.sxc"#$sheet1.A1 under *UNIX where /home is a mounted filesystem and username specifies the directory where the file is stored. Under Windows®, the specification is similar and could be ="file:///c:/name.sxc"#$sheet1.A1 where the drive is “C:”.

Note: the single quotes surrounding the file name, and the # character that describes the location within the file, in accordance with URL convention.

Printing Spreadsheets

Clicking the Print File Directly icon in the Function bar sends all the sheets in the document to the printer. However, if there’s a print range selected, then only selection is printed. To set the print range, select the cells to be printed, then use the Format > Print Ranges > Define command. There is further information on this topic in the OpenOffice.org Help.

To print the only current sheet, go to menu File > Print... In the Print dialogue, select the Selection option and click OK. If, however, there is selected a certain range of cells, only those cells are printed and in the column width as shown in the sheet.

If various sheets are to print simultaneously, for example, Sheet 1 and Sheet 2, select them before hand (hold down the Ctrl key and click the sheet tabs). The white tabs are the selected ones. Next, go to the Print dialogue, enable the Selection option and only the selected sheets will be printed. After having printed the desired sheets, remember to click the sheet that is being worked on while holding down the Shift key so that only that sheet is selected. Failure to do this will result in all modifications being applied on all sheets.
Chapter 4: Spreadsheets in Calc

Formatting a Spreadsheet

A spreadsheet is hardly ever used without formatting. Cell contents, such as texts and numbers, are given certain formats, and the cells themselves are formatted with different colours, borders and other attributes.

Either create the numbers format or use one of the many predefined formats. For cells, a wide selection of cell Styles is provided and personal cell Styles can be defined in the same way as one does text Styles.

Certain values in spreadsheets are often given particular emphasis, e.g. in a table of turnovers to show all the values above the average in green and all those below the average in red. This is possible using the Conditional Formatting for spreadsheet documents (covered in a later chapter.)

Formatting Numbers

Enter a number into the sheet, for example, 1234.5678. This number will be displayed in the default number format, with two decimal places. One will see 1234.57 when the entry is confirmed. Only the display in the document will be rounded off; internally, the number retains all four decimal places after the decimal point.

1. Set the cursor at the number and choose Format > Cells to start the Cell Attributes dialogue.

2. On the Numbers tab there is a selection of predefined number formats. A preview box, n the bottom right of the dialogue, shows how the current number will appear with a particular format.

3. This dialogue also allows defining other attributes (in addition to number formats) which apply to the selected cells or cell contents. For example, font, size, and colour can be defined on the Font tab page.

Modifying the number of the decimal places displayed in a cell is sometimes required. The easiest method is to use the Number Format: Add Decimal Place or Number Format: Delete Decimal Place icons on the object bar.

Dates

1. Likewise, from the list of options, the date and time can be formatted as desired.

The year in the date details is often stated as two digits. Internally the year is managed by OpenOffice.org as four digits, so that in the calculation of difference from 1/1/99 to 1/1/01 the result will correctly be two years.

- Tools > Options > OpenOffice.org > General defines up to which year a two-digit year “xx” should be displayed as “20xx”.

This means that if a date of 1/1/30 or higher is entered, it will be treated internally as 1/1/1930 or higher. All lower years apply to the next century. So, for example, 1/1/20 is converted into 1/1/2020.
Formatting Cells and Sheets
The distinction between direct and Style formatting holds true for cells as well as for text documents, e.g. A choice between applying a particular font size directly as direct formatting to a cell or defining a Style to apply the desired font size. Styles make particular sense for documents that are used extensively or are to be templates. It does not make sense to use Styles for documents that are only printed and discarded.

Using AutoFormat for Tables
A quick way to format a table or a cell range is offered by the Format - AutoFormat function. In a spreadsheet, first select the cells to which to apply AutoFormatting, including the column and row headers and any sum rows or columns. At least 3x3 cells must be highlighted before this menu item is activated. Then start the AutoFormat dialogue.

![AutoFormat Window](image)

The preview shows an example of how each selected format in the Format panel will look. Click OK to apply the format to the selected range in the spreadsheet.

**Note:** If there is no change in colour of the cell contents, then under Tools > Options > Spreadsheet > View > Show or in the View menu, Highlight values may be checked. In this case, the specified colours will be used.

A user-format can also be set as an AutoFormat:

1. Format a spreadsheet to as desired.
2. Select the whole sheet, e.g. by clicking the empty button in the top left corner (above the first row header).
3. Call up the AutoFormat dialogue and click Add.... A dialogue will appear in which to give the new format a name.

The format defined in this way can then be used in the future on other spreadsheets. By choosing an appropriate background colour and a pattern for the cells in the sheet, an eye-appealing spreadsheet is created.
Use the More button to display additional options in the dialogue. In the additional section that is then displayed, select which properties of the chosen format are to be excluded from the automatic formatting. For example, removing the check mark in front of Font, the font will not be taken into account by the AutoFormat.

**Layout of Spreadsheets**

Sheets do not have to have the look of any of the predefined formats. There are many ways to apply a different layout for spreadsheets, as well as tables in text documents.

**Designing Spreadsheets Clearly**

Calc assists in designing a sheet in a variety of ways. For example, here are three different views of the same sheet, varying only in layout:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Total</td>
<td>4490</td>
<td>6195</td>
<td>9682</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This is a sample sheet without any special formatting, as it appears by default.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Total</td>
<td>4,490</td>
<td>6,195</td>
<td>9,682</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The above graphic shows the sheet formatted using one of the AutoFormats, it will look appealing without requiring any further editing.
In this example, the sheet has been formatted with certain cell attributes in the **Format > Cells** dialogue. In addition the view of the grid lines and sheet headers has been deactivated in **Tools > Options > Spreadsheet > View** and a graphics file loaded as background in **Format > Page > Background**.

**Note:** An image loaded via **Format > Page > Background**, is only visible in print or via **File > Page View**. For a background image to appear on screen as well, insert the graphic image by choosing **Insert > Graphics > From File** and put the image behind the cells by way of the context menu command **Arrangement > To the Background**.

To later select the background image, use the Navigator.

**Formatting Text in a Spreadsheet**
1. Select the text for formatting.
2. Choose the desired text attributes from the spreadsheet object bar.

**Note:** **Format > Cells** is another choice. The **Cell Attributes** dialogue allows choosing various text attributes on the **Font** tab page.

**Formatting Numbers in a Spreadsheet**
1. Select the numbers containing the numbers to be formatted.
2. To format numbers in the default currency format or as percentages, use the icons on the spreadsheet object bar. For other formats, choose **Format > Cells**... Choose from the preset formats or define a personal format on the **Numbers** tab page.

**Formatting Borders and Backgrounds for Cells and Pages**
- Basically, a format can be assigned to any group of cells by first selecting the cells (for multiple selection, hold down the **Ctrl** key when clicking), and then activating the **Cell Attributes** dialogue via **Format > Cell**. In this dialogue, select attributes such as shadows and backgrounds.
- To apply formatting attributes to an entire sheet, choose **Format > Page**. This permits defining headers and footers, for example, to appear on each printed page.
Addressing Cells

Cells can be addressed directly by means of their coordinates in the row-and-column matrix. Use absolute or relative referencing, or give cell ranges their own names.

Addresses and References, Absolute and Relative

Relative Addressing

The cell in column A, row 1 is addressed as A1. Address a range of adjacent cells by first entering the coordinates of the upper left cell of the area, then a colon followed by the coordinates of the lower right cell. For example, the square formed by the first four cells in the upper left corner is addressed as A1:B2. By addressing an area in this way, one is making a relative reference to A1:B2. Relative here means that the reference to this area will be adjusted automatically when the formulas are copied.

Absolute Addressing

Absolute references are the opposite of relative addressing. A dollar sign is placed before each letter and number in an absolute reference, e.g., $A$1:$B$2.

Calc can convert the current reference, in which the cursor is positioned in the input line, from relative to absolute and vice versa by pressing Shift +F4. When starting with a relative address such as A1, the first time this key combination is pressed, both row and column are set to absolute references ($A$1). The second time, only the row (A$1), and the third time, only the column ($A$1). Pressing the key combination once more, both column and row references are switched back to relative (A1)

Calc shows the references to a formula. If, for example the formula =SUM (A1:C5; D15:D24) is clicked in a cell, the two referenced areas in the sheet will be highlighted in colour. For example, the formula component $A$1: C5 may be in blue and the cell range in question bordered in the same shade of blue. The next formula component $D$15: $D$24 can be marked in red in the same way.

When to Use Relative and Absolute References

First examine what happens without a relative reference. Assume a calculation in cell E1 that sums the cells in range A1:B2. The formula to enter into E1 would be: =SUM (A1:B2). If, later, a new column must be in front of column A, the elements to be added would then be in B1:C2 and the formula would be in F1, not in E1. After inserting the new column, all formulae would therefore have to be checked and corrected in the current sheet, and possibly in other sheets.

Fortunately, Calc does this work automatically. After inserting a new column A, the formula =SUM (A1:B2) is updated to =SUM (B1:C2). Row numbers are also automatically adjusted when a new row 1 is inserted. Absolute and relative references are always adjusted in Calc whenever the referenced area is moved. But be careful when copying a formula since in that case only the relative references will be adjusted but not any absolute references.
Absolute references are used when a calculation refers to one specific cell in the sheet. For example, if a formula that refers to exactly this cell is copied relatively to a cell below the original cell, the reference will also be moved down if the cell coordinates are not defined as absolute. Aside from when new rows and columns are inserted, references can also change when an existing formula referring to particular cells is copied to another area of the sheet. Assume, for example, the formula =SUM(A1:A9) is entered in row 10 but the calculated sum must be in the adjacent column to the right. In this case, simply copy this formula to the cell to the right. The copy of the formula in column B will be automatically adjusted to =SUM(B1:B9).

There are many methods to copy a formula, one of which is:

1. Select the cell containing the formula.
2. Choose Edit > Copy, or press Ctrl + C to copy it.
3. Select the cell into which the formula is to be copied.
4. Choose Edit > Paste, or press Ctrl + V. The formula will be positioned in the new cell, and all non-absolute references will be updated.

Copying a formula into multiple cells can be quick and easy. One way to copy into adjacent cell areas is as follows:

1. Select the cell containing the formula.
2. Position the mouse on the bottom right of the highlighted border of the cell, and continue holding down the mouse button until the pointer changes to a cross-hair symbol.
3. With the mouse button pressed, drag it down or to the right over all the cells into which the formula will be copied.
4. Upon releasing the mouse button, the formula will be copied into the cells and automatically adjusted.

Where values and texts must not be automatically adjusted, then hold down the Ctrl key when dragging. Formulas, however, are always adjusted accordingly when dragging.

Now look at what happened when rows and columns are added. Assume a calculation in cell E1 that sums the cells in range A1:B2. The formula to enter into E1 would be: =SUM(A1:B2). If, later, a new column must be in front of column A, the elements to be added would then be in B1:C2 and the formula would be in F1, not in E1. After inserting the new column, all formulae would therefore have to be checked and corrected in the current sheet, and possibly in other sheets.

Fortunately, Calc does this work automatically. After inserting a new column A, the formula =SUM(A1:B2) is updated to =SUM(B1:C2). Row numbers are also automatically adjusted when a new row is inserted. Absolute and relative references are always adjusted in Calc.
**Addressing by Name**

A neat way of making the references to cells and cell ranges in formulas legible is to give the ranges names. For example, name the range A1:B2 as **Start** then in the formula simply enter =SUM(Start). Following the insertion or deletion of rows and columns OpenOffice.org also correctly assigns the ranges identified by name. Remember, range names cannot contain any spaces.

For example, it is much easier to read a formula for sales tax if written as = Amount * Tax_rate instead of = A5 * B2. In this case, cell A5 would be named as **Amount** and cell B2 as **Tax_rate**.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sales Tax Rates</td>
<td>Amount</td>
<td>Tax</td>
</tr>
<tr>
<td>2</td>
<td>5</td>
<td>$11.00</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>6</td>
<td>$12.00</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>7</td>
<td>$13.00</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>8</td>
<td>$14.00</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>9</td>
<td>$15.00</td>
<td></td>
</tr>
</tbody>
</table>

In order to specify range names, follows these steps:

1. First highlight the area to be named.
2. Select **Insert > Names > Define**, or use the Ctrl + F3 key combination.
3. Enter the name for the first area.
4. Click **Add**.

Other cell ranges can also be named in this dialogue by entering the desired name in the field and then selecting the respective cells. Use the **Define Names** dialogue to define names for formulas or parts of formulas needed more often.

5. Close the dialogue with **OK**.

**Recognizing Names as Addressing**

OpenOffice.org can correlate names with areas for the most part automatically, as long as the row and column coordinates are entered. Refer to the following graphic.
The automatic formula recognition allows entering, for example, the formula \( =\text{SUM}(\text{July}) \) in cell B8. This formula can then be copied to the right. Cell C8 automatically shows the formula \( =\text{SUM}(\text{August}) \), cell D8 \( =\text{SUM}(\text{September}) \), and so on. This feature also works for horizontal calculations. Try it out by entering the formula \( =\text{SUM}(\text{London}) \) in cell E4. The New York entry must be treated as a special case because this name contains a space. Thus, it must be enclosed in single quotation marks: \( =\text{SUM}('\text{New York}') \).

Automatic recognition does not work with formulas. One cannot enter the formula \( =\text{SUM}(\text{sum}) \) in cell E8. Instead, enter \( =\text{SUM}(B8:D8) \) or \( =\text{SUM}(E3:E6) \). The latter formula will also be inserted automatically if the cursor is placed in cell E8 and the Sum icon in the Formula bar is clicked.

This function is active by default. To turn it off, select Tools - Options... > Spreadsheet Document > Calculate and uncheck the box in front of Automatically find column and row labels.

Use Insert > Names > Labels... to define any names required as shown in the previous section.

Note: To have names automatically recognized, names must consist of alphanumeric characters and the first character must be a letter. To use non-alphanumeric characters (including spaces), enclose the names in single quotation marks (’ ‘). Where a single quotation mark appears in a name, e.g., Jan ’97, enter a backslash in front of the quotation mark (Jan ’97). This type of referencing is not compatible with earlier versions of OpenOffice.org.

Calc automatically recognizes an area, called a range, of cells that belong together. To determine which cells make up a particular range, place the cell cursor in the desired range and press Ctrl + * but remember to use only the * from the numerical key pad as Ctrl + Shift + 8 (the asterisk over the 8) does not work. The range will be highlighted.

**Only Copy Visible Cells**

Assume the user has hidden are a few rows or columns in a cell range and now only the visible cells are to be copied.

Calc behaves differently depending on the method used to hide the invisible cells and what is the intended action to be performed upon them.
**Method** | **Result**
--- | ---
Cells were **filtered out** by way of AutoFilters, default filters or special filters. | Only the visible cells are copied.  
**Copy** the visible cells, for example, with copy and paste via the clipboard, with the middle mouse button or drag and drop while pressing the Ctrl key.

Cells were **filtered out** by way of AutoFilters, default filters or special filters.  
**Move** the visible cells, for example, by way of cut and paste via the clipboard or drag and drop without pressing an additional key. | All cells, including the hidden ones, are moved.

Cells were **hidden manually** by way of the **Hide** command in the context menu of the row or column headers, or through an outline.  
**Copy or move** the visible cells. | All cells, including the hidden ones, are copied or moved.

### Referencing a Cell in Another Document

Cells can also be referenced in other spreadsheets:

1. For the following example, the source document is named 'C:\test\test.sxc'; and it contains a sheet named **Sheet1**.

2. Open a different or new spreadsheet document.

3. Place the cursor in cell A1 and enter the following formula:
   
   ```excel
   ='C:\test\test.sxc'#Sheet1.A1
   ```

4. Alternatively, enter the file name as a URL designation:
   
   ```excel
   ```

   Similarly access a file on the Internet by using:
   
   ```excel
   ```

5. Drag the box in the lower right corner of the active cell to select a range of cells.
   
   **OpenOffice.org** automatically inserts the corresponding references in the adjacent cells. As a result, the sheet name is preceded with a "§" sign to designate it as an absolute reference.
Using References in Formulas

So far users have been introduced to formulas containing absolute values, absolute and relative references and references to named ranges. Occasionally we have also mentioned the AutoPilot: Functions. Here is an example of references used in formulas, with the help of the AutoPilot: Functions.

Consider the example from the previous topic. Now, use the functions AutoPilot to calculate the average of monthly sales for each location.

1. Position the cursor in cell B8, where the average will be displayed. Activate the AutoPilot: Functions by clicking its icon on the formula bar.

2. Select the AVERAGE function. Where the category that contains this function is unknown, simply leave the default set to all categories and repeatedly press the letter A until the AVERAGE function is selected.

3. Click Next in the AutoPilot: Functions. On the right half of the AutoPilot, another input area will appear where one can enter the arguments of the function.

4. Click in the input field into which values are to be entered, in this case starting with field number 1. Enter either B3:B6 or January or use the mouse to select that range in the sheet. To do so, simply click on the first cell, B3, hold down the mouse button and drag to B6.
While dragging the mouse to highlight the desired range, the AutoPilot dialogue will be automatically minimized so that only the active input field is visible. The field indicates the area being selected with the mouse. The dialogue can be reduced or enlarged manually by clicking the Shrink / Maximize button to the right of the input field.

5. Finally, click **OK** to close the AutoPilot.

The formula is calculated according to the given arguments, and the final result appears in cell B8.

**References to Other Sheets**

In any sheet cell, users can show a reference to a cell in another sheet.

1. Open a new, empty spreadsheet.

2. For example, enter in cell A1 of Sheet1 the following formula and complete the input with the **Enter** key:

   \[=\text{Sheet2.A1}\]

3. Now click the sheet tab labelled *Sheet2* on the bottom window border to go to *Sheet2* of the current document. Set the cursor in cell A1 there and enter text or a number.

4. Upon switching back to *Sheet1*, see the same content in cell A1 as was entered on *Sheet2*. If the contents of *Sheet2.A1* change, then the contents of *Sheet1.A1* also change.

In a corresponding way a reference can also be made to a cell of another document. Open another spreadsheet in addition to the new spreadsheet, which is already saved as a file (this does not work unless a document has previously been saved).

1. If the samples from [http://www.pathtech.org/ootemplates/](http://www.pathtech.org/ootemplates/) are installed, choose **File > Open** and open the *Movie1* document from the spreadsheet samples.

2. Change back to the new, still almost empty spreadsheet. Set the cursor in a free cell and enter an equals sign to begin a formula.

3. Now switch to the document that has *Movie1* loaded. Click cell C3.

4. Switch back to the new spreadsheet. In the calculation row notice that Calc has added the reference to the formula. By way of example, the following will now be located there:

   In *NIX:
   
   \[='file:///OpenOffice.org/share/samples/english/spreadsheets/Movie1.sdc'#$movievisits.C3\]

   In Windows®:
   
   \[='file://C:/OpenOffice.org/share/samples/english/spreadsheets/Movie1.sdc'#$movievisits.C3\]

5. Confirm the formula by clicking the green check mark.

The reference to a cell of another document thus contains the name of the other document in single inverted commas, then a hash #, then the name of the sheet in the other document followed by a point and the name of the cell there C3.
Chapter 4: Spreadsheets in Calc

The name of the sheet automatically receives a leading dollar sign, since the sheet has absolute addressing.

Examine the name of the other document in this formula and notice that it is written as a URL. This means that a URL from the Internet can be entered too. For example, supposing there is an Internet page containing current stock exchange information in spreadsheet cells, just follow these steps to load this page in Calc:

1. In a Calc document, position the cursor in the cell in which to start inserting the external data.

2. Select Insert > External Data. The External Data dialogue appears.

3. In the dialogue, enter the URL of the document or Web page. Write the URL in the following way: (fictional example) http://www.my-broker.com/table.html. Enter a file name from the local or network file system in the usual way, i.e., via the File > Open dialogue.

OpenOffice.org loads the Web page or file in the background, that is, without displaying it. In the large list box of the External Data dialogue are the names of all the sheets or areas from which to choose.

4. Select one or more sheets or areas, optionally activate the automatic update function to every n minutes and click OK.

The contents are inserted as a link in the Calc document.

5. Save the spreadsheet. Upon re-opening, Calc updates the linked cells.

6. Under Tools > Options > Spreadsheet > General, choose to have the update, on opening, execute always, upon request or never. The update can be started manually in the dialogue under Edit > Links.
Using Charts

Data from spreadsheets can be represented graphically in a chart. A wide variety of charts and diagrams suited for illustrating the structure of the data can be selected and created from a spreadsheet.

1. Open an existing spreadsheet or enter data in a new sheet with row and column headings.
2. Select the data together with the headings.
3. Long-click the Insert Object icon found in the Main toolbar to display the floating toolbar. Then click the Insert Chart icon and the cursor will change to a cross-hair symbol with a small chart symbol.
4. In the spreadsheet document, open a selection rectangle defining the location and size of the chart. Both can be modified subsequently.
5. As soon as the mouse button is released, a dialogue appears that makes further entries possible. Simply clicking the Create button creates a chart with the default settings.

This example, using Movie1.sxc from the sample archive mentioned above, shows the number of times people of different age groups in various cities go to the movie theater annually.
If the age groups, rather than the towns, should appear on the horizontal axis, tilt the chart. As long as the chart remains selected, the main toolbar contains a **Data in Columns** icon. Click and rotate it with the mouse.

Other changes to the individual elements of the chart are also possible. Either double-click on the individual parts of the chart or, with the chart selected, choose the individual functions from the **Format** menu. For example, double-clicking on the colour preview in the legend automatically reformats all relevant data points. On the other hand, clicking on the background in the box of the legend, formats the background to the legend.

If the chart was created from the data of a Calc spreadsheet, clicking on the data series in the chart becomes highlighted.

Suppose there's an Calc spreadsheet in the background, and now it needs to be selected for further editing. Open the **Show Draw Functions** floating toolbar and select the first tool, the **Select** arrow. This allows the chart to be selected by clicking.

In a Calc chart, a data series can be forwards or backwards. A series can be arranged in such a way that the lowest 3D representations are as far forward as possible and the higher ones further back. To change the arrangement in the chart, use the appropriate command from the context menu of a data series or choose **Format > Order**. The output data in the Calc spreadsheet will not be rearranged.

---

**Note:** When a chart is inserted in a presentation or drawing document with the **Insert > Insert Chart** floating toolbar, it is displayed with a set of sample data. To insert a chart in a spreadsheet, highlight the cells in the spreadsheet whose values should be displayed in the chart.

In Writer documents too, charts can be inserted that are obtained from the data of a Writer table. Where no data are selected in a OpenOffice.org Writer table, selecting **Insert > Object > Chart** also inserts a chart containing sample data in OpenOffice.org Writer.

Values in a chart containing sample data can be changed by double-clicking on the chart and then choosing **Edit > Chart Data**. When the values of a chart obtained from selected data are changed, the values in the cells of the table must be changed. If the chart is in a text document, press (F9) to update the chart.

Modification of chart data is also possible if, for example, a chart is copied a chart from a Calc document into a Writer document and is now double-clicked in the Writer document. Remember, however, only this copy is being edited and not the original document.
The type of chart can also be changed, after the fact. Double-click on the chart and choose **Format > Chart Type**, a dialogue appears offering various types from which to choose.

![Chart Type dialog box](image)

Experiment with the different options in the Chart Type dialogue. Try switching between 2D and 3D representations. With the **Columns** chart type, a **Combination Chart** of lines and columns can be created.

- The three-dimensional representations make special effects possible. In 3D charts, one can even adjust the illumination settings, such as light source, ambient light and the colour filter.
- 3D charts can be rotated and flipped with the mouse for optimal design.
- By choosing **Insert > Statistics**, users can apply statistical indicators to **XY** charts, such as standard deviations, with regression curves and more besides. A single or double logarithmic representation of the axes can also be set here.
- In line charts there are various icons that can be applied automatically via OpenOffice.org Chart, as desired. Manual application is also possible using graphic files or graphics from the Gallery such as Bullets.
In a chart, individual data series or data points can be selected by clicking on them and then opening the context menu to choose one of the numerous options to format the view.

**Editing Chart Titles**
Suppose the user has inserted a chart in a Calc document and wants to change the title.

1. Double-click on the chart.
   A gray border appears around the chart and the menu bar now contains commands for editing the objects in the chart.

2. Double-click on the default title text. A gray border appears around the text which can now be changed.

3. Press Return to create a new line.

4. A single-click on the title, instead of double-clicking, allows moving it with the mouse.

5. Select *Format > Title > Main Title* to edit the formatting of the main title. This opens the Title dialogue.

6. Select the *Characters* tab to change the font or other similar attributes.

7. Click **OK**.

8. In the document, click outside the chart to exit chart editing mode.

**Editing Chart Legends**
Suppose there is a chart in a Calc document that requires application of a colour gradient to the legend.

1. Double-click on the chart.
   A gray border appears around the chart and the menu bar now contains commands for editing the objects in the chart.

2. Select *Format > Legend* or double-click on the legend. This opens the Legend dialogue.

3. Select the appropriate tab, for example, the *Area* tab for modifying the background of the legend.

4. From the pull-down list select **Gradient**.

5. Select a gradient from the list.

6. Click **OK**.

7. In the document, click outside the chart to exit chart editing mode.

**Note:** Users can define custom gradients, hatching, bitmaps and colours in OpenOffice.org Draw.

To select the legend, first double-click on the chart (see step 1), then click on the legend. Now the legend may be moved within the chart using the mouse.
Adding Texture to Chart Bars
Assign a bar type to a bitmap rather than, say, using full colour.

1. Switch to edit mode by double-clicking on the chart.
2. Double-click on the corresponding bar (all bars of this colour are now selected).
3. From the context menu, select the Object Properties entry
4. Choose the Area tab page.
5. Click on Bitmap. Now select a bitmap from the list box as texture for this bar.
6. Clicking OK to accept the setting.

Editing Chart Axis
When the scale of the vertical Y axis requires changing, do the following:

1. Double-click on the chart.
   A gray border appears around the chart and the menu bar now contains commands for editing the objects in the chart.
2. Select Format > Axis > Y axis to edit the Y axis, or double-click on the Y axis. This opens the Y axis dialogue. Modify as needed.

To modify the scale of the x-axis,

1. Select the Scale tab and make any adjustments.
2. Click OK.
3. In the document, click outside the chart to exit chart editing mode.
Database Functions in Calc

Spreadsheets in Calc are also able to manage records consisting of several fields, as in a database. Think of each row of the Calc spreadsheet as a record, whose fields are arranged in the individual columns. Then, for example, sort or group the Calc database by rows, look for key words and calculate totals.

Note: The database ranges in Calc spreadsheets have nothing to do with the databases and spreadsheets that are addressed in Tools > Data Sources and edited in the data source browser (F4).

In Calc, a spreadsheet can contain several sheets which are manipulated. Combining several adjacent rows of a spreadsheet into a database area is a way, for example, to sort them together. Furthermore, external files can be imported into a Calc spreadsheet, for example files in dBase format. The records from the dBase file would then become rows and the data fields would become columns in a Calc spreadsheet.

In the data source browser, on the other hand, the dBase file (or other data source) is edited directly, and SQL queries, for example, may be performed.

Defining Database Ranges

For example, if a user would like to manage the household budget with Calc, enter the records in an empty Calc spreadsheet and select the area as a database range.

Creating Records in a Spreadsheet

1. Open a new spreadsheet.

2. Enter the column titles in the first row, e.g. “Date” in cell A1, “Item” in cell B1, “Amount” in C1. Then enter some information.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Date</td>
<td>Amount</td>
</tr>
<tr>
<td>1</td>
<td>01/02/00</td>
<td>Flowers $12.80</td>
</tr>
<tr>
<td>2</td>
<td>01/03/00</td>
<td>Breakfast $2.48</td>
</tr>
<tr>
<td>3</td>
<td>01/04/00</td>
<td>Software $49.50</td>
</tr>
<tr>
<td>4</td>
<td>01/05/00</td>
<td>Newspaper $0.60</td>
</tr>
<tr>
<td>5</td>
<td>01/06/00</td>
<td>Fishing Trip $22.50</td>
</tr>
<tr>
<td>6</td>
<td>01/07/00</td>
<td>Hat $6.25</td>
</tr>
<tr>
<td>7</td>
<td>01/08/00</td>
<td>Shoes $99.40</td>
</tr>
</tbody>
</table>

To format the sheet in the same manner as in the illustration above, proceed as follows:

1. Select row 1 by clicking on the row header.

2. Click the Bold icon.

3. Select the entire column A by clicking on the column header.

4. Open the context menu

5. Choose Format Cells.

6. In the Cell Attributes dialogue, click the Numbers tab
7. Choose a date format for Column A.
8. Select column C by clicking on the column header,
9. Apply a currency format. Clicking the **Number Format: Currency** icon on the object bar is sufficient.
**Defining Database Ranges**

1. Select the three column area and define the selected area as a database range by choosing Data > Define Range.

2. The selected range already appears in the Define Database Range dialogue. Be sure to mark the check box Contains column headers so that the first row is correctly taken into account. This box becomes visible when the More button is clicked.

3. Enter a name for the range

4. Close the dialogue with OK.

The selected range is now defined as a database range, which among other things, means that the rows (records) can be conveniently sorted. Any sort lists and filters that have been defined for the database range will also be updated.

**Sorting Database Ranges**

Select a range of cells and define these as a database range by choosing Data > Define Range.
Set the cursor in the database range and choose Data > Sort. In the dialogue that appears, select the column to be sorted, for example, Amount, as the sort criterion and click OK.

Up to two additional criteria can be specified, one to follow the other, for the sort function. For instance, sort the expenditures first by date, then by item if they have the same date, and then by amount if they have the same date and item.

**Filtering Database Ranges**
To filter out only certain records so that they can be modified, use the spreadsheet filtering function. Choose between using a dialogue to specify the criteria exactly (in that case range definitions are also possible), or creating an AutoFilter that will help filter according to specific values or text.

Imagine that the output list is already 8000 records long. With this number of records it is no longer possible to get an overview. Now, only those records that occurred after 1/2/2000 and which apart from this involve an amount in excess of 100 currency units must be shown. Here is one way:

1. Set the cursor in the database range
2. Choose Data > Filter > Standard Filter to open the dialogue.
3. Enter the following:
a) Date > 1/2/2000 AND Amount > 100.

In the dialogue, the existing contents of the data fields in the pull-down listes can be selected, or an amount, say100, can be entered directly.

If **OK** is clicked at this time, only those records that meet all criteria are shown. Select **Data > Filter > Remove Filter** to reset the view.

Displaying only records with a specific content is easily done with the aid of the AutoFilter:

1. Place the cursor in the database range.
2. Click on the **AutoFilter** icon on the main toolbar. The column headers of the database range have now been given small buttons.
3. Click on the button next to the **Date** field and select for example, 1/2/00. Only records that contain this date will be shown.

On the main toolbar, reset the view with the **AutoFilter** icon.
Grouping Database Ranges and Calculating Subtotals

Assuming there is sample data that can be expanded and actually used for a budget, the date should be summarized and printed in totals and subtotals. This can be done in just a few steps.

1. Place the cursor in the database range.
2. Choose **Data > Subtotals**. The **Subtotals** dialogue appears.
3. Specify the desired options for calculating the subtotals.
4. Group subtotals according to **Date** (i.e. calculates a new subtotal for each date), and
5. Use the function **Sum** (adds the subtotals) to calculate **Amount**.

![Subtotals Dialogue](image)

When the Enter key is pressed or **OK** is clicked, the sheet will be grouped according to the subtotals. For every group of entries with an identical date, a subtotal is calculated.
The grand total is displayed at the bottom.

<table>
<thead>
<tr>
<th></th>
<th>Date</th>
<th>Item</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>01/02/00</td>
<td>Flowers</td>
<td>$12.80</td>
</tr>
<tr>
<td>3</td>
<td>01/03/00</td>
<td>Sum</td>
<td>$12.80</td>
</tr>
<tr>
<td>4</td>
<td>01/04/00</td>
<td>Breakfast</td>
<td>$2.48</td>
</tr>
<tr>
<td>5</td>
<td>01/05/00</td>
<td>Sum</td>
<td>$2.48</td>
</tr>
<tr>
<td>6</td>
<td>01/06/00</td>
<td>Software</td>
<td>$49.50</td>
</tr>
<tr>
<td>7</td>
<td>01/07/00</td>
<td>Sum</td>
<td>$49.50</td>
</tr>
<tr>
<td>8</td>
<td>01/08/00</td>
<td>Newspaper</td>
<td>$0.60</td>
</tr>
<tr>
<td>9</td>
<td>01/09/00</td>
<td>Sum</td>
<td>$8.60</td>
</tr>
<tr>
<td>10</td>
<td>01/10/00</td>
<td>Fishing Trip</td>
<td>$22.50</td>
</tr>
<tr>
<td>11</td>
<td>01/11/00</td>
<td>Sum</td>
<td>$22.50</td>
</tr>
<tr>
<td>12</td>
<td>01/12/00</td>
<td>Hat</td>
<td>$6.25</td>
</tr>
<tr>
<td>13</td>
<td>01/13/00</td>
<td>Sum</td>
<td>$6.25</td>
</tr>
<tr>
<td>14</td>
<td>01/14/00</td>
<td>Shoes</td>
<td>$99.40</td>
</tr>
<tr>
<td>15</td>
<td>01/15/00</td>
<td>Sum</td>
<td>$99.40</td>
</tr>
<tr>
<td>16</td>
<td>Grand Total</td>
<td></td>
<td>$193.53</td>
</tr>
</tbody>
</table>

Notice the controls to the left of the row headers. These enable the user to view which records (rows) have been summarized. Clicking on a minus sign shows only the row with the results. The easiest way to control the display is with the small digits above the group area. When 1 is clicked, only the grand total is displayed. Clicking 2 reveals the subtotals, while selecting 3 shows all elements.

**Transferring Data From a Data Source to a Spreadsheet**

Individual tables of data from the data source browser are transferable into a Calc spreadsheet document.

There is a choice of two different methods for transferring the data. One, the desired database file, in dBase or text format, can be loaded directly via the File > Open dialogue, in which case, the whole database table is imported into a Calc spreadsheet document. Or, two, by dragging and dropping what is selected.

**Opening a Database File in Calc**

Open a dBase or text format document as one opens any OpenOffice.org file.

1. Choose File > Open.
2. In the dialogue, go to the folder where the database file is located.
3. Enter the name of the file or go to the File type list box, select dBase, for example.
4. Select the name.
5. Click Open.

To open a text document, select the file type Text CSV.
When making a dBase import, a dialogue open from which to choose the character set of the file. For example, in some languages, databases created under DOS use different characters than those used in databases created under Windows®. The dBase IV format uses Codepage 437 (US).

4. After confirming this dialogue with OK, the database file is loaded in the Calc spreadsheet document.

The first row provides information on the type and length of the individual data fields. This information is contained as dBase header in the file. (When saving a Calc sheet with the file type dBase, the first row of data is used to create the header information.)

Before working on the data in the spreadsheet, we would like to introduce the second method for transferring selected records from the data source view to the Calc spreadsheet.

**Dragging and Dropping Copies into Spreadsheets**

This method works with all formats, and users have the choice of transferring all or only selected records into the spreadsheet document. To use this method, log into the data source in Calc.

1. Choose **Tools > Data Sources**.
2. The **Data Source Administration** dialogue opens.
3. Click **New Data Source**.
4. In the **Database type** field, select dBase to log into a dBase database.
5. Click the “...” button
6. Select the folder containing the database file(s) in *.dbf format.

7. Click OK.

8. In the Name field, enter a name to be displayed for the data source.

9. Click Apply.

10. Click the Tables tab. Put a check mark next to the names of the table(s) needed in the data source view.

11. Click OK.

12. Open the data source browser (F4).

13. Click on the plus (+) sign next to Tables to view the existing tables in the database.

14. In a dBase database, each *.dbf file in the directory is a table of its own.

15. Click the name of the table. The records are displayed in the data source browser.

Select the records and insert them into the spreadsheet.

1. To manually select a record(s) for transfer into the spreadsheet, click the row header of the record (the gray field without text at top left). Click the first and last record row headers of a continuous range of records while pressing the Shift key to select the range, or hold down the Ctrl key and click the desired records individually.

2. Drag the selected records to the row headers in the sheet where the records are to be inserted. Then release the mouse button.

To automatically transfer only specific records from a large database into the spreadsheet, use the filters in the data source browser:

1. Set the cursor in the data field which contains the data (should be the same in all filtered records). For example, to filter only records that have Main Street in their address, place the cursor in a field containing Main Street.

2. Click the AutoFilter icon.

3. Now only the records containing the precise text, Main Street, are visible.

4. Select the Main Street records. For example, using the Shift key as described above, drag the selected records into the spreadsheet document and release the mouse button at the point where the first field should be inserted.
Evaluating Data With Calc

Calc provides several powerful tools for evaluating data. The DataPilot helps produce any kind of sub-evaluation of the data as a separate spreadsheet. With the DataPilot, analyzing the data thoroughly is made easy via consolidation, Goal Seek and multiple operations.

DataPilot

The DataPilot helps to analyze and assess data that has already been entered.

It allows the user, from one and the same value, to generate reports as a function of the point of view that is most prominent.

Imagine a data analysis table containing a company's sales figures, not only for specific product groups, but also for branches and years. Use the DataPilot to quickly find the data which is interesting and pertinent to current requirements.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Article</td>
<td>Area</td>
<td>Salesperson</td>
<td>1990</td>
<td>1999</td>
<td>2000</td>
</tr>
<tr>
<td>4</td>
<td>Video</td>
<td>New York</td>
<td>Fisher</td>
<td>$200,000.00</td>
<td>$197,000.00</td>
<td>$220,000.00</td>
</tr>
<tr>
<td>5</td>
<td>Audio</td>
<td>New York</td>
<td>Fisher</td>
<td>$350,000.00</td>
<td>$235,000.00</td>
<td>$420,000.00</td>
</tr>
<tr>
<td>6</td>
<td>Accessories</td>
<td>New York</td>
<td>Fisher</td>
<td>$550,000.00</td>
<td>$600,000.00</td>
<td>$760,000.00</td>
</tr>
<tr>
<td>7</td>
<td>Video</td>
<td>New York</td>
<td>Fisher</td>
<td>$300,000.00</td>
<td>$180,000.00</td>
<td>$310,000.00</td>
</tr>
<tr>
<td>8</td>
<td>Audio</td>
<td>New York</td>
<td>Fisher</td>
<td>$270,000.00</td>
<td>$200,000.00</td>
<td>$270,000.00</td>
</tr>
<tr>
<td>9</td>
<td>Accessories</td>
<td>New York</td>
<td>Fisher</td>
<td>$25,000.00</td>
<td>$50,000.00</td>
<td>$40,000.00</td>
</tr>
<tr>
<td>10</td>
<td>Video</td>
<td>New York</td>
<td>Fisher</td>
<td>$180,000.00</td>
<td>$220,000.00</td>
<td>$234,000.00</td>
</tr>
<tr>
<td>11</td>
<td>Audio</td>
<td>New York</td>
<td>Fisher</td>
<td>$210,000.00</td>
<td>$240,000.00</td>
<td>$230,000.00</td>
</tr>
<tr>
<td>12</td>
<td>Accessories</td>
<td>New York</td>
<td>Fisher</td>
<td>$100,000.00</td>
<td>$80,000.00</td>
<td>$90,000.00</td>
</tr>
<tr>
<td>13</td>
<td>Video</td>
<td>Miami</td>
<td>Brown</td>
<td>$150,000.00</td>
<td>$160,000.00</td>
<td>$180,000.00</td>
</tr>
<tr>
<td>14</td>
<td>Audio</td>
<td>Miami</td>
<td>Brown</td>
<td>$270,000.00</td>
<td>$250,000.00</td>
<td>$300,000.00</td>
</tr>
<tr>
<td>15</td>
<td>Accessories</td>
<td>Miami</td>
<td>Brown</td>
<td>$100,000.00</td>
<td>$20,000.00</td>
<td>$15,000.00</td>
</tr>
<tr>
<td>16</td>
<td>Video</td>
<td>Kissimmee</td>
<td>Clark</td>
<td>$250,000.00</td>
<td>$300,000.00</td>
<td>$340,000.00</td>
</tr>
<tr>
<td>17</td>
<td>Audio</td>
<td>Kissimmee</td>
<td>Clark</td>
<td>$250,000.00</td>
<td>$250,000.00</td>
<td>$350,000.00</td>
</tr>
<tr>
<td>18</td>
<td>Accessories</td>
<td>Kissimmee</td>
<td>Clark</td>
<td>$100,000.00</td>
<td>$20,000.00</td>
<td>$10,000.00</td>
</tr>
<tr>
<td>19</td>
<td>Video</td>
<td>Washington</td>
<td>Smith</td>
<td>$200,000.00</td>
<td>$220,000.00</td>
<td>$250,000.00</td>
</tr>
<tr>
<td>20</td>
<td>Audio</td>
<td>Washington</td>
<td>Smith</td>
<td>$240,000.00</td>
<td>$260,000.00</td>
<td>$260,000.00</td>
</tr>
<tr>
<td>21</td>
<td>Accessories</td>
<td>Washington</td>
<td>Smith</td>
<td>$90,000.00</td>
<td>$60,000.00</td>
<td>$90,000.00</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>22</td>
<td>Filter</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>Curn - 1999</td>
<td>Area</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>Article</td>
<td>Kissimmee</td>
<td>Miami</td>
<td>New York</td>
<td>Washington</td>
<td>Total Result</td>
</tr>
<tr>
<td>27</td>
<td>Accessories</td>
<td>$100,000.00</td>
<td>$10,000.00</td>
<td>$175,000.00</td>
<td>$50,000.00</td>
<td>$365,000.00</td>
</tr>
<tr>
<td>28</td>
<td>Audio</td>
<td>$250,000.00</td>
<td>$210,000.00</td>
<td>$350,000.00</td>
<td>$240,000.00</td>
<td>$1,530,000.00</td>
</tr>
<tr>
<td>29</td>
<td>Video</td>
<td>$250,000.00</td>
<td>$150,000.00</td>
<td>$685,000.00</td>
<td>$300,000.00</td>
<td>$1,285,000.00</td>
</tr>
<tr>
<td>30</td>
<td>Total Result</td>
<td>$600,000.00</td>
<td>$370,000.00</td>
<td>$1,684,000.00</td>
<td>$520,000.00</td>
<td>$3,184,000.00</td>
</tr>
</tbody>
</table>

<p>| | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>31</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

OpenOffice.org User Guide 224
What use is the DataPilot?
A table that has been created with the DataPilot is an interactive table, i.e. data can be arranged, rearranged or summarized according to different points of view. This functionality is especially useful for Sales Control. On the one hand it may be important to view the turnover figures at regular intervals while, on the other, it may be relevant to analyze sales figures on a regional basis.

Creating DataPilot Tables
1. Select the data range of a table together with the row and column headings.
2. Choose Data > DataPilot > Start. The dialogue Select Source appears.
3. Select the option Current selection.
4. confirm with OK.
5. The column headings of the table will be shown as buttons in the DataPilot dialogue, which can then be positioned via drag and drop as required in the layout areas Column, Row and Data.
6. Drag the required fields into one of the three areas. The field will be dropped accordingly.

If the button is dropped in the Data area it will be given a caption that also shows the formula that will be used in the data range to create the data.
- Double-clicking on one of the fields in the Data area calls up the Data Field dialogue.
Use this dialogue to select the functions to be used for displaying the data in the data area. To make a multiple selection, press the \texttt{Ctrl} key while clicking the functions.

- The order of the buttons can be changed at any time by simply moving them to a different position in the area with the mouse.
- Replace a button by dragging it to the other buttons.
- When double-clicking one of the buttons in the \textbf{Row} or \textbf{Column} area, the Data Field dialogue appears. Here, select if and to what extent Calc should calculate and display subtotals.

Exit the DataPilot by pressing \textbf{OK}. A \textbf{Filter} button will now be inserted into the table — the default position is under the selected area and two lines further down the DataPilot table is inserted with a bold outline.
Selecting DataPilot Output Ranges

Click the button More in the DataPilot dialogue. The dialogue will be extended. Select a named area from the list box Results to into which to create the DataPilot table. If the required output area does not have a name, enter the coordinates of the upper left cell of the area into the field to the right of the list box Results to. Clicking on the appropriate cell with the mouse also enters the coordinates.

By activating the check box Ignore empty rows, these will, then, not be taken into account when the DataPilot table is created.

If the check box Identify categories is activated, the categories will be recognized by means of their headings and assigned accordingly when the DataPilot table is created.

Editing DataPilot Tables

Click one of the buttons in the table that the DataPilot has created and hold the mouse button down. A special symbol appears next to the mouse pointer.

Dragging the button to a different position in the row alters the order of the columns. If a button from the row to the left edge of the table is dragged into the line headings area, a column can be changed into a row. The mouse pointer alters its appearance from the icon for a column heading to that of a line heading.

To remove a button from the table, just drag it out of the table. Release the mouse button when the mouse pointer becomes a not allowed icon. The button is, thus, deleted.

Note: Double-clicking on the name of a table element hides or shows the merged elements below it.

Filtering DataPilot Tables

Although the DataPilot tables are usually created according to user requirements, there may be occasions when not all of the data provided by the tables is of interest. If this should be the case, filters should be used that apply conditions to the data such that if the conditions are not met the excess data is removed from the tables.

Click the Filter button in the sheet to call up the entry mask for the filter conditions. The Filter dialogue will appear. This dialogue provides different criteria which can be used for selecting data.

Updating DataPilot Tables

If the data of the base table has changed, Calc recalculates the tables to bring the analysis up-to-date. Here are the steps to accomplish to recalculate the tables:

1. Click with the right mouse button on one of the button fields
2. Choose the Refresh entry or choose Data > DataPilot > Refresh.

Deleting DataPilot Tables

To delete a DataPilot table, select any cell in the analysis table, then choose Data > DataPilot > Delete.
Consolidating Data

During consolidation, the contents of the cells from several sheets will be combined in one place. Choose a function so that, for example, displays the sum, the standard deviation or the variance of the data.

1. Open the document that contains the areas to be consolidated.
2. Choose Data > Consolidate to open the Consolidate dialogue.

3. From the Source Data Area list box, select an area as a starting point to consolidate with other areas.
4. If the area is not named, click in the field next to the Source Data Area. A blinking text cursor appears. Type a reference for the first source data area or select the area in the sheet with the mouse.
5. Click Add to insert the selected area as a Consolidation Area.
6. Select additional areas and click Add after each selection.
7. Specify where to display the result by selecting a target area from the Copy results to list box.
8. If the target area is not named, click in the field next to Copy results to and enter the reference of the target area (or the top left cell in the target area). Alternatively, select the area using the mouse or simply position the cursor in the top left cell of the target area.
9. Select a calculation rule for determining how the values of the consolidation areas should be linked. The sum function is the default setting.
10. Click OK to consolidate the area.
If a new sheet, independent from the source areas, should not be created, but retaining links to the source areas or consolidating areas in which the order of rows or columns varies is preferred., click the More button in the Consolidate dialogue.

1. Select **Link to Source Data** to insert only the formulas that generate the results in the target area, rather than the actual results. With linked data, any values modified in the source area are automatically updated in the target area. The corresponding cell references in the target area are inserted in consecutive rows, which are automatically ordered and then hidden from view. Only the final result, based on the selected calculation rule, is displayed.

2. Under **Consolidate by** do the following:
   a) Select either **Row Labels** or **Column Headers** if the cells of the source area are to be consolidated according to a matching row label or column header rather than to the identical position of the cell in the area.

   To consolidate by row or column headers, the text must be contained in the selected source areas, or included in the selection with the mouse.

   The data from the consolidation and target areas is saved when the document is saved. Opening a document later, in which consolidation has been defined, this data will again be available.

   **Note:** The text in the headers or labels must be identical, so that rows or columns can be accurately matched. If the row or column label does not match any that exist in the target area, it will be appended as a new row or column.
Applying Goal Seek

With the help of Goal Seek one can calculate a value that, as part of a formula, leads to the result specified for the formula. Thus the formula is defined with several fixed values and one variable value and the result of the formula.

Goal Seek is best illustrated by means of an example.

To calculate annual interest, create a table with the values for the capital (C), number of years (n), and interest rate (i). The formula is: \[ I = C \times n \times i / 100 \]

**Note:** Formula can also be entered using the variable names: \[ \text{Interest} = \text{Capital} \times \text{Year} \]

* Interest rate / 100.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Capital</td>
<td>Years</td>
<td>Interest</td>
<td>Interest</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>$150,000</td>
<td>1</td>
<td>7.5%</td>
<td>$11,250</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

In this example, the investment capital of $150,000 and an interest rate of 7.5% is calculated to result in annual interest income of $11,250. (The cells are formatted after calculation: A5 and E5 as currency, and C5 as percent. The cell width is adjusted automatically.)

For ease of use, assign names to cells so that they can be used in the formula.

**Naming Cells**

Using the example graphic above:

1. Select cell A5 in the example
2. Select Insert > Names > Define. The Define Names dialogue appears.
3. Enter the name C in the text field. At the bottom of the dialogue, the reference: $Sheet1.$A$5 is displayed.
5. Click Add.
6. In the next field, enter an i, set the cursor in cell B5.
7. Click Add.
8. Next, enter ann in the empty field, set the cursor in cell C5,
9. Click Add.
10. Close the dialogue with OK.
11. Now enter the formula in E5 using the variables = C*n*i instead of =A5*B5*C5.

**Start Goal Seek**

Assume an interest rate of 7.5% and that the number of years (1) will remain constant. However, the user may want to know how much more or less investment would be needed to attain a particular annual return. For example, calculate how much capital would be required for an annual return of $15,000 by performing the following steps:

1. Place the cursor in cell E5.
2. Select **Tools > Goal Seek** and the **Goal Seek** dialogue appears.
3. The correct cell, (E5), should already be entered in the field **Formula Cell**.
4. Place the cursor in the field **Variable Cell**.
5. In the sheet, click in the cell (A5) that contains the value to be changed.
6. Enter the expected result of the formula (i.e., the desired value) under **Target Value**. In this example, the value is 15,000.
7. Click **OK**.
8. A dialogue appears with the result of the **Goal Seek**. The result is provided for use as desired. If the result should be used, click **Yes** to enter the result in cell A5.

**Applying Multiple Operations**

**Multiple Operations in Columns or Rows**

If the data of a data range is one above the other (for columns) or next to each other (for rows), select the data range together with the cell or cell range next to or below it as the target range. In the **Column/Row** field, enter the cell reference to the first cell in the data range. In the **Formula** field, enter the cell reference to the cell with the formula that applies to the data range.

**Examples**

The company produces toys which sell for $10 each. Each toy costs $2 to make, in addition to which there are fixed costs of $10,000 per annum. How much profit will be made in a year if a particular number of toys are sold?

Consider the following table:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Selling price</td>
<td>10</td>
<td>Annual sales</td>
<td>Annual profit</td>
</tr>
<tr>
<td>2</td>
<td>Direct costs</td>
<td>2</td>
<td>500</td>
<td>-6000</td>
</tr>
<tr>
<td>3</td>
<td>Fixed costs</td>
<td>10000</td>
<td>1000</td>
<td>-2000</td>
</tr>
<tr>
<td>4</td>
<td>Quantity</td>
<td>2000</td>
<td>1500</td>
<td>2000</td>
</tr>
<tr>
<td>5</td>
<td>Profit</td>
<td>= B4*(B1 &gt; B2) &gt; B3</td>
<td>2000</td>
<td>6000</td>
</tr>
</tbody>
</table>
Calculating With One Formula and One Variable

1. Open a new spreadsheet for this tutorial.

2. To calculate the profit, first enter any number as the quantity (items sold) > in this example 2000. The profit is found from the formula \( \text{Profit} = \text{Quantity} \times (\text{Selling price} - \text{Direct costs}) - \text{Fixed costs} \). Enter this formula in B5.

3. In column D enter certain annual sales one under the other, e.g. in steps of 500 from 500 to 5000.

4. Highlight the range D2:E11, and thus the values in column D and the empty cells alongside in column E.

5. Choose Data > Multiple operations.

6. With the cursor in the Formulas field, click cell B5.

7. Set the cursor in the Column field and click cell B4. This means that the quantity in B4 is the variable in the formula which is replaced by the highlighted column values.

8. Close the dialogue with OK.

9. Profit will be displayed in column E.

Calculating with Several Formulas Simultaneously

1. Use the spreadsheet created above/

2. Delete column E.

3. Enter \( \text{= B5 / B4 in C5} \): This calculates the annual profit per item sold.

4. Select the range D2:F11. i.e all three columns.

5. Select Data > Multiple Operations.

6. With the cursor in the Formulas field, mark cells B5 through C5.

7. Set the cursor in the Columns field and click cell B4.

8. Close the dialogue with OK.

9. Profit will be displayed in column E and the annual profit per item in column F.

Multiple Operations Across Rows and Columns

Calc allows joint multiple operations for columns and rows in, so-called, cross-tables. The formula cell has to refer to both the data range arranged in rows and the one arranged in columns. Select the range defined by both data ranges and call the multiple operation dialogue. Enter the reference to the formula in the Formula field. The Row field is used to enter the reference to the first cell of the range arranged in rows and the Column field the first cell of the range arranged in columns.
**Calculating with Two Variables**

Consider columns A and B of the sample table above. Now try varying not only the quantity produced annually, but also the selling price, and calculate the profit in each case.

Expand the table shown above so that D2 through D11 contain the numbers 500, 1000 and so on, up to 5000. In E1 through H1 enter the numbers 8, 10, 15 and 20.

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
<td>D</td>
<td>E</td>
</tr>
<tr>
<td>1</td>
<td>Selling price</td>
<td>10</td>
<td>8</td>
<td>10</td>
</tr>
<tr>
<td>2</td>
<td>Direct costs</td>
<td>2</td>
<td>500</td>
<td>-7000</td>
</tr>
<tr>
<td>3</td>
<td>Fixed costs</td>
<td>10000</td>
<td>1000</td>
<td>-4000</td>
</tr>
<tr>
<td>4</td>
<td>Quantity</td>
<td>2000</td>
<td>1500</td>
<td>1000</td>
</tr>
<tr>
<td>5</td>
<td>Profit</td>
<td>=B4*(B1&gt;B2)&gt;B3</td>
<td>2000</td>
<td>2000</td>
</tr>
</tbody>
</table>

1. Highlight the range D1:H11.
2. Select Data > Multiple Operations.
3. With the cursor in the Formulas field, click cell B5.
4. Set the cursor in the Rows field and click cell B1. This means that B1, the selling price, is the horizontally entered variable (with the values 8, 10, 15 and 20).
5. Set the cursor in the Column field and click in A1. This means that B4, the quantity, is the vertically entered variable.
6. Close the dialogue with OK.
7. See profits in the range E2:H11. In some cases, pressing (F9) is needed to update the table.
Using Scenarios

Scenarios are important aids for making numbers that are dependent on each other and their resulting calculations visible.

Modify specific basic requirements in the table and see the new result. Name a scenario, created in this manner, and compare it with other scenarios.

Using Ready-Made Scenarios

If the samples from http://www.pathtech.org/oootemplates/ are installed, choose one of the ready-made example scenarios with which to work.

1. Choose File > New > Templates and Documents and from the dialogue open the Samples.

2. Open the spreadsheet examples to see the spreadsheet documents available.

3. Double-click the document with Recar in the name.

This is a sample spreadsheet in which several scenarios have been created.

Areas in which the scenarios that differ by initial values are located are surrounded by frames. Select the appropriate scenario in the list box appearing at the top of every frame.

Scenarios can also be selected in the Navigator:

1. Open the Navigator with the F5 key or the Navigator icon on the function bar.

2. Click the Scenarios icon in the Navigator (the icon with the question and exclamation marks).

In the Navigator, see the defined scenarios with the comments that were entered when the scenarios were created.

Creating Personal Scenarios

Assuming that the spreadsheet used in the previous section is available, create a scenario by selecting all the cells that provide the data for the scenario. For example, create an additional scenario called High Dollar Rate using the following steps:

1. Select the cells that are already highlighted by the frame of the existing scenario. Remember, multiple-select cells that are not contiguous, i.e. that are distributed across the table, may also be selected. To select multiple cells, hold down the Ctrl key as each cell is clicked. However, In this case, simply select the range F18:F23.

2. Choose Tools > Scenarios.... The Create Scenario dialogue appears.

3. Enter High Dollar Rate as the name of the scenario and leave the other fields at their default values.

4. Close the dialogue with OK. The new scenario is automatically activated.
4. Change any values in the frames to the values that are to apply to the new scenario. In this case, modify the dollar rate and all other values that could be affected by it, i.e. economic growth and sales prices. As changes are made, moments later the results from these operating figures are displayed.

To discover which values in the scenario affect other values, choose Tools > Detective > Track to Dependents. Arrows appear that point to the cells that are directly dependent on the current cell.
Validity of Cell Contents

For each cell the user can define, in advance, what type of contents will be valid for this cell. This will make it easier for other users to employ these sheets correctly.

The validity rule is activated when a new value is entered. If an invalid value has already been inserted into the cell, or if a value is inserted in the cell either with drag and drop or by copying and pasting, the validity rule will not take effect. To determine and display which cells contain invalid values, choose Tools > Detective at any time and select the command Mark Invalid Data.

Additional details about Data Validity can be found in the OpenOffice.org Help.

Using Cell Contents Validity

1. Select the cells upon which to define a new validity rule. Where needed, select multiple cells by clicking on all respective cells while holding down the Ctrl key.
The validity rule is a component of the cell format. To copy the validity rule to other cells, choose Edit > Copy and Edit > Paste Special, and select Format.

2. Select Data > Validation.... The Data Validation dialogue appears.

3. On the Values tab page, enter the conditions for new values entered into cells. Values already entered will not be affected.

4. In the field Allow, All Values is selected by default. This means that there are no restrictions. As needed, choose one of the other options: Whole Number, Decimal, Date, Time, and Text Length.

5. This choice sets the first condition. By choosing, for example, Whole Numbers, values such as 12.5 are not allowed, even if they satisfy the other conditions.

Choosing Date allows date information both in the form 1/1/97 as well as in the form of a serial date. Similarly, the Time condition permits time values as 12:00 or serial time numbers. Text Length stipulates that cells are allowed to contain text only.

6. After setting the first condition under Allow, select the next condition under Data. According to what is chosen, additional text fields (Value, Minimum and Maximum) may appear to further specify the condition.

7. A few possible conditions resulting from this register could be as follows:

   Integer greater than 1, Decimal between 10 and 12.5, Date earlier than or equal to 1/1/2000 ,Time not equal to 00:00, Text with a length of more than 2 characters.

After the conditions for cell validity have been determined, if any values are subsequently entered which do not meet the conditions, Calc displays a warning message. Fill out the other two tabs in the dialogue to specify more detailed messages to aid a user working with a spreadsheet.

- On the Input Help tab page, enter the title and the text of the tip, which will then be displayed if the cell is selected.

- On the Error Alert tab page, select the action to be carried out in the event of an error.

- If Stop is selected as the action, invalid inputs are not accepted, and the previous cell contents will be retained.

- Select Warning or Information to display a dialogue in which the entry can either be canceled (the cell value will be retained) or accepted (even if the new value violates the validity rule).

- If Macro is selected, then specify the macro to be carried out in the event of an error via the Browse button.
Sample macro:
Function Example Validity(CellValue as String, TableCell as String)
    Dim msg as string
    msg = "Invalid value: " & CellValue & ""
    msg = msg & " in table: " & TableCell & ""
    MsgBox msg, 16, "Error message"
End Function

Note: After changing the action for a cell on the Error Alert tab page and closing the dialogue with OK, another cell must be selected before the change takes effect.
Printing or Exporting Spreadsheets

There are many print options for putting spreadsheets on paper. Another way of distributing data is to publish it on the Internet in HTML format or as PDF files.

Printing Sheet Details

When printing a sheet one can select which details are to be printed:

- Row and column headers
- Sheet grid
- Notes
- Objects and graphics
- Charts
- Drawing objects
- Formulas

To choose the details proceed as follows.

1. Select the sheet for printing.
2. Choose **Format > Page**.
   
   This command is not visible or available if the sheet was opened with write protection on. In that case, click the **Edit File** icon on the function bar.

3. Select the **Table** tab. In the **Print** area mark the details to be printed
4. Click **OK**.
5. Print the document.

Defining Number of Pages for Printing

If a sheet is too large for a single printed page, Calc prints the current sheet evenly divided over several pages. Since the automatic page break does not always take place in the optimal position, users may define the page distribution themselves.

1. Go to the sheet to be printed.
2. Choose **View > Page Break Preview**.
3. This displays the automatic distribution of the sheet across the print pages. The automatically created print ranges are indicated by dark blue lines, and user-defined ones by light blue lines. The page breaks (line breaks and column breaks) are marked as black lines.

4. The blue page break lines can be moved using the mouse. Look for further options in the Context menu, including adding an additional print range, removing the scaling and inserting additional manual line and column breaks.
Printing Sheets in Landscape Format

In order to print a sheet use one of the number of interactive options available under View > Page Break Preview. To make a hard copy in landscape format, proceed as follows:

1. Go to the sheet for printing.
2. Select Format > Page.
   
   This command is not visible if the sheet has been opened with write protection on. In that case, click the Edit file icon on the function bar.

3. Select the Page tab.
4. Select the Landscape paper format
5. Click OK.
6. Choose File > Print to open the Print dialogue .

   Depending on the printer driver and the operating system, it may be necessary to click the Properties button and to change the printer to landscape there.

   In the Print dialogue under Print range, select the pages to be printed:
   
   • All > All sheets will be printed.
   • Pages > Enter the pages to be printed. The pages will also be numbered from the first sheet onwards. If one sees, in the Page Break Preview, that sheet1 will be printed on 4 pages and only the first two pages of sheet2, enter 5–6 here.
   • Selection > Only the selection will be printed. If cells are selected, these are printed. If no cells are selected, all those sheets whose names (at the bottom on the sheet tabs) are selected will be printed. By pressing Ctrl while clicking a sheet name this selection may be changed.

If under Format > Print range the user has defined one or more print ranges, only the contents of these print ranges will be printed.

Printing Rows or Columns on Every Page

Suppose a sheet is so large that it must be printed on four pages. The pages will be arranged as follows:

<table>
<thead>
<tr>
<th>Page 1</th>
<th>Page 2</th>
<th>Page 3</th>
<th>Page 4</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The top two rows of the sheet should not be printed on pages 1 and 3, but should be the topmost rows on print pages 2 and 4. The first column A should not be printed on pages 1 and 2, but should be on pages 3 and 4.

1. Select Format > Print ranges > Edit and the Edit print ranges dialogue opens.
2. Click the icon at the far right of the Rows to repeat area.
The dialogue shrinks so that more of the sheet can be displayed.

3. Select the first two rows and, for example, click cell A1 and drag to A2.

   In the shrunken dialogue the user will see $1 : $2. Rows 1 and 2 are now rows to repeat.

4. Click the icon at the far right of the Rows to repeat area. The dialogue is restored again.

5. If one also wants column A as a column to repeat, click the icon at the far right of the Columns to repeat area.

6. Click column A (not in the column header).

7. Click the icon again at the far right of the Columns to repeat area.

   **Note:** Rows to repeat are rows from the sheet.

8. Define headers and footers, to be printed on each print page, independently of this via Format > Page.
Saving and Opening Sheets in HTML

Saving Sheets in HTML
Calc saves all the sheets of a spreadsheet together as one HTML document. At the start of the HTML document a heading and a list of hyperlinks are automatically added which lead to the individual sheets within the document.

Numbers are shown as written. In addition, in the \texttt{<SDVAL>} HTML tag the exact internal number value is written so that the exact values are available when opening the HTML document with Writer.

1. To save the current Calc document as HTML, choose \textbf{File > Save As}.
2. In the area with the other Calc filters, choose the \textbf{File type} HTML Document.
3. Enter a \textbf{File name} and click \textbf{Save}.

Opening Sheets in HTML
HTML documents may be opened with write-protection enabled. To edit a read-only HTML document, click the \textbf{Edit File} icon on the function bar.

OpenOffice.org offers various filters for opening HTML files, which may be selected via the \textbf{File > Open} dialogue in the \textbf{File type} field (pay particular attention to the area, as the name \texttt{Web pages} is always the same):

- Open in Writer/Web filter \texttt{Web pages} or as default which does not require selecting a filter.
  All the options of OpenOffice.org Writer/Web are now available, such as \textbf{Show HTML source}.
- In the OpenOffice.org Writer filter open \texttt{Web pages}.
  All the options of Writer are now available. However, please note that not all editing options that Writer offers can be saved in HTML format.
- In the Calc filter open \texttt{Web pages}.
  All the options of Calc are now available to the user. Again, note that not all options that Calc offers for editing can be saved in HTML format.
Formulas and Values as CSV Files

CSV is an acronym for “Comma Separated Values.” CSV-files are pure text files, which contain the contents of the cells of a table/area of a spreadsheet. Commas, tabs, spaces, colons or semicolons can be used as the field delimiters between the cells. Text is automatically put between either quotation marks or single quotes, as selected, while numbers are written directly.

Exporting Formulas and Values as CSV Files
1. Select the area/table that is to be written as a csv file.
2. Where formulas are to be exported as formulas, e.g. in the form =SUM(A1:B5), proceed as follows:
   a) Choose Tools > Options > Spreadsheet > View.
   b) Under Display, check the Formulas field.
   c) Click OK.
   To export the calculation results instead of the formulas, do not mark Formulas.
3. Choose File > Save as to open the Save as dialogue.
4. In the File type field select the format Text CSV.
5. Enter a name and click Save.
   a) From the Export Text dialogue that appears, select the records and the field and text delimiters for the data to be exported.
   b) Confirm with OK.

   Caution: If the numbers contain commas as the decimal separator or thousands separator, do not select the comma as the field delimiter. If the text contains double quotation marks, select the single quotation mark as separator and vice versa.

6. If necessary, after saving the document, uncheck Formulas in order to see the calculated results in the table again.

Importing a CSV File
1. Choose File > Open to bring up the dialogue.
2. In the File type field, select the format Text CSV.
3. Select the file from the list.
4. Click Open.
   When a file has the .csv extension, the file type is automatically recognized.
5. The Import text files dialogue opens.
6. Click OK.
7. If the CSV file contains formulas as formulas, uncheck **Formulas** (in **Tools > Options > Spreadsheet > View**), so that the calculated results are visible in the table.
**AutoFill**

Copying text, values and other cell contents to a spreadsheet is very easily using the mouse. Here the user needs to consider a few special features. When several values are copied at once, Calc forms a logical series out of the initial values, such that, if certain texts are entered that are in sort lists, the list will be continued accordingly.

**Applying Sort Lists**

By way of experiment, enter the text Jan or January in an empty cell. Select the cell and click the mouse on the box in the lower right corner of the cell border. Drag over several cells to the right or downwards. Upon releasing the mouse button, the highlighted cells will be filled with the names of the months.

This predefined series can be found under **Tools > Options > Spreadsheet > Sort Lists**. Custom lists can also be tailored to local needs, such as a list of a company's branch offices. These lists are handy for expanding as headings and other repetitive tasks by simply entering the name in the list with which to start and then expanding this entry by dragging as described above.

**Automatic Row Filling**

1. Enter a number in a cell.
2. With the mouse drag the bottom right corner of the cell downwards.
3. When the mouse button is released, the cells selected in this manner are filled with numbers. The starting number is increased by 1 in each case.

If two or more adjacent cells have been selected, that contain different numbers, and these are dragged together, any recognizable arithmetic pattern of the numbers is continued. For example, if A1 contains the number 1 and A2 the number 3, then joint copying of the two cells by dragging downwards causes the progression to continue with 5, 7, 9, 11 and so on.

1. First select the range in the table to completely fill.
2. Select **Edit > Fill > Row** to open the dialogue
3. Select the type of progression. e.g.
   1. Select 2 as the starting value, 2 as the increment and geometric progression as the progression type.

   In this way a list of the powers of 2 is produced.
Chapter 4: Spreadsheets in Calc

The dialogue also allows series of dates and times to be automatically filled in. For example, to insert the first date of each month of the year as row headers, proceed as follows:

1. Enter a date, e.g., 1/1/99 into a cell (without quotation marks).
2. Highlight this cell and the 11 cells below it.
3. Select Edit > Fill > Series.
4. In the dialogue, select Date and Month.
5. Click OK.

The first date of each month automatically appears in the selected cells.

 Protecting Sheets
To prevent the values entered in a sheet from being modified by another person, protect the sheet. To do this, follow these steps:

1. Display the Protect Sheet dialogue (Tools > Protect Document > Sheet).
2. Enter a password,
3. Click OK.

Likewise the entire document can be protected so that it is only possible to open it by entering the password.

- All cells in a newly created spreadsheet document have the protected attribute. This attribute can be turned on and off via the Cell Protection tab page of the Cell Attributes dialogue, which is opened by choosing Format > Cells or via the Format Cells... context menu command.
- The Protected” attribute can be set or removed for each cell individually. In any case, it does not take effect until the entire sheet and/or the entire document is protected. Apply this protection using Tools > Protect Document > Sheet... or Tools > Protect Document > Document....
• While a password can be applied for protecting the sheet and the document, this is not required. However, if a password is set, then protection can only be removed later by entering the correct password. If no password is set, there is still effective protection against a document being accidentally modified.

• Sheet protection prevents modification of the contents of this specific sheet. Document protection prevents the sheets from being inserted, deleted, resorted or renamed.

• If a user has a document with confidential data that should be protected from being opened by unauthorized persons, protect it with a password. The password makes this protection of the entire document dependent on the protection mechanism of cells, sheets and documents described above. To save a document with a password, select File > Save As... and check the Save with Password check box.

Creating a Reference

If a user wants to insert a value, say the result of a profit calculation, into another sheet or into another spreadsheet document, a reference must be created.

1. Select the cell where to insert the result
2. Enter =.
3. Next select the cell that contains the original result
4. Press Enter.

This cell can also be included in another spreadsheet or in another file. The result is automatically inserted into the reference cell and is also updated when changes are made later.

The content of a cell can be dragged to a cell in another document. With this action, either choose to transfer a copy of the cell, as it now stands, into the other document or create a link so that the other document always reflects the current content of the cell.

After setting all the necessary preferences and changes, save the document and print it.

Further Information

The document based on this template is protected. In order to make modifications in the protected cells, first disable the protection via Tools > Protect Document > Spreadsheet. This must be done individually for every protected sheet, including the hidden sheets.
Inserting a note
To keep a note, perhaps reminding one to sell a certain share later on, select the relevant cell and choose Insert > Note. A shadowed area in the document appears in which to enter text. To make this note visible all the time, click in the relevant cell (cells with notes have a small red dot in the corner, provided "Note Indicator" in Tools > Options > Spreadsheet > View is marked), open the context menu and choose Show Note. Otherwise, one only sees the note when the mouse pointer is moved on to the cell.

Inserting a sheet into another document
Select the cell range and copy it to the clipboard (Copy icon on the function bar). Open the document into which to insert the sheet (generally a text document) and insert the sheet (Insert command).

Displaying formulas
To display the references in the spreadsheets, choose Tools > Options > Spreadsheet > View and mark Formulas. The best way to examine an individual formula is to click the cell containing the formula and then click the AutoPilot: Functions icon on the formula bar.

Using print ranges
Print ranges have been used in the sample document to print specifically targeted cells.

Freezing Columns
Select the column to the right of the column to be frozen, say a list of names, by clicking on the column header, and click Freeze in the Window menu. This makes it possible to scroll horizontally, while the area to the left of the freeze line remains fixed. This fixes the display so that the column containing the names is always in view. This function is especially useful for large sheets.

Splitting a Calc Window
Sometimes a user may need to work with a spreadsheet in which the active data is in different rows. Scrolling up and down can be inconvenient. In this case splitting the display can be an advantage. Select the cell that which to split the display, and click Split in the Window menu. This makes it possible to scroll vertically in each of the split sections. This function can be especially useful for large sheets.

Conditional Formatting
With this function, information can be displayed simply by entering a letter. For example, if this is an employee list, use this feature to instantly find out if a particular employee is present, sick, or on vacation.

To do so, use the following steps:

1. Open the Stylist (click the icon in the Function bar)
2. create three Cell Styles.
3. For the Cell Styles, choose names that correspond to the information to be represented. In the case of the employee list, choose: Sick, Vacation and Present.
4. Click in the Stylist, and open the context menu and click the **New** command to activate the **Cell Style** dialogue.

5. On the **Organize...** tab, enter the word **Sick** and assign a background colour to the Cell Style by way of the **Background** tab page.

6. Click **OK**

7. Repeat this process for the two remaining Cell Styles.

8. Now, using the mouse, select the range to which to apply the conditional formatting. Choose **Format > Conditional Formatting** to open the **Conditional Formatting** dialogue.

9. For **Condition 1** define: **Cell value > equals -“s”** (s=sick). In the **Cell Style** list box, select the Style **Sick**.

10. For **Condition 2** define: **Cell value > equals -“v”** (v=vacation). In the **Cell Style** list box, select the Style **Vacation**.

11. For **Condition 3** define: **Cell value > equal -“p”** (p=present). In the **Cell Style** list box, select the Style **Present**.

![Conditional Formatting](image)

**Note:** The use of quotation marks is absolutely necessary to define conditions!

Upon entering a “v” (without quotation marks) in a cell in the previously selected area and pressing the **Enter** or **Arrow** key, the cell will be displayed in the defined colour.

**Note:** A maximum of three conditions is possible.
Defining Validity

To avoid invalid entries in a spreadsheet, define a validity condition. Select the cells to which the validity condition is to apply, and open the Validity dialogue (in the Data menu). On the Criteria tab, define the acceptable entry criteria (in this example: Text length, equal and 1) in the appropriate lists and fields.

![Validity Dialogue](image)

Next, click on the Error Alert tab. Select the option Show error message when invalid values are entered and click Stop in the Action list box. Under Error message, enter an appropriate text (e.g. Only v (vacation), p (present), or s (sick) are valid entries.).

If a user were to now enter more than one letter in the corresponding cell in the sheet, the message defined above appears.

Creating Input Help

Using the Validity dialogue, custom help functions can be created for a previously selected area. Select the Input Help tab and check the box Show input help when cell is selected. Enter a title in the respective field, and enter the help text in the field below. This text is then displayed as a Help tip for the user.
Linking Sheet Information

The information contained in a schedule can also be used by linking it to the vacation accounts and automatically subtracting used vacation days, for example.
Chapter 5: Creating Presentations With Impress

Presentations have more than just drawings and graphics to offer. Use presentations to link several slides to form a slide show, to animate the elements on the slides and to assign special transition effects between slides. Slides often contain text which, in the outline view mode, is displayed and entered in a hierarchical structure. Change the text or rearrange the order of the slides at any time.

There are several ways to create a presentation:

Use **AutoPilot Presentation**.

- Use the templates and sample documents supplied, which are modified as necessary.
- Start with an empty document.

OpenOffice.org Impress provides many graphics features for creating presentations, all of which are found in OpenOffice.org Draw, too. Please take the time to read chapter 6 on OpenOffice.org Draw to discover the complete capabilities of Impress.

The sample documents referenced in this section may be found, at the time of writing, at [http://www.pathtech.org/oootemplates/Samples/](http://www.pathtech.org/oootemplates/Samples/).
OpenOffice.org Impress Toolbars and Windows®

1. Zoom floating toolbar
2. Text floating toolbar
3. Rectangles floating toolbar
4. Ellipses floating toolbar
5. 3D Objects floating toolbar
6. Curves floating toolbar
7. Lines floating toolbar
8. Connectors floating toolbar
9. Alignment floating toolbar
10. Arrange floating toolbar
11. Insert floating toolbar
12. Effects window
13. Presentation window
14. Navigator window
15. Stylist window
16. Color bar
How to Create a Basic Presentation

The following brief step-by-step example demonstrates different methods of how to create a presentation document.

As with text documents, there are various ways to start creating a presentation:

- Open the AutoPilot Presentation by choosing File > AutoPilot > Presentation. The AutoPilot starts automatically each time a new presentation is created. If desired, switch off the automatic mode on the first page of the AutoPilot. The AutoPilot is described in detail in the Help.
- By turning off the AutoPilot in Tools > Options > Presentation > General, a new, empty document (for example, by choosing File > New > Presentation) is opened.
- Alternatively open an existing presentation document that is modified and saved under a different name.
- Or use one of the many templates available in the Templates and Documents dialogue. Pressing Shift+Ctrl+N opens this dialogue or use File > New > Templates and Documents.

For more information on the various dialogues used here, refer to Help.

Creating a Presentation With the AutoPilot

Chapter 5: Creating Presentations With Impress

The AutoPilot Presentation opens automatically. The first page allows starting with an empty presentation, a template or the last presentation opened. By clicking the **From template** option, OpenOffice.org Impress collects all existing presentation templates and displays them in the list box.

2. For the purposes of this example, select the template “new_product_intro” and click Next. On page two of the AutoPilot dialogue choose another Page Style if needed. The selection of presentation layouts available to choose from are from the predefined template directories. As on the first page of the AutoPilot, all templates are displayed as Page Styles.

![AutoPilot Presentation (New Product Introduction)](image)

On this page, however, the default is “Presentation Backgrounds”. From this page, select the presentation medium for the presentation: Slide, Overhead, Screen or Paper. The dimensions, margins, and orientation of the presentation will depend on these selections.

3. To continue following this example, do not change the background or medium of the presentation. Click **Next**.
4. Page three of the AutoPilot deals with the slide transition.
   a) In the first list box select the slide effect “Cross-Fade From Left”.
   b) Select the default “Medium” for the speed of change.

5. Select **Automatically** as the presentation type (i.e. repeatedly runs through presentation, with fixed time lapses, until the Escape key is pressed).

6. Now one can determine further parameters:
   a) Use the **Duration of page** spin box to determine how long each slide is shown before the next one appears. Once the presentation is completed, a different duration for each slide can be set individually.

   b) Use the **Duration of pause** spin box to determine how long the pause will be at end of the presentation before it starts again. If the **Show Logo** check box is marked, the “Created with OpenOffice.org” logo will be displayed on the pause page. The **Default** presentation type runs the presentation from beginning to end with manual slide transition, e.g. by mouse click.
7. Click Next.

![Image of a presentation interface]

8. Enter additional text which should appear in the presentation on page four.
9. Click **Next**.

The fifth and final page of the AutoPilot determines the number of the slides needed in the presentation. A list of names of all the slides in the presentation is also presented. If there are some slides to be removed from the presentation, click the **Page** icon with the green check mark next to the name. The check mark will disappear, which indicates that that slide will not be included in the presentation. To reverse this action, click the page icon again.

![AutoPilot Presentation (New Product Introduction)](image)

10. Click the plus sign in front of a slide, the headings from the first outline level will be shown.

11. By checking the **Create summary** check box, the Auto Pilot creates an additional last slide with a summary of all the titles of the previous slides in the presentation. Normally this is not necessary, since most templates already include such a page.

12. Click **Create** to create the presentation.

   - Clicking **Create** on any of the AutoPilot pages creates the document and eliminates the need to go through all the pages of the Auto Pilot.
   - Once created, edit, save, and print or run the presentation, et cetera.

   To start a presentation on a computer screen, simply press `Ctrl+F2` key or click the **Presentation** icon on the main toolbar.
Creating a Simple Presentation Without the AutoPilot

This section explains, with the help of a simple example, how to create a presentation based on one of the existing templates.

- Open a new presentation document based on one of the supplied templates by choosing File > New > Templates and Documents, or with Shift+Ctrl+N.

- In the Templates and Documents dialogue that appears, click the Templates icon on the left and then double-click “Presentation Backgrounds”. Double-click one of the templates, such as “Note Pad”.

- Now there is a slide in which any predefined text can be replace with the text of choice.

  Note: If the document is in the Master view mode when opened, switch to the Slide view mode using the respective icon in the lower left corner of the document window. A document will always be opened in the view in which it was last saved. If Tips and/or Extended tips is enabled, hovering the mouse pointer over one of these will popup which is which.

To create a second slide, click the Insert Slide... command in the small Presentation window. (If the small presentation window is not visible, click the Presentation Box On/Off icon on the Object bar). In the next dialogue, select a page layout and confirm with OK.

Alternatively one can also click in the area right of the “Slide 1” tab to create a new slide, without any selection dialogue. The new slide has the same layout as the current slide.

1. The user will then see “Slide 2”.
2. Press OK.
3. Click once on the lower text frame and delete it, say, with the Delete key.
4. Click in the text frame at the top and enter a title.
5. Next insert a 3D object by long-clicking the 3D Objects icon to open its floating toolbar.
6. Select the Sphere icon.
7. Click on the slide below the Live in 3D text, drag open a 3D rectangle, and then release the mouse button. Voilà, a 3D sphere.
8. Drag the sphere into the center of the slide and enlarge it by dragging one of the handles in one of the corners. When dragging, hold down the Shift key so that the sphere remains a sphere.
9. Assign an interesting colour or colour gradient to the sphere by way of the list boxes on the object bar. Placing a bitmap as a pattern on a 3D object, for example, a world map from the Gallery is covered in another chapter.

Save the presentation by either pressing the Ctrl+S shortcut keys and specifying the name and location for the file or use File > Save as and again specify the location for storage.

**Switching Presentation Views**
To the right, above the vertical scroll bar, there are some icons for switching views and for starting the presentation.

[Diagram showing different presentation views]

- Drawing View
- Outline View
- Slide View
- Notes View
- Handout View
- Start Slide Show
To the left of the horizontal scroll bar in the drawing view, notes view and handout view, see the following icons:

Slide View    Master View    Layer View    Navigation

**Arranging Slides**

Switch to the Slide View by clicking the respective icon above the vertical scroll bar located at the right of the screen. Now the position of individual slides can be rearranged and effects defined for the transition between slides.

In the slide view, change the sequence of the slides by dragging them to any other position in the presentation.

Long-click a slide in the slide view to copy the slide using drag and drop while pressing the Ctrl key. The mouse pointer will have a small plus sign next to it when dragging to indicate a copy. Drag and drop is also possible between the slide views of OpenOffice.org Impress documents.
If the context menu of a selected slide is called up, the **Show/Hide Slide** command will be seen. One can use this command to temporarily remove the current slide from the presentation, without deleting it from the actual document. A slide that is not shown in the presentation receives a name highlighted in gray.

**Incorporating Slide Show Effects**
In the Slide View mode, define transition effects to precede the display of each slide:

1. **Click on the second slide once to select it.**
2. **On the object bar under Transition, select “Automatic” and enter the desired display time for the first slide, for example 00:01:00. That means that the second slide will be displayed for one minute.**
3. **Select a desired effect from the Effects list on the object bar.**
4. **Click the small button to the left underneath the second slide to preview the selected effects.**
5. **Save the presentation again using Ctrl+S or from File > Save menu item.**

**Showing a Presentation**
By following the previous steps there is now a finished presentation ready for display.

To run it, click the **Slide Show** icon on the main toolbar, and the presentation will start automatically in default mode, that is to say, in full-screen mode.

Click once with the mouse and the second slide will be displayed (preceded by the defined transition effect). After the last slide, a black slide is displayed, which means that the presentation is over. End the presentation by pressing the **Escape key.** The **Escape key** may also be used to stop the presentation before the end, as necessary.

At this point, more slides may be added to the presentation or some of the other effects attempted.
Chapter 5: Creating Presentations With Impress

Editing Presentations

This section shows how to use the versatile features of Impress to fine tune a presentation. Many of the methods available in Draw can also be used in Impress, such as entering text and converting it into 3D, turning objects into curves and polygons, editing connectors and glue points and so on. For details, please refer to the chapter on Draw.

Defining Background colours

The background of a slide in a presentation or drawing document can be handled either in the master view or by assigning another Page Style to the slides or by modifying the current Page Style.

- Switch to the master view by using the icon in the lower left-hand corner of the work area.

  The master view permits editing the background for all slides. All objects that are entered in this view, whether company logos, lines or text, are displayed in the background on all slides that use the current Page Style (the master page). This allows headers and footers on to be reproduced on all presentation slides. Objects inserted in the Master View cannot be modified in the normal Slide View.

- Change only the background used in the presentation using the following steps:
  a) Right click in any slide
  b) Choose Slide > Page Setup
  c) Select the Background tab
  d) Choose a colour, gradient, hatching or bitmap for the background.
  e) Click OK
  f) The next dialogue asks if the settings should apply to all slides or just to the current slide. By answering “Yes” to the question “Background settings for all slides?”, the Background Presentation Style will be modified for the current master page and all slides with this Page Style will have the modified background. Answering “No”, means that only the background of the current slide is modified.

- Modify the Presentation Styles in the Stylist by following these steps:
  1. Open the Stylist,
  2. Click the Presentation Styles icon, if it is not already selected, to see all existing Styles of this type in the Stylist.
  3. Select the Background Style.
  4. Right-click to open the context menu for this Style and choose Modify.
  5. Choose the background for all slides with the current Page Style.
  6. Click OK.
Note that this modification is only valid for the current presentation document.

Switching Page Styles

The subordinate designs which make up the slide design determine the way an object looks, including its background. The slide design can also be called a “Master Slide”. In Impress, assign a different slide design to each slide as desired.

1. Go to the slide that is to have a different Master page.
2. Select Format > Styles > Slide Design... to open the dialogue
3. Click Load.... to see the Load Slide Design dialogue.
4. Select a new slide design from the dialogue, e.g. from the area “Presentation Backgrounds”
5. Confirm this with OK.
6. If the Exchange background page check box is checked, the new slide design applies to all pages of the current document. If there is no check mark in it, then this action only applies to the current slide. This provides the flexibility to define a different slide design, and thus a different background, for example, for one single slide. Assuming, that Exchange background page is not checked, the background selected will now be assigned to the slide currently in use.

Presentation Styles

As part of slide design there are a whole set of Presentation Styles that may be assigned to the slides. Open the Stylist to see a list of the predefined Styles. Existing Styles may be modified but any modifications are valid only for those slides in the current document that uses this slide design or new Styles created.

The built-in Styles, Outline 1 through Outline 9, enable the user to give the outlined headings and topics on the slides a uniform look.

Open a new, empty presentation with a slide layout that allows greater structural depth. The slide layout called “Title, Text” is suitable for this purpose.

1. Activate the outline view mode by clicking View > Master View > Outline View (starting in the Menu bar) or by pressing the F12 key.

Note: The slide layout chosen determines the number of levels of outline. If a slide layout which does not permit any outline is chosen, notice that the outline functions are not available.
Using Outline View

One way to create a completely new presentation is in the Outline View mode. All slide titles appear in a list along with the headings and sub-topics. The hierarchy of the headings as well as the sequence of the slides can be easily modified.

1. The preview window should have opened; if not, it can be shown by choosing View > Preview. The Preview window enables the user to view the slide layout, including text, background, and background objects. The Preview window can be at the window border by pressing the Ctrl key and dragging the window to the position of choice.

2. Now open the Stylist either by choosing Format > Stylist or with the F11 key or opening it if it is docked.

3. The cursor should now be blinking next to the small icon for slide 1.

4. Enter the desired text, for example First Page. This will be the title for slide 1.

5. Press the Enter key. This displays a small icon for slide 2 in the next line of the Outline view.

6. Enter a title for the second slide, for example, Second Page.

7. Press the Enter key again to get the small icon for slide 3.

8. Now press the Tab key before entering any text. This action ensures that the text entered here will be a subtitle on slide 2.

9. Continue to enter more subtitles of the first level on page two.

10. Pressing Shift + Tab moves one level up. Thus enabling the user to make a new slide out of a first level sub-topic.

The levels created by following these steps automatically contain the Presentation Styles title, outline 1, outline 2, et cetera. These Styles can be modified by having a new slide design assigned to them, for example, a new font, font size and font colour. These designs can, of course, be edited (for example, via the Stylist's context menu).
Slide Transitions, Effects and Animation

With Impress, grabbing an audience's attention using animated objects and interesting slide transitions is easy.

Automatic Slide Transition

When showing a series of slides, use the slide transition effects to present them in an interesting way. For example, the current slide can roll out of the window while the new slides rolls in. This effect is called “roll from left”.

The best thing to do is to assign this effect in the Slide View. Simply click on the third icon from the top in the scroll bar on the right of the presentation window or choose View > Master View > Slide View.

In the slide view, all slides which have a slide transition effect, have a small button. Click this button to preview the selected effect.

The Slide Transition window is described in detail in OpenOffice.org Help.

Effects for Objects

The objects in a slide can have various effects, for example, they can roll into the presentation from the left side, the text can be slowly drawn on screen, et cetera.

1. All these effects can be assigned using the Drawing View (View > Master > Drawing).
2. Access the Effects window, i.e. with the Effects icon in the Main toolbar.
3. Select the object to which to apply the effect.
4. Open the Effects window
5. Select the desired effect.

6. ![ ] Click the Assign icon in the Effects window, or double-click the effect to assign it.

7. An object can also be faded in (Effects button) and, additionally, faded out (in the Effects window, on the Extras tab click the Object Invisible icon) per mouse-click.

The Effects window is described in detail in OpenOffice.org Help.

**Selecting Hidden Objects**

- To select an object that is completely covered by another object, click on its position while holding down the Alt key.

- If several objects are lying on top of one another, every Alt+click selects a different object lying in this position. Hold down Shift as well to click through the objects in the reverse order.

- Press the Tab key to select an object. Press Tab again to select the next object. Press Shift+Tab to go through the objects in the reverse order.

**Individual Presentations**

A slide show presents the slides in sequence, from beginning to end. To start presenting the slides in the presentation, either click the Slide Show icon on the main toolbar, or use the keyboard shortcut Ctrl+F2.

Presentations usually start with the first slide; however, to begin with the currently selected slide, proceed as follows:

1. Choose Tools > Options > Presentation > General.

2. In the area Starting the presentation, check the Always with current slide box.

**Note:** that this setting has priority over the Individual Presentation described below.

Other options permit the user to show only or to never show certain slides:

1. To prevent display of a slide, go to the Slide View (for example by choosing View > Master View > Slides View), select the slide and select Slide Show > Show/Hide Slide .

   The name of the selected slide will now appear highlighted in gray, meaning that the slide will not be shown.

2. Choose Presentation > Show/Hide Slide again when the slide should be included again.
A more elegant way to keep individual slides hidden in certain presentations can be found under **Presentation > Custom Slide Shows**.

1. Open the **Slide Show > Custom Slide Shows** dialogue,
2. Click the **New** button. The **Define Custom Slide Show** dialogue appears.
3. In this dialogue, enter a name for the presentation. On the left, there is a list of the existing slides. Select a slide to show in the custom presentation and click the button with the arrows pointing to the right.
4. The slide will be inserted in the right field. Any slide listed on the right will be shown in the custom slide show.
5. Rearrange the order of the slides in the right field via Drag&Drop.
Exporting, Printing and Presenting

There are many possible ways of outputting finished presentation documents. For example, electronically display finished presentations, print the pages in colour on paper or print high resolution transparencies, or transfer them wholly or partially to other applications and then use them within those applications. Printing offers a choice between outputting the document directly to a printer, or printing it to a file that may then be copied to a printer.

Printing a Presentation Slide

In Impress, the current document is easily printed by clicking the Print File Directly icon in the function bar. Printing is immediate, according to the printer default settings, and no dialogue appears. There is an exception in text documents where a certain area of text is selected and, in this instance, a dialogue appears upon clicking the Print icon. This dialogue asks for confirmation of printing the whole text or only the selected area.

When printing via the Print dialogue, Impress offers choices of whether to print only a selected range of pages, only certain pages identified by their page numbers or all pages of the document. Take a look at the print dialogue, which is opened via File > Print or by pressing Ctrl+P.

The appearance of the Print dialogue may vary according to the selected printer. However, in most cases, there are options to specify whether to print the entire presentation, certain slides, or only the current selection. Other options specify how many copies to print and how these should be collated.

Click the Options... button in the Print dialogue to display additional options. When printing text, drawing and presentation documents, the Brochure option is available for two-to-a-page text on a single sheet. The size of the pages is reduced and printed in two columns per page and double-sided, so that the pages need only be folded and fastened in the middle to create a complete brochure.

Since presentation objects are usually in the form of vector graphics, they can be printed out in any resolution supported by the local printer or film recorder. Where the slides are to be sent to a film recording service or to be printed on a high-resolution colour printer in a print shop, mark the Print to file check box in the Print dialogue. It will then be printed to a file that can be sent to the film recording service or commercial printer.

Note: first install and select the printer driver for the printer or film recorder that will be used by the printing or film recording service. Most printing and film recording services require files created for a PostScript printer. If there is no PostScript printer available, OpenOffice.org permits installation of a PostScript printer driver that can be used to print to a file. On Unix-based systems, use spadmin to active this driver.
Exporting Presentations as Web Pages

When the Web Page export file format is chosen, Impress automatically starts an AutoPilot to help produce an attractive HTML presentation. A number of HTML pages are created that are connected to one another by hyperlinks and in which the graphics are saved as GIF or JPEG images. One can work on these HTML pages in Writer to give them headings and additional hyperlinks, for example.

1. Select File > Export...
2. Choose the file format HTML.
3. Enter a file name
4. Click Save.

This opens the HTML Export AutoPilot. This AutoPilot is described, in detail, in OpenOffice.org Help.

In the HTML Export AutoPilot, choose whether the created Internet presentation should contain frames, be navigates using graphic buttons or with text links and whether a link should be offered on the home page allowing the user to download the original Impress presentation.

3d Discussion

✓ Objects
✓ Lighting
✓ Shadows
✓ Orientation
In addition to the export of default HTML documents and HTML documents with frames, Impress documents can be exported as WebCast or in the automatic mode.

- WebCast export automatically produces scripts for web servers with Perl or ASP support. This format allows a presenter (e.g. during a telephone press conference with accompanying slide show over the Internet) to change the slides on the viewers' browsers.

**Note:** Examples can be found in `<instdir>/OpenOffice.org<release>/share/config/webcast` where `<instdir>` is the directory in which the network or standalone installation is located.

- Automatic export takes over the settings for the viewing time of each page in the presentation. A default HTML presentation is the result, in which the pages are “turned” automatically.

Sound reminders for turning the pages can also be exported, if desired. The sound files would then be copied in the target directory and played back when a HTML page is loaded.

**Exchanging Data via the Clipboard**

Objects in a drawing or presentation document can also be copied to the clipboard and then inserted elsewhere. The objects are stored as vector graphics on the clipboard using the following procedure:

1. Select an object in the current document
2. Copy it to the clipboard with Ctrl+C.
3. Switch to the application into which to insert the object.
4. Insert the contents of the clipboard at the desired location with Ctrl+V.
Creating a Business Report

This section explains how to create a business report for a presentation. In the following example, it is assumed that the presentation will be shown via a computer.

Creating a Business Report in Presentation Form

Since OpenOffice.org Impress has no business report template, this section will start with a completely new document. To start, follow these steps:

1. Create an empty presentation document (File > New > Presentation). Using AutoPilot Presentation is described quite well in OpenOffice.org Help.

2. Select Empty presentation

3. Click Create. This brings up the Modify Slide dialogue where the appearance of the first slide can be defined.

4. Enter a name and select the desired layout, e.g. Title slide.

5. On the “Title slide” click on the existing text and overwrite it with appropriate text, for example “Elegy Software” and “Annual Report 2003”.

![Modify Slide dialogue](image)
6. To insert another slide, click the area next to the tab at the bottom of the screen. Assign a name for the new slide and choose a layout (in the context menu of the slide tab, click Modify Slide).

**Note:** Do not assign a name like “Slide2.” If the order of the slides needs to be changed later, the label might not describe the content of this slide. Clear, descriptive names like “Overview” or “Introduction” are more useful.

Insert additional slides, as necessary, from the insert menu on the main toolbar (a long click may be needed). The corresponding tabs appear at the bottom of the screen. Click the tab of the slide to edit, e.g. Overview, and then click the **Outline View** icon above the vertical scroll bar.

**Entering Text in the Outline View**

To establish an outline, use the Outline View mode. Using the icons in the object bar, promote or demote an outline point one level, or move it up or down in the hierarchy. The icons in the main toolbar can also be used to determine which outline levels are to be displayed.

In the Outline view, all slides in the presentation document are listed hierarchically, and the title of each slide is preceded by a slide icon.

Enter the desired text and use the icons in the Main toolbar to structure the outline. Create a subsection to a slide by placing the cursor at the start of the respective line and pressing the **Tab** key. Use the **Shift+Tab** key combination to move the line up one level in the hierarchy. After completing the edit of the presentation outline, click the **Drawing View** icon (directly above the **Outline View** icon) to return to the normal view.

**Changing the Slide Layout**

Changing the slide layout can only be done while in the Drawing View (the first icon in the vertical scroll bar). Double-click the tab of the slide to modify and select the desired layout from the predefined layouts.

**Designing Slides**

Designing a slide can only be done in the Drawing View, and the **Select** tool must be activated.

To change the font size and style of the title, for example, select it and assign new attributes from the **Font** and **Font Size** fields in the Object bar.

Borders may be defined by clicking the paragraph to which to apply the border and defining the attributes in the list boxes **Line Width** and **Line Style**.

To apply a uniform background and recurring elements (company name, subject) to all slides, click the **Master View** icon to the left of the horizontal scroll bar. The default texts in the master view may be safely ignored as these are not visible on the slides. The only text visible on the slides is that which is entered by the user. Using the **Text** floating toolbar on the main toolbar, a frame can be opened for background text.

Using the **Stylist** is an excellent method for managing the appearance the slides. Here is a step-by-step procedure:
1. Open the Stylist by clicking the **Stylist** icon in the Function bar.
2. Click the **Presentation Styles** icon.
3. Select a background style, and
4. Open the **Modify** dialogue via the context menu.
5. Click the corresponding slide tab and make any changes.

By modifying the **Background** Style, all slides can be assigned the same background.

*Note: Since the Master View can be activated at any time, it is always possible to make changes at a later time.*
Creating a Slide Show

In completing a slide show, it is necessary to take a few additional steps to ensure a successful presentation.

Defining or Changing Slide Order

To change the slide order, click the Slide View icon above the vertical scroll bar. In this mode, all slides in the presentation document are displayed in reduced size. Click the slide to be moved and drag it with the mouse to the desired position. The position where the slide will be inserted is indicated by a vertical black bar.

Creating Cross-Fade Effects

To apply cross-fade effects, one must have Impress in the Slide View or Drawing View.

Click on the slide when in the Slide View mode. Set the effect and transition period that is to apply to the slide Transition using the two left list boxes.

In Drawing View, choose Slide Show > Slide Transition to bring up the dialogue in which slide transition effects are defined. In the Slide Transition dialogue, select the option Manual Transition which will switch from one slide to the next in the presentation on clicking the mouse or pressing the right arrow key.

Starting Presentations

The easiest way to start a presentation is by clicking the Slide Show icon on the main toolbar or choose Slide Show > Slide Show. The on-screen presentation starts immediately. Presentation settings can be adjusted under Slide Show > Slide Show Settings.
This dialogue also lets the user determine which slides to include in the presentation. Select any other desired options, and click OK.
Working with Connectors

In addition to the individual frames, connectors are important components of an organization chart because they help represent the relationships within the organization. Impress provides a variety of connector types. Click on the Connectors icon in the Main toolbar, and a floating window with the available types appears.

Frames and connectors can be linked either from “edge to edge” or from “middle to middle,” or a combination of both. These possibilities are described below.

"Edge to Edge” Connectors

Select the desired connector by clicking it, and then drag it to the first frame. A small symbol is displayed on every edge of the frame. Put the mouse pointer on one of the symbols (the symbol will be given a dashed-line border). Press the mouse button and drag the connector to the desired frame. As soon as the mouse touches the frame, symbols appear on each edge here as well. Continue dragging the connector to the desired symbol (that symbol also receives a small, black border) and release the mouse button.

When a frame that is connected to another frame is moved, notice that the connector also changes position. The actual connection line between the two frames remains the same, so that for minor shifting of the frames, the connector usually does not have to be edited. With major frame movements, however, it is often necessary to reedit, because the connector may shift to a different position.

To change the position of a connector, simply click on it. Small points appear, at both the beginning and end of the connector. If the cursor is rested on one of the points, a small square appears next to the mouse pointer. Press the mouse button and drag the beginning or end point to the desired frame.
"Middle to Middle” Connectors
If a connector is selected from the Connectors floating toolbar and click in the middle of one of the frames, a black, dashed-line border appears around the entire frame. Press the mouse button and drag the connector into the middle of another frame, which also receives a black border, and release the mouse button.

The advantage of this method is that when the frames are moved later, the connector fits perfectly, so that the beginning and end of the connectors lie in the middle of each frame. This function comes in handy in switching the position of two frames because the connectors need not be edited manually.

Editing Connectors
To change the properties of a connector, select it and click Connector... in the context menu to open the Connector dialogue.

Choose the desired connector type from the list box. The Standard Connector is the default. The user can also modify the line skew and the line spacing in this dialogue. All changes will be shown in the small Preview window. To apply a different colour to the connector, open the Line dialogue with the context menu. Hints and Tips for a Successful Presentation

Using a Snap Grid
To work with greater precision, use the grid function. To display a grid, click the option Use Snap Grid under Tools > Options > Presentation > Grid. In addition, one can also select Visible Grid to help position the objects more easily.
Editing Glue Points

By default, the connectors dock to the handles in the center of the object pages. However, using the glue points, the user can make the connectors dock to any point of an object. For detailed instructions, refer to the Help > Contents > Index > Search term > glue points; using.
Hints and Tips for a Successful Presentation

Using the Mouse as a Pointer
There are occasions when using the mouse as a pointer is preferable to other methods, such as a laser pointer. To use the mouse, select the option **Mouse pointer as pen** in the **Slide Show** dialogue. This allows highlighting charts or pointing to important aspects during a presentation. To change slides manually, double-click the mouse.

Changing Bullet Symbols in Outline View
To change a bullet symbol whilst in the Outline view, place the cursor in the desired line/paragraph and click the **Bullets and Numbering** icon (only visible in the Object bar of the Outline view). A dialogue appears from which to choose a different symbol.

Inserting, Deleting and Renaming Slides
1. To insert an additional slide, do the following:
   a) Select the slide that precedes where the new slide will be put.
   b) Now click the empty space between that tab and the horizontal scroll bar and a new slide appears with the page layout of the previous slide.
      Alternatively, choose **Insert Slide** from the context menu of the slide tab area. In the **Insert Slide** dialogue, assign a name to the new slide and define a layout.
2. Deleting a slide is easy.
   a) Click the tab at the bottom of the work area to activate it and
   b) Open the context menu.
   c) Choose **Delete** Slide and
   d) Confirm the subsequent warning with **Yes** to delete the slide.
3. Likewise renaming a slide is simple. To rename:
   a) Select the respective slide by clicking the name on the tab,
   b) Press the **Alt** key and
   c) Click the slide name again. The old name will be selected and can then be overwritten.
Creating and Printing Handouts

Providing handouts, to help the audience follow a presentation, is often useful. To prepare handouts, use the Handout View mode. Since the handouts contain both the individual slides and space for notes, they can be a very helpful presentation aid.

In the vertical scroll bar, click the Handout View icon. Open the Modify Slide dialogue via the context menu (Slide - Modify Slide...) to specify how many slides are printed on a single sheet of paper.

Click OK to create the handouts. To print them, choose File > Print and click Options to open a dialogue in which the user chooses how the handout should be printed.

Organizing and Printing Notes

Enter notes for individual slides in the Notes view. Access the Notes view using the Notes icon located at the right of the document window scroll bar.

- Once notes are entered, print them by selecting File > Print... then click Options.... The Printer Options dialogue appears.

- In the Printer Options dialogue, in the Contents area, select Notes. Click OK. In the Print dialogue, select the slides for printing (all or specific ones) and click OK. Be sure to go back and deselect Notes in the Printer Options dialogue, otherwise the document will always be printed with notes.
Chapter 5: Creating Presentations With Impress

**Note:** The settings in Printer Tools apply only to the current document. For specific settings for all presentations, choose Tools > Options > Presentation... and select the Print tab.

**Using the Navigator**
Move quickly from slide to slide by opening the Navigator (function key F5). All the slides of the presentation are listed here. Simply double-click the relevant slide title to jump to that slide.

**Edit Jump Targets**
In the bottom corners are areas for which one can define an interaction. To edit or view the interaction, click (again in background mode) on the area while pressing the Alt key and open the context menu and choose the Interaction command.

**Modifying Object Size**
To change the object size, drag a selection frame around the respective objects.

After selecting the frames, open the Position and Size dialogue from the context menu. In the tab Size, apply the same size to all selected frames under the group box Size.

**Note:** Alternatively, rather than using a selection frame, click on the individual objects and press the Shift key at the same time to make a multiple selection.

**Creating Additional Objects**
For additional objects, copy one and simply insert it as often as necessary. Then, position the rectangles in the document and align them using the snap lines.

**Note:** To display vertical and horizontal snap lines, click on the respective ruler and drag a snap line from the ruler to the desired position.

**Changing Font and Font Size**
Change fonts and font sizes using a Style, so that these changes once only have to be made once. Click in one of the frames and open the Stylist. The Graphics Style Object with shadow is selected. In the context menu, choose Modify to open the Graphics Style: Object with shadow dialogue, and click on the Font tab to define the desired font type and size. Upon clicking OK, the text in all of the frames will be displayed according to the selected settings.

**Modifying colours**
To assign a different colour to a frame, use the mouse to drag a selection frame around the respective frame. Select Area in the context menu to open the dialogue of the same name.

Select a colour on the Object Fill tab. Further design options are available with the various colour schemes in the Gradients tab. Choose one of the existing colour gradients, all of which can also be edited and modified.
Chapter 6: Creating Drawings with Draw

OpenOffice.org Draw can be used to create drawings with different degrees of complexity. This ranges from a simple drawing to an interactive multi-page document. To create drawings or graphics, open an empty document and design all the elements by hand, or work with the templates and sample graphics that can be reached by selecting File > New > Templates and Documents or directly from the Gallery, inc the case of graphics.

Draw enables creation and saving vector graphics. These graphics can also be exported as pixel graphics. Furthermore, it is also possible to insert pixel graphics (bitmaps) into draw pages at any time.

OpenOffice.org Draw Functions

This section contains an overview of some of the OpenOffice.org Draw capabilities.

Creating and Publishing Vector Graphics

OpenOffice.org Draw is an object-oriented vector graphic drawing program. The objects can be lines, rectangles, 3D cylinders or other polygons. All objects already have set properties, such as size, colour of the surfaces, colour of contours, linked files, associated actions when clicked and much more. Any or all of the properties can be modified at any time.

Because of the vector technology objects can be rotated in any direction and have their size altered, without unsightly step effects occurring on the edges. Furthermore, as all of the objects can be controlled individually, they can be moved and overlapped as required.

Creating 3D Objects

Draw does not restrict graphics to two dimensions. Cubes, spheres, cylinders and other 3D objects, can be created, rotated at will and each object can be illuminated individually by means of various light sources. These features together with default or freely defined colour gradients, allow quick and easy creation of eye catching company and Internet presentations.

Manage Organization Charts

OpenOffice.org Draw is object-oriented. The objects could be rectangles, for example, containing text and linked to each other. If rectangles are moved, connectors will automatically follow. This makes drawing and maintaining a company or departmental organizational chart much easier. The connectors can also be freely placed at glue points, which makes the creation of technical drawings with explanatory texts easier.

Drawing

Make straight lines, free lines, bezier curves and other types of rectangles and geometrical figures in the usual ways. The 3D functions can be used to create 3D objects such as cubes, spheres, cylinders, tori and more. Rotate two dimensional contours in the third dimension. Choose colouring, colouring with bitmap textures, perspectives and/or illumination to create impressive 3D objects for invitation cards, brochures, business cards and other stationery.

To insert additional elements into a drawing use clipart available in the gallery. It doesn't matter if they are vector or pixel graphics.
Export
Use Draw to quickly and easily create buttons and icons for Web pages et cetera and export them as GIF, JPG, PNG or other formats.

Construct
There are many tools that Help create exact drawings. For example, define a grid to which an object can be snapped during construction and moving, or temporarily snap new objects to the edges and points of existing objects. The size of the object can be altered at any time by entering the required measurements in the Properties dialogue. It is also simple to insert dimension lines which can be used in a variety of ways.

Integrate
And, in case it is not obvious, Draw allows the user to add texts, tables, charts and formulas from the other program modules of OpenOffice.org into any drawing.
The OpenOffice.org Draw Window

Toolbars and Windows® in OpenOffice.org Draw

The above graphic shows the various floating windows that enable OpenOffice.org Draw. Each window has a corresponding icon on one of the toolbars. Most are icons are located on the Main toolbar that is on the left of OpenOffice.org main window. Please ensure that at least Help > Tips is enabled so that hovering the cursor over an icon provides a meaningful explanation of what each does. Enabling Extended Tips gives even more information.

Note: that the user can also access functions through the context menu instead of using menu commands, which makes for less work with the mouse.
Chapter 6: Creating Drawings with Draw

Drawing Rectangles and Ellipses and Entering Text

The drawing module in OpenOffice.org (Draw) has many functions for creating and editing vector graphics. In this section introduces the most commonly used functions.

More detailed information can be found in OpenOffice.org Help.

Open a new drawing document by choosing File > New > Drawing. In addition to the blank drawing page, notice the main toolbar on the left and the object bar for drawings at the top of the work area. With the View > Toolbars command, adding the option bar and/or the colour bar at the bottom edge of the window is easy and useful as shown in the following illustration:

![Toolbar and Object Bar](image)

If these instructions are used to create a presentation document instead of a new drawing document then notice one of the visible differences between Impress and Draw: The buttons at the top right above the scroll bar (only in Impress) indicate drawing view while the buttons at the bottom left indicate the slide view.

Draw and edit vector graphics in the drawing view. The other views, which are only available in Impress by clicking the buttons at top right, Help create presentations. They are introduced in the chapter on Impress and are also described in Help.

In the slides view, the user works on the individual slides of the presentation, whereas the master view allows defining a uniform background for all slides. In addition, the layer view can be turned on and off as desired. For example, the layer view is where objects that are not always supposed to be visible can be managed.

The main toolbar contains several floating toolbars. When opened, these toolbars provide additional related icons. The floating toolbars are indicated by small triangles on icons and are opened by long-clicking the corresponding icon on the main toolbar until the floating toolbar appears. When a toolbar is “floating”, it can be moved from its original position and placed anywhere else in the work area.

Long-click the Rectangle icon to open the floating toolbar and click on the Rectangle icon. The pointer changes to a cross-hair symbol with a small square.

![Floating Rectangle Toolbar](image)

1. Draw a rectangle on the slide. It has preset attributes, including a blue fill and a thin black line as a border. There are eight handles with which can be dragged to change the size of the object.
2. Draw further rectangles. These can be overlaid with the existing rectangles.

3. Click the **Ellipse** icon and draw a few ellipses. Also try drawing a few 3D objects, as shown in the illustration. Several examples are available in the 3D (three-dimension) theme in the Gallery.

4. Click each of the objects and modify the fill colour, line colour, and the line width using the list boxes and icons on the object bar.

**Note:** Clicking once on any tool, makes the tool available for only one single task. Double-click the icon to allow it to remain active until another tool is chosen.

Defaults, such as blue as the filling colour, can be changed. Make sure that no object is selected and choose a different colour on the object bar as the new default.
Rotating and Resizing Objects

When clicking an object for the first time, eight handles appear with which the size may be changed. The whole object can also be dragged to move it to another position on the slide.

Click the **Rotate** icon on the main toolbar under **Effects** and directly on the main toolbar in Impress.

When the mouse pointer is positioned over a handle, the pointer indicates that the object can be rotated by dragging the mouse. In the middle of the object, a small circle indicates the pivot point. It can be moved to any other position with the mouse. When the corners of the object are dragged with the mouse, the object rotates around the pivot point. Dragging the middle points on the sides slants the object in relation to the opposite edge.

Click on the object once again to display the eight handles. By double-clicking within the object, the handles change and the text cursor appears positioned in the middle of the object. Text can now be entered which is automatically connected to the object. Some interference may appear on screen. Press **Ctrl+Shift+R** to refresh the screen.

To resize an object, simply click on one of the handles and drag until the object is the size needed.
Chapter 6: Creating Drawings with Draw

Arranging and Aligning Objects

Arranging Objects

Where objects are overlapping and the position of the individual objects in the foreground or background must be changed, use either the context menu commands, or use the icons on the Arrange floating toolbar.

- Click on the object which is to move either in front of or behind other objects. Then click on one of the icons in the upper row of the Arrange floating toolbar, for example, to move the object completely to the back. To position it directly behind another object, click the Behind Object icon. Then click on the object behind which the current object is to be positioned. This effect will only be seen if the objects are presently overlapping or are moved to do so later.

- Select two objects at the same time by holding down the Shift key and clicking the objects, one after the other, and then clicking Reverse. This switches the order of the two objects.

Aligning Objects

Position objects anywhere using the mouse. However, to position an object at exactly the upper margin of a slide, for instance, or center two objects vertically above each other, use the icons on the Alignment floating toolbar.

- If an individual object is selected and then one of the icons on the Alignment floating toolbar is clicked, the object is aligned at the page margins. Two or more objects selected together, will be aligned to each other.

- A special type of alignment is the Distribution of objects. When, at least, three objects are selected at once, use the Distribution command. In Impress, this command can be found in the context menu, while in Draw it is found as an option in the Modify menu.

The selected objects are distributed so that their borders or midpoints are the same distance apart. The two objects that are the horizontally or vertically farthest apart from each other are fixed points, i.e. immovable. The other objects between the outermost objects can be moved using this function.

Note: Remember that everywhere in OpenOffice.org a multi-level undo function is available. Activate this function by clicking the Undo icon on the function bar or by pressing Ctrl+Z. Each time this command is used, it reverses a previous action.
**Drawing Sectors and Segments**

The **Ellipse** floating toolbar contains several icons for drawing sectors and segments. Sectors look like “perfectly cut pieces of pie”. Segments look like halves of a pie.

Drawing sectors of an ellipse or circle requires multiple steps, though the process functions intuitively:

1. Open the **Ellipse** floating toolbar and click on the **Circle Pie** icon. The pointer changes to a cross-hair symbol accompanied by a small sector symbol.
2. Use the mouse to drag open the shape of a circle. The outline of a circle follows the movement of the mouse.

   **Note:** The first click defines the first corner of the delimiting rectangle which surrounds the circle. The delimiting rectangle will later be obvious from the eight handles that appear when selecting the circle. To draw the circle such that the first click defines the center, press the Alt key while dragging the mouse.

3. Release the mouse button when the circle has reached the desired size. Now notice that a radius which follows the movement of the mouse is drawn in the circle.
4. Position the radius at the point where it is wanted so as to place one boundary of the sector and click once.
5. Now when moving the mouse, notice that the first radius is set and a second radius follows the movement of the mouse. Click again to complete the circle pie.

Drawing ellipses is done in a similar fashion. The dimensions of the delimiting rectangle, formed when first drawing the shape, determines the dimensions of the ellipse. When drawing a segment, proceed in exactly the same manner as described above for sectors. The only difference is that in the last step no second radius follows the movement of the mouse, but rather a secant (straight line) cuts through the circle.

The other icons in the **Ellipse** floating toolbar can be used to draw ellipses and arcs. This process also functions as described above although, only the perimeter of the ellipse or the circle is drawn.
**Entering Text**

To enter a text in a drawing, decide if the text should have a “normal” format as in a text document or if the text should be handled as a graphic object that can be rotated, expanded, minimized, et cetera. “Normal” text can also appear in the form of a legend (in a frame with an arrow).

Open the **Text** floating toolbar from the main toolbar.

**Note:** Where Asian language support is enabled under **Tools > Options > Language Settings > Languages**, there will be additional icons for entering vertical text.

![Text toolbar](image)

**Normal Text**

1. Enter “normal” text by clicking the **Text** icon.

2. Drag open a delimiting frame in the document which sets the position and maximum width the text area should have. If the text is long, extend the frame in order to incorporate the whole text. Position and the size of the frame can later be changed using the mouse; but the frame cannot be made smaller than the text itself.

3. Enter the text. Select the text by holding down the Shift key while using the arrow keys or use the mouse. The font and font size can now be modified as in regular text documents.

When the mouse is clicked anywhere on the document other than the text, text edit mode is no longer in effect. Clicking the text once again, the text will be selected as an object. Now, it can, for example, be rotated or the entire text moved. By double-clicking the text it can be edited it again, for example, delete characters or set additional font attributes.

**Fitting Text to Frames**

1. With the **Fit Text to Frame** icon, draw a delimiting frame which predetermines the position and size of the text.

2. Enter any text in the frame.

3. Click in any free area of the document.

Notice that the entered text is scaled so that it exactly fits into the frame.
Callouts
1. Using the Callouts icon, drag the mouse from where the callout arrow should point, to the point where the callout text should appear.
2. Release the mouse button.
3. Edit the size of the frame of the callout.
4. To start entering text into the callout, just double-click the line. The callout frame appears with a wide gray border, indicating text edit mode.
5. Enter the callout text.
6. Change the line properties by clicking on the line, opening the context menu and clicking on the Line command. Select arrowheads for the lines in the Style pull-down list on the Line tab page.

Converting Text Into 3D
Selected text can be transformed into a 3D body by choosing Convert > To 3D from the context menu. The 3D body will fill the area created for the text frame.

3D text can be rotated using the Rotate icon from the Effects floating toolbar on the Main toolbar.

By clicking inside the delimiting frame and dragging with the mouse button pressed, the object will rotate on all the axes at the same time. However, by clicking one of the eight handles and dragging it with a pressed mouse button, the object rotates on only one axis.

The pivot point, which first appears as a small circle in the middle, can be moved. Thus, while rotating the object, it rotates around the new pivot point. Open the 3D Effects window by clicking the 3D Controller icon from which another, different illumination can be applied to the 3D object. The 3D Effects window is described in more detail in Help.
Chapter 6: Creating Drawings with Draw

Drawing, Editing and Converting

Curves and Objects
With vector graphics in drawing and presentation documents, design not only ellipses and rectangles, but also irregularly shaped curves forming open or closed figures. Both Impress and Draw make it very easy to draw and edit even quite unusual figures.

Drawing Curves
1. The tools for drawing special shapes are found in the Curves floating toolbar indicated by this icon on the Mail toolbar. Drag the floating toolbar away from the Main toolbar into an empty drawing or presentation document.

2. Select the Curve icon. The cursor appears as a cross-hair symbol with an accompanying symbol that indicates the new function.

3. Create a curve using the mouse.
   a) The point where the mouse button is first clicked determines the starting point.
   b) Move the mouse in the direction the curve should take from the starting point. The point where the mouse button is released, defines this direction.
   c) Moving the mouse without holding the button down and the curve will follow the movement of the mouse.
   d) Click where the second point of the curve should be.

By holding down the mouse button, the direction of the curve from the second point can be defined to the next point (in the same manner as was done at the starting point), release the mouse and move to the third point, click again and keep the mouse button pressed, and so on.

But when the mouse button is released after clicking on the second point of the curve, and another point in the slide is clicked, the second point will be defined as a corner point. At a corner point, the curve abruptly changes direction, thus forming a corner. If there is a point three defined as a corner point in this way, a straight section between points two and three will appear.

When the Shift key is held down, directions are limited to multiples of 45 degrees. By holding down the Alt key, the curve will be closed, and an additional curve can be drawn. These can be combined with the first one to form a single object.

4. To end curve drawing, double-click the last point to be set then continue working with other tools.
The curves, that have been drawn using the above steps, are Bézier curves. The points on a Bézier curve are called data points.

- Each data point on the Bézier curve can be “symmetric”. The curve then has the same curvature either side of the point.
- Or the data point is “smooth”. The curve then has different curvatures either side of the point.
- If the curve is not steadily continued at the data point, but instead forms a corner or tip, it is a corner point. Any type of data point can be converted into any other, thus giving good control over the shape of the curve.

Note: When precisely linking two existing points in a drawing using lines, click the Line icon on the main toolbar and also activate the option bar via View > Toolbars > Option Bar. Select the Snap to Object Points icon on this toolbar.

**Editing Curves**

Data points can be edited if they are displayed as small rectangles. To work on a curve later, when it is no longer selected, click the Edit Points icon on the object bar and select the curve. If the object bar is not visible, click briefly on Select on the main toolbar:

1. Now click Edit Points on the far left of the object bar or on the option bar.

2. Click once on the point for editing. It will appear as a filled square, and there should be two Bézier lines with control points at the ends. (Please note that sometimes one of the control points is directly on top of the Bézier point and thus hard to see.) In the case of corner points, which define right angles, the control points lie directly on the Bézier point.

Now move the Bézier point and the control points as needed. Note how the curve changes accordingly. The change in form of the cursor indicates in each case the function that can be executed.

The object bar contains several icons with which can, among other options, change the type of the selected point. A detailed explanation of the various options can be found in Help.

3. To convert the type of data point, select the point. The object bar shows the type of point: corner point, smooth transition or symmetric transition.

4. Click one of the icons to change the type of point.

Of course, curves can also be edited in the “conventional” manner, i.e., changing width, colour, and (in the case of a filled curve) the object fill. The options for changing these attributes are found in the Object bar. If the Edit points icon is not pressed, use the context menu or the Format and Modify menus.

Also try out the other icons on the Curves floating toolbar. When a filled curve is finished by double-clicking, it is automatically closed and all “internal areas” are filled.
Vectorizing Bitmaps

With Draw or Impress, transform pixel images, so called bitmaps, into vector drawings. One of the advantages of vector graphics is that they look good in any scale when printed. This is different when printing scaled bitmaps, since unattractive effects may appear, such as missing or zigzag lines, et cetera.

1. Select the bitmap to vectorize, for example by clicking once on the object.

2. Select Convert > To Polygon from the Modify menu in Draw. For Impress, select from the context menu of the selected object.

   The Convert to Polygon dialogue enables setting some parameters for the conversion and previewing the result.

3. Clicking on OK and the selected bitmap is now a vector graphic.
Converting Text Characters to Curves

Sometimes one needs to fancy up some text, say for a logo or sign, such that the text is non-linear. The following procedure shows one way to accomplish this task.

1. Use the **Text** icon from the **Text** floating toolbar on the main toolbar and then type the text, letters or special characters in a Draw document. Remember to use a reasonable font size and font type to avoid unnecessary editing later.

2. With the text object still selected, choose the command **Modify > Convert to Curve**. The text is converted to a vector object that can be edited.

3. If the text consists of more than one character, the characters will be displayed as a grouped object. To edit a single character, enter the group. To do this, use the **Enter Group** command in the context menu of the group or press F3. Then click the character to be edited.

4. Now, click the **Edit Points** icon on the option bar (top left in the graphic below). Click the object to see all the Bézier points of the object. The object bar, provides various icons for editing, inserting and deleting points.

![Diagram of a logo with Bézier points](image)
5. Use the **Zoom** floating toolbar to enlarge the view. If the black filling of the characters is a
distraction during the editing process, temporarily change it to, say, 10% gray by choosing
**Format > Area**.

**Converting to Curves, Polygons, 3D**
Many objects quite effectively edited by converting them. The following examples illustrate
this concept:

- Open a rectangle. This has the default settings for colour, line thickness etc. and should
  now be selected.

- Choose **Modify > Convert** (in Impress the corresponding command can be on the context
  menu of the rectangle). The menu subcommands are: To Curve, To Polygon, To
  3D, To 3D Rotation Object.

- Choose **Modify > Convert > To Curve** to convert the rectangle into a Bézier curve. Now
  edit the existing points. As shown in the following graphic, move the points, convert them
  from corner points into rounded points, delete them, insert new points et cetera as the
  rectangle is converted into a heart shape. All these options are described in detail in **Help**
  under the search words **Edit points** and **Bézier object bar**.

Choose **Modify > Convert > To Polygon** to convert the original rectangle into a “Polygon
with 4 points”, as will then be stated on the status bar. Now, for example, a polygon
down can be broken down into its basic parts by choosing **Break** from the **Modify** menu. The
status bar will then read “4 Lines selected”. Each of the lines can be shifted
separately.

With a polygon selected, click the **Edit Points** icon to modify points, insert new ones and
anything else needed in this mode.
Select **Modify > Convert > To 3D** to generate a three-dimensional object from the two-dimensional object in (g) above. This conversion uses an extrusion method such that the polygon is “pulled” perpendicular to its plane by a certain amount into the third dimension.

A 3D object can be rotated and edited via the **3D Effects** window that is called up from the context menu.

To create a 3D object by means of a rotation extrusion, choose **Modify > Convert > To 3D Rotation Object**. A polygon will be rotated 360 degrees around an axis into the third dimension.

By rotating a rectangle a little bit before converting it into a 3D rotation object, a more striking object will be created.

While these examples showed conversion of only basic objects, such as simple rectangles, imagine how much can be done when converting complex objects.

For example, drag a drawing from the Gallery to the page and convert it into a 3D object. Draw positions the objects contained in the drawing in various 3D levels corresponding to their arrangement in 2D levels. For example, in 3D the stars from the European flag stand out vividly from the blue background of the flag.

Most objects can be converted to 3D:
• Groups can be converted as long as they contain convertible objects.
• Bitmaps will be laid as a texture over a rectangular object of adequate size.
• Metafiles will be broken down into a group of polygons and then converted.
• Draw objects with text on them display the text in raised form on their surface (e.g. a rectangle which was double-clicked and on which text was placed).
Working With Objects

Individual objects in an impress or draw document can be selected, copied, cut and pasted in much the same way as words in text. Other actions are also possible that are only available for graphic objects. For example, objects may be duplicated, cross-faded or grouped. Figures placed in the drawing area, such as rectangles, circles, lines et cetera, are treated as objects.

Duplicating Objects

Objects, in Draw, are easily duplicated. This feature allows the user to make a set number of copies of an object which differ in consistent degrees from one copy to the next in position, orientation, size, and colour.

For example, to create a stack of coins, use the duplicate function.

First create the bottom coin by doing the following as shown in the graphic below:

1. 1. Draw an ellipse or circle at the bottom of the slide.
2. 2. Choose the Edit > Duplicate... command to open the Duplicate dialogue.
3. 3. Enter the following values:

   ![Duplicate Dialogue](image)

Follow these steps to create a stack of coins as shown on the right of the above graphic:

1. Select 30 as the number of copies. The x-axis is the horizontal axis from left to right. Entering positive values in the field for the x-axis placement causes a shift to the right. If the stack of coins should increase from the bottom up, enter a negative value in the y direction (vertical).
2. To make the coins to become smaller the higher they get, enter a negative value for the width and height.
3. Finally, define a colour scheme from bottom to top. Select, for example, a darker yellow for the beginning colour (bottom) and a lighter yellow colour for the end colour (top).

4. Click OK to create the duplicates.

**Cross-Fading Between Two Objects**

The cross-fading function is only available for drawings in Draw and not in Impress documents. To insert into a presentation an object that was created by cross-fading two objects, copy it from the drawing into the presentation document by way of the clipboard.

In the process of cross-fading a transition between two objects is calculated and the increments will be positioned on the page. In the increments, the form, orientation, and colour of the objects, as well as other attributes, are adjusted uniformly.

1. For example, in an empty drawing document, draw an object at the bottom left and another one at the upper right (use two different colours).

2. Select both objects.

3. Select the command **Edit > Cross-fading**. A dialogue appears where further settings can be defined.

4. Click **OK**.

Draw calculates the increments and displays the results.
This new object is a group which consists of the specified number of individual objects. Enter the group by pressing F3 and then edit the individual objects. The **Modify** menu in Draw contains all the necessary commands for working with groups and these functions can be also found in Impress under the **Format > Group** menu command or in the context menu. Further information can be found in **Help**.

1. Working With a Group of Objects

Several objects at one time can be selected, grouped, combined, merged, subtracted and intersected.

- Selecting several objects at the same time has a temporary effect; i.e. whenever the mouse is clicked elsewhere on the page or slide, the grouped area is deselected.
- Grouping and combining are valid until the group or the combination is deselected using the command from the context menu or the **Modify** menu.

These commands can also be used to group together several groups, add a combination and combine the results as a group or combination.

**Grouping Objects**

Several objects can be combined into a group. To do this, select them together, right-click to bring up the context menu and choose **Group**. Any and all changes made to a group have an effect on all objects in the group. In particular, groups can be moved, rotated, etc. as a single object.

For example, in drawing a bicycle, first construct a wheel, composed of a tire, rim, spokes, and hub, and then group these objects together. This makes it easy to rotate the wheel, duplicate it, and move the second wheel to the appropriate position. Finally, draw the frame and the rest of the bicycle, and form a new group.

To edit an object that is part of a group, there is no need to redefine the group. Use the **Enter** group command which allows editing any object in the group. When edits are completed,

**Entering Groups**

Enter a group by first selecting it, either by clicking it or by using the keyboard. Once selected, the user can decide whether to employ the context menu command, the F3 key or double-clicking the group to enter it.

**Exiting Groups**

Exiting a group may be accomplished in these three ways: using a menu command, the key combination

Ctrl+F3, or double-clicking outside all of the objects in the group. The group remains selected upon exit; thus making it possible to quickly enter and exit a group using the keyboard.
Navigating Between Objects of a Group

Using the Tab and Shift+Tab keys the user can move forward and backward along the row of objects in a group edited with F3 or on a page. If the keys are pressed again on a final object while going in one direction, the first object selected will appear next.
Combining Objects and Constructing Shapes

In Draw and Impress graphic objects may be combined in different ways. Several single objects can be brought together to create new objects by using Boolean set operators on the original geometry.

**Combining Objects**
1. Select several objects.
2. Choose **Combine** from the context menu.

In contrast to groups, which consist of single objects, a combination fuses the component objects into one single new geometric object with its own new properties. The combination may be undone again later, but the individual objects may not be recoverable.

The user should recognize the property that stands out the most in a combination when the individual objects overlap. In this case, the combination is the result of the Boolean/logical operator XOR, and shapes, discussed later, are other logical combinations. The areas of overlap are the ones which stand out the most in a combination, as they will be converted into “holes”.

In the illustration, several objects are shown to the left as they are before being combined, and at the right after being combined. The combination is given the attributes of the object farthest to the back (i.e. undermost object).

**Constructing Shapes**

The commands **Shapes > Merge, Subtract and Intersect** also form a new geometric object out of the original objects. The new object comes into being through the use of logical amount operators (boolean O) on the source geometries.
1. Select several objects.
2. Choose **Shapes** from the context menu. In the submenu, choose **Merge, Subtract** or **Intersect**.

In the following illustrations the original shapes are shown on the left and the result on the right.
**Shapes - Merge**

The selected polygons are merged so that they make one object, the surface of which is the sum of all the parts (Boolean OR).

**Shapes - Subtract**

All other polygons selected are subtracted from the undermost polygon. This entails the other polygons first being merged and then subtracted from the polygon positioned under/behind all the others. Holes are taken into account. Logically this operation corresponds to the following formula: \( A > (B_1 \mid \ldots \mid B_n) \)

**Shapes - Intersect**

The selected polygons are joined into one single polygon that corresponds to the intersection area (Boolean AND). Only the area where all polygons overlap remains.

Choosing **Shapes > Subtract** and **Shapes > Intersect** also permits cutting parts out of a bitmap. The illustration below shows examples.
Graphic Objects in Drawings and Presentations

Both Draw and Impress use a vector graphic format. However, pixel graphics or bitmap graphics may also be inserted into presentations or drawings and documents or certain sections of a document can be exported in a pixel graphic format.

Inserting Bitmaps

Bitmap images can be inserted in any Writer, Calc, Draw or Impress document.

2. Select the file. With the File type field users can limit the selection to certain file types.
3. Check the Link box to hyperlink to the original file where embedding is not needed.
   
   If the Link box is checked, whenever the document is updated and loaded the bitmap image is reloaded, and any editing steps, that have been applied to the local copy of the image in the document, are re-applied and the image is displayed.

   If the Link box is not checked, the copy created with the first insertion is embedded and used.

4. Click Open to insert the image.

Editing Bitmaps

When a bitmap image is selected, the object bar offers the tools for editing the image. Only a local copy is edited in the document, even if an image you is inserted as a link.

The object bar may look slightly different depending to the module being used. The illustration shows the object bar in Draw:

A number of filters are located on the Filter floating toolbar, that the user can open with the icon on the far left of the object bar.

Some of the filters open another dialogue when started, and the user can use these options, for example, to select the intensity of the filter.

Text and graphics can be added to the bitmap image by selecting these objects together and exporting the selection as a new bitmap image.

Applying Text to Bitmaps

To apply text to a pixel image and save it in JPEG format, for example, follow these steps:

1. Open a new drawing document.
2. Insert the pixel image by choosing Insert > Graphics.
3. Unselect the image by clicking somewhere else in the document.
4. Open the Text floating toolbar from the Main toolbar and select an option; for example, the **Fit Text to Frame** icon.

5. Draw a frame around the pixel image and enter some text inside this frame.

6. If desired, select this text and assign another colour to it. The background of the text is automatically transparent.

7. Select the pixel image and the text by drawing a frame around both. The Status bar will read “2 draw objects selected”.

8. Choose **File > Export** and, in the **Export** dialogue,

9. select the file type “JPEG - Joint Photographic Experts Group”

10. Enter a name.

11. Check the **Selection** check box to export only the selected objects.

12. Click **Save**.

Another dialogue permits setting options to define the quality of the JPEG image. Remember that the higher the quality, the larger will the file be.

When a graphic object (for example, an inserted Pixel image) is selected in Impress or Draw, the graphic object bar will be automatically be displayed. This bar enables modification of the colour tone, brightness and contrast of the graphic object.

Changing the transparency value of graphic objects is also possible. At a higher transparency values a graphic object becomes see-through, and objects lying behind it will be visible. When the work is saved as an OpenOffice.org document, the transparency is saved too.

**NOTE: When exported as a graphic format, transparency is only saved where the graphic format supports the transparency and this function is enabled at the time of export.**

**Saving Bitmaps**

Saving changes to a bitmap image as an image file, for example in one of the GIF, JPEG or TIFF file formats, is only possible in Draw or Impress by selecting and exporting the bitmap image. The following provides a step-by-step procedure:

1. Select the bitmap image.

   Also select any additional objects as necessary. Pressing the **Shift** key for each selection or by open a frame around all objects, to include, say, text with the bitmap image.

2. Choose **File > Export** to open the dialogue.

3. In the **File type** field select the file format desired. For example GIF, JPEG et cetera.

4. To only export the selected objects, check the **Selection** box.

   If **Selection** is not checked, the entire page of the document is exported.

5. Enter a name for the file.

6. Click **Save**.
Working With colours

The object bar has a list box from which to choose the colour for a selected object from a number of predefined colours. The colour of the border line can be chosen independently of the colour of the filling.

The colour Bar

If wanted or needed, the colour bar can be displayed on the edge of a drawing or presentation. The colour bar offers a choice of colours. Selected objects can be coloured by simply clicking on a colour. To display the colour bar, select View > Toolbars > colour Bar.

The colour bar displays all predefined colours with their respective names in the same order as in the list box of the Object bar. User-defined colours appear at the end of the colour bar and the bottom of the list box.

The field at top left of the colour bar is for the colour “Invisible”.

Change the size of the colour bar using the mouse. Alternatively, hold down the Ctrl key and double-click in the gray part of the colour bar to obtain a movable, variable-size window that can be manipulated in the same way as most other windows. For example, it can be moved by dragging the title bar and its size changed by dragging the edges or corners of the window. To dock the window again, hold down Ctrl and double-click on a gray area of the floating colour bar.
**Defining Custom colours**

Any number of colours can be defined by the user, have names assigned and be saved in colour palette files.

1. In a drawing document, choose **Format > Area...** to open the **Area** dialogue.
2. In the dialogue, click the **colours** tab.

![Area dialogue](image)

This provides everything needed to modify the colour of a selected object. Here, the user can also define and organize new colours.

To apply a colour that is not yet in the colour palette, first define the new colour and assign a name to it.

**Note:** Modifications to the standard colour palette are permanent. These are saved automatically, and are irreversible. This should not present problems if only adding a new colour to the palette, but it can create difficulties if the standard colours are changed.

1. To define a new colour, the best thing to do is choose a colour from the colour palette which resembles the new colour. It will be displayed in the upper of the two preview boxes.

2. The list box provides two settings, **RGB** and **CMYK**, for defining the colour. Select the colour model in the list box that corresponds to what is needed for this colour.
The colour models RGB and CMYK are just two of the models most used to define colours. RGB stands for red-green-blue and this model is particularly useful for colours being displayed on a computer monitor as it combines the three basic colours used. CMYK stands for Cyan-Magenta-Yellow-black or Cyan- Magenta-Yellow-Key and is the colour model that best describes the subtractive colours used in printing. Select the colour model that corresponds to the desired output medium (monitor or a printer). When exporting image files, it is best to ask the photo-exposure service in which colour model and format the image is expected.

3. Define the colours by modifying the values in the spin boxes. Enter values directly, or click the buttons to change the existing values. The result is shown immediately in the lower preview box.

If selecting colours from a colour spectrum is preferable to specifying the values with the spin buttons, click Edit. This opens the colour dialogue. In this dialogue it is also possible to specify the colour in the HSV or HSB (Hue-Saturation- Value/Brightness) model. Select the colour and click OK.

4. Once a new colour is chosen, specify whether it should replace the original colour or be defined independently.

**Note:** It is recommended that only custom-defined colours be replaced.

1. To replace the colour displayed in the upper preview box, click Modify.

2. To set the new user-defined colour, assign a name to the colour in the Name field, and click Add and OK.

The new colour will immediately be added to the palette of existing colours; however, if the dialogue is exited by using the Cancel button, the colour of the current object does not change.

Nonetheless, the modifications in the colour palette do remain in effect.

Further instructions on saving and loading the colour palette and other palette files are found in Help.
Replacing colours using the Eyedropper

In Draw and Impress, images inserted in a bitmap format such as, GIF, JPEG and metafile images like WMF can have their colours edited using the **Eyedropper**. To open the Eyedropper window, choose **Tools > Eyedropper**.

![Eyedropper window](image)

The Eyedropper can replace selected colours and, to a point, similar colours, with other colours, up to four colours at one time. If the replacement is not what is desired or needed, reverse it with one click on **Undo** on the function bar. Use the Eyedropper to match the colours of different bitmaps or to redo a bitmap with, say, the colours of a company logo.

The **Transparency** attribute also serves as a colour. Transparency, in an image with a colour, can be replaced for example, with white. This is **Helpful** when, for example, the printer driver has problems with printing transparent graphics.

If the user wants to produce an image on HTML pages to publish in the internet, like the illustration of a product, for example, it usually looks better when one does not see a rectangular picture, but rather sees only the illustration of the product against the uniform background of the web page. If there is a white background in the picture behind the product, use the Eyedropper to replace the colour white with “Transparent” (i.e. no colour) and save and/or export the image in a format that supports the transparency attribute (such as GIF). When using this method, be sure that the illustration of the product itself does not contain any white parts, since these would also become transparent just like the background.

To replace colours with the Eyedropper

1. Insert an image in a Bitmap format (e.g., BMP, GIF, JPG, TIG) or in a metafile format like WMF. To do this, choose **Insert > Graphics** in Draw and Impress.

2. Open the **Eyedropper** window by choosing **Tools > Eyedropper**.

3. In the Eyedropper window, click the Eyedropper icon in the upper left-hand corner. The mouse pointer will turn into a special pointer with which one can indicate the colour to be replaced in the current document. The colour box next to the eyedropper icon in the Eyedropper window displays the colour the mouse pointer is resting on.
4. Click the left mouse button when the colour is found which is to be replaced. This colour will automatically be registered in the first of the four rows in the Eyedropper window.

5. Now, in the list box to the right in the same row, select the new colour which should replace the selected colour in the whole bitmap image.

6. If in the same editing step one wants to replace another colour, click the check box in front of the next row. Now select the eyedropper icon in the upper left hand corner again and choose a new colour. Up to four colours can be replaced in one editing step.

7. Select the bitmap image or the metafile image in which the colours are to be changed, by clicking in it.

8. In the Eyedropper window click Replace. If too many similar colours were replaced, undo the step using Ctrl+Z and decrease the colour tolerance in the spin button. Then click Replace.
Gradients and Patterns for Objects and Background

The objects in drawings and presentations do not have to have uniform colours. They can also have colour gradients, transparency gradients, patterns and hatching effects. Users can also define a colour, a gradient or a pattern for a background that is visible in all slides of a presentation.

Defining Gradients

To assign a predefined gradient to an object, proceed as follows:

1. Select the object.
2. From the context menu or under Format on the menu bar, choose Area....
3. Select the Gradient option, then make a selection from the gradient list.

Defining a custom colour Gradient

Before defining a new, custom colour gradient, save the current colour gradient list as a file to ensure there is a backup [say why?] or load a different list from another file.
If the user has selected an object and then defined a new gradient, the new gradient is immediately assigned to the selected object. If one does not want immediate assignment, undo the selection before opening the dialogue for defining gradients. To do this, click with the selection tool on a position where there are no objects.

1. In the **Area** dialogue, click the **Gradients** tab. This tab enables definition of all of the options for new colour gradients.

2. From the list of existing colour gradients, click the gradient to use as a basis for creating the new colour gradient.

3. Click the **Add...** button.
   a) In the dialogue, assign a name for the new gradient. For example, enter the name “UFO”.
   b) click **OK**. The name will appear as a new entry at the end of the list and is selected for editing.

4. Click **Modify** to save the changes in the new gradient. The preview shows how the gradient looks.

5. Close the **Area** dialogue with **OK**.
The new colour gradient may be used immediately.

**Interactively Defining a colour Gradient**

Colour gradients can be modified by clicking and dragging them with the mouse. However, in order to be defined interactively, the object must already have a colour gradient.

1. Select an object which has a colour gradient.

2. In **Draw**, open the **Effects** floating toolbar from the **Main toolbar**.

3. On the **Effects** floating toolbar, click the **Gradient** icon. Two objects in colour which are linked by a vector should now be visible.
Depending on the type of gradient, one or both of the objects can be moved with the mouse and thus determine the origin, end and angle of the colour gradient. When the colour bar is displayed, assign colours by dragging and dropping the selection to each object to determine the start and end colours.

In a similar manner, the transparency of an object can be set using the Transparency icon. With this tool, defining a grayscale gradient which spans from black (0% transparency, i.e. opaque) to white (100% transparent) is possible.

**Organizing the Attribute Tables**

The icons Load Gradients List and Save Gradients List open dialogues for opening and saving gradients. The current gradient list, for instance, might consist of all gradients which are custom defined for a certain project. Save the list, then reload the standard list. This way the list (and the memory space) can be kept free from resources that are not needed. To continue working on this project later, simply reload the custom gradient list. The same procedure applies for loading and saving lists of hatchings and bitmaps.
3D Globe

This section describes how to create a three-dimensional globe with Draw in just a few steps. When finished, rotate the finished Globe using the mouse.

Creating Texture on a 3D Object

*Note: If only the globe shown here is needed, and creating a similar one is not on needed, use the finished globe from the Gallery in the 3D Effects theme. Drag the globe into the document.*

To create a custom 3D globe, first open an empty draw document, insert a globe and then apply a world map as a texture to the globe (worldmap2.wmf from the StarOffice collection is a good choice but there are others available via the Internet). Then adjust the illumination.

1. Open an empty drawing document by choosing **File > New > Drawing**.
2. Open the **3D Objects** floating toolbar ![3D Objects](image) on the left of the **Main toolbar**.
3. Select **Sphere** from the toolbar,
4. Drag open a area to create the globe. All 3D objects can be opened in this way. If creating an oblong shape is preferable, press the **Shift** key while dragging. This behavior for 3D objects is opposite to the way other objects such as ellipses and rectangles behave.
5. Open the Gallery. ![Gallery](image) The Gallery themes appear as subdirectories.
6. Locate the map to be used. If there is a Maps theme, click the it and the Gallery shows the maps.

7. Click any rectangular world map, say, worldmap2.wmf.

8. Hold down the Shift and Ctrl keys and drag the map of the world onto the sphere. This lays the map of the world on the sphere as a texture.

9. If the Gallery hides the globe, users can fix the Gallery window so that it no longer overlaps with the document. At the edge of the Gallery window click the Stick/Floating icon (looks like a thumb tack).

The texture is laid onto the sphere in its original size in the default setting. Since the map of the world is much larger than the sphere, only a small segment is seen as a green area on the sphere. This will soon be changed.

1. Click the sphere to select it.

2. Display the context menu for the sphere and choose Area. The Area dialogue appears with the Area tab page.

3. Select the Bitmap field, removing the mark in the Tile field.

4. Close the dialogue with OK.
Now the world map can be seen as texture on the sphere. OpenOffice.org has automatically selected the most appropriate projection method. To see this, double-click on the sphere and then rotate it.

In Tools > Options > OpenOffice.org > View tab, check the appropriate box for 3D objects to refresh during interaction.

**Using Illumination**

Now one needs to provide illumination for the world globe. Select an overall blue illumination, for example, so that the oceans will have a blue colour, and a yellow highlight that will shine on the side of the earth facing the sun.

1. Select the world globe since the illumination preferences being set always refer to the currently selected object.

2. Open the 3D Effects window by clicking the 3D Controller icon at the bottom of the main toolbar.

3. In the 3D Effects window, click the Illumination button.

   a) Use this feature to change the default setting of the light source to “blue” and move it down and to the left.

   b) Click Assign.

4. Repeat step 3 to apply a second light source in “yellow” to shine on the earth from the above right.

**More 3d Effects**

Take a look at the 3D Effects window. The individual tabs and icons are described in detail in Help. What follows is just a brief overview:

**3D Effects: Favorites**

This dialogue window offers a few special effects that can be used on the 3D object. To save interesting effects so that they are available for selection on this tab, file the appropriate 3D object in the Gallery, more specifically in the 3D theme folder.
3D Effects: Geometry

By using this feature, the user can control the manner and quality of how the object surface is geometrically calculated and displayed. For example, interesting effects can be produced by deliberately reducing the number of segments of a sphere. Properties of the 3D font, such as the slant of the edge (bevel), depth, et cetera are determined here.

3D Effects: Shading

This feature permits specifying the setting of the shader (flat, phong or Gouraud) to be used to display the 3D object. Gouraud provides the best shading, but requires the most computing time. Also use this feature to specify a shadow for the 3D object and to select the camera distance and focal length.
3D Effects: Illumination

Control of illumination of a selected 3D object is easily done in a variety of ways. In addition to the general ambient light, eight additional light sources are available, all of which can be aligned, adjusted for colour, or turned on and off individually.

3D Effects: Textures and Material

With these two sections, control the appearance of the surface of 3D objects. See Help for an explanation of the numerous possibilities.
Designing 3D Objects From Font Characters

The step-by-step methodology described below is particularly useful in preparing objects that could be used for logos and other identifiers. What follows is presented in tutorial form.

First Step:

1. Open an empty drawing document either using File > New > Drawing or the New icon on the Function toolbar.
2. Create a text box containing a single capital letter. In this procedure, the letter “P” is used.
3. Choose a character set for formatting.
4. Set the font size to about 400 pt.

   This font size is to provide a usably sized object that, when converted to 3D, the text takes up exactly the space that is drawn for the text, independent of the font size selected.

5. Draw the text box using the Text icon on the floating toolbar.

6. Select the letter and then manually enter 400 in the Size field on the text object bar. At this point, other attributes, such as another typeface or emphasis attribute, like bold, may be selected.

**Second Step:**

Select the text field with the letter and choose Convert > To 3D on the Modify menu. Modify the colour of the object by selecting Area on the Format menu. Of course it is also possible to assign a gradient or a bitmap graphic to the object.
**Third Step:**

Select the letter “P” again so that it can then be modified in a different way. Click the **Format/ 3D Effects** menu item. The options available include options for setting the depth of the object and the focal length of the camera. In addition, the user can set the individual illumination and the texture model.

- The sample object was given its special shape by adjusting the camera to an extremely short focal length.
Fourth Step:

Now add some text to the logo. Start by inserting a text box and populate it with name of the company and in a format that is suitable. To put a border around the text, convert the text to a polygon by choosing Modify > Convert > To Polygon. Of course, the surface of the newly created object can also be modified.
• For a border around the company name, convert it into polygons. Then select a line width greater than 0.00 and a line style not equal to “transparent” on the object bar to make the borders of each letter visible.

_Fifth Step:_
Create a simple drawing object as a background for the logo, for example an ellipse. Choose **Modify > Position** to place the object all the way to the back.
Now there is a perfect 3D logo created with OpenOffice.org in only five steps!

**Note:** that the user can also access the functions through the context menu instead of using menu commands, which makes for less work with the mouse.
Using a Grid
To work with great precision, for example to place rectangles one on top of the other, use the grid function. To turn on the grid, choose Tools > Options > Drawing > Grid and select the Snap to Grid option. As an additional aid, selecting Visible Grid makes it easy to place documents exactly on top of each other in the document.
Mechanical or Construction Drawings

This section explains how to produce a mechanical drawing with OpenOffice.org. The same method can be used to create other similar drawings, such as, construction blueprint, garden layout et cetera.
Creating a Construction Plan

To create a drawing like the preceding illustration, click the Rectangle icon and drag the floating toolbar into the work area. Then, select Curves and Lines and Arrows and drag these floating toolbars into the work area as well. Choose a tool with which to begin, such as the Rectangle, and use it to drag open an area to represent the first surface. Finally, draw in the details with the Line tool.
Add some more details.
Complete the drawing.
Using Snap Lines

It is advisable to use snap lines to position lines and objects more precisely.

To display a snap line, click on a ruler and hold down the mouse button to drag it into the document. To move the snap line, rest the mouse pointer on it until a double arrow appears. Shift the line by holding down the mouse button and dragging the line to the desired position. To delete a snap line, simply drag it back onto the ruler. In Draw, snap lines can also be positioned in a numerically exact way using the Edit Snap Line... command from the context menu of the snap line.

Note: Snap lines are lines which are visible only on the screen and are used for the sole purpose of precise positioning and alignment. An unlimited number of horizontal and vertical snap lines can be created.

Using Dimension Lines

With Draw, dimension lines can be directly inserted into a drawing. Drag the snap lines from the ruler into a document and positioned so that there is a snap line over every major line in the drawing. To do this, click the Dimension Line icon on the Lines floating toolbar. The mouse pointer will turn into a cross and a dimension line may be dragged directly from one side to the other, or, even better, from one snap line to another.

To edit the look of dimension lines, select them, open the context menu and click Dimensions.... The dialogue that appears, permits determination of the appearance and position of the dimension lines.

To increase the space between a dimension line and the measured object, move the mouse pointer to one of the points on the dimension line. The mouse pointer will turn into another icon, enabling either expansion or reduction of the space. Note: To obtain an absolutely horizontal or vertical dimension line or one at a 45° angle, press the Shift key while dragging the dimension line.
Working With Multiple Layers

The next step is to position the details in the motor drawing. It is a good idea to use the layer function if testing several different variations.

To get a better overview, turn on the Layer view, by pressing the symbol on the bottom left border of the work area. Alternatively, choose View > Layer (a check mark will appear in front of the command). To insert a new layer, open the dialogue Insert Layer. It can also be opened through the context menu of the tabs Layout, Controls and Dimension Lines arranged at the bottom of the screen. Enter a unique name, e.g. “Sketch1”. Repeat this procedure for another level and enter the name as “Sketch2”.

Now click the Suggestion1 tab and place the details of this level; for example, by dragging the desired clipart from the Gallery into the document.

After the details are positioned on Layer1, do the following:

1. click the Sketch2 tab and arrange elements there as well. Notice that the elements from Sketch1 are visible.

2. To change this, click the Sketch1 tab and call up the context menu and select Modify Layer.

3. In the Modify Layer dialogue, remove the check from the Visible check box

4. Click OK to view only the Layout level and the Sketch2 level.

As a rule all layers will be displayed. To view a particular layer, deactivate the Visible field on all the other layers.

After completing the drawing, save and/or print the document as needed.

Note: Visualize layers as transparent sheets, one on top of the other, which together form a complete picture. It is also possible to view individual "transparencies", i.e. Layers.

Using One colour per Layer

If more than one layer at a time is displayed, apply an identical colour to all elements on the same layer for a better overview.
Chapter 7: Databases and Data Sources

Data sources of various types may be registered in OpenOffice.org.

Registering a Data Source

To register a data source for viewing and/or editing in OpenOffice.org, select Tools > Data Sources. This command opens the Data Source Administration dialogue, and is described in detail in Help.

![Data Source Administration dialogue]

To continue registering a data source in OpenOffice.org, click New Data Source in the top left corner of the dialogue. Then choose the type of data source in the Database type pull-down list.

Select from the following database types (depending on the operating system):

<table>
<thead>
<tr>
<th>Database type</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adabas</td>
<td>A slightly scaled-down version of the well-known relational database system. Adabas is installed with its own setup program. (See <a href="http://www.softwareag.com/adabas/">http://www.softwareag.com/adabas/</a>)</td>
</tr>
<tr>
<td>JDBC</td>
<td>Link to databases contacted via a JDBC driver.</td>
</tr>
<tr>
<td>ODBC</td>
<td>Link to databases contacted via an ODBC driver.</td>
</tr>
<tr>
<td>dBase</td>
<td>files can be edited directly with the driver for direct access in the file system.</td>
</tr>
<tr>
<td>ADO</td>
<td>Link to databases contacted via the ADO driver.</td>
</tr>
<tr>
<td>Text</td>
<td>Register text files, such as comma-separated CSV files (read-only).</td>
</tr>
<tr>
<td>Spreadsheet</td>
<td>One can register OpenOffice.org Calc and MS Excel spreadsheets (read-only).</td>
</tr>
<tr>
<td>Address Book</td>
<td>This address book driver allows the user to register the system address book or another address book source (read-only). It also ensures that data fields are correctly assigned to the templates provided with OpenOffice.org, in form letters, for example.</td>
</tr>
</tbody>
</table>
How to register a new data source of a particular database type is explained in Help. Use the data source icon on the Main Toolbar or select View > Data Sources to view and, if necessary, edit the data sources via spreadsheets and queries. At the upper edge is a window which can be shown or hidden, moved around and/or docked to another edge.

In the Data Sources view, on the left is the Data Sources Explorer and, on the right, the table view.

In the Data Sources Explorer on the left open a data source by clicking the plus sign in front of its name. This opens the subordinate “containers” for links, queries and tables. When a query or table is clicked, its contents appear in the table view on the right.

One can create new tables, queries and links by clicking the relevant entry in the Data Sources Explorer and right-clicking with the mouse to open the context menu.
**AddressBooks**

**Registering an AddressBook**

One of the many data sources in OpenOffice.org is an external addressbook. The contents of the data fields are then available, in fields and controls for example. An address book which may be already in use in the system environment is such a data source. For example, an LDAP server, Evolution or a Mozilla/Netscape address book.

In the templates and AutoPilots from OpenOffice.org, fields are used for the contents of the addressbook. When these fields are activated, the general fields used in the templates are automatically replaced with the actual fields used in the local system.

In order to call the dialogue by following the steps listed below.

**Using the AutoPilot to import an AddressBook**

Select **File > AutoPilot > Address Data Source**. This AutoPilot is described in **Help**.

**Manually Registering an Existing Address Book**

1. Choose **File > Templates > Address Book Source**. The **Templates: Address Book Assignment** dialogue appears.

![Templates: Address Book Assignment](image)

2. In the **Data source** box, select the system address book or the data source to use as the address book.

   If the system address book is not yet registered in OpenOffice.org as a data source, click the **Administratate** button. This opens the **Administratate Data Sources** dialogue, in which the address book can be registered as a new OpenOffice.org data source. Read further how to do this in the next section, **System address book as data source**.

---

**Chapter 7: Databases and Data Sources**
3. In the **Table** box, select the database table to use as the address book.

4. Under **Field assignment**, set the fields for company, department, first name, et cetera to the actual field names used in the address book.

5. After this point, the addressbook is recognized as an OpenOffice.org address book data source.
System Address Book as Data Source

1. Select File > Templates > Address Book Source.

2. Click the Administrate button to call the Data Source Administration dialogue (see also instructions above). Another way to call the same dialogue is to choose Tools > Data Sources.

3. Click the New data source button.
4. Under **Database type** choose the **Address book** entry.
5. Click the **Data Source** button to call the **Data Source** dialogue.

![Data Source Dialogue]

6. Select the data source.
7. Click **OK**.

   If “LDAP address book” is selected, the **Data Source Administration** dialogue will display a **LDAP** tab page, where one can enter the LDAP server and its parameters.

8. Go to the **Tables** tab page. Check the tables that should be visible in OpenOffice.org.
9. On the **General** tab page, enter a name for this data source in the **Name** box.
10. Close the dialogue by clicking **OK**.
Importing Data Into OpenOffice.org

If one is exchanging data with a database that does not have an ODBC link and which does not allow dBase import and export, it is often possible to exchange the data via a common text format.

Importing and Exporting Data in Text Format

To exchange data in a text format use the Calc import/export filter.

1. Export the desired data from the source database in a text format. The CSV text format is highly recommended since it separates data fields by using commas and records by inserting line breaks.

2. Open the data with the “Text CSV” file filter. Select this file filter in the Open dialogue in the Files of type list box. Select the file and click Open.

3. This displays the Import text files dialogue. Here users can decide which data to include from the text document.

Once the data is in a Calc spreadsheet, it can be edited as desired. Users have two ways of saving the data in a OpenOffice.org data source:

- Save the current OpenOffice.org Calc spreadsheet in dBase format in the folder of a dBase database. To do this, choose File > Save As, then select the File Type “dBase” and the folder of the dBase database.
- Check the data range in the OpenOffice.org Calc spreadsheet and drag the area into a table container in the data source view. The table container is the area on the left of the database explorer that is designated “Tables” (see diagram). An AutoPilot is started automatically.

Exporting in CSV Text Format

The current Calc spreadsheet can be exported in a text format which can be read by many other applications.

1. Choose File > Save as.

2. In Save as type select the filter “Text CSV”.

3. Enter a file name.

4. Click Save.
5. This opens the **Export of text files** dialogue, in which to select the character set, field delimiter and text delimiter.

6. Click **OK**. A warning informs users that only the active sheet was saved.
Database Tables

This section describes how to create a new database table via the OpenOffice.org design view.

Table Design

Open the data source browser (F4). Open a data source by clicking the plus sign in front of the name. The tables container, called “Tables” can now be seen. Open the table container and click a table. Right-click the table name to open the context menu. Choose New Table Design to create a new table.

In the Design view, create the fields for the table.

- Enter new fields from top to bottom row-by-row. Click the cell at the far left and enter a field name for each data field.
- In the adjacent cell to the right, define the field type. When one clicks in the cell, a field type can be selected from the drop down list box

**Note:** Each field can only accept data corresponding to the specified field type. It is not possible to enter text, for example, in a number field. Memo fields in dBase III format are references to internally-managed text files which can hold up to 64KB text.

If the user wishes, an optional Description for each field can also be entered. The text of the description will appear as a tip on the column headings in the table view.
Field Properties
Enter properties for each selected data field. Depending on the database type, it is possible that not all input facilities will be available.

In the Default box, enter the contents that should be entered for every new record. This can, of course, be subsequently modified.

In the Entry required box, specify whether or not the field may remain empty.

No matter which field type, a list box provides the available types

Note: To change the name or type of a data field after-the-fact, please note that the table itself may not be opened during this modification; only the design view may be opened.
Form Design

Any OpenOffice.org document can be expanded into a form. One simply adds one or more form functions.

The Form icon on the main toolbar opens a floating toolbar by long clicking the icon. This floating toolbar contains the basic functions to edit a form. One will find again many of these functions in the object bar if a form element is elected in the document.

If one clicks a form element in the editing mode, Object bar, Format menu commands and context menus offer context-sensitive editing functions. In the form design, the designer can include controls, Apply properties to them, define Form properties and Define subforms.

The Form Navigator is useful in designing a form. Click the icon on the object bar or the floating toolbar.

Clicking the Open in Design Mode icon controls whether the form document can be saved such that it always opens in editing mode or not.

If an error is received when assigning the properties for the objects contained in the form (for example, when assigning a non-existent database table to an object), a corresponding error message will be seen. This error message can have an More button. If one clicks More, then a dialogue displaying clear information, warnings and errors about the current problem is displayed.
Searching in Tables and Form Documents

In spreadsheets and documents in which form functions are used, one can click the Find Record icon to open a dialogue to find any text and values. Use the icon at the bottom of the form bar, not the similar looking icon on the main toolbar on the left.

Searches may be in all data records or in all data fields. Select whether the text must be at the beginning, end or any location of the data field. The ? and * wildcards can also be used, as in the Find and Replace dialogue. Additional information about the database search function can be found in Help.

Searching With a Form Filter
1. Open a form.

2. Switch on the design mode.

   For example, open an empty text document and press F4, open the bibliography database table biblio in the data source view. While pressing Shift+Ctrl, drag a few column headers into the document so that the form fields are created there.

3. Turn off the design mode. To do this, open the Form Functions floating toolbar and click the Design Mode on/off icon, so that it does not appear to be pressed.

4. On the form toolbar, click the Form-based filters icon. The current document is displayed with its inserted form functions as an empty edit mask. At the bottom edge will be the filter bar.

5. Enter the filter conditions into one or several fields.

When formulating filter conditions, various operators and commands are available. Apart from the relational operators there are SQL-specific commands that query the content of database fields. If these commands are used, in the OpenOffice.org syntax, OpenOffice.org automatically converts these into the corresponding SQL syntax. SQL commands can also be entered directly. The following tables give an overview of the operators and commands:

Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
<th>Condition is satisfied if...</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>equal to</td>
<td>... the content of the field is identical to the specified expression. The operator = will not be displayed in the query fields. If a value without any operator is entered, the operator = will be automatically adopted.</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>not equal to</td>
<td>... the content of the field does not correspond to the specified expression.</td>
</tr>
<tr>
<td>&gt;</td>
<td>greater than</td>
<td>... the content of the field is greater than the specified expression.</td>
</tr>
<tr>
<td>&lt;</td>
<td>less than</td>
<td>... the content of the field is less than the specified expression.</td>
</tr>
</tbody>
</table>
### Operator | Meaning | Condition is satisfied if...
---|---|---
`>=` | greater than or equal to | ... the content of the field is greater than or equal to the specified expression.
`<=` | less than or equal to | ... the content of the field is less than or equal to the specified expression.

### Commands

<table>
<thead>
<tr>
<th>OpenOffice.org command</th>
<th>SQL command</th>
<th>Meaning</th>
<th>Condition is satisfied if...</th>
</tr>
</thead>
</table>
| IS EMPTY | IS NULL | is null | ... The field name is empty. For Yes/No fields with three states, this command automatically queries the undetermined state (neither Yes nor No).
<p>| IS NOT EMPTY | IS NOT NULL | is not empty | ... the field name is not empty. |
| LIKE (placeholder * for any number of characters placeholder ? for exactly one character) | LIKE (% placeholder for any number of characters Placeholder _ for exactly one character) | is an element of | ... the data field contains the indicated expression. The (<em>) placeholder indicates whether the expression x occurs at the beginning of (x</em>), at the end of (<em>x) or inside the field content (<em>x</em>). Either the SQL % character or the familiar (</em>) file system placeholder can be entered as a placeholder in SQL queries in the $[officename$] interface. The * or % placeholder stands for any number of characters. The question mark (?) in the $[officename$] interface or the underscore (_) in SQL queries is used to represent exactly one character. |
| NOT LIKE | NOT LIKE | is not an element of | ... the field name does not contain the specified expression. |
| BETWEEN x AND y | BETWEEN x AND y | falls within the interval [x,y] | ... the field name contains a value that lies between the two values x and y. |
| NOT BETWEEN x AND y | NOT BETWEEN x AND y | Does not fall within the interval [x,y] | ... the field name contains a value that does not lie between the two values x and y. |
| IN (a; b; c,...) Note that the semicolons are used as separators in all value lists! | IN (a, b, c,...) | contains a, b, c,... | ... the field name contains one of the specified expressions a, b, c,... Any number of expressions can be specified, and the result of the query is determined by an Or link. The expressions a, b, c,... can be either numbers or characters |
| NOT IN (a; b; c...) | NOT IN (a, b, c,...) | does not contain a, b, c... | ... the field name does not contain one of the specified expressions a, b, c,... |</p>
<table>
<thead>
<tr>
<th>OpenOffice.org command</th>
<th>SQL command</th>
<th>Meaning</th>
<th>Condition is satisfied if...</th>
</tr>
</thead>
<tbody>
<tr>
<td>= TRUE</td>
<td>= TRUE</td>
<td>has the value True</td>
<td>... the field name has the value True.</td>
</tr>
<tr>
<td>= FALSE</td>
<td>= FALSE</td>
<td>has the value false</td>
<td>... the field name has the value false.</td>
</tr>
</tbody>
</table>
Examples of Usage

<table>
<thead>
<tr>
<th>Command/Operator</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>= 'Ms.'</td>
<td>returns field names with the field content “Ms.”</td>
</tr>
<tr>
<td>LIKE 'H?llo'</td>
<td>returns field names with field content such as “give” and “gave”</td>
</tr>
<tr>
<td>LIKE 'S*'</td>
<td>returns data fields with field contents such as “Sun”.</td>
</tr>
<tr>
<td>BETWEEN 10 AND 20</td>
<td>returns field names with field content between the values 10 and 20. (The fields can be either text fields or number fields)</td>
</tr>
<tr>
<td>IN(1; 3; 5; 7)</td>
<td>returns field names with the values 1, 3, 5, 7. If the field name contains an item number, for example, create a query that returns the item having the specified number.</td>
</tr>
<tr>
<td>NOT IN ('Smith')</td>
<td>returns field names that do not contain “Smith”.</td>
</tr>
</tbody>
</table>

Remarks about possible wildcards and operators can be found in the Help > Contents > Index > Search term > queries; designing. If filter conditions are entered into several fields they will be joined by the Boolean AND.

If on the filter bar, the Apply filter icon is clicked, the filtering is performed in the database. The form bar is seen and the habitats navigated. By clicking the Close button in the filter bar, the form will be displayed without a filter.

In the form view, click the Apply Filter icon to change to the filtered view.

The filters that have been set can be removed by clicking on the icon Remove Filter/Sort.

If several filter conditions are to be connected with OR, click the Filter Navigation icon on the filter bar. The dockable Filter Navigator window appears.

The filter conditions that are set appear in the Filter Navigator. As soon as a filter is set, at the bottom of the Filter Navigator notice a blank filter level in which “Or” can be selected by clicking on it. Once the blank filter level is selected, enter other filter conditions in the form. These conditions are linked by Boolean OR to the previously defined conditions.

The context menu can be called for every entry in the Filter Navigator. Edit the filter conditions in this area directly as text. In addition users can also select the filter conditions (SQL: “Is Null” or (SQL: “Is not Null”) to check if a field has content or not. It is also possible to delete the entry by using the context menu.

Filter conditions can also be moved within a form in the Filter Navigator by Drag&Drop or copy them by holding down the Ctrl Key.
While designing a form, set the “Filter proposal” property for each text box in the **Data** tab of the corresponding Properties dialogue. These fields allow subsequent searches in the filter mode, selections via a pull-down list all the summarized information contained in such fields. The field contents can also be easily selected using the AutoComplete function. Please note however, that this function requires a lot of memory space especially when used in large databases and should, therefore, be used sparingly.
Chapter 8: Customizing OpenOffice.org

Use this section as a guide on customizing the user interface of OpenOffice.org. This should be mainly of interest to advanced users of OpenOffice.org.

Modifying and Customizing the User Interface of OpenOffice.org

There is much freedom in configuring menus, toolbars and keys to suit personal preferences. One is free to change:

- Items on the menu bar. These can be deleted, new ones added, copied from one menu to another, renamed, and so on.
- Toolbar configuration. These may be freely configured to suit. Under Windows®, icons may even be dragged and dropped while holding down the Alt key to change toolbar appearance.
- Shortcut keys as desired.

To make configuration changes, select Tools > Configure to open the Configuration dialogue. Help also provides much useful guidance for configuring OpenOffice.org.

Configuring the Keyboard

In most instances, one configures new keyboard shortcuts to enable a macro to perform a certain action on a document. Other actions can also be given a shortcut; for example, adding all unknown words in a text document to the active user dictionary with a single command to shortcut keys or to a separate icon. The following procedure is a simple example which illustrates how to enable a keyboard shortcut that gives this capability to OpenOffice.org:

1. First ensure that the following conditions exist:
   - A user-defined dictionary is active.
   - The language of the dictionary has to be set up on “All”.
   - The dictionary file is not a read-only file.

2. Open a text document.


4. Select the Keyboard tab to specify a key combination.

5. Search for an available key combination in the Keyboard list box such as F4.

6. Click Modify

7. Select Category > Options area at the lower left of the Keyboard tab,

8. select the Adding unknown words function next to it.

9. close the dialogue with OK.
Now, by pressing the F4 key or whatever shortcut keys were selected, one can start a spellcheck of the current text document, automatically placing all unknown words in an active user-defined dictionary.

**Configuring Menus**

Configuring a menu item is similar to configuring a keyboard shortcut as shown above. The step-by-step procedure that follows should help in setting up a new menu item, in this case, the extendedPDF macro from oomacros.org. While OpenOffice.org modules include pdf export commands, these do not allow HTML links; thus it may be convenient to add this feature.

This procedure will work only if there is an installed extendedPDF macro. The following explains how to integrate extendedPDF commands into the File menu.

**Note:** Installing the extendedPDF macro is covered by the macro document itself.

1. Open a document.

2. Choose **Tools > Configure** to open the Configuration dialogue.

3. Click the **Menu** tab.
4. In the large list box, scroll to find the command in which to integrate the new extendedPDF command (e.g., “Export”) and select it.

5. Locate in the Functions menu, the category and function to add. In this case this would be found in the category, OpenOffice.org Basic Macros > extendedPDF and the Function would be extendedPDF.

6. Click New. The new menu command is inserted in the large list box.

7. The order of the items by moving the names to the large list box using Drag&Drop.

8. Click OK to close the Configure dialogue. OpenOffice.org automatically saves the changes.

The new menu items should now be available.

**Changing Toolbars**

- To copy an icon, say from an object bar to the function bar, so that it is always visible, simply hold down the Alt key and drag the icon to its new location. OpenOffice.org automatically remembers the configuration of the toolbars.

- To delete an icon, hold down the Alt key while dragging it out of its toolbar and drop it outside of the toolbars.

- To have a separating dash on the toolbar, drag an icon slightly to the right while holding down the Alt key.

- To delete a separating dash, drag the icon to the right of the separating dash slightly to the left while holding down the Alt key.

The context menu of a toolbars contains a Visible Buttons command. This opens a submenu with a list of predefined icons. Icons with check marks beside them are visible on the selected toolbar. Click on an item to switch the icon from visible to hidden and vice versa.

The Visible buttons command in the context menu of the toolbars may also be used to have a quick overview of the icon names and their functions.

**Inserting, Moving and Deleting Icons on Toolbars**

1. Open a document of the type which has the toolbar to modify. For example, to modify the text object bar for all text documents, open a text document, and then do the same for the other document types.

2. Open the context menu of the toolbar and select the Edit command.

3. At the bottom of the dialogue select the desired function category and the function.

4. If no suitable icon is displayed for this function, click Icon... and select an appropriate icon. Confirm with OK.

5. Now drag the selected icon out of the dialogue while keeping the mouse button pressed and drop it on the toolbar. Release the mouse where the new icon is to be located.

6. Close the dialogue.
7. On a Windows® system only, to move this icon to a new position, drag it to the new position while keeping the Alt key pressed.

8. Again for Windows® only, to remove an icon from a toolbar, drag it out of the toolbar while keeping the Alt key pressed.

If the toolbar is to be docked with another border, proceed as follows:

1. Hold the Ctrl key down and double-click a gray area of the toolbar to open the toolbar as a floating window.

2. Drag the toolbar to its new position. If the mouse key is released while holding down the Ctrl key, and if the toolbar is also over a window border, the toolbar will dock with the window border.

**Changing Icon Views**

Icon views can be changed between two choices, flat icons and 3D icons.

1. Choose **Tools > Options > OpenOffice.org**.

2. In the View register uncheck **Flat buttons**.

3. Click OK to confirm the new settings and close the dialogue.

The **Flat buttons** check box switches between flat and 3D view. The **Large buttons** check box switches between large and small icons.
Changing the Look of the User Interface

OpenOffice.org has different ways of display that reflect different operating systems. Thus, the user can change the windows and dialogues to suit personal taste:

Choose Tools > Options > OpenOffice.org > View. In the Look & Feel combo box, choose an appearance reminiscent of Macintosh, XWindows® or OS/2. The “Standard” setting has the familiar look of a Microsoft Windows® application.

Selecting Measurement Units

One can select separate measurement units for Writer, Writer/Web, Calc, Impress and Draw documents.

1. Select Tools > Options.
2. Click on the document type that is to have its measurement unit changed. For example, click on Text Document to select the measurement unit for Writer.
3. Click on General.
4. On the General tab page, under Settings, is a combo box for selecting the measurement unit.
5. Close the dialogue with OK.

Moving, Deleting or Copying Icons

- To move an icon keep the Alt key pressed and drag the icon to its new position. It will be moved within the same toolbar and copied between toolbars.
- To delete an icon from a toolbar, keep the Alt key pressed and drag the icon to a place where there is no toolbar.
- To insert or delete a dash, drag the icon in the same way to the side.
Sending Faxes and Configuring OpenOffice.org for Faxing

To send a fax directly from OpenOffice.org, both a fax modem and a fax driver that allows applications to communicate with the fax modem must be installed as they would with a printer.

Sending a Fax via dialogue

Print the current document with the fax machine as a printer:

1. Open the **Print** dialogue by choosing **File > Print** and select the fax driver in the **Name** pull-down list.
2. Clicking **OK** opens the dialogue of the fax driver where one enters the fax recipient.

Configuring OpenOffice.org for Faxing via Icon

OpenOffice.org can be configured for faxing such a way that a single click on an icon is sufficient to send a fax:

1. Choose **Tools > Options > Text Document > Print**.
2. Select the installed fax driver from the **Fax** pull-down list.
3. Click **OK**.
4. Open the context menu on the function bar and click **Visible Buttons** to see a list of immediately configurable buttons for this toolbar. All buttons that are currently visible have a check mark.
5. In the context menu, click to mark the **Send Standard Fax** button. The button is now visible on the function bar. By clicking on it, the fax driver entered in step 2, is activated to send the current document.
Further Information

OpenOffice.org can be configured in other ways. However these require programming skills that are beyond the scope of this document. For information on this type of configuration, See http://documentation.openoffice.org.
Chapter 9: Advanced Techniques

This contains topics of interest to advanced users of OpenOffice.org including information on revision marking function (redlining) in Writer and Calc.

Copying and Moving Data Using Drag and Drop

The easiest and often most intuitive way to copy and move data in OpenOffice.org is by dragging and dropping with the mouse.

Dragging and Dropping Within a OpenOffice.org Document

There are many options for moving or copying objects using drag and drop. Selected text, text areas, draw objects, graphics, buttons and other form functions, hyperlinks, table areas and many more can be moved with the mouse.

Pay attention when dragging using the mouse pointer. The mouse pointer shows a plus sign when copying and an arrow when making a link or hyperlink.

<table>
<thead>
<tr>
<th>Mouse Pointer Shape</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image.png" alt="Image" /></td>
<td>Moving</td>
</tr>
<tr>
<td><img src="image.png" alt="Image" /></td>
<td>Copying</td>
</tr>
<tr>
<td><img src="image.png" alt="Image" /></td>
<td>Creating a link</td>
</tr>
</tbody>
</table>

Pressing Ctrl or Shift+Ctrl when releasing the mouse button, usually influences whether the item is copied, moved, or a link is created. Drag objects out of the Navigator; in the submenu of the Drag Mode icon, specify whether to copy the object, insert it as a link or insert it as a hyperlink. Drag and drop operations in OpenOffice.org can be cancelled at any time by pressing the Esc key before releasing the mouse button.

Inserting Objects From the Gallery

Objects can be inserted in a document as either a copy or as a link. A copy of an object is independent of the original object. Changes to the original object have no effect on the copy. Links, on the other hand, remain dependent on the original object; thus, changes to the original object are also reflected in the link.

**Inserting an object as a copy**

1. Open the Gallery.
2. Choose a theme from the left area.
3. Select the object by a single click.
4. Drag the object into the document or right-click to open the context menu and select **Insert** and **Copy**.

**Inserting an object as a link**
1. Open the Gallery.
2. Choose a theme from the left area.
3. Select the object by a single click.
4. Drag the object into the document while pressing the **Shift** and **Ctrl** keys, or right-click to open the context menu and select **Insert** and **Link**.

**Inserting an object as a background graphic**
1. Open the Gallery.
2. Choose a theme from the left area.
3. Select the object by a single click.
4. Open the context menu and choose **Insert > Background > Page** or **Paragraph**.

**Inserting an object as a texture (pattern) for another object**
1. Open the Gallery.
2. Choose a theme from the left area.
3. Select the object by a single click.
4. Drag the object on to the other object in the document while pressing **Ctrl**.

**Copying Graphics From the Gallery**
Graphics, dragged from the Gallery, are inserted into a text, spreadsheet or presentation document where they are dropped.

If the graphic is released directly on a draw object, please note the following:

- If it is moved, by dragging without pressing any key (no additional symbol appears next to the mouse pointer), only the font attributes are copied from the graphic and applied to the draw object where the mouse button is released.
- If it is copied by dragging while holding down the **Ctrl** key (a plus sign appears next to the mouse pointer), the graphic is inserted as an object.
- If a hyperlink is created, by dragging while holding down **Shift+Ctrl** (a linking arrow appears next to the mouse pointer), the drawing object is replaced by the graphic from the Gallery; however, the position and size of the replaced draw object are retained.

**Inserting Graphics From a Document in the Gallery**
Graphics, from HTML pages and other similar sources, can be placed in the Gallery by drag-and-drop.
1. Display the Gallery theme to which to add the graphic.
2. Position the mouse pointer above the graphic, without clicking.
3. If the mouse pointer changes to a hand symbol, the graphic refers to a hyperlink. In this case, click the graphic while pressing the \texttt{Alt} key to select it without executing the respective link.

   However, if the mouse pointer does not change to a hand symbol, simply click the graphic to select it.
4. Once the graphic is selected, release the mouse button.
5. Click again on the graphic image, keeping the mouse button pressed for more than two seconds, to copy the graphic image to memory.
6. Without releasing the mouse button, drag the graphic into the Gallery.

\textbf{Note:} Draw objects that are created using the \textbf{Draw functions} floating toolbar, cannot be incorporated in the gallery.

\section*{Copying Graphics Between Documents}

Graphics can be copied from one document to another.

\textbf{Note:} If the document is to be published, please observe copyright laws and, for safety, obtain the consent of the authors of the original.

1. Open the document in which to insert the graphic object.
2. Open the document from to copy the graphic.
3. Click the graphic to select it.
4. Right-click to open the context menu or use \texttt{Ctrl+C}
5. Select \texttt{Copy} to place the graphic into the clipboard.
6. Bring the target document into focus.
7. Select the location for the graphic.
8. Right-click to open the context menu and select \texttt{Paste} at the position where to insert a copy of the picture or use \texttt{Ctrl+V}.
9. If the graphic is connected with a hyperlink, the hyperlink and not the graphic is inserted.

\section*{Copying Draw Objects into Other Documents}

In OpenOffice.org it is possible to directly copy draw objects between text, spreadsheets and presentation documents.

1. Select the draw object or objects.
2. Copy the draw object to the clipboard by using \texttt{Ctrl+C} or by right-clicking to open the context menu and selecting \texttt{Copy}.
3. Switch to the other document and place the cursor at which to insert the draw object.
4. Insert the draw object at the target position by using Ctrl+V or use the Paste command from the context menu.

**Inserting a Draw object in a text document**

An inserted draw object is anchored in a text document at the current paragraph. Anchors can be changes by selecting the object and clicking on the Change Anchor icon on the object bar. This opens a popup menu that permits changing the possible types of anchor.

**Inserting a Draw object in a spreadsheet**

An inserted draw object is anchored to a spreadsheet in the current cell. Change the anchor between cell and page and back by selecting the object and clicking on the Change Anchor on the object bar.
Drag and Drop With the Data Source View

The simplest and quickest way of transferring data from a data source into a text or spreadsheet document, or creating forms based on a data source, is the drag-and-drop method.

Copying with Drag&Drop

To reverse a mistake made during a drag and drop operation, position the cursor in the document and choose the **Undo** command from the **Edit** menu (or via the keyboard).

**Note:** *Copying by drag and drop is possible in the both directions:*

- A text table or a selected range of a spreadsheet can be dragged using drag and drop to a table container in the data source explorer or vice versa.
- Likewise, simpler text can be copied using drag and drop from one document to a data field in the data source view. Read up on how this happens in **Help.**

Using data in a text document

A database field can be inserted in a text document by dragging a field name from the column header of the data source view into the document. This inserts a field for this database field in the document. This is especially useful when designing form letters. Simply drag the desired fields, such as, home address, form of address et cetera, into the document.

The best way to insert a complete record is to select the corresponding header and drag it into the document. When the mouse button is released, the **Insert database columns** dialogue appears, where one can decide whether to use all database fields, and whether to copy the data into the document as text, a table or fields. All currently selected records will be inserted.

Applying data to a table document

One or more records can be inserted into the current sheet of a spreadsheet by selecting the rows in the data source view and dragging and dropping them into the spreadsheet. The data is inserted in the place where the mouse button is released.

Inserting controls in a text form

When a text form, linked to a database, is created, one can generate controls by drag-and-drop from the data source view: When a database column is dragged into the text document, a field is inserted. By holding down Shift+Ctrl while dragging, a text field is inserted, grouped with an appropriate label field. The text field already contains all the database information that is needed for the form.
Copying Sheet Areas to Text Documents

1. Open both the text document and the spreadsheet.
2. Select the sheet area to copy.
3. Point to the selected area and press the mouse button. Keep the mouse button pressed for a moment, then drag the area into the text document.
   If the documents are not visible next to each other, first drag the mouse pointer to the destination document button. Continue to hold down the mouse button. The document addressed in this way is displayed, and the mouse pointer can be moved within the document.
4. Once the cursor is located in the place where to insert the sheet area, release the mouse button. The sheet area is inserted as an OLE object.

Select and edit this OLE object at any time.

a) To edit the OLE object, simply double-click on it.
   Alternatively, select the object and choose Edit > Object > Edit or choose Edit from the context menu. The object can be edited in its own frame within the text document, but the icons and menu commands needed for spreadsheets are visible.

b) Choose Open to open the source document of the OLE object.

Inserting Data From Spreadsheets

- When copying the contents of a cell (text or numbers), using the clipboard is best. Copying formulas that are in the cells into the clipboard, such as from the input lines of the formula bar, is also possible; thus, they can now be inserted into the text.
- To copy a simple, rectangular area of cells into a text document as a sheet, select the cells in the sheet and then use either the clipboard or drag & drop to insert them into the text document. This will be an OLE object in the text document that can edited.
- If cells are dragged to the character view of a presentation document, they will also reappear there as OLE objects. Once dragged into the outline view, each cell will form a line of the outline view. Dragging using drag-and-drop will move the cells. Press the Shift key, when dragging, create a copy.

Inserting Data From Text Documents

Text can be transferred into other document types such as spreadsheets and presentations but, there is a distinction made that depends on whether the text should be set in its own text frame, transferred into a spreadsheet cell or transferred into the structure of a presentation.

- If text is transferred via the clipboard, one can paste it to the destination with or without text attributes. Use the shortcut keys Ctrl+C to copy and Ctrl+V to paste.
  To select the format in which the clipboard contents will be pasted, do a long click on the Paste icon on the function bar. Select the format from the submenu.
- To obtain a selection of formats, choose Edit > Paste Special.
• In a text document use File > Send > Outline to presentation to create a new presentation document that contains the headings from the text document as the outline. The headings must be formatted with a corresponding Paragraph Style before the user can see this command.

• To transfer the same headings to the first superordinate paragraph (or several paragraphs) of the text, select the AutoAbstract to presentation command. Again, the headings must be formatted with a corresponding Paragraph Style before the user can see this command.

**Copying Text Using Drag and Drop**

• If one selects a text section and drags it into a spreadsheet with drag & drop, it will be then be inserted as text into the cell where the mouse is released.

• When a text section is dragged to the character view of a presentation, an OLE object is inserted as a OpenOffice.org plug-in.

• If text is dragged to the outline view of a presentation, it is inserted at the point where the cursor is positioned.
Revision Marking Function

The revision marking function in Writer and Calc highlights changes to documents so that whomever is editing the file can see who changed what and when.

Recording and Displaying Changes

When several authors are working on the same text or spreadsheet, the review function (marking changes, redlining) makes it possible to document who made which changes, so that this is clear to everyone. On the final edit of the document, it is then possible to look at each individual change and decide whether it should be accepted or rejected.

For purposes of illustration, imagine you, the reader, are delivering a report. Now, before publication, the report must be read by the senior editor and the proofreader, and both will add their changes. Perhaps the senior editor writes *clarify* after one paragraph and crosses out another entirely. The proofreader checks the spelling of your document and notes two cases where explicit references to the gender of an imaginary person could be reworded to avoid gender entirely. The edited document comes back to you, and you can choose to incorporate or ignore the suggestions of the two reviewers. Plus, you also e-mailed a copy of the report to a good friend and colleague who has done research on a similar topic in the past, asking for a few suggestions, and the document is now returned by e-mail with your colleague's suggestions. It is now a simple matter to produce a final version of the document from the results you get back.
Accepting or Rejecting Changes
When bringing a document in which others have noted their changes back together again, the user can accept or reject the changes individually or all together.

- If one has put multiple copies of the document in circulation, first of all, merge these into one document (see Merging Versions).
- Open the document and choose Edit > Changes > Accept or Reject. The Accept or Reject Changes dialog appears.
- Select a change on the List tab. The change is selected and displayed in the document and now the users makes a decision with one of the dialog buttons.

If one author has changed another author's change, one will see the changes hierarchically arranged with a plus sign for opening up the hierarchy.

When the list of changes is too long or confusing, switch to the Filter tab in the dialog and specify only the changes of certain authors, or only the changes of the last day, or that the list should be restricted in some other way.

Changes can also be filtered by the descriptions. Wildcards (as with regular expressions in the Find & Replace dialog) are permitted when entering the filter.

Text document changes that have not yet been accepted are displayed in the list. Changes that have been accepted are removed from the list and appear in the text without any further marking.

Spreadsheet changes that have been accepted are combined in the list in a single entry, so that one can continue to see which changes have already been accepted.

colour-coded entries inform the user about the result of the filter that is set. Entries in black can be accepted or rejected and match the filter criteria. Entries in blue do not, themselves, match the filter criteria but have subentries that are included by the filter. Grayed entries cannot be accepted or rejected and do not match the filter criterion. Green entries do match the filter but in spite of this cannot be accepted or rejected.
Comparing Versions of a Document

Perhaps one of the authors who received a copy of the document made changes but did not record them by choosing Edit > Changes > Record. Nonetheless, the delivered copy of the document can be compared with the original document.

1. Open the original document and then choose Edit > Compare Document.
2. From the file selection dialogue, select the copy of the document.
3. Confirm the dialogue.

Now OpenOffice.org combines both documents in the original document. All text passages that occur in the document but not in the copy are identified as having been inserted, and all text passages that are missing in the original document are identified as deletions.

Now start the revision process by accepting the “insertions”, in which case the relevant texts stay in their original form, or accepting the “deletions”, in which case the marked text contained in the copy are not inserted in the document.

Merging Versions

It is not always one and the same document that is edited by different authors and passed from one to the next author. It often makes more sense to give a separate copy of the document to each author. For example, three copies are returned in addition to the original document, with different changes in each copy.

It is easy to merge these documents into the original. The only requirement is that the documents differ only and exclusively in the recorded changes. In other words, all “normal” text must be identical.

1. Open the original document into which to merge all the copies.
2. Select Edit > Changes > Merge Document.... This opens a typical file selection dialogue from which to choose a copy of the document.
3. After merging the documents, the designated changes from the copy in the original document will be visible.

Recording Changes

The review function is available in OpenOffice.org for both text documents and spreadsheet documents. Not all changes are recorded (for example, the changing of a tab stop from align left to align right is not recorded). However, all usual changes made by a proofreader are recorded, such as additions, deletions, text alterations, usual formatting et cetera.

1. To start Revision Marking, open the document to be edited and choose Edit > Changes and click Record which display a check mark when enabled.
2. Now start making any changes. Note that all new text passages entered are underlined in colour, while all deleted text remains visible but is crossed out and shown in colour.
3. If a marked change is moved with the mouse pointer, one will see a reference to the type of change, the author, date and time of day for the change in Help Tips. If Extended Tips is also enabled (on the Help menu), any available comments on this change will be displayed.
Changes in a spreadsheet document are highlighted by a border around the cells; when a cell is pointed to more detailed information on this change is seen in Help Tips when Extended Tips is also enabled (on the Help menu).

Comments on each marked change may be entered by placing the cursor in the area of the change and then choosing Edit > Changes > Comment... In addition to Extended Tips, the comment is also displayed in the list in the Accept or Reject Changes dialogue.

To stop recording changes, choose Edit > Changes > Record again to disable the function (The check mark is removed). Now the document can be saved and returned to the person who asked for the changes.

In a text document, highlight all lines that have changed with an additional marking. This can be in the form of a red line in the margin, for example.

Select the type of additional selection under Tools > Options... > Text Document on the Changes tab or under Tools > Options > Spreadsheet on the Changes tab. In these dialogues, determine how and in what colour the changes should be flagged, where on the page the dash should be and so forth.

**Version Management**

The File menu contains a Versions command. The Versions function allows the user to save multiple versions of the same document in the same file. One can choose to view individual versions of a document, or display the differences between versions with colour markings. In the dialogue to open a document, choose which version of the document is wanted for editing from a list box.
Protecting Contents in OpenOffice.org

The following is an overview of the different ways of protecting contents in OpenOffice.org from being modified, deleted or viewed.

Protecting All Documents When Saving
All documents that are saved in XML format (OpenOffice.org Format) can be provided with a password. These documents can no longer be opened without the password. The content is secured, so that it cannot be read with an external editor either. This applies to content, graphics and OLE objects.

Turning on protection
1. Select File > Save As
2. check Save with password.
3. Save the document.

Turning off protection
1. Open the document and enter the correct password.
2. Choose File > Save As and uncheck Save with password.

Information that is entered under File > Properties, such as the name of the author, date created, word and character counts et cetera, are not encrypted.

Protecting Revision Marking
With every change made in Calc and Writer, the review function records who made the change. This function can be turned on with protection, so that it can only be turned off when the correct password is entered. Until then, all changes continue to be recorded and acceptance or rejection is not possible.

Turning on revision protection
1. Choose Edit > Changes > Protect Records.
2. Enter and confirm a password of at least 5 characters.

Turning off revision protection
1. Choose Edit > Changes > Protect Records.
2. Enter the correct password.

Protecting Cell Ranges in Calc
In Calc, protection can be applied to spreadsheets and the whole document. As part of the process, choose whether the cells are protected against accidental changes, whether the formulas can be viewed, whether the cells are visible and/or whether the cells can be printed.

Protection may be password protected, but this is not always necessary. Once a password is assigned a password, protection can only be removed by entering the correct password.
**Note:** Cell protection for cells, setting the *Protected* attribute, is only effective when the whole table is protected. The default condition is that every cell receives the *Protected* attribute. Thus, in cells where the user may make changes, the attribute must be removed selectively for those cells. Once this is done then protect the whole table and save the document.

### Turning on protection

- For cells: Select cell range. Choose *Format > Cells > Cell Protection* tab.  
- For spreadsheets: Choose *Tools > Protect Document > Sheet*.  
- For documents: Choose *Tools > Protect Document > Document*.  
  - Enter and confirm a password of at least 5 characters.

### Turning off protection

- For spreadsheets: Choose *Tools > Protect Document > Sheet*.  
- For documents: Choose *Tools > Protect Document – Document*.  
  - Where a password has been assigned, enter the correct password.

### Protecting Sections in Writer

Any section of a OpenOffice.org Writer text document can be protected against changes with a password.

**Turning on protection**

1. Select the section.  
2. Choose *Insert > Section > Section*,  
3. Under *Write protection* mark the *Protect* and *With password* check boxes. (If the section already exists: *Format > Sections*.)  
4. Enter and confirm a password of at least 5 characters.

**Turning off protection**

1. Choose *Format > Sections > Section*  
2. Under *Write protection*, uncheck *Protect*.  
3. Enter the correct password.

### Protecting Cells in a OpenOffice.org Writer Table

The contents of individual cells of a Writer text table can also be protected from changes.

**Turning on protection**

- Place the cursor in a cell or select cells. Choose *Format > Cell > Protect*.  
- First, ensure that *Tools > Options > Text Document > Formatting Aids > Cursor in protected areas* has *Enable* checked. Place the cursor in the cell or select the cells. Then choose *Format > Cell > Unprotect*.  
- Select the table in the Navigator, open the context menu and select *Table > Unprotect*.  
- Use *Shift+Ctrl+T* to remove protection for the entire current table or all selected tables.
Automatic Protection of Indexes and Tables
Tables of contents, alphabetical indexes and so on that are created automatically in Writer, are automatically protected against accidental changes.

**Turning on protection**
1. Place the cursor in the index/table of contents.
2. From the context menu choose **Edit Index/Table**.
3. On the Index/Table tab page, check **Protected against manual changes**.

**Turning off protection**
1. Ensure that **Tools > Options > Text Document > Formatting Aids > Cursor in protected areas** has **Enable** checked.
2. Place the cursor in the index.
3. From the context menu choose **Edit Index/Table**.
4. On the Index/Table tab page, uncheck **Protected against manual** changes or, in the Navigator, select the index, open the context menu and select **Index > Read-only**.

Protecting frames, graphics and OLE objects
Many objects can be inserted in OpenOffice.org documents. Users can protect the content, position and/or size of inserted graphics. The same applies to frames (in Writer) and OLE objects.

- **Turning on protection**
  For graphics inserted in a document: Choose **Format > Graphics > Options** tab. Under **Protect**, mark **Contents, Position** and/or **Size**.

- **Turning off protection**
  For graphics inserted in a document: Choose **Format > Graphics > Options** tab. Under **Protect**, uncheck as appropriate.

Protecting Drawing Objects and Form Objects
Draw objects, that are inserted in a document using the **Draw Functions** floating toolbar, can be protected from being accidentally moved or changed in size. Likewise, the user can do the same with form objects inserted using the **Form Functions** floating toolbar.

**Turning on protection**
1. Select **Format > Position and Size > Position or Size** tab.
2. Check the **Protect** check box.

**Turning off protection**
1. Choose **Format > Position and Size > Position or Size** tab.
2. Uncheck the **Protect** check box.
Protecting Records

Changes made in a document can be recorded by choosing either Edit > Changes > Record or Edit > Changes > Protect Records. If Protect Records is selected, one must enter the correct password in order to turn off the function or accept or reject changes.

1. Select Protect Records. This opens the Password dialogue.
2. Enter a password consisting of at least 5 characters and confirm it.
3. Click OK.
Changing Defaults and Other Configuration Items

**Saving Configuration With Document**

Users can set a global configuration (so that it applies to all documents of this type), or can connect the configuration to a specific document, which must exist as a file.

1. Load the document to which to connect the configuration or open any document of the same type.

2. Set the configuration. For example, select the toolbars that should be visible or define what is on the toolbars, menus or status bar and so on. All such configuration options are found under **Tools > Configure**.

3. Click **Save...** in the dialogue under **Tools > Configure**. Another dialogue appears from which to save the configuration.

4. In the **File Type** list box, select <All>.

5. In the large list box of the **Save** dialogue, select the file that is to be connected to the configuration.

6. Click **Save**. A prompt appears, asking whether to replace the file or not. This query concerns only the configuration connected to the document, not the “actual” contents of the document.

7. Confirm overwrite.

The configuration is now connected to the active document. Check this by loading the document and choosing **File > Document Template > Organizer** then double-clicking the document.

As soon as one loads or opens this document, the configuration, that was saved with it, becomes active. The global default configuration is restored when another document is loaded or opened that does not contain custom configuration information. Select manual settings at any time by choosing **Tools > Configure** and clicking the **Reset** button.

**Inserting and Editing Tab Stops**

Set a tab stop by clicking on the ruler. Alternatively, a user can set tab stops by choosing **Format > Paragraph**. Both methods affect the current paragraph or all selected paragraphs.

Click the ruler once to set a left-justified tab. Right-click a tab icon on the ruler to see the context menu in which the tab type can be changed.

To set several decimal tabs one after the other, keep clicking the icon to the left of the ruler until the desired tab type is shown, then click on the ruler.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Description:</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Left Tab" /></td>
<td>Setting left tabs</td>
</tr>
<tr>
<td><img src="image" alt="Right Tab" /></td>
<td>Setting right tabs</td>
</tr>
<tr>
<td><img src="image" alt="Decimal Tab" /></td>
<td>Setting decimal tabs</td>
</tr>
<tr>
<td><img src="image" alt="Centered Tab" /></td>
<td>Setting centered tabs</td>
</tr>
</tbody>
</table>
Double-click the ruler to open the **Paragraph** dialogue.

Double-click the white area of the ruler to set one tab. The **Paragraph** dialogue appears with the **Tabs** tab page.

**Note:** To assign tabs directly to a current **Paragraph Style**, open the context menu of that paragraph and choose **Edit Paragraph Style** to call the **Paragraph Style** dialogue where tabs are then entered.

**Moving Tabs on the Ruler**

There are three ways to set tabs:

1. Move individual tab stops on the ruler using the mouse.
2. To move several tab stops on the ruler, press the **Shift** key before clicking a tab. Drag one tab while continuing to press **Shift** to move that tab as well as all the tabs to the right of it. The spacing between those tabs remains the same.
3. Press **Ctrl** instead of **Shift** when dragging a tab on the ruler to move that tab and all the tabs to the right of it. This results in the spacing between those tabs changing proportionally to their distance from the margin.

**Changing the Properties of Tabs**

To change tab type, click the tab to be changed on the ruler, then open the context menu.

**Deleting Tabs**

Deleting a tab with the mouse is easy. Simply hold down the mouse button while dragging the tab outside the ruler.

**Changing the Defaults**

To change the settings of the default tab stops, see the settings in **Tools > Options > (Document Type) > General**. The Context Menu of the ruler toolbar allows changes to the displayed units to centimeters, inches, point, pica et cetera. These changes are only valid until exiting OpenOffice.org, and they only apply to the ruler from which context menu the changes were made. To change the ruler measurement units permanently, choose **Tools > Options > Text Document > General** and change the measurement unit there.
Changing the colour of Text

Click the **Font colour** icon in Writer and other modules, and keep the mouse button pressed to obtain a floating toolbar from which to choose from the range of colours.

![Font colour (Writer)](image)

![Font colour (other modules)](image)

The following applies to all modules (Writer, Calc, Draw, Impress): Select the text that is to take another colour, then click the colour wanted on the floating toolbar.

*Note: Only in Writer: If one confirms the symbol with a short-click while no text is selected, then the mouse pointer changes its appearance and is displayed as a watering can. Use this watering can symbol with the mouse key pressed to drag across a text area. This text area takes the selected colour. The function remains active for as long as the symbol is “pressed”, or until clicked without dragging, or until the **Esc** key is pressed.*

Inserting Landscape pages into a Portrait-oriented Document

1. Open the Stylist (**Format > Stylist** or **F11**)
2. In the Stylist window, click on the **Page Styles** icon (fourth icon from left)
3. The type "Standard" should already be highlighted, hold the right menu button down to see the context menu and choose "**New...**"
4. In the dialog that appears, give the new page style a descriptive name; for example, **Landscape**
5. Click on the **Page** tab and change the page orientation to Landscape by clicking on the corresponding radio button. At the same time, make other changes to the page style, as needed (such as adjusting the margin sizes).
6. Click on **OK**. The new style will appear as one of the style choices.
7. Place the text cursor in the document at the location at which to insert the Landscape page
8. Select **Insert > Manual Break**
9. In the dialog that appears, select **Page Break** and in the **Style list**, select the new page style, e.g. "Landscape";
10. Click **OK**
More on Templates

Changing Default Templates
When a new document is opened using File > New, a blank document appears based on the
default OpenOffice.org template for that document type. Users can edit or modify this
document or replace it with an existing document so that the new document contains
personalized custom format attributes or other contents.

Modifying Default Templates
If there is an existing OpenOffice.org document which is satisfactory, use it. However, this
step is not necessary. However, if one is not what is needed, one can do the following to create
a new template:

1. Open a new, empty document
2. Edit it until it makes a good template. For example, edit the Styles in the Stylist.
3. By way of example, the following describes how to proceed for text documents and these
   steps can be applied for other types of OpenOffice.org documents. Templates, of course,
   can be defined for each OpenOffice.org module.
   a. Now save the document, created in step 2, by choosing File > Templates > Save and
      saving the document in, say, the Default category.
   b. Select File > Templates > Organize.
   c. Double-click Default in the list on the left. This will display the user-defined templates
      in the user/template directory.
   d. Select the template was just saved and open the context menu or open the submenu of
      the Commands button.
   e. Choose Set as default template.

That is all that is needed. The next time a new text document is opened, the new document
will correspond to the template defined as default in step 5 above.

Resetting Default Templates
To reset the modified text template to the original default template, proceed as follows:

1. Select File > Templates > Organize.
2. Open the context menu and choose Reset default template. In the submenu, select the
document type to restore. Thereafter, when a user opens an empty text document, it will
again correspond to the OpenOffice.org default template for text documents.

Using Custom Templates
There are several ways to make work easier by using custom templates. One of the most
important is quick access to the templates. Templates can be stored in different locations in
OpenOffice.org. Opening a new document using a custom template will then differ
accordingly.
New templates saved using **File > Templates > Save** or by selecting the “Template” file type in the “normal” **Save** dialogue. User templates are usually stored in the `<path_to>/OpenOffice.org1.x.x/user/template` directory. The template is made available, anytime, by selecting it in the **New** dialogue (**File > New > From Templates and Documents**). When the template is opened, a new document will be created based on that template.

Remember to update the view of the templates in the dialogue to ensure that newly created templates are visible. In this case, select **File > Templates > Organize** and in the submenu of the **Commands** button, choose **Update**. To modify the template oneself, call this file via **File > Templates > Edit** and then edit it.
Access to servers via WebDAV and FTP protection

Some passwords in OpenOffice.org can be saved. This saving applies according to context and dialogue either for the duration of the current session, or it is permanently stored in a file.

- Passwords are stored permanently for access to WebDAV services and FTP, provided that in the corresponding dialogues the Save password box is checked and a master password is entered.

- If no a master password is entered, the passwords are only saved for the duration of the current OpenOffice.org session.

- If the saving is permanent in a file, the file is protected by the master password.

If, in a new OpenOffice.org session, a user accesses a permanently saved password for the first time, he is automatically asked for the master password. If it is entered correctly, all permanently saved passwords are known and are not asked for again in the current OpenOffice.org session.
Chapter 10: Introducing OpenOffice.org Basic and Macros

OpenOffice.org provides a number of sample macros to help guide the user in programming macros but also to serve as useful aids that can be used immediately. Use these to get an overview of how to write a macro.

These macros are only available in English regardless of the installation language.

**Accessing the Sample Macros**

**Calling the Sample Macros**

1. Select **Tools > Macros > Macro**. The **Macro** dialog appears.

2. In the Macro From field, double-click **Gimmicks**. The Gimmicks modules appear.

   ![Gimmicks modules](image)

3. Choose one of the modules. For example the **AutoText** module by clicking the entry.

4. Click the **Run** button, to run the module.
Editing the Sample Macros

1. Follow the steps as described above in the section "Calling the Sample Macros", clicking the **Edit** button instead of the **Run** button in the last step.

2. The Basic IDE appears. This is where one can view and edit the program code.

   The following illustration shows a self-defined program code.

   ![Basic IDE screenshot with sample code]

   Instructions on how to use the Basic IDE can be found in **Help > Contents > Macros and Programming > General Information and User Interface Usage > OpenOffice.org Basic IDE.**
The Sample Macros

The following sample macros are in the Gimmicks module.

AutoText
This macro opens an empty Writer document and inserts a table in which the names of all the AutoTexts are listed.

One can print the document to have a handy list of the available AutoTexts.

ChangeAllChars
Use this macro in a text document to replace all text and numbers with the characters "x" and "X". This can be helpful, for example, if the document is to be used as a template but the original text is not to be legible.

If one edits this macro, other replacement characters can be defined in the program code.

GetTexts
This macro carries out a search in the active document (text document, spreadsheet, or drawing) and compiles a list of the contents.

This sample will help the user learn how to reference objects in the documents.

ReadDir
Use this macro to see how a OpenOffice.org Draw document can be filled with content and how the contents of directories are read.

A dialog asks for a directory and then the macro creates a graphic list of all the files and subdirectories.

Userfields
This macro helps users manage several sets of user data and allows switching back and forth between them. This can be quite helpful when more than one person uses the same copy of OpenOffice.org and each person wants to see his or her own user data in the fields.
Chapter 11: Using OpenOffice.org Math

**Formula Entry**
Main View of OpenOffice Formula.

**Tool bar**
The tool bar is divided into two parts.
The upper part is for adjusting the on screen size of the image. The lower part contains an icon for an interactive cursor, and an icon for inserting special characters.

**Command Icon Box**
The command icon box provides a method of writing an equation using GUI similar to other word processors.

The upper two rows in the icon box are menus that call the actual command buttons into the lower portion of the command box. The command buttons are used to insert the appropriate command at the cursor position in the command field.

**Command Dialog Box**
The command dialog box displays the commands that create the equation. The dialog box can be edited directly.

**Creating an Equation with Dialog Commands**

To create an equation with an equation editor, enter the programming commands in logical sequence into the dialog box. The commands entered are similar to the commands used to generate equations in TeX (a scientific publishing format).

Maintaining logical consistency of the commands entered into the dialog box is important. The brackets used in the dialog box must be matched, for example all "(" must have a corresponding ")".

Here are some examples. As can be seen, it is really simple to type formulas in the dialog box.

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>1+1=2</td>
<td>1+1=2</td>
</tr>
</tbody>
</table>

The next example shows how round brackets ( ) and braces { } are used. The parenthesis are used when it is desired to display grouping in the equation, the brace is used to group the commands, but to not display. If braces are needed in an equation, then the lbrace and rbrace commands are used.

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>(1+2) over (2+3)</td>
<td>( \frac{1+2}{2+3} )</td>
</tr>
<tr>
<td>{ 1+2 } over { 2+3 }</td>
<td>( \frac{1+2}{2+3} )</td>
</tr>
<tr>
<td>lbrace 1+2 rbrace over lbrace 2+3 rbrace</td>
<td>( \frac{1+2}{2+3} )</td>
</tr>
</tbody>
</table>

Here is a more complicated example.

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>{ {1 over 5} +4} over {5+{4+1}over{3+3+1}}</td>
<td>( \frac{\frac{1}{5} + 4}{\frac{4+1}{3+3+1}} )</td>
</tr>
</tbody>
</table>
## Special Formatting

Of course there are many other types of groupings that can be created with Open Office.

### Exponentiation:

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>$2^3$</td>
<td>$2^3$</td>
</tr>
<tr>
<td>$5^{(1+3+3^2)}$</td>
<td>$5^{(1+3+3^2)}$</td>
</tr>
</tbody>
</table>

### Subscripting:

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>$2_{\alpha}^3$</td>
<td>$2_{\alpha}^3$</td>
</tr>
<tr>
<td>$(1 \text{ over } 2)<em>{%alpha} + 4</em>{\beta}$</td>
<td>$(\frac{1}{2}) + 4_{\alpha}$</td>
</tr>
</tbody>
</table>

### Leading and trailing superscript and subscript:

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>$2_{\text{Isup}(123)}$</td>
<td>$(123)^2$</td>
</tr>
<tr>
<td>$2_{\text{rsup}(123)}$</td>
<td>$(123)^2$</td>
</tr>
<tr>
<td>$2_{\text{lsup}(123)}$</td>
<td>$(123)^2$</td>
</tr>
<tr>
<td>$2_{\text{rsup}(123)}$</td>
<td>$(123)^2$</td>
</tr>
<tr>
<td>Bi lsup{209}+fe lsup{58} toward Mt lsup{266}</td>
<td>$209^{\text{Bi}} + 58^{\text{fe}} \to 266^{\text{Mt}}$</td>
</tr>
<tr>
<td>lsup{109} +n lsup{1}</td>
<td>$2^{(123)}$</td>
</tr>
</tbody>
</table>

In the last example, the 'Mt' has both leading superscript and subscript applied. This requires only typing both commands after 'Mt'.

### Center subscript / superscript:

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>${2-4\times3}_{\text{sub(123)}}$</td>
<td>$2-4\times3$</td>
</tr>
<tr>
<td>$+18_{\text{csub (plus) - (1+2+3+4) csub [minus]}}$</td>
<td>$+18 - (1 + 2 + 3 + 4)$</td>
</tr>
</tbody>
</table>

### Under brace / Over brace:

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>$+18_{\text{underbrace plus - (1 + 2 + 3 + 4) underbrace minus}}$</td>
<td>$+18 - (1 + 2 + 3 + 4)$</td>
</tr>
</tbody>
</table>
**Various types of Brackets**

In almost all equations various types of brackets are required. OpenOffice formula allows the use of several kinds of brackets.

{} **structural braces**: used to group parts of an equation for programming purposes.

( ) **Parenthesis**: used to group parts of an equation. Parenthesis are displayed in the final equation.

[ ] **square brackets**: usage is the same as parenthesis ().

{} **braces**: as the keyboard characters {} are used for program commands and are not displayed in the resulting formula, braces must be typed as lbrace for '{' and rbrace for '}'

The size of brackets can be controlled with the commands 'left' and 'right'

**Command Input Field**

\[(1+2 \cdot \frac{2}{2-1})\]

left \((1+2 \cdot \frac{2}{2-1})\) right

left lbrace \(a^2+b^2=c^2\) right rbrace
Special Characters

Many equations use special characters in addition to the usual characters of the alphabet. Open office provides an easy method to use Greek characters, while any other character in the available fonts can be used.

The Sigma appears in the tool bar when Open Office Formula is active. This activates the dialog for special characters.

The Greek letters and other symbols can be entered directly into the command dialog box by entering the name of the special character followed by %, for example %SIGMA produces and %mu gives .
Special Operators

The following examples show the use of some special operators

**Integral Sign:**

Command Input Field

\[
\text{int from } \{0\} \text{ to } \{\text{infinity}\} \{a^2 \text{ over } 3\} = \text{?} \\
\int_{0}^{\infty} \frac{a^2}{3} = ?
\]

**Summation Character:**

Command Input Field

\[
\text{sgn (sigma) cdot sum from } \{\text{SIGMA in PHI}\} \{1 \text{ over } \{1 - \text{aleph}_{\text{sigma}}^2\}\} \\
\text{sgn}(\sigma) \cdot \sum_{\sigma \in \Phi} \frac{1}{1 - \aleph^2_{\sigma}}
\]

**Product Character:**

Command Input Field

\[
\text{prod from } \{i=1\} \text{ to } \{i=100\} \{\{ (x_i+1) \text{ cdot x_i^3} \text{ over } \{ x_i^2 - 1 \}\} \} = \text{?} \\
5^{(1+3+3^2)}
\]

\[
\prod_{i=1}^{100} \frac{(x_i+1) \cdot x_i^3}{x_i^2 - 1} = ? \\
5^{(1+3+3^2)}
\]
Vectors and Matrices

Vectors and Matrices are created by the 'stack' and 'matrix' commands respectively. These commands are used with the octothorp # to indicate elements, and double octothorp ## to indicate new line. An empty element is indicated by structural braces {}.

**Vector**

Vectors are composed using the 'stack' command as follows:

**Command Input Field**

```plaintext
left (stack {A # B # a+b=c} right )
```

**Formula**

\[
\begin{pmatrix}
A \\
B \\
a+b=c
\end{pmatrix}
\]

```
left( stack {alignr 1 # 2 } right ) + left( stack { 2 # 3 } right ) + left( stack { 3 # 1 } right)
```

\[
\begin{pmatrix}
1 \\
2 \\
3 \\
\end{pmatrix} +
\begin{pmatrix}
2 \\
3 \\
\end{pmatrix} +
\begin{pmatrix}
3 \\
1 \\
\end{pmatrix}
\]

**Matrix**

Matrices are composed using the matrix command as follows:

**Command Input Field**

```plaintext
left( matrix { 1 # 2 ## 2 # 3 } right ) = x
```

```
abs matrix { a # b ## c # { } } = y
```

```
abs matrix { {1 over 2} # b ## c # d } = z
```

**Formula**

```
\[
\begin{pmatrix}
1 & 2 \\
2 & 3 \\
\end{pmatrix} = x
\]

\[
\begin{pmatrix}
a \\
b \\
\end{pmatrix} = y
\]

\[
\begin{pmatrix}
1 & 2 \\
2 & b \\
\end{pmatrix} = z
\]

\[
\begin{pmatrix}
c \\
d \\
\end{pmatrix}
\]
Formatting

There are some additional formating commands that are available in Open Office Formula. These allow adjustment of the size, colour, and layout of the equation.

Size

The instruction size changes the size of text in the equation.

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>size -2 { a+b } = size +10 { C }</td>
<td>( a+b=C )</td>
</tr>
</tbody>
</table>

Colour

The instruction colour changes the colour of the text in the equation.

Colours available are red, blue, green, yellow, white, and black (default),

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>colour blue A left( matrix { { colour red 1 } \ # { colour blue 2 }} # { colour green 3 } \ # 4 } right) = colour black { x }</td>
<td>( A = \begin{pmatrix} 1 &amp; 2 \ 3 &amp; 4 \end{pmatrix} )</td>
</tr>
</tbody>
</table>

Layout

Various text formatting commands are available to change the layout.

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>bold {&quot;bold&quot;} newline &quot;newline&quot;</td>
<td>( \textbf{\textit{newline}} )</td>
</tr>
</tbody>
</table>
## Alignment

The alignment commands are available to change the position of the elements of an equation with respect to each other.

<table>
<thead>
<tr>
<th>Command Input Field</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>stack{ align a ={} # align b+c+d ={}}</td>
<td>( a = 12 )</td>
</tr>
<tr>
<td>stack{ align 12 # align b^2 - 2 }</td>
<td>( b + c + d = b^2 - 2 )</td>
</tr>
<tr>
<td>5^(1+3+3^2)</td>
<td>5^{(1+3+3^2)}</td>
</tr>
</tbody>
</table>
Examples

Now for the complicated examples:

**Command Input Field**

nroot [4] [nroot [3] {1 over 3+x^2} ]

Idline R_ %alpha rdline =left Idline matrix {sin %alpha # -cos %alpha & cos %alpha # sin %alpha} right rdline

{partial over {partial t} x(t)}+a(x)=%lambda cdot F(x,t)

matrix {
  a_{11} # a_{12} # dotsaxis # a_{"1m"} \\
  a_{21} # a_{22} # dotsaxis # a_{"2m"} \\
  dotsver # dotsver # dotsver # dotsver \\
  a_{{"n1"}} # a_{{"n2"}} # dotsaxis # a_{{"nm"}}
}

sqrt [1-x] = 1 - x over 2 - 1 over 2 x^2 over 4 - dotslow

t= size +6 int from {r_0} to {r_1} size -8 {dr over sqrt [2 over \%my [E_cm - V(r)] - 1^2 over \%my^2 r^2] } }

left ( stack [n # k] right ) = fact n over {fact k cdot fact (n-k)}

f(x) = left lbrace matrix {1 # x in setZ ## 1 over x \\
  # x in setQ ## 0 # x in setR } right none

[a;a_0,a_1,a_2,dotslow ] = a+{1 over {a_0}+1 over {a_1}+{1 over {a_2}+1 over dotslow} } } }

**Formula**

\[
\sqrt[3]{\frac{1}{3} + x^2}
\]

\[
\begin{vmatrix}
\sin \alpha & -\cos \alpha \\
\cos \alpha & \sin \alpha
\end{vmatrix}
\]

\[
\frac{\partial}{\partial t} x(t) + a(x) = \lambda \cdot F(x, t)
\]

\[
a_{11} \quad a_{12} \quad \cdots \quad a_{1m}
\]

\[
a_{21} \quad a_{22} \quad \cdots \quad a_{2m}
\]

\[
\vdots \quad \vdots \quad \ddots \quad \vdots
\]

\[
a_{n1} \quad a_{n2} \quad \cdots \quad a_{nm}
\]

\[
\sqrt{1-x} = 1 - \frac{x}{2} - \frac{1}{2} \frac{x^2}{4} - \cdots
\]

\[
t = \int_{r_0}^{r_1} \frac{dr}{\sqrt{\frac{2}{\text{my}} [E_{cm} - V(r)] - \frac{r^2}{\text{my}^2 r^2}}}
\]

\[
\binom{n}{k} = \frac{n!}{k! (n-k)!}
\]

\[
f(x) = \begin{cases} 1 & x \in \mathbb{Z} \\ \frac{1}{x} & x \in \mathbb{Q} \\ 0 & x \in \mathbb{R} \end{cases}
\]

\[
\binom{a ; a_0, a_1, a_2, \ldots}{1} = a + \frac{1}{a_0 + \frac{1}{a_1 + \frac{1}{a_2 + \ldots}}}
\]
Chapter 12: Troubleshooting Common Problems

Error Message contains “Get Storage: "No Content"

The full error message reads:

| OpenOffice can not be started due to an error in accessing the | Please contact your system administrator. |
| OpenOffice.org configuration data. | The following internal error has occurred: Get Storage: "No Content" |

The reason this message often occurs is because there is a file called Common.xcu that sometimes gets corrupted. In most cases, it seems that this file sometimes ends up being filled with 0s and the problem seems to occur more often under Windows®, possibly as a result of a crash or improper exit while OpenOffice.org was open.

Under Windows®

To locate this file under Windows®, it is easiest to use Windows® Explorer's Find function (sometimes called Search).

Multi-user installations:

Where OpenOffice.org is installed as multi-user under Windows® NT/W2k/XP, this file is likely to be in a special system user directory. Therefore, having administrator rights and enabling the option to view system directories in Explorer is essential before using the Find function. This particular file should be found in C:\Documents and Settings\user\Application Data\OpenOffice.org1.x.x\user\registry \data\org\openoffice\Office\Common.xcu where user is an actual user name.

Once the file is located, simply rename the file (for example to something like Common.xcu.old). Now restart OpenOffice.org, a new Common.xcu is created and the problem should have disappeared.

Single-user installations:

Where OpenOffice.org is installed for a single user, this file is likely to be in C:\Program Files\OpenOffice.org1.x.x\user\registry\data\org\openoffice\Office\Common.xcu. However, if the OS is NT/W2k/XP, this file could still be in a special system user directory. Therefore, having administrator rights and enabling the option to view system directories in Explorer is essential before using the Find function. For Windows® 95/98/ME, the location should be as mentioned above.

Again, once the file is located, simply rename the file (for example to something like Common.xcu.old). Now restart OpenOffice.org, a new Common.xcu is created and the problem should have disappeared.

Note: that there may be files called Common.xcu under paths such as C:\<some path>\OpenOffice.org1.x.x\share\registry\...... et cetera. Do NOT delete these files!
**UNIX systems**

The default location of this file under a UNIX installation (single or multi-user) is `$HOME/ OpenOffice.org1.x.x/user/registry/data/org/openoffice/Office/Common.xcu` where `$HOME` is the user's home directory. As above, simply rename the file (for example to something like `Common.xcu.old`) and restart OpenOffice.org. A new `Common.xcu` is created and the problem should have disappeared.

**Outline numbering is not retained after a save.**

This is issue 27534 which is fixed in release 1.1.4. However, in documents generated by OpenOffice.org1.1.0 up to 1.1.3, one must employ a workaround to achieve expected behaviour. The problem is that a line in “settings.xml” is being set incorrectly when a document is saved. Unfortunately the only way to fix this is to manually edit the `.sxw` file.

The following provides a procedure to follow:

1. Make a temporary directory in which to unzip the `.sxw` file. For example, `my_text`.
2. Change into this directory.
3. Use unzip or similar zipfile utility to unpack the document file that is not retaining its numbering.
4. Edit `settings.xml` and locate the line in it that looks like the following:

   ```xml
   <config:config-item config:name="UseOldNumbering" config:type="boolean">false</config:config-item>
   
   ```

5. Set the value from 'false' to 'true'.

6. Now using zip or similar utility, repack the files in the temporary directory under a new name and give it the `.sxw` extension. Under Linux the command could be:

   ```bash
   zip -r my_new_fixed_document.sxw *
   
   ```

7. Open the fixed document in OpenOffice.org and check that numbering is what is wanted.

   If a copy of StarOffice 6.0 is available, one can get the same effect by opening and saving the document in StarOffice6.0. By doing so, this line will be removed totally. Likewise OpenOffice.org1.0 might also work.

   In either case, when the document is opened using OpenOffice1.1.x, the line, described above, is added with value 'true'; so that will be no further problems with outline “numbering.”
Chapter 12: Troubleshooting Common Problems

How get the page count to not count a title page? (How do I offset the page count?)

If you have a title page or cover page in your document, Writer's "page count" field still counts those pages and will be too high.

Unfortunately, you can't offset the "page count" field. So we're going to use a formula, instead, to insert our proper page count. Here's what you need to do:

1. Place your cursor where you want to insert the offset page count (perhaps in your header).
2. Press the F2 key to bring up the formula bar. Type in the formula "=page - 1" (the "=" will already be in there). The "page" variable is the number of pages in the document, not the page you're currently on. Subtract the number of pages that you don't want to have counted in the page count (in this example, 1, for a title page).
3. Press the Enter key to insert the formula.
4. Choose Tools > Update > Fields from the menu (or press F9) to force the formula to refresh. (Otherwise, the page count formula will just be 0.)
5. To edit this formula again later, place your cursor immediately before the formula, and press F2.

*Note: Every time the page count changes, you'll need to refresh the formula again.*

What to do when your document prints or exports to pdf with blank pages after a page break

This is issue and is affected by the book-centric paradigm of left/right, even/odd pages that is so deeply ingrained into OpenOffice.org that it applies even when using nothing but the Default page style.

1. Create a Title page style from Default or First Page.
2. Lay out the Title page however it needs to look.
3. Next, select Insert > Manual Break.. and specify Next Style as "First Page", numbered 1. This results in the phantom page which the following steps will correct.
4. Select the Stylist and modify the First page style layout to be "Left Only".
5. The status bar will now show "Page 1 2/2", which is what is wanted. The page style following First Page is default and the page numbering will proceed without surprises from there.
Public Documentation License, Version 1.0

1.0 DEFINITIONS.

1.1. "Commercial Use" means distribution or otherwise making the Documentation available to a third party.

1.2. "Contributor" means a person or entity who creates or contributes to the creation of Modifications.

1.3. "Documentation" means the Original Documentation or Modifications or the combination of the Original Documentation and Modifications, in each case including portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism generally accepted for the electronic transfer of data.

1.5. "Initial Writer" means the individual or entity identified as the Initial Writer in the notice required by the Appendix.

1.6. "Larger Work" means a work which combines Documentation or portions thereof with documentation or other writings not governed by the terms of this License.

1.7. "License" means this document.

1.8. "Modifications" means any addition to or deletion from the substance or structure of either the Original Documentation or any previous Modifications, such as a translation, abridgment, condensation, or any other form in which the Original Documentation or previous Modifications may be recast, transformed or adapted. A work consisting of editorial revisions, annotations, elaborations, and other modifications which, as a whole represent an original work of authorship, is a Modification. For example, when Documentation is released as a series of documents, a Modification is:

A. Any addition to or deletion from the contents of the Original Documentation or previous Modifications.

B. Any new documentation that contains any part of the Original Documentation or previous Modifications.

1.9. "Original Documentation" means documentation described as Original Documentation in the notice required by the Appendix, and which, at the time of its release under this License is not already Documentation governed by this License.

1.10. "Editable Form" means the preferred form of the Documentation for making Modifications to it. The Documentation can be in an electronic, compressed or archival form, provided the appropriate decompression or de-archiving software is widely available for no charge.

1.11. "You" (or "Your") means an individual or a legal entity exercising rights under, and complying with all of the terms of this License or a future version of this License issued under Section 5.0 ("Versions of the License"). For legal entities, "You" includes any entity which controls, is controlled by, or is under common control with You. For purposes of this definition, "control" means (a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity.

2.0 LICENSE GRANTS.

2.1 Initial Writer Grant.

The Initial Writer hereby grants You a world-wide, royalty-free, non-exclusive license to use, reproduce, prepare Modifications of, compile, publicly perform, publicly display, demonstrate, market, disclose and distribute the Documentation in any form, on any media or via any Electronic Distribution Mechanism or other method now known or later discovered, and to sublicense the foregoing rights to third parties through multiple tiers of sublicensees in accordance with the terms of this License.

The license rights granted in this Section 2.1 ("Initial Writer Grant") are effective on the date Initial Writer first distributes Original Documentation under the terms of this License.

2.2 Contributor Grant.

Each Contributor hereby grants You a world-wide, royalty-free, non-exclusive license to use, reproduce, prepare Modifications of, compile, publicly perform, publicly display, demonstrate, market, disclose and distribute the Documentation in any form, on any media or via any Electronic Distribution Mechanism or other method now known or later discovered, and to sublicense the foregoing rights to third parties through multiple tiers of sublicensees in accordance with the terms of this License.

The license rights granted in this Section 2.2 ("Contributor Grant") are effective on the date Contributor first makes Commercial Use of the Documentation.

3.0 DISTRIBUTION OBLIGATIONS.

3.1. Application of License.

The Modifications which You create or to which You contribute are governed by the terms of this License, including without limitation Section 2.2 ("Contributor Grant"). The Documentation may be distributed only under the terms of this License or a future version of this License released in accordance with Section 5.0 ("Versions of the License"). and You must include a copy of this License with every copy of the Documentation You distribute. You may not offer or impose any terms that alter or restrict the applicable version of this License or the recipients' rights hereunder. However, You may include an additional document offering the additional rights described in Section 3.5 ("Required Notices").

3.2. Availability of Documentation.
Any Modification which You create or to which You contribute must be made available publicly in Editable Form under the terms of this License via a fixed medium or an accepted Electronic Distribution Mechanism.

3.3. Description of Modifications.

All Documentation to which You contribute must identify the changes You made to create that Documentation and the date of any change. You must include a prominent statement that the Modification is derived, directly or indirectly, from Original Documentation provided by the Initial Writer and include the name of the Initial Writer in the Documentation or via an electronic link that describes the origin or ownership of the Documentation. The foregoing change documentation may be created by using an electronic program that automatically tracks changes to the Documentation, and such changes must be available publicly for at least five years following release of the changed Documentation.


Contributor represents that Contributor believes that Contributor's Modifications are Contributor's original creation(s) and/or Contributor has sufficient rights to grant the rights conveyed by this License.

3.5. Required Notices.

You must duplicate the notice in the Appendix in each file of the Documentation. If it is not possible to put such notice in a particular Documentation file due to its structure, then You must include such notice in a location (such as a relevant directory) where a reader would be likely to look for such a notice, for example, via a hyperlink in each file of the Documentation that takes the reader to a page that describes the origin and ownership of the Documentation. If You created one or more Modification(s) You may add your name as a Contributor to the notice described in the Appendix.

You must also duplicate this License in any Documentation file (or with a hyperlink in each file of the Documentation) where You describe recipients' rights or ownership rights.

You may choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or more recipients of Documentation. However, You may do so only on Your own behalf, and not on behalf of the Initial Writer or any Contributor. You must make it absolutely clear than any such warranty, support, indemnity or liability obligation is offered by You alone, and You hereby agree to indemnify the Initial Writer and every Contributor for any liability incurred by the Initial Writer or such Contributor as a result of warranty, support, indemnity or liability terms You offer.


You may create a Larger Work by combining Documentation with other documents not governed by the terms of this License and distribute the Larger Work as a single product. In such a case, You must make sure the requirements of this License are fulfilled for the Documentation.

4.0 APPLICATION OF THIS LICENSE.

This License applies to Documentation to which the Initial Writer has attached this License and the notice in the Appendix.

5.0 VERSIONS OF THE LICENSE.

5.1. New Versions.

Initial Writer may publish revised and/or new versions of the License from time to time. Each version will be given a distinguishing version number.

5.2. Effect of New Versions.

Once Documentation has been published under a particular version of the License, You may always continue to use it under the terms of that version. You may also choose to use such Documentation under the terms of any subsequent version of the License published by [Insert name of the foundation, company, Initial Writer, or whoever may modify this License]. No one other than [Insert name of the foundation, company, Initial Writer, or whoever may modify this License] has the right to modify the terms of this License. Filling in the name of the Initial Writer, Original Documentation or Contributor in the notice described in the Appendix shall not be deemed to be Modifications of this License.

6.0 DISCLAIMER OF WARRANTY.

DOCUMENTATION IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE DOCUMENTATION IS FREE OF DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT. THE ENTIRE RISK AS TO THE QUALITY, ACCURACY, AND PERFORMANCE OF THE DOCUMENTATION IS WITH YOU. SHOULD ANY DOCUMENTATION PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL WRITER OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF ANY DOCUMENTATION IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

7.0 TERMINATION.

This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein and fail to cure such breach within 30 days of becoming aware of the breach. All sublicenses to the Documentation which are properly granted shall survive any termination of this License. Provisions which, by their nature, must remain in effect beyond the termination of this License shall survive.

8.0 LIMITATION OF LIABILITY.