HACHA v3.5

DrSoftware@hacha.org
Making life easier... One program at a time
Vous en rêvez... Je le fais

Hacha (Hache en Français) est un programme qui permet de couper tous les fichiers afin qu'il soit plus facile de les transporter, de les partager, de les copier sur des disquettes, de les partager, ou de les envoyer via email sur Internet.

Hacha peut également permettre de faire des sauvegardes de disques durs! Il est possible de compacter tous les dossiers d'un disque dur, puis de couper le fichier compacté en morceaux de 700 Mégas avec hacha, afin qu'ils puissent être gravés sur des CDs.

Avec cette version il est possible de couper un fichier de 602 Mégas en seulement 1minute et 17 secondes !! Cette version peut couper sans problème des fichiers de plus de 2 GB.

Utilisez Hacha pour :

1.- Distribuer des fichiers via Internet :

Pour le webmestre:
Certains sites ne permettent pas de télécharger des fichiers supérieurs à 3 Mégas. Comment faire alors pour télécharger un film ou un CD musical ? C'est la raison pour laquelle de nombreux sites utilisent Hacha.

Pour l'utilisateur:
Il est plus facile de télécharger plusieurs fichiers à la fois, plutôt que de télécharger un seul gros fichier et cela évite par ailleurs les problèmes liés aux coupures ou aux mauvaises connexions.

2.- Eviter les limitations de taille maximale des emails :
La plupart des serveurs de courrier électronique ne permettent pas d'envoyer des fichiers de plus de 1 ou 1,5 Mégas. Dès lors, Hacha permet de couper le fichier en plusieurs parties et de les envoyer en plusieurs emails séparés.

3.- Emmener les fichiers à la maison / au bureau / à l'université / etc.
Hacha permet de couper des fichiers afin de les copier facilement sur des disquettes et de les transporter ou de les envoyer par emails.
Cette version génère un code de validation CRC (Cyclic Redundancy Check) qui permet de vérifier si le fichier recréé est identique au fichier original. Elle permet également de renommer les parties et de les ranger dans des dossiers séparés.

CRC = (Cyclic Redundancy Check) est une méthode de calcul mathématique de vérification de données, propriété de Hacha, cette méthode n'est pas commercialisée et se trouve uniquement dans mes programmes.

Configuration minimale pour utiliser Hacha :

*.- OS/2 avec Odin
*.- Linus avec vine
*.- Windows 95, Windows 98, Windows Me, Windows XP.
*.- Mémoire suffisante pour se souvenir d'écrire au "Dr. Software".

Hacha occupe seulement 97 K! Y compris l'aide...

La fenêtre initiale :

Il y a seulement 3 options, vous ne pouvez pas vous tromper:

  • Couper Pour couper un fichier en plusieurs parties.
  • Coller Pour recréer un fichier à partir de ses parties.
  • Idiome & Aide (clic droit sur l image).

Pas possible de faire plus simple !

OPTION COUPER

Une fenêtre apparaît afin de sélectionner le fichier à couper. Par défaut, la taille de coupe est 1,38 Mégas (une disquette) mais vous pouvez indiquer la taille de coupe désirée.

Si vous renommez les parties, je recommande de ne pas laisser d'espace dans les noms.

Par exemple, si vous voulez couper le fichier qui s'appelle "Kiss_TourJapan.mp3", il apparaîtra alors dans la case nom et les parties seront nommées:

Kiss_TourJapan.mp3.0
Kiss_TourJapan.mp3.1
Kiss_TourJapan.mp3.2
..
..
Kiss_TourJapan.mp3.nn

Comme indiqué précédemment, il est possible de changer les noms des parties. Par exemple si vous renommez le fichier "monTheme.mp3" les parties seront nommées :

monTheme.mp3.0
monTheme.mp3.1
..
..
monTheme.mp3.nn

Mais attention, lorsque le fichier original sera recréé, il récupérera son nom original, dans ce cas "Kiss_TourJapan.mp3".

Pour couper un fichier il y a 3 options :

"Origine = Destination".-
Si cette option est cochée, les parties seront rangées dans le même dossier que le dossier du fichier original. Si l'option n'est pas cochée, il est possible de choisir le dossier de destination.

Effacer Source
Si cette option est cochée, à la fin du processus, le programme effacera le fichier source. Si l'option n'est pas cochée, le fichier source ne seras effacé.

Créer CRC
Cette option est très importante, puisse qu'elle génère le code de vérification interne du fichier recréé qui permet de valider la reconstruction fidèle du fichier original. Je recommande donc de cocher cette option.

OPTION COLLER

Si vous souhaitez récréer le fichier original à partir de ses parties cliquez sur "coller" et sélectionner la première partie (*.0). Une fenêtre apparaît et il est possible de sélectionner différentes options :

Option CRC
Si cette option a été cochée, lors de la coupe, à la fin de la reconstruction, le programme vérifie l'intégrité du fichier reconstruit. Je recommande donc d'utiliser cette option..

Effacer Source
Permet d'effacer les parties à la fin du processus de reconstruction. En cas d'échec les parties ne sont pas effacées !

Origine = Destination
Cette option permet de déterminer l'emplacement du fichier recréé. Si l'option est cochée, le fichier est recréé dans le dossier où se trouvent les parties. Sinon, il faut déterminer le dossier de destination.

Note : d'autres programmes tentent de copier les parties sur des disquettes. Par expérience, ce n'est pas une bonne solution. Cette version peut couper et coller les parties créées avec d'autres version antérieures du programme Hacha.

Hacha 3.5 est Freeware!

"Hacha" est un FreeWare (gratuit)! Vous avez l'autorisation de faire des copies gratuites ou de distribuer ce programme ainsi que sa documentation (aide). En revanche, il est interdit de le vendre ou de bénéficier de donations pour ce programme..

Hacha v3.5 peut être téléchargé directement sur mon site Web www.hacha.org. Ceux qui le désirent peuvent mettre le programme sur leur site Web, mais ils doivent indiquer que le site officiel du programme Hacha est www.hacha.org.

Hacha 3.5 est distribué gratuitement et sans aucune garantie, ni déclarées, ni implicites. Vous pouvez l'utiliser sous votre entière responsabilité. Le Dr. Software n'est pas responsable des éventuelles pertes de données, des infarctus causés par le bonheur d'avoir trouvé une telle merveille gratuite ou des mots de tête dus à l'utilisation abusive de ce programme.

Tous droits réservés au fabuleux ©Dr. Software. La version française du programme ainsi que la documentation a été traduite par César Ramos - Anais Marquet - Gabrielle Santa Croce.


"Hacha" (Axe - Ascia - Hache) was created for:
Dr. Software More freeware:
http://www.hacha.org
[ Back ]