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Preface

TIBCO Business Studio™ is designed for business analysts who need to 
document business processes and also for those who implement business 
processes.

Topics

• Related Documentation, page viii

• How to Contact TIBCO Customer Support, page ix
 TIBCO Business Studio - Modeling User’s Guide
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Related Documentation

This section lists documentation resources you may find useful.

TIBCO Business Studio Documentation
The TIBCO Business Studio documentation set consists of user’s guides for its 
main features, modeling and simulation.This documentation has the following 
main sections:

• Getting Started takes you through the basics of TIBCO Business Studio, 
including several tutorials. 

• Concepts and Definitions explores the concepts and terminology related to 
TIBCO Business Studio. 

• Tasks describes common tasks that you perform using TIBCO Business Studio. 

• Reference provides detail about the major components of TIBCO Business 
Studio such as the properties sheets and user interface (UI).

The following documentation is also provided:

• TIBCO Business Studio Installation Guide: Read this manual for instructions on 
site preparation and installation.

• TIBCO Business Studio Release Notes: Read the release notes for a list of new 
and changed features. This document also contains lists of known issues and 
closed issues for this release.

Other TIBCO Product Documentation
You may find it useful to read the documentation for the TIBCO Staffware Process 
Suite™, which may be used or integrated with TIBCO Business Studio. 
Information about this set of products can be found on the TIBCO Staffware 
Process Suite: Documentation Library CD.

Third Party Documentation
The Eclipse help also contains useful information on the Workbench and the 
Eclipse UI.
TIBCO Business Studio - Modeling User’s Guide
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How to Contact TIBCO Customer Support

For comments or problems with this manual or the software it addresses, please 
contact TIBCO Support as follows.

• For an overview of TIBCO Support, and information about getting started 
with TIBCO Product Support, visit this site:

http://www.tibco.com/services/support/default.jsp

• If you already have a valid maintenance or support contract, visit this site:

http://support.tibco.com

Entry to this site requires a username and password. If you do not have a 
username, you can request one.
 TIBCO Business Studio - Modeling User’s Guide
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Chapter 1 Getting Started

If you are new to using this product, TIBCO recommends that you do the 
following:

1. Use the cheat sheet accessible from the Welcome page (and from the Help 
menu). The cheat sheet guides you through the process of creating a Project 
and Package. 

2. Follow the tutorials in the help that explain creating a Process in detail. This 
will help you become familiar with the Process Editor.
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Who Should Use TIBCO Business Studio?

TIBCO Business Studio is for business analysts and those responsible for the 
implementation of business processes. The following diagram shows how TIBCO 
Business Studio is intended to be used:
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About Projects, Packages and Processes

In TIBCO Business Studio there is a hierarchy consisting of Project, Package and 
Process:

Some objects such as Business Assets can be shared at the Project Level. Others 
such as Data Fields and Participants can be created at either the Package level 
(where they can be shared amongst Processes in that Package), or at the 
individual Process level (where they can only be used by that Process).
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Getting Help in TIBCO Business Studio

TIBCO Business Studio uses online help and cheat sheets:

• The main help for TIBCO Business Studio is displayed by selecting Help > 
Help Contents. The help and associated tutorials can also be accessed from 
the Welcome page that is displayed when you first start TIBCO Business 
Studio.

• Context-sensitive help is displayed by pressing F1. Help on the selected view 
or Palette tool/object is displayed.

• Cheat sheets can be displayed by selecting Help > Cheat Sheets. They can 
also be accessed from the Welcome page that is displayed when you first start 
TIBCO Business Studio.
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Using the Sample Processes

TIBCO Business Studio provides a workspace that contains several sample 
Processes. To start the TIBCO Business Studio sample workspace, do the 
following:

1. Click Start > All Programs > TIBCO > TIBCO Business Studio 1.1 > TIBCO 
Business Studio (Samples). This starts TIBCO Business Studio and opens the 
Samples workspace rather than your default workspace.

2. Expand the Basic Samples and Tutorial Solutions Projects, which contains 
the following Packages and Processes:

— OfficeProcedures.xpdl - This contains Processes called Book Meeting 
Room and Submit Expenses.

— SimulationPackage.xpdl - This contains a Process called Claims Mgmt 
Solution. This is the details of how to simulate this process is described in 
a tutorial contained in the Simulation help.

3. Expand the Modeling Tutorial Solutions and Simulation Tutorial Solutions 
Projects, which contains the following Packages:

— Tutorial n Solution.xpdl - These contain the solutions to tutorials 
contained elsewhere in the Modeling and Simulation help.

4. Expand the Industry Samples Project, which contains sample Packages and 
Processes related to banking, health care, insurance and so on.
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Creating a Project

You must create a Project to use TIBCO Business Studio. TIBCO Business Studio 
supports the full project life cycle, bringing together all artifacts in a single place. 
The Project is the container for these artifacts. As such, Projects help to facilitate 
sharing and organization of resources. For example, team members may have 
different responsibilities but need to use the same resources that are made 
available through the TIBCO Business Studio Project.

Each Project has a corresponding directory in the file system (specified when you 
create the Project). 

To create a new TIBCO Business Studio Project, do the following:

1. Select File > New > Project.

2. Click Next to create a new TIBCO Project.

3. Enter the Project Name.

4. Either accept the default location for the Project (your workspace) or de-select 
Use default and click Browse to select a different location.

5. Click Finish. 

The newly-created Project is displayed in both the Project Explorer and the 
Navigator views.

In the Navigator View, a Project contains folders and files. The Project Explorer 
View provides a different view of the Project in which you can see the Packages 
and Business Assets.
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Creating a Package

A Package is a mandatory container for Processes and their infrastructure 
(Participants and Data Fields). For example, in the insurance environment, 
separate packages could contain the Processes used by the Claims Department, 
the Policy Origination/Maintenance Team and the IT Department. Processes can 
be shared between Packages so libraries of process components can be created 
and reused. For more information on reuse, see Re-using Processes on page 54.

To create a Package, do the following:

1. Right-click the Project under which you want to create the Package and select 
New BPMN Package.

2. If you want to change the Project, click Browse. 

3. Enter the name of the Package or accept the default filename. The filename 
must have .xpdl as the extension. Click Next.

4. The Package Details dialog shows the ID and Name of the Package. Either 
click Next to accept the defaults or modify these as necessary:

— ID defaults to the same name as the filename of the package with any 
invalid characters or spaces removed.

— Name defaults to the same name as the filename of the package and is used 
for purposes such as simulation reports.
 TIBCO Business Studio - Modeling User’s Guide



8 | Chapter 1  Getting Started
5. The Package Details dialog is displayed. This allows you to specify or change 
the optional details about the Package:

— Author - username of the user who created the Package.

— Created - displays the date/time that the Package was created.

— Description - text description of the package.

— Documentation Location - URL or filename of any supporting 
documentation.

— Status - project life cycle status for informational purposes. How or 
whether you use life cycle statuses is up to you, but they are typically used 
as follows:

UNDER_REVISION - for packages in development

UNDER_TEST - for packages in User Acceptance Testing (UAT)

RELEASED - for packages in production

— Business Version - version information about the Package.

6. Click Finish.

The version you specify is unrelated to any source control system and 
versioning is entirely user-defined.
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Creating a Process

You can create business process diagrams with the Process Editor to model actual 
and future business processes in your organization. The Process Editor provides 
tools on a Palette that use Business Process Modeling Notation (BPMN) features. 
By creating your business process this way, you can fully prepare it for 
implementation by a specialist in your organization.

1. Before creating a Process, you must create a Project and a Package to contain 
your Process. 

2. In the Project Explorer, select the Package you created, right-click and select 
New Process. 

3. The Create New Process wizard is displayed.

4. If necessary, browse to change the Project and Package then click Next.

5. Enter the Name of the Process and click Next.

6. Select the Destination Environment (optional). This controls the validation 
that TIBCO Business Studio performs when you save the Process:

— If you select the TIBCO iProcess Modeler, the Process will be validated for 
future import into the TIBCO iProcess Modeler as well as for BPMN 
correctness.

— If you select Simulation, the Process will be validated for simulation in 
TIBCO Business Studio as well as for BPMN correctness.

— If you do not select a destination environment, basic BPMN validation will 
be performed.

You can change or select the destination environment after the Process has 
been completed on the Advanced tab of the Process Properties.

7. Click Finish.
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8. When you start the Process Editor, you see the following window (the Palette 
might be collapsed; if so, click the black arrow to expand it):

You can expand this window to fill your screen by double-clicking the title bar 
(in this example, the area labeled MyProcess1).

The Process Editor provides a Default Pool and Default Lane that you can 
rename if you plan on using Pools and Lanes. You add elements of your 
business process using the Palette. 
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Working with Processes

This section describes some common tasks and shortcuts to help you use the 
Process Editor to create Processes. For additional information, see Process Editor 
Tips and Tricks.

Adding Objects
Add an object (for example, an Activity) by doing the following:

1. Click the appropriate tool in the Palette.

2. If you want to add more than one object of the same type, hold down the Ctrl 
key.

3. Position the pointer on the Process at the place where you want to place the 

object. The pointer changes shape: 

4. Click on the Process. The object is added.

Connecting Objects
To connect two objects with Sequence Flow, do the following:

1. Click the Flow tool.

2. Position the pointer over the object that will be the source of the Sequence 

Flow. The pointer changes shape: 

3. Draw the Sequence Flow using one of the following methods:

— Click the source object, then position the pointer over the target of the 
Sequence Flow. If you are satisfied with the shape of the flow, click the 
Target.

— Click the source object, holding down the mouse button, drag the pointer 
to the target object and release the mouse button.

While drawing the Sequence Flow, you can add bendpoints by right-clicking 
or pressing the spacebar.
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Selecting Objects
Select objects using one of the following methods:

• Use the Select tool on the palette. Hold down the Ctrl or Shift keys to select 
more than one object.

• Using the Marquee tool. This allows you to drag a rectangle around all the 
objects that you want to select.
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Tutorial 1: Creating a Simple Process

To get started working with the Process Editor, use this tutorial to create a simple 
Process that represents part of the hiring process within a company. In this 
tutorial, we will do the following:

• Create the Project, Package and Process

• Customize the Lane

• Add Some Objects to Your Process

• Add Flow to the Process

• Add a Gateway

Task A Create the Project, Package and Process

1. Make the Project Explorer active by selecting Window > Show View > Project 
Explorer.

2. If you have not already done so, create a Project.

3. Next, create a Package.

4. Select the Package you created, right-click and select New Process. 

5. Click Next to accept the current Package and Process.

6. Enter Hiring for the Name and click Finish.

7. Double-click the title bar:

The Process Editor expands to fill the window. You can double-click the title 
bar at any point to restore it to its original size (for example, if you need to see 
other windows).

Task B Customize the Lane

1. Rename the lane by double-clicking Default Lane and entering the text HR 
Department.
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2. Make the Lane larger:

a. Click the Lane.

b. Position the mouse pointer over the bottom edge. The pointer changes 

shape .

c. Drag the lower edge of the Lane to make it larger.

Task C Add Some Objects to Your Process

1. If the Palette is not visible, expand it by clicking the Show Palette button to 
the right of the window:

2. On the Palette, click Start Event.

3. Press F1. This displays context help on Process Editor (if the Process Editor is 
maximized, double-click the title bar to see the help). You can get context help 
on specific tools in the palette by selecting them.

4. Position the mouse pointer over the white area of the Lane and click.

The Start Event (indicated by a circle) is added to your Process.

5. Double-click the Start Event and enter the text Start.

6. On the Palette, click Activity.

7. Position the mouse pointer over the white area of the Lane (following the Start 
Event) and click.

The Activity is added to the Process.

8. Double-click the newly-added Activity and enter the text Receive 
Application.
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9. Add another Activity in the same manner, naming it Review Application. 
Your Process should now look like this:

Task D Add Flow to the Process

The Process now consists of three disconnected objects. Now we will add 
Sequence Flow to the Process.

1. On the Palette, click the Flow tool.

2. Click the Start Event (this marks the beginning of the Flow).

3. Click the Receive Application Activity (this marks the target of the Flow).

The Process should look like this:

4. Another way to add Sequence Flow is by dragging: click the Receive 
Application Activity, click the Flow tool and holding down the mouse button, 
drag the pointer to the Review Application Activity and release the mouse 
button.

Task E Add a Gateway

1. Click the Gateway tool and add a Gateway after the Review Application 
step.

• If you have several Sequence Flows to add, hold the Ctrl key down while 
adding them to avoid having to re-select the Flow tool.

• For easier alignment of objects in the Process Editor, you can select either or 
both of the following options:

— View > Grid - This allows you to align objects to a grid.

— View > Alignment Guides - As you move objects in a Process Editor, a blue 
line appears when the center of two objects coincide.
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2. Double-click the Gateway and name it Accept?.

3. Add Flow that connects the Review Application Activity and the Gateway. 
The Process should look like this:

4. From the Gateway, add Regret Letter and Interview. Add Sequence Flow to 
connect these to the Gateway:

5. Double-click the title bar to see the Project Explorer. Note that at this point you 
have not saved the Process. This is indicated in the Project Explorer by an 
asterisk (*) next to the Package that contains the Process. For example:

6. Right-click the Package, select Save and note that the asterisk disappears.

Summary

This tutorial explored using some of the Palette tools to create a simple (although 
incomplete) Process. Continue with Tutorial 2: Extending a Simple Process on 
page 17.
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Tutorial 2: Extending a Simple Process

In the previous tutorial we created a simple Process that represented the 
beginning of a hiring process. In this tutorial, we will add to this Process, 
exploring some of the advanced features of the Process Editor, including:

• Add a Timer Sequence Flow

• Add Notes and Associations

• Configure Service and User Activities

• Add an Exclusive Gateway

• Add an Activity Loop

• Add Conditional Flows

These features are part of the complete set of Business Process Modeling Notation 
(BPMN).

Task A Add a Timer Sequence Flow

1. Open the Hiring Process that you created in Tutorial 1: Creating a Simple 
Process.

2. Add a new Activity Remind Interviewer from the Review Application 
Activity and connect it with a Sequence Flow:

3. Right-click the Sequence Flow that you created and select Properties View.
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4. The properties of the Sequence Flow are displayed, including the Type of 
Sequence Flow:

5. Select Exception and an Exception Type of Timer. This means that this 
Sequence Flow is followed based on a time-based expression supplied when 
the Process is implemented. In this case, if a specific time limit is exceeded, the 
interviewer is sent a reminder to review the application.

6. The Sequence Flow now looks like this:

Task B Add Notes and Associations

To annotate your Process, you can add notes and associate them with an object as 
described in this section.
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1. Click the Note tool and add the following note to the Remind Interviewer 
Activity. You can enter the text in the Properties view:

2. You can associate this note with the Remind Interviewer by selecting the 
Association tool, then clicking the note and then the Remind interviewer 
Activity:

3. Add notes to the Sequence Flow coming out of the Accept? Gateway to 
indicate the Yes and No paths.

Task C Configure Service and User Activities

Some activities can be performed automatically (for example, an automated email 
reminder) and others must be performed by a user (such as conducting an 
interview). In TIBCO Business Studio, automatic activities are called "service 
activities" and manual activities are called "user activities."

1. Right-click the Remind Interviewer Activity that you created and select 
Properties View.

2. The properties of the Activity are displayed, including the Activity Type, 
which is Task by default.

3. Because the sending of the reminder email is an Task that could be automated, 
select Service.
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4. The Remind Interviewer Activity changes appearance to indicate that it 
represents a Service Task:

5. Repeat this for the Interview Activity, but make it a User Task.

Task D Add an Exclusive Gateway

At the end of the interview, a decision is made as to whether to hire the candidate. 
However, in this case it is not a simple yes-no decision. We will construct a 
Gateway to represent the exclusive choice of three options.

1. Add a Gateway to represent the conclusion of the interview. Give it the name 
Hire? and position it to the right of the Interview Activity.

2. Add a flow from the Interview Activity to the newly-added Gateway.

3. Add two new Activities and flows that connect them to the Gateway as 
follows:

4. Add a Sequence Flow from the Gateway back to the Regret Letter Activity.

This indicates that the result of the Interview is one of the three results that 
flow from the Hire? Gateway.

Note that you can also create a User Task by right-clicking the Activity and 
selecting Task Type > User Task.
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Task E Add an Activity Loop

Some Activities may need to be repeated. For such Activities you can use a loop. 
In our example, the Remind Interviewer Activity may need to be repeated. 

1. Right-click the Remind Interviewer Activity and select Properties View.

2. The properties of the Activity are displayed, including the Activity Markers.

3. Select Loop.

4. The Activity changes to show that it contains a loop:

Task F Add Conditional Flows

In our example, we don’t want to endlessly keep looking for candidates. If we 
identify a likely candidate, we need to begin the hiring process again.

Similarly if we create a shortlist, we may decide to make an offer to one of the 
short-listed candidates.

1. Add a Sequence Flow that connects the Shortlist but keep looking Activity 
back to the Receive Application Activity. You may need to reposition the flow 
to make the process diagram legible.

2. Right-click the Sequence Flow that you created and select Properties View.

3. The properties of the Sequence Flow are displayed, including the Type of 
Sequence Flow. 

4. Select Conditional (this can be completed by the Implementer. A diamond is 
added to the source of the Sequence Flow to indicate that it is conditional:

5. In the Properties view, in the Name field of the Sequence Flow, enter a 
description of the condition. This is to help the Implementer with the technical 
implementation of the condition.

6. Add an End Event to the right of the Offer Activity, label it and connect it 
with a Sequence Flow.
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7. Add a Sequence Flow from the Shortlist but keep looking Activity to the End 
Event.

8. Save the Process.

The process diagram that you created should look similar to this:

Summary

In this tutorial we explored some of the advanced features of the Process Editor, 
including features that form the complete set of BPMN. Although this is a 
reasonable approximation of the hiring process, it could be extended further. For 
example after making an offer there could be another process that starts. Also the 
interview Activity could be broken down into further steps that could be 
represented as a Sub-Process.
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Tutorial 3 - Deploying to the TIBCO iProcess Modeler

This tutorial shows how to take the Process defined in the previous tutorial and 
deploy it to the TIBCO iProcess Modeler.

In the previous tutorials, we created a Process that approximated a hiring process 
in an organization. Because we did not specify a destination environment when 
we created the Process, only basic BPMN validation was performed when we 
saved it. If we want to deploy this Process to the TIBCO iProcess Modeler, we 
need do the following:

• Set the Destination Environment and Correct Validation Errors

• Export the Process from TIBCO Business Studio

• Import the Process into the TIBCO iProcess Modeler

Task A Set the Destination Environment and Correct Validation Errors

1. Go to the Properties View for the Hiring Process and click the Advanced tab.

2. Select the TIBCO iProcess Modeler as the Destination Environment. The 
Hiring Process is validated for potential import into the TIBCO iProcess 
Modeler. Note that a red "x" appears in the Project Explorer. This is because 
the Process cannot be imported into the TIBCO iProcess Modeler in its current 
state.

3. Several errors are reported in the Problems View. 

4. From the Problems view, correct the errors and warnings as follows:

— Several errors are generated because the Process cannot have Default or 
Conditional Sequence Flows on Activities (they must flow from a 
Gateway). Change the Sequence Flows from the Shortlist but keep 
looking Activities to Uncontrolled.

— Several warnings are generated because the Activities must be either User, 
Service or Sub-Processes. Right-click each error and select Quick Fix to 
change the each of these Activities.

5. Save the Package and check to Problems view to ensure that all the validation 
errors have been corrected.

Task B Export the Process from TIBCO Business Studio

Export the Process and its containing Package as follows:

1. Select the Package that contains the Hiring Process.
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2. Select File > Export. The Export dialog is displayed.

3. Select TIBCO iProcess Modeler XPDL and click Finish.

4. The exported Process appears in the Project Explorer under Exports > 
iProcess Modeler XPDL and in the file system in your workspace in the 
\projectname\Exports\iProcess Modeler XPDL directory.

Task C Import the Process into the TIBCO iProcess Modeler

Import your TIBCO Business Studio Process as you would any other Process (see 
the TIBCO iProcess Modeler: Procedure Management Guide for more information). 
See Object Mappings - TIBCO iProcess Modeler on page 78 for information about 
how TIBCO Business Studio objects are mapped into TIBCO iProcess objects.

Open the Process in the TIBCO iProcess Modeler and complete its detailed 
implementation. Then execute and test the Process.

1. Start the TIBCO iProcess Client.

2. In the Procedure Manager, select the Library into which you want to import 
the Process.

3. Select Procedure Management > Load From and browse for the .xpdl file of 
the Package that contains the Hiring Process. Click OK.

4. Information about the Package and Procedures is displayed. Click Load.

5. The imported Procedure looks like this:
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Creating Data Fields

Data Fields identify the inputs and outputs of an Activity. For example, an 
Activity called "Process Student Course Request" could require a form with the 
list of courses the student wants to take as input. The availability is checked and a 
form that lists the courses they are enrolled in is output.

To create a new Data Field, do the following:

1. In the Project Explorer, expand the Package where you want to add a Data 
Field.

2. Right-click Data Fields and select New Data Field. The New Data Field 
dialog is displayed.

3. The dialog displays the name of the Project and Package where the Data Field 
will be created. If you want to change either, click the Project or Package 
button to browse.

Data Fields can be created at either the Package level or at the Process level. 
Creating them at the Package level enables them to be shared amongst 
Processes. Select the Process check box and specify a Process if you want to 
create the Data Field at the Process level.

Click Next.

4. Specify the Name, Type, and Initial Value of the Data Field and click Finish.

The Data Field that you created appears in the Project Explorer.

Associating Data Fields with Activities
By associating a Data Field with an Activity you can identify the inputs and 
outputs of the Activity.

To associate a Data Field with an Activity do the following:

1. In the Process Editor, highlight the desired Activity.

2. In the Properties view, click the Parameters tab.

3. Click Add... to browse for the desired Data Field(s). To select more than one 
Data Field, use either the Ctrl key (to select several individual Data Fields) or 
the Shift key (to select a range of Data Fields).

4. Click OK.

5. The Data Field you selected is displayed in the Properties view.
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Creating Participants

Participants are used to identify who or what performs an Activity. 

To create a new Participant, do the following:

1. In the Project Explorer, expand the Package where you want to add a 
Participant.

2. Right-click Participants and select New Participant. The New Participant 
dialog is displayed.

3. The dialog displays the name of the Project and Package where the 
Participant will be created. If you want to change either, click the Project or 
Package button.

Participants can be created at either the Package level or at the Process level. 
Creating them at the Package level enables them to be shared amongst 
Processes. Select the Process check box and specify a Process if you want to 
create the Data Field at the Process level.

Click Next.

4. Specify the Name and Type (see Participants on page 38) of the Participant 
and click Finish.

The Participant that you created appears in the Project Explorer.

Associating Participants with Activities
By associating a Participant with an Activity you can identify who or what 
performs the Activity.

To associate a Participant with an Activity do the following:

1. In the Process Editor, highlight the desired Activity.

2. Either:

— In the Properties view, browse for the desired Participant and click OK.

— Right-click the Activity, select Participant, browse for the Participant and 
click OK.

3. The Participant you selected is displayed in the Properties view and also 
when you hover the pointer over the Activity in the Process Editor.
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Chapter 2 Concepts and Definitions

This section of the help defines concepts and terminology related to TIBCO 
Business Studio.
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Standards Support

TIBCO Business Studio supports several industry standards, namely Business 
Process Modeling Notation (BPMN) and XML Process Definition Language 
(XPDL).

Business Process Modeling Notation (BPMN)
BPMN is a graphical notation developed by the Business Process Management 
Initiative (BPMI) for representing the steps and flow of business procedures. The 
TIBCO Business Studio Process Editor supports the core set of this notation and 
the Properties View supports the complete set.

For more information, see http://www.bpmn.org. 

XML Process Definition Language (XPDL)
XPDL is used to represent the underlying structure of a business process to 
TIBCO Business Studio. Packages are stored in XPDL format. Normally, you do 
not use XPDL directly, but indirectly by creating a business process using the 
Process Editor or by creating a Package.
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Process Components

Process components represent reusable building blocks that encapsulate the 
management of a particular item in a business process. The process components 
form a reusable library that you can call upon in different contexts. For example, 
you might have an item to "verify the caller’s address/contact details" in the 
business process for taking out an insurance policy. This could be implemented as 
a Sub-Process and this particular Process Component could also be used in the 
context of renewing an insurance policy.
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Flow Objects

Flow Objects are the main category of BPMN objects used to define the business 
process. They include:

• Activities

• Events

• Gateways

Example

The following process contains a Start Event, a Gateway, two Activities and an 
End Event:

Activities
An Activity represents work that a company or organization performs using 
business processes. An Activity can be atomic (it is not broken down into a finer 
level of detail) or non-atomic. Atomic Activities are represented in the Process 
Editor by Tasks. For more information, see http://www.bpmn.org.

When creating the TIBCO Business Studio Process, each time a different person, 
group, role, or system does something, an Activity is added to the Process.

Activities may be triggered by events such as the receipt of an email, phone call or 
workflow item, and may involve making a judgement on the presented facts and 
performing an action (such as entering data to a computer system, phoning 
someone in the same or different organization, and so on).
TIBCO Business Studio - Modeling User’s Guide

http://www.bpmn.org


Flow Objects | 31
Tasks

A Task in a process diagram represents an atomic Activity (one that cannot be 
further broken down). It looks like this in the Process Editor:

If the Activities can be broken down into finer steps, they should be represented 
as Sub-Processes.

User Tasks are those that require human interaction. A User Task in TIBCO 
Business Studio looks like this:

Service Tasks can ideally complete without human interaction (for example, an 
automatic email notification). A Service Task in TIBCO Business Studio looks like 
this:

The Activity Type and Task Type are set in the Properties view. Activity Markers 
are also set in the Properties view and are indicated by symbols within the Task.

Sub-Processes

Some Activities can contain further steps, or Sub-Processes. Activities that contain 
a Sub-Process look like this in a Process Editor:

For more information about how Processes can be reused, see Re-using Processes 
on page 54.
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Activity Markers

Activity Markers indicate parts of the BPMN complete set that you can select on 
the Properties of the Activity. The currently selected Activity Marker is indicated 
by the following symbols on the Activity:

• Multiple  - Indicates a Task or Sub-Process that is replicated a fixed number 
of times.

• Loop  - Indicates a Task or Sub-Process that may have more than one 
instance, depending on the conditions of the Loop. When the condition is 
placed before the Activity, the Loop is in effect a While loop; after the Activity 
it functions like an Until loop.

• Compensation  - occurs outside the Normal Flow of the Process and is 
event-based.

• Ad-hoc  - These Activities occur when needed.

Events
An Event in a process is something that happens, for example the start of the 
Process. 

Gateways
Gateways are a control mechanism for the Sequence Flow in the process. They are 
represented by a diamond:

Although the Gateway resembles a decision box in a flow chart, Gateways are 
used for branching, merging, forking and joining as well as for conditional 
decisions.

As shown on the Properties view of a Gateway, these are the different types of 
Gateway that you can create:
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Exclusive (XOR)

In an Exclusive Gateway, there are several paths through which the Process can 
continue, but only one is actually chosen when the Process is run. There are two 
types of Exclusive Gateway:

• Exclusive (Data Based) - The Sequence Flow is chosen based on an expression 
using data from the Process. This type of Gateway is indicated in the Process 
as follows:

• Exclusive (Event Based) - The Sequence Flow is chosen based upon an 
external event (for example, a JMS message).

Inclusive (OR)

In an Inclusive Gateway used as a fork, each output Sequence Flow is 
independently evaluated according to an expression. This means that anywhere 
from zero to the maximum output Sequence Flows can be taken. In practice, you 
should either provide a default Sequence Flow or ensure that at least one 
Sequence Flow evaluates to True. 

When used as a Merge, any upstream Sequence Flows are synchronized, but the 
Gateway does not wait for all Sequence Flows.

Complex

A Complex Gateway is used to fork or merge depending on how an expression 
evaluates. When used as a Decision, the expression determines which of the 
outgoing Sequence Flow are chosen for the Process to continue.

When used as a Merge, the expression determines which of the incoming 
Sequence Flows is required for the Process to continue.

Parallel (AND)

A Parallel Gateway is used to fork or merge several parallel paths 
(synchronization). When several Sequence Flows enter a parallel gateway, the 
process flow waits until all arrive at the gateway before continuing. This type of 
gateway is indicated in the Process as follows:
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Example

The following shows a typical Conditional Gateway:

There is one uncontrolled input Sequence Flow to the Gateway, and conditional 
and default output Sequence Flows. This example is compatible for export to the 
TIBCO iProcess Modeler (see Import the Process into the TIBCO iProcess Client 
on page 62).
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Connecting Objects

You can create a relationship between Flow Objects or between Flow Objects and 
other information using the following Connecting Objects:

• Associations

• Sequence Flows

Associations
An Association is a connection from a Note to a Flow Object (for example, an 
Activity) used to make a Process more readable:

Sequence Flows
Sequence Flows indicate the order in which Activities will be performed. You can 
set up Sequence Flows between Flow Objects. When you create a Sequence Flow, 
you can highlight it, right-click and select one of the following types of Sequence 
Flow:

•  - Shows the default flow from a Gateway or Activity.

•  - Shows a flow that is only followed if the associated 
condition is met.

•  - Indicates a flow that does not have a condition associated 
with it (the default).

•  - Can be either a standard Exception Flow  or a Timer 

Flow .

Associations are not preserved during export to the TIBCO iProcess Modeler.
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Example

In this example, an enquiry is responded to either by email (the default), or 
depending on a condition, by fax.
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Project Objects

Before you can create business processes, you must create a Project and a Package.

Project
Projects help to facilitate sharing and organization of resources. Each Project has a 
corresponding directory in the file system (specified when you create the Project).

Package
A Package consists of one or more Business Processes. The Package and any 
Processes stored in it are saved in .xpdl format. You can Export a package and its 
Processes and then import them into the TIBCO iProcess Modeler for 
implementation.

Process

TIBCO Business Studio allows you to create a Process that models actual and 
future business processes in your organization. Each Process contains one or more 
Activities, which are linked together via Sequence Flows.

Data Fields

Data Fields are used to represent the data that is used internally in a Process as 
either input to or output from an Activity. For example, suppose an Activity is to 
identify a list of suitable candidates for an available position. You can create Data 
Fields to represent the pool of candidates going into the Activity and the suitable 
candidates that have been identified.

There are several types of Data Field:

• String - string value

• Float - decimal number

• Integer - integer value

• Datetime - combination of date/time

• Boolean - true or false
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Parameters

Parameters are similar to Data Field but are either input to or output from an 
external source. For example, during simulation Parameters are either created by 
TIBCO Business Studio or imported from a file. Parameters can be any of the 
following types:

• String - string value

• Float - decimal number

• Integer - integer value

• Datetime - combination of date/time

• Boolean - true or false

Participants

Participants are used to identify who or what performs an Activity. For example, 
in a hiring process, a person (Human Participant) interviews the candidate and an 
email system (System Participant) sends out an automatic follow-up reminder. 
There are several types of Participant:

• Role - identifies the role responsible for performing an Activity. For example, 
in a financial institution there may be roles such as Reconciler, Manager, and 
so on.

• Organizational Unit - identifies the department or unit within an 
organization that performs an Activity. For example, Legal, Marketing and so 
on.

• Human - identifies a specific person or user that performs an Activity.

• System - identifies an activity that is performed by the system.

Business Assets
Business Assets include any documents, spreadsheets, and so on that are relevant 
to the project. 
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Prince2 Assets

TIBCO Business Studio provides Assets to support Prince2 project management 
methodology. To add these to your Project, expand the Project, right-click 
Business Assets and select Create Prince2 Template. For example:

You can add a new Stage File by right-clicking Business Assets > Prince2 and 
selecting New Stage File.

Ad-hoc Assets

Ad-hoc Assets include Microsoft Office documents and image files not recognized 
as Project Management Assets. You can add Business Assets by right-clicking and 
selecting New > Folder or New > File, and selecting the appropriate Parent 
Folder. 

To view the folder or files you have created, go to the Navigator view. In the 
Navigator view, you can also drag files and folders to different locations.
 TIBCO Business Studio - Modeling User’s Guide



40 | Chapter 2  Concepts and Definitions
Swimlanes

Swimlanes consist of Lanes and Pools. 

Lanes
A Lane is a subdivision of a Pool that is used as a container for partitioning 
Processes. How you use Lanes is specific to your business. A Lane can be Normal 
or Closed. The contents of a Normal Lane are visible. The contents of a Closed 
Lane are not visible and are used for "black-box" Processes where you do not 
know the details of the contained Processes.

Important If you delete a Lane in TIBCO Business Studio, all the objects in that 
Lane are also deleted.

Examples

Suppose the back office of a financial institution has a Process in which the 
Securities Reconciliations Department, the Cash Reconciliations Department, the 
Legal Department and a custodian are all involved. When defining this process, 
they can be represented by lanes within the pool:

Currently only one Pool per Process is supported. Sequence Flow can cross the 
boundaries of Lanes.
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Sequence Flow can connect objects in different Lanes:
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The previous example shows a securities trade between a Broker and a Custodian. 
The same trade could be represented as follows:

This shows the Custodian Lane in a Normal state and the Broker Lane in a Closed 
state. The trade might be represented this way because it is documenting the 
Custodian’s part in the trade and the Custodian has no knowledge of the internal 
processes of the Broker.

Pools
A Pool is used as a container for partitioning Processes in ways that make sense 
for your business. They are used in conjunction with Lanes.

Currently only one Pool per Process is supported.
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Chapter 3 Tasks

This section of the help describes some of the common tasks that you perform 
using TIBCO Business Studio, including:

• Migrating Processes Created in Previous Versions

• Creating Business Processes

• Re-using Processes

• Source Controlling Processes

• Integrating with the TIBCO Staffware Process Suite

• Integrating with Aris Software

• Exporting Procedure Documentation
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Migrating Processes Created in Previous Versions

Processes created in previous version of TIBCO Business Studio must be migrated 
to the current version before they can be opened. To migrate a Process, select it, 
right-click and select Migrate to Latest Version.
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Creating Business Processes

This section describes some typical workflow patterns1 and how you can 
implement them in a TIBCO Business Studio Process.

Forking
It is likely that when creating your Process you want an Activity to lead to two or 
more other Activities to be performed in parallel (concurrently). For example, 
when a customer order is dispatched, the inventory is updated and an invoice 
sent to the customer.

1.  Barros, Kiepuszewski, ter Hofstede, van der Aalst
(http://is.tm.tue.nl/research/patterns/)
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BPMN uses the term “fork” to refer to the dividing of a path into two or more 
parallel paths. In TIBCO Business Studio, there are two ways to create a fork in 
the Process, either with two outgoing, uncontrolled Sequence Flows from an 
Activity or with a Parallel Gateway: 

You specify that a Gateway is Parallel by selecting the Gateway Type on the 
Properties view.

These two methods of forking achieve the same result.

Combining Sequence Flow
There are several ways to combine Sequence Flows:

• Joining

• Merging

If the flow should take one or more different paths, Decisions might be required.
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Joining

Joining represents the merging or synchronizing of two or more parallel paths in 
the Process. Use a join for example, if Activity A and B must be completed before 
Activity C can begin.

This is achieved in TIBCO Business Studio by using a Parallel Gateway as follows:

You specify that a Gateway is Parallel by selecting the Gateway Type on the 
Properties view.

Merging

There are three types of Merge:

• Simple Merge - alternative paths are combined, but only one of the input 
Sequence Flows is possible at runtime, so the target Activity is performed only 
once.

• Multiple Merge - multiple Sequence Flows are combined, but without any 
control on the input to the target Activity (as a result, the target Activity could 
be performed more than once).

• Complex Merge - multiple Sequence Flows merge at a Complex Gateway. You 
specify a condition in the Gateway that controls which or how many Flows 
proceed through the Gateway.
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A Simple Merge is accomplished in TIBCO Business Studio like this:

A Multiple Merge looks like this:

The key difference between these two types of merge is that a Simple Merge has 
flow control upstream in the Process, so the target Activity (Activity D) is 
executed only once. With a Multiple Merge, however, there is no flow control 
upstream and the target Activity may be executed more than once.
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A Complex Merge looks like this:

The condition associated with the Complex Gateway specifies what is required to 
pass the Gateway. For example, it could specify that any two of Activities A, B or 
C must be completed before proceeding with Activity D. Another alternative 
would be for Activity A and either Activity B or C to complete before Activity D 
can begin.

Decisions
Decisions points in the Process are achieved with Gateways. There are several 
types of decisions:

• Multiple Choice

• Exclusive Choice
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Multiple Choice

There are two ways to provide for a multiple choice type decision, either with 
conditional Sequence Flows, or with an Inclusive Gateway:

In the previous example, the conditions on the Sequence Flows determine 
whether Activity B, C or both are chosen.

When an Inclusive Gateway is used, Boolean conditions on the outgoing 
Sequence Flows determine which Activity is chosen.
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Exclusive Choice

An exclusive choice is represented by using an Exclusive Data-Based Gateway:

In this example, either Activity B or C is chosen, depending on a Boolean 
condition associated with each outgoing Sequence Flow.
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Re-using Processes

When identifying the Process Components you require for your business process, 
it is important to analyze the entire business. One way to do this is by thinking in 
terms of the products, services and resources (by considering the specifications 
for each).

To facilitate the re-use of Process Components, an Activity (or several Activities) 
can call another Process that you have already defined. A Process that is called by 
another Process is called a Sub-Process. If the main Process is imported into the 
TIBCO iProcess Modeler, any Sub-Processes are imported as sub-procedures.

Calling a Sub-Process
To call a Sub-Process, do the following:

1. In the Process Editor, click the Activity from which you want to call a 
Sub-Process.

2. In the Properties View, select Sub-Process for the Activity Type.

3. Browse for the location and name of the Process you want to call as a 
Sub-Process.

Example

The following example demonstrates how Sub-Processes are used in an insurance 
environment:

This is the top-level Process. Because of its Destination Environment setting, this 
Process is not executed in the TIBCO iProcess Engine. The Destination 
Environment is set when Creating a Process or in the Properties view of the 
Process.
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Each of the Activities in the Process call Sub-Processes that are executed in the 
TIBCO iProcess Engine (its Destination Environment). For example, the 
Sub-Process called from the Claims Management Activity could look like this:

This Sub-Process is executed in the TIBCO iProcess Engine, and calls other 
Sub-Processes. Note the following about this Sub-Process:

• The Validate Policy Sub-Process can be re-used. For example, when a 
customer calls to renew their policy, the first step of the Renewal Process 
could be to confirm that they have an existing policy. The Validate Policy 
Activity could be re-used for this purpose in the Renewal Process.

• The Process Claimant Activity has a Loop Activity Marker, that indicates that 
the Activity is repeated for each Claimant.

• The actual Sub-Process called by the Assess Liability Activity is a manual 
Process. However, the to be Sub-Process (planned for the future), could be 
implemented as an automatic Process that consists of a series of questions 
used to determine liability. Simulation could be used to demonstrate the 
performance and cost-savings of migrating the Assess Liability Activity to an 
automatic Process.

Expanding a Sub-Process
An Activity that calls a Sub-Process looks like this:

To expand the Sub-Process associated with this Activity, do the following:
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1. In the Process Editor, select the Activity that calls the Sub-Process.

2. In the Properties view, select the General tab.

3. Click Open Sub-Process:

4. The Sub-Process opens in the Process Editor.

How Projects, Packages and Processes Support Reuse
• Project - The container for all project life cycle artifacts.

• Packages - A mandatory container for Processes and their infrastructure 
(Participants and Data Fields). Can be organized along project or 
departmental lines, depending on business requirements.

• Processes - model actual and future business processes in your organization. 
Processes can be shared between Packages so libraries of process components 
can be created and reused.

Example

The following example shows a Project and the associated Packages and 
Processes used in an insurance environment.
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In this example, the Validate Policy Process might call a Sub-Process in another 
Package (for example, the Search Claim History Process). This Sub-Process is in 
the same Project in this example, but it could be located in a different Project.

Importing a TIBCO Business Studio/TIBCO iProcess Modeler Package
Processes and the Packages that contain them are stored in .xpdl format. The 
easiest way to import a Process and the Package that contains it is by dragging the 
.xpdl file of the package onto the desired location in the Navigator View. 
Alternatively, you can do the following:

1. Select File > Import.

2. In the Import dialog, select either 

— TIBCO Business Studio XPDL Package or

— TIBCO iProcess Modeler XPDL Package

and click Next.

3. Depending on which option you selected in the previous dialog, enter the 
following:
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TIBCO Business Studio - Click Browse to select the Extensible Stylesheet 
Language file to be used for the import and click Finish.

TIBCO iProcess Modeler - Do the following:

a. Click Browse to select the From Directory where the XPDL file you want 
to import is located.

b. Click Browse to select the Into folder where you want the imported 
package to be placed.

c. Select Overwrite existing resources without warning if you want to 
automatically overwrite any existing Packages or Processes with the same 
name. 

d. Click Finish.

4. The Package/Processes that you have imported are shown in the Project 
Explorer.
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Source Controlling Processes

One problem that occurs when dealing with Processes across their normal 
lifecycle (from creation, testing, rollout to maintenance) is how to know that a 
given Process created by the Analyst, elaborated by the Implementer and signed 
off by the process owner is exactly the one that is in use in a given environment 
(for example, a development, user-acceptance or production environment).

Particularly in large/complex projects where data is shared or modified by 
several people, a source control system becomes necessary. Most enterprises have 
one or more products for source configuration management (SCM). This may be a 
commercial product such as Perforce, Rational's Clearcase or an open source 
solution such as:

• Concurrent Versions System (CVS) (http://www.nongnu.org/cvs/) or

• Subversion (http://subclipse.tigris.org/).

TIBCO does not provide its own SCM product, preferring to integrate with the 
Enterprise's choice for SCM. The Eclipse feature for integrating with such an SCM 
product is known as the Team Synchronization (see the Eclipse help). Since 
Eclipse provides CVS by default, the following section describes how to use 
Subversion; you should contact your SCM vendor for commercial plug-ins.

Using Subversion with TIBCO Business Studio
This section describes how to use the Eclipse software update mechanism to 
install Subclipse and use it for source control. Subclipse is an Eclipse plug-in that 
adds Subversion integration to the Eclipse environment.

1. Select Help > Software Updates > Find and Install.

2. Select Search for new features to install and click Next.

3. Click New Remote Site, add the Subclipse update URL (currently 
http://subclipse.tigris.org/update_1.0.x) and click OK.

4. Click Finish. Eclipse searches for updates.

5. Follow the installation prompts to install Subclipse. Complete instructions are 
available at http://subclipse.tigris.org/install.html.

This section assumes that you or your Subversion administrator have installed an 
SVN server (see http://subclipse.tigris.org/).
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6. Right-click an existing project that contains items you wish to source control. 
Select Team > Share Project. Obtain the URL for the Repository Location from 
your Subversion administrator.

Creating a Project from an Existing Project in Source Control
1. Select File > Import. The Import wizard is displayed.

2. Select Checkout projects from SVN and click Next.

3. Set up the repository with the assistance of your Subversion administrator, 
(this should point to the parent directory to the one containing the Project 
folder) and click Next.

4. Select the Project folder and click Next.

5. Select the method for checking out the Project and click Next.

6. Either use the default workspace or click Browse to check out the Project 
elsewhere.

7. Click Finish. The Project is checked out to your workspace.

Browsing SVN Repositories
You can browse SVN repositories as follows:

1. Select Window > Open Perspective > Other.

2. Select SVN Repository Exploring.

3. This opens a perspective from which you can browse SVN repositories. For 
example:
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Integrating with the TIBCO Staffware Process Suite

If after modeling your business process, you plan to execute it in the TIBCO 
iProcess Engine, you must perform the following steps:

• Correct any Validation Errors

• Export the Process from TIBCO Business Studio

• Import the Process into the TIBCO iProcess Client

Task A Correct any Validation Errors

1. Go to the Properties View for the Process and click the Advanced tab.

2. Select the TIBCO iProcess Modeler as the Destination Environment.

3. Save the Package you want to export. 

The Process is validated for potential import into the TIBCO iProcess Modeler 
and any errors are reported in the Problems View. For more information about 
the validation that is performed, see Process Validation on page 77.

To correct a problem do one of the following:

— Right-click the problem and select Quick Fix (if enabled for the current 
problem). This gives you the option of having TIBCO Business Studio 
automatically correct the problem for you.

— Right-click the problem and select Show in Process Editor. This displays 
the Process in the Process Editor, allowing you to manually correct the 
problem.

Task B Export the Process from TIBCO Business Studio

TIBCO Business Studio can export Packages/Processes in XPDL format which 
can be read by the TIBCO iProcess Modeler. 

To export a Process, do the following:

1. Select the Packages you want to export.

2. Select File > Export. The Export dialog is displayed.

3. Select TIBCO iProcess Modeler XPDL and click Next.

4. Change your package selection if required.
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5. Select a destination for the export by either:

— Selecting Project (to put the export in the Exports\iProcess Modeler XPDL 
sub-directory within your Project directory), or 

— Selecting Path: and clicking Browse... to specify a directory for the export.

6. Click Finish.

Task C Import the Process into the TIBCO iProcess Client

Import your TIBCO Business Studio Process as you would any other Process (see 
the TIBCO iProcess Modeler: Procedure Management Guide for more information). 
See Object Mappings - TIBCO iProcess Modeler on page 78 for information about 
how the TIBCO Business Studio objects are mapped into TIBCO iProcess objects.

Open the Process in the TIBCO iProcess Modeler and complete its detailed 
implementation. Then execute and test the Process.
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Integrating with Aris Software

You can import processes created with Aris 6.2 software into TIBCO Business 
Studio. First, you must use the XML Export Wizard in Aris 6.2 to create an XML 
file. Then use the Import Wizard in TIBCO Business Studio to import the XML 
into TIBCO Business Studio.

For more information, see Object Mappings - Aris Software on page 83.

Exporting from Aris
To export the Aris data, do the following:

1. Log in to the Aris database that contains the data you want to export.

2. Highlight the group or Business Processes that you want to export.

3. Right-click and select Export/Import > XML Export. The Select Attribute 
Language dialog is displayed.

4. Select the language and click Next. The Select Export File dialog is displayed.

5. Browse for the location for the Export.

6. Click Finish to complete the export.

Importing Aris into TIBCO Business Studio
To import an Aris XML file into TIBCO Business Studio, do the following:

1. Select File > Import. The Import Wizard is displayed.

2. Select ARIS XML and click Next.

3. Browse for the Directory where the Aris XML file is located.

4. Browse for the Project folder into which you want to import the ARIS XML 
file and click Finish to complete the import.

• Only eEPC (Extended event-driven process chain) type processes created 
using the Aris Toolset, Aris 6.2 can be imported.

• Regardless of whether you have selected processes from several different 
groups in Aris, they are imported under one Package in TIBCO Business 
Studio.
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Example

In Aris Version 6.2, in the Demo62 database, there are several examples of eEPC 
processes. The following example shows the TIBCO Business Studio import of the 
Aris example process Ticket Reservation (in Movie Palace > Business processes 
> Customer service >Ticket reservation). 
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Exporting Procedure Documentation

From within TIBCO Business Studio you can export information about your 
Process and the Package that contains it to an .html file.

To export documentation about your Process:

1. Select File > Export.

2. Select Procedure Documentation and click Next.

3. Select the Package or Process you wish to export. If you select a Process, the 
containing Package is exported as well.

4. Select a destination for the export by either:

— Selecting Project (to put the export in the \Exports\Procedure 
Documentation sub-directory within your Project directory), or 

— Selecting Path: and clicking Browse... to specific a directory for the export.

5. Click Finish.

6. The Procedure Documentation is saved to the location you specified. See 
Viewing Procedure Documentation for more information.

Viewing Procedure Documentation
To view Procedure documentation:

1. Export the documentation as described in Exporting Procedure 
Documentation.

2. In the Project Explorer, expand Exports > Procedure Documentation.

3. Right-click the .html file for the package and select Open.
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Chapter 4 Reference

This section of the help describes the major parts of the TIBCO Business Studio 
user interface, including the perspectives and views that are provided. 

These are some of the main components of TIBCO Business Studio:

Icons to quickly switch 
perspectives

Palette

Process Editor
Project Explorer and 
Navigator views

Context help - available by pressing F1Outline view Properties view of the current object (for 
example, Activity)
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The TIBCO Business Studio Modeling Perspective

In Eclipse, a Perspective includes the views and set of editors that you commonly 
use for a specific type of work. TIBCO has created several TIBCO Business Studio 
perspectives that include the views and editors you commonly use when creating 
business processes. The Modeling Perspective includes the following:

• Navigator View

• Project Explorer View

• Problems View

• Outline View

• Properties View

• Cheat Sheets View

Navigator View
This view shows files and folders related to a Project in a hierarchical view.

To display this view, select Window > Show View > Navigator.

By right-clicking in the Navigator view, you can create new Projects, Packages, 
folders and files.

You can also drag files from Windows Explorer into the Navigator.

Project Explorer View
This shows a view of the Project in which you can view the Packages and 
Business Assets. In contrast to the Navigator view, the Project Explorer view does 
not differentiate between files and folders; it shows a contextual view of the 
Project.
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For example, the following shows both the Navigator and Project Explorer views 
of the same Project.

To see this view, select Window > Show View > Project Explorer.

Problems View
The Problems view is where the software displays warnings, errors and messages 
about the resources used in your Project. To see this view, select Window > Show 
View > Problems.

The Problems view also displays error messages that result from validation of 
your Process. When you save your Process, it is validated for BPMN correctness 
and for export to the TIBCO iProcess Modeler or for simulation (depending on the 
Destination Environment setting of the Process).

Example
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Outline View
The Outline View allows you to focus on specific areas of a large process. The 
Outline View looks like this:

To see this view, select Window > Show View > Outline. By positioning the 
mouse pointer over the shaded area and holding the left mouse button down, you 
can reposition the shaded area of the Outline View and thus see different parts of 
the process.

Properties View
The Properties View shows you detailed information about the currently selected 
object and allows you to specify the characteristics of an object. 

Area of the Process 
that is shown in the 
Process Editor.

Remainder of Process 
(not visible in the 
Process Editor).
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The Business Process Modeling Notation (BPMN) complete set is supported by 
the Properties View. For example, if you are creating a Gateway in your process 
diagram, you can select the type of Gateway you want in the Properties View:

To see this view, select Window > Show View > Properties. To view property 
information, you must have an object selected.

Process Properties

When you have selected a Process in the Project Explorer, the following Properties 
are available. 

Properties related to simulation are only present when Simulation is selected as 
the Destination Environment.

Tab Property Description

General Name Name of the Process. You can 
re-name the Process here by 
entering a new name.
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Activity Properties

When you have selected an Activity in the Process Editor, the following 
Properties are available:

Advanced Destination 
Environments

Enter the target environment 
for the Process. When you 
save the Process, validation is 
performed according to this 
setting:

• If you select TIBCO 
iProcess Modeler, the 
Process will be validated 
for future import into the 
TIBCO iProcess Modeler 
as well as for BPMN 
correctness.

• If you select Simulation, 
the Process will be 
validated for simulation 
in TIBCO Business Studio 
as well as for BPMN 
correctness.

• If you do not select a 
destination environment, 
basic BPMN validation 
will be performed.

Simulation Simulation 
Parameters

Summary of the simulation 
data, specifically the 
weightings and percentages 
applied to transitions in the 
Process.

Tab Property Description

Tab Property Description

General Name Name of the Activity.

Description Description of what the 
Process does.
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Activity type Either Task or Sub-Process 
(see Activities on page 30). If 
you select Sub-Process, you 
must browse to locate the 
Sub-Process.

Activity Markers Select from Multiple, Loop, 
Compensation, or Ad-hoc. 
For more information, see 
Activity Markers on page 32.

Participant Specify the Participant 
responsible for this Activity 
(see Participants on page 38).

Parameters Data Fields Click Add... to select a Data 
Field to be used as the input 
or output to the Activity. You 
can use the Ctrl and Shift 
keys to select several Data 
Fields. Click Remove to clear 
the selected Data Field from 
the Activity, or Remove All to 
clear all Data Fields.

Visualization Color Click the button next to Color 
to select the fill color for the 
Activity.

Simulation Select a Duration 
Distribution, Time unit, and 
values for the selected 
distribution. The Activity 
Cost is calculated and 
displayed.

Description Text description associated 
with the Activity.

Tab Property Description
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Gateway Properties

When you have selected a Gateway in the Process Editor, the following Properties 
are available:

Sequence Flow Properties

When you have selected a Sequence Flow in the Process Editor, the following 
Properties are available:

Event Properties

When you have selected an Event in the Process Editor, the following Properties 
are available:

Tab Property Description

General Description Description of what the 
Gateway does.

Gateway type Choose the type of Gateway 
(see Gateways on page 32 for 
more information).

Description Text description associated 
with the Gateway.

Tab Property Description

General Description Description of the Sequence 
Flow.

Type Choose the type of Sequence 
Flow (see Sequence Flows on 
page 35 for more 
information).

Tab Property Description

General Name Name of the Event.

Simulation (Start 
Event only)

You can modify the number 
and interval of case starts for 
simulation.
TIBCO Business Studio - Modeling User’s Guide



The TIBCO Business Studio Modeling Perspective | 75
Lane Properties

When you have selected a Lane in the Process Editor, the following Properties are 
available:

Cheat Sheets View
When you first start TIBCO Business Studio, a Welcome Cheat Sheet is displayed. 
You can view TIBCO Cheat Sheets and other Cheat Sheets by selecting Help > 
Cheat Sheets and selecting from the list. 

Process Editor
The Process Editor is where you create your business process. It includes a Palette 
that contains the tools you use to create your Process.

Palette

You can create your Process using the tools on the Palette. The Business Process 
Modeling Notation (BPMN) core set is supported by the Palette, which contains 
the following tools:

Tab Property Description

General Name Name of the Event.

Type Either a Normal Lane or a 
Closed Lane (see Lanes on 
page 40).

Palette Item Description

Allows you to select objects.

Allows you to select several objects by drawing a box 
around them.

Visually connects a Note to a Flow Object. 

Adds Sequence Flows to the Process. This shows the 
order of Activities in a Process.
 TIBCO Business Studio - Modeling User’s Guide



76 | Chapter 4  Reference
Alignment Tools

For easier alignment of objects in the Process Editor, you can select either or both 
of the following options:

• View > Grid - This allows you to align objects to a grid.

• View > Alignment Guides - As you move objects in a Process Editor, a blue 
line appears when the center of two objects coincide.

You can also align objects that you have selected by choosing options from the 
View > Alignment menu. For example, if you have two Activities selected, you 
can align them horizontally on their centers by selecting View > Alignment > 
Align Middle. Alternatively you can use the alignment buttons on the toolbar 
that correspond to the menu options.

Allows you to add a Task to the Project. A Task is 
considered an atomic Activity because the work it 
represents cannot be broken down to a finer level of 
Process Model detail.

Gateways are used to control the divergence and 
convergence of several Sequence Flows. You can insert 
Gateways in your Process for branching, forking, 
merging and joining of flows.

Indicates the beginning of the Process.

Indicates the end of the Process.

A Lane is a sub-division of a Pool. Pools are used to 
indicate the Participants in a Process. Within a Pool you 
can use Lanes to characterize Activities. Note If you 
delete a Lane in TIBCO Business Studio, all the objects 
in that Lane are also deleted.

Adds a note to the Process. Notes are used for 
explanation/annotation of the Process.

Palette Item Description
TIBCO Business Studio - Modeling User’s Guide



Process Validation | 77
Process Validation

When you created your Process you specified the Destination Environment. If 
you specified the TIBCO iProcess Modeler, when you save your Process, TIBCO 
Business Studio performs validation to ensure that the Process can be imported 
into the TIBCO iProcess Modeler.

Any error messages resulting from this validation will be displayed in the 
Problems View and indicate which parts of your Process need to be changed.

General Rules for Export to the TIBCO iProcess Modeler

Events

• A Start event is mandatory, and you should use only one.

• Start events must not have Sequence Flow input and must have a single 
uncontrolled output sequence flow.

• Stop events must not have Sequence Flow output.

Process Objects

• All Activities must be either Service, User Activities, or Sub-Processes (see 
Activities).

• Conditional Sequence Flows can only be used from a Gateway, and the 
Gateway must have only one input, only one conditional output sequence 
flow exiting, and optionally only one default output Sequence Flow. Note that 
a default Sequence Flow can only be used in conjunction with a Conditional 
Sequence Flow.

• Event Sequence Flows must only be used from Activities or as the only flow 
output of a Gateway.

• Parallel Gateways can only have non-conditional Sequence Flows (input and 
output).

• Ensure there is at least one object other than a diagram note.

• Sub-Processes should be in the same Package as the calling Process.

• The first eight alphanumeric characters of the Process name should be unique.

• The first 15 alphanumeric characters of single-instance Data Field names (or 
eight characters for arrays) should be unique within the Process and its 
containing Package.
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Correcting Validation Errors
Any problems that result from validation are shown in the Problems view. To 
correct the problem do one of the following:

• Right-click the problem and select Quick Fix (if enabled for the current 
problem). The gives you the option of having TIBCO Business Studio correct 
the problem for you.

• Right-click the problem and select Show in Process Editor. This displays the 
Process in the Process Editor, allowing you to correct the problem.

Object Mappings - TIBCO iProcess Modeler
When you import a Process into the TIBCO iProcess Client, the original objects 
(from the TIBCO Business Studio version) are mapped into objects that the TIBCO 
iProcess Modeler supports. This section describes the mapping between TIBCO 
Business Studio and TIBCO iProcess Modeler objects.
TIBCO Business Studio - Modeling User’s Guide



Process Validation | 79
Project Objects

TIBCO Business 
Studio Object

Corresponding TIBCO 
iProcess Modeler 
Object

How to Complete...

Project None

Package None (used when 
importing to the TIBCO 
iProcess engine, but no 
equivalent object)

Process Procedure (name taken 
from the first 8 
alphanumeric characters 
of the Process or created if 
that name is not unique)

Sub-Process (Process 
referenced in an 
Activity)

Sub-Procedure Define input and 
output parameters

Participant Addressee (Work Item 
Steps)

Create TIBCO iProcess 
Engine users/groups

Data Field (Package and 
Process)

Field (name taken from 
the first 15 alphanumeric 
characters of the Process 
or created if that name is 
not unique)

Adjust field 
length/type as 
required

Parameter I/O parameter and field
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Activities and Tasks

TIBCO Business 
Studio Object

Corresponding TIBCO 
iProcess Modeler 
Object

How to Complete...

Sub-Process Call from a 
Task

Sub-Procedure call from a 
Step

Map input and output 
parameters to Data 
Fields

Service Tasks Enterprise Application 
Integration (EAI) step 
with no type set

Select EAI step type 
and complete the 
details

User Task Work Item Step Define the Work Item 
Step form

Activity Parameter Step Annotation/Form 
Definition on Work Item 
Step

Activity Marker Step Annotation

Start/End Event Start/Stop
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Gateways

Connecting Objects

TIBCO Business 
Studio Object

Corresponding TIBCO 
iProcess Modeler 
Object

How to Complete...

Unconditional Gateway 
(branching)

Complex Router

Gateway with one 
input, one conditional 
output, and optionally 
one default output

Condition with the 
Expression "Undefined" 
= "Undefined"

Complete the 
condition

Gateway with one 
Exception Sequence 
Flow output

Event object with 
Deadline

Complete the 
deadline details

Parallel Gateway 
(multiple unconditional 
input)

Wait

Default Gateway 
(multiple unconditional 
input)

Complex Router

TIBCO Business 
Studio Object

Corresponding TIBCO 
iProcess Modeler 
Object

How to Complete...

Association None
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Swimlanes

Special Considerations - TIBCO iProcess Modeler Import

When importing a Procedure from the TIBCO iProcess Modeler into TIBCO 
Business Studio, you should consider how implement AND behavior. The 
following is how AND behavior is implemented in the TIBCO iProcess Modeler:

Sequence Flows of the 
Exception type (on an 
Activity)

Deadlines Link Complete the 
deadline details on the 
source activity

Note Unattached Annotation 
(any attached Association 
is not Preserved)

TIBCO Business 
Studio Object

Corresponding TIBCO 
iProcess Modeler 
Object

How to Complete...

Pool Not mapped

Lane Lane (only mapped in 
TIBCO iProcess Engine 
10.3.5 and later)

TIBCO Business 
Studio Object

Corresponding TIBCO 
iProcess Modeler 
Object

How to Complete...
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When imported into TIBCO Business Studio, the flow from the first Activity 
becomes XOR and looks like this:

Furthermore if the Process is simulated, one of the output Sequence Flows 
becomes Conditional and the other Default.

To preserve the original AND behavior from the TIBCO iProcess Modeler, you 
must insert a parallel Gateway as follows:

Object Mappings - Aris Software
When you import a Process from Aris Software into TIBCO Business Studio, the 
original objects from Aris are mapped into objects that TIBCO Business Studio 
supports. This section describes the mapping between Aris objects and TIBCO 
Business Studio objects.

Aris Object Corresponding TIBCO Business 
Studio Object

Event Depending on the position of the Event, 
a Start Event, End Event or Description 
of a Sequence Flow.

Function (User Activity type; eg. 
)

User Task.
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Function (System Activity type; eg. 

)

Service Task.

AND Rule Parallel Gateway.

XOR Rule Exclusive Data Based Gateway.

OR Rule Inclusive Gateway.

Rule Default Gateway.

• Organizational Unit Type, 
Organizational Unit, System 
Organizational Unit, and so on.

• Position Type, Position, Position 
Description, Person Type, 
Internal Person, External 
Person, Group

Participant (if one per Activity, added to 
the Activity Properties; otherwise 
added as a Note with an Association).

D Attribute (ERM), K Attribute 
(ERM), FK Attribute (ERM), COT 
Attribute, Technical Term

Data Field.

Non-function object without 
connections

Note.

Non-function object that is not a 
recognized data type or participant 
and has only one connection 
(incoming or outgoing) to a 
function object

Note with an Association.

Aris Object Corresponding TIBCO Business 
Studio Object
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Chapter 5 Tips and Tricks

This chapter contains tips for working with the TIBCO Business Studio user 
interface.
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Process Editor

The following tips relate to the Process Editor:

I can’t see the Palette. Make sure you are in the Process Editor and 
that the Palette is expanded (click the arrow to 
the right, top of the scroll bar).

How can I create several 
objects of the same type 
using the Palette?

Press the Ctrl key while adding the objects to 
your Process. For example, if you want to 
create several Sequence Flows, press and hold 
the Ctrl key while clicking the Flow tool and 
adding the Sequence Flows.

How do I align objects in 
the Process Editor?

There are two features that allow you to better 
align objects in the Process Editor - Grid and 
Alignment Guides. These are both available 
from the View menu when using the Process 
Editor. Grid allows you to snap objects to the 
grid lines, and Alignment Guides shows a 
centering line when you have aligned two 
objects.

With several objects selected in the Process 
Editor you can also select options from the 
View > Alignment menu to control the vertical 
and horizontal alignment of the objects.

I’m using Grid alignment 
in the Process Editor and I 
want to place an object 
without using the Grid.

Pressing the Alt key while moving an object 
allows you to position it between grid lines.

How can I easily resize an 
Activity in the Process 
Editor?

Pressing the Ctrl key while resizing one side of 
an object automatically resizes the opposite 
side as well.

I can’t get my Sequence 
Flows to look right.

Occasionally when you reposition a Sequence 
Flow several times you create too many 
bendpoints and make the flow illegible. To 
restore a Sequence Flow, click the flow and 
select Reset Bendpoints.
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I can’t get a Sequence Flow 
to dock where I want it to 
dock.

Sequence Flows are docked at the nearest 
docking point rather than where you attempt 
to dock them. Try repositioning the middle of 
the Sequence Flow to change the docking 
point. 

How can I position 
Sequence Flows using the 
keyboard?

Highlight the Sequence Flow, the press the 
Period key (.) to move along the bendpoints. 
With a bendpoint highlighted, use the arrow 
keys to position them and change the shape of 
the flow. When you are done, press the Return 
key.
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Workbench

The following tips relate to the Eclipse Workbench:

How can I quickly change 
Perspectives?

There are buttons in the upper right of the 
screen so you can change between the 
Simulation and Modeling perspectives. You 
can also do this using Ctrl + F8.

My windows are a mess. 
How can I reset them?

Select Window > Reset Perspective. This 
restores the current Perspective to its default.
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Problems View

The following tips relate to the Problems view:

How can I correct 
validation errors?

Either:

• Right-click the problem and select Quick 
Fix (if enabled for the current problem). 
This gives you the option of having TIBCO 
Business Studio automatically correct the 
problem for you.

- or -

• If no quick fix is available, right-click the 
problem and select Show in Process Editor. 
This displays the Process in the Process 
Editor, allowing you to manually correct 
the problem.

In the Problems view I see 
not only problems for my 
Process/Project, but 
problems for all 
Processes/Projects.

Click  to display the Filters dialog. This 
allows you to customize the problems display. 
For example, you can select options to display 
problems for the selected resource only, or for 
any resource in the same Project.
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Index

A

Activity 30
properties 72

Activity Marker 32
Ad-hoc Activity Marker 32
Ad-hoc Asset 39
Aris software

export 63
import 63
integrating with 63

Asset 38
ad-hoc 39
Prince2 39

Association 35

B

Business Process Modeling Notation (BPMN) 28
business processes patterns 47

C

Cheat Sheets View 75
Compensation Activity Marker 32
Connecting Objects 35
creating a Package 7
creating a Process 9
creating a Project 6
creating Data Fields 25
creating Participants 26
customer support ix

D

Data Field 37
associating with an Activity 25
creating 25

decision behavior 51

E

errors 77
correcting 78

Event 32
properties 74

exclusive choice behavior 53
expanding a Sub-Process 55
exporting from Aris 63
exporting procedure documentation 65
exporting to the TIBCO iProcess Modeler 77

F

Flow Objects 30
forking behavior 47

G

Gateway 32
properties 74
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I

importing a Package 57
importing Aris procedures 63

J

joining behavior 49

L

Lane 40
properties 75

Loop Activity Marker 32

M

merging behavior 49
Modeling perspective 68
Multiple Activity Marker 32
multiple choice behavior 52

N

Navigator View 68

O

object mapping - Aris Software 83
object mapping - TIBCO iProcess Modeler 78
Outline View 70

P

Package 37
creating 7
import 57

Palette 9, 75
using 11

Participant 38
associating with an Activity 26
creating 26

Perspective 68
Pool 43
Prince2 Asset 39
Problems View 69, 89
Procedure documentation 65

exporting 65
Process 37

adding objects to 11
correcting errors 78
creating 9
properties 71
re-use 54
selecting objects 12
validation 77
working with 11

Process Component 29
Process Editor 9, 75

alignment tools 76
tips 86
using 11

Project 37
creating 6
creating in source control 60
purpose 6

Project Explorer View 68
Project Objects 37
Properties View 70

Q

Quick fixes 78
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S
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selecting Objects 12
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properties 74
using to connect objects 11
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Sub-Process 31

calling 54
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Subversion 59
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package import 57
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