How do I do that in ArcGIS/Manifold: illustrating classic GIS tasks

Edited by: Arthur J. Lembo, Jr.; Cornell University
Introduction from the editor:

In 1988, the United States Geological Survey (USGS) created a classic document titled “The Process for Selecting Geographic Information Systems” (Guptill, et. al., 1988). The document provided an overview of the process for selecting geographic information systems, in addition to a checklist of functions that a GIS should include. The functions were broken into five separate categories: user interface, database management, database creation, data manipulation and analysis, and data display and presentation. The document became required reading for those of us involved in the selection of GIS, and was often used as a supplementary checklist in competitive benchmarks of GIS software. Although the document is over 15 years old, many of the functions listed are still relevant today, and represent some of the most commonly used features within GIS. In fact, the document was so forward thinking that most GIS software products are still unable to perform all the tasks listed.

Therefore, this document attempts to illustrate the GIS processes listed in the USGS document using two popular GIS software systems: ArcGIS 8.3 and Manifold 6.0. While the document does illustrate the steps required to complete the classic GIS tasks in a side-by-side format, it is not meant to be a comparison or an endorsement of either product (they just happen to be the two most popular products in our lab). Rather, it is meant to act as a cheat-sheet for GIS professionals needing some direction in performing classic GIS functions. Many individuals are beginning to experiment with Manifold GIS, and the large user base of ArcView 3.x user continues to migrate to ArcGIS. It is our hope that this document assists these users in performing some of the more common tasks.

This document represents a midterm examination assignment for 16 of our students in the upper level graduate course Spatial Modeling and Analysis. The students and instructor spent many hours in lab working through each of the tasks over a three week period.

The resources and time available to illustrate these tasks prohibited the ability to review every function listed in the USGS document. Therefore, we selected a large subset of the functions though to represent the common GIS functions employed by users today.

We are especially grateful to those individuals who volunteered as technical referees for each note. The referees represented long-time users of the software products, business partners, and certified trainers of the software from government, private industry, and academia. For the ArcGIS tasks, five referees were chosen, while four referees were chosen to evaluate the Manifold tasks.

---


How do I do that in ArcGIS/Manifold

© Arthur J. Lembo, Jr.
None of the referees were affiliated with Cornell University, and were anonymous to the authors.

One difficulty in creating this document was interpreting the actual meaning of some of the USGS defined tasks. Another difficulty was attempting to find the most suitable approach for solving the problem. As most users know, there are many ways to solve a particular problem using commercial GIS software. In this document we have attempted to illustrate the most straightforward method for performing the tasks, and have relied on the referees to make sure that a suitable approach was chosen. However, any errors remaining within the document are our own, and not the fault of the referees.

Also, while each of the GIS products allow the creation of sophisticated scripts, or integrate third-party software, we have attempted to only utilize those features accessible out-of-the-box in hopes that it will provide basic guidance for users of the software.

Time marches on, and some functionalities not envisioned by the USGS document now exist. We hope to expand the scope of this document to include more sophisticated functions now offered by the commercial GIS vendors.

It is our hope that this document provides a quick reference for users to find the necessary steps to complete the classic GIS tasks.

Arthur J. Lembo, Jr.; Ph.D.
May, 2004
Cornell University
# Table of Contents

- Database Management .................................................................................................................. 6
  - Adding a column to a table ........................................................................................................ 7
  - Sorting Tabular or Graphical Data .......................................................................................... 10
  - Calculating values for new fields using arithmetic or related tables-making field calculations ............................................................. 13
  - Relating Data Files and Fields ................................................................................................. 16
- Database Creation .......................................................................................................................... 18
  - Assigning Topology .................................................................................................................. 20
    - Creating a Polygon from Line Segments ............................................................................... 23
    - Correcting Topological Errors ............................................................................................. 25
- Import and Export .......................................................................................................................... 27
  - Importing database tables, raster data, and vector data ......................................................... 27
- Data Manipulation and Analysis ..................................................................................................... 32
  - Data Retrieval .......................................................................................................................... 33
  - Select data by area masks ......................................................................................................... 37
- Data Restructuring .......................................................................................................................... 39
  - Convert from raster to vector .................................................................................................... 39
  - Convert from vector to raster .................................................................................................... 41
  - Modify raster cell size by resampling ....................................................................................... 43
  - Data Restructuring; changing raster values by selected area ................................................. 45
  - Changing raster values by geographic feature ........................................................................ 49
  - Reducing Unnecessary Coordinates – Weeding ....................................................................... 52
  - Smoothing Data to Recover Sinuosity ..................................................................................... 54
    - TIN from Point Data ............................................................................................................... 56
    - Kriging from Point Data ......................................................................................................... 58
    - Generate Contour Data from Points ........................................................................................ 60
    - Generate Contour Data from Raster ...................................................................................... 64
  - Data Transformation .................................................................................................................... 66
    - Mathematical transformation of raster data ........................................................................ 66
    - Projection definition and coordinate transformation ............................................................ 70
  - Vector Overlay ........................................................................................................................... 75
    - Polygon in polygon overlay ................................................................................................... 75
    - Point in polygon overlay ......................................................................................................... 77
    - Topological intersection ......................................................................................................... 80
    - Line in polygon ....................................................................................................................... 83
- Raster Processing ............................................................................................................................. 85
  - Mathematical operations on one raster ...................................................................................... 85
  - Mathematical operations on two rasters ..................................................................................... 87
  - Neighborhood Functions .......................................................................................................... 89
- Statistical Function .......................................................................................................................... 92
  - Calculating Areas, Perimeters and Lengths ............................................................................. 92
  - Cross Tabulation of Two Data Categories ............................................................................... 94
- General ............................................................................................................................................... 96
Database Management

Database management functions provide for tracking, retrieval, storage, update, protection, and archiving of stored data.

Adding a column to a table

Pete Kane, Cornell University

This technical note compares the process of adding columns to a table using both ArcGIS and Manifold GIS. Simple tables are used to help illustrate the process.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

As an example, a simple table is opened in Manifold.

As an example, a simple table is opened in ArcGIS.

Adding a column to the data table requires a few simple steps:

1. Right-click on any of the column headers at the top of the table.

Adding a column to a table in ArcGIS requires a few simple steps.

1. Click the options button at the bottom right of the table and then click add field.
2. Click on add and then columns in the dropdown menu.

3. Type the name and select the appropriate data type of the new column in the box that appears.

4. The new column will appear to the right of all other columns in the table.

2. A window will pop up prompting you to input the name and data type for the column. Enter the name of the new column and the appropriate data type in the dropdown menu.

3. The new column will appear to the right of all other columns in the table.
Other Considerations:

How do I do that in ArcGIS/Manifold

© Arthur J. Lembo, Jr.
Sorting Tabular or Graphical Data

Pete Kane, Cornell University

This technical note compares the process for sorting tabular or graphical data in ArcGIS and Manifold. Simple tables are used to illustrate the process.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS (ArcCatalog)</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

Tabular data can be sorted according to data type (alpha numeric, date, time) and can use any number of columns.

As an example, a simple table is opened in Manifold.

![Manifold table example](image)

We will begin by sorting records in a table by one column.

Sorting tabular data by a single column involves a few simple steps.

1. Right-click on the heading of the

Tabular data can be sorted based on alphabetical or numerical order. The user has the option to sort either by one column or multiple columns.

As an example, a simple table is opened in ArcGIS.

![ArcGIS table example](image)

We will begin by sorting records in a table by one column.

Sorting tabular data by a single column involves a few simple steps.

1. Right-click on the heading of the
column whose records you would like to sort, and select either “sort ascending” or “sort descending”.

Data records can also be sorted based on more than one record. In this example, we will sort first by name and then by area. Both sorts will be in ascending order.

1. Click on the View pull down menu and then select sort. This will pull up the sort window.

2. In the sort window, choose which column you would like to sort, pressing the up arrow until it is above the other columns on the list. Then choose which column you would like to sort second, third, etc. Continue ordering the columns until

1. The data must first be arranged so that the column that will be sorted first is to the left of the column that will be sorted second. In this example, we will sort first by name and then by Area. The name and area columns will thus be furthest to the left.

2. Click the header of the column to sort first.

3. Press the control button on the keyboard followed by the column that will be sorted second. Continue this step until all desired columns have been selected.

4. Right-click the heading of one of the selected columns and select either “sort ascending” or “sort descending.”
all desired columns are selected and in the correct order.

3. An option also exists for case sensitive sorting. If this option is chosen, words beginning with capital letters will be placed on the top of the table while the same word in lowercase is placed at the bottom.

4. Click OK once all of the columns, orders, and options have been selected. The resulting table in our example shows the data sorted first by name and then by area.

4. The final step is to right-click on the heading of one of the selected columns and select either “sort ascending” or “sort descending.”

Other Considerations:
Calculating values for new fields using arithmetic or related tables-making field calculations

Pete Kane, Cornell University

This technical note compares the process for calculating values for new fields in database tables using ArcGIS and Manifold. Simple tables are used to illustrate the process.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGis (ArcMap)</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: Editor Toolbar</td>
</tr>
</tbody>
</table>

As an example, the active table in Manifold is used to convert the area of several lakes in a table from square miles to square kilometers.

1. Open up the table you wish to perform calculations on.
2. Click on a column heading and select add, then click active column.
3. In the Add Active Column dialog, choose a name for the desired function, a name for the new resulting column, and the appropriate computation control to determine when and how often the calculation is performed.
4. After you click OK in the active column dialog, a script window will appear. This is where you enter the appropriate formula to carry out your

As an example, the field calculator in ArcMap is used to convert the area of several lakes in a table from square miles to square kilometers.

1. Start an edit session by clicking on the tools menu from the toolbar and then “Editor Toolbar.”
2. Open the table you wish to perform calculations on.
3. On the editor toolbar, select “start editing.”
4. In the “start editing” window, select which folder or database you want to edit from. The calculations will be
desired task. When referring to a field such as area, it is important to reference it as:

```javascript
Record.Data("Area").
```

This is how you reference the records with active columns. Close the script window after the formula is complete.

5. After closing the script window, open the associated table, right-click on the newly formed column and choose re-compute. This will run the script and provide the results in the new column.

6. Use the fields and functions in the field calculator to build your desired calculation. In the example below, area is being converted from square miles to square kilometers.

5. Right-click on the field heading and select “calculate values.”
7. The resulting table shown below has been modified by a calculation, converting the area from square miles to square kilometers.

Other Considerations:
A simpler method is to use the transform toolbar in two steps:

First use the intrinsic fields to populate a new column

Then use the multiply feature to calculate the value.

Other Considerations:
Calculations may be faster outside of an edit session but the edit session is advantageous because it allows you to save changes.
Relating Data Files and Fields
Pete Kane, Cornell University

This technical note compares the process of relating data files and fields using both ArcGIS and Manifold GIS. Simple tables are used to help illustrate this process.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

As an example, we will use the lakes table to help illustrate the relate process by relating the lakes table to a table representing water pH.

1. Open the table that you would like related.

2. Click on the table menu and then on relations.

As an example, we will use the Lakes table to help illustrate the relate process by relating the lakes table to a water table listing the pH of each lake.

1. Right-click on the layer you would like to relate in the table of contents, and select "joins and relates" ->"relate."

2. In the relate window, choose the field to base the relate on as well as the table you wish to relate.

4. In the add relation dialog, choose the table you would like to relate and a field from each table that will be used to link the records. The relation is complete.

Other Considerations:

3. Click OK. The relation is complete.
Database Creation

Database creation functions are those functions required to convert spatial data into a digital form that can be used by a GIS. This includes digitizing features found on printed maps or aerial photographs and transformation of existing digital data into the internal format of a given GIS.

### Digitizing

*Jackie Grant, Cornell University*

This technical note compares the process for digitizing points, lines and polygons in Manifold and ArcGIS. Simple line drawings are used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

A map of parcel boundaries is displayed, and road centerlines are traced.

The *Tools* toolbar includes facilities for digitizing points, lines, and areas. To add features, simply enable the appropriate button and begin digitizing the features.

<table>
<thead>
<tr>
<th>Other Considerations</th>
<th>Other Considerations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manifold also includes facilities to snap features to existing points, lines, or polygons. Users can mix feature types together (i.e. points, lines, and polygons).</td>
<td>ArcGIS also includes facilities to snap features to existing points, lines, or polygons. Users cannot mix feature types together (i.e. points, lines, and polygons).</td>
</tr>
</tbody>
</table>
Assigning Topology

Identifying Intersection Points

Jerry Brian, Department of Applied Economics and Management, Cornell University

Stephen Shaw, Department of Biological and Environmental Engineering, Cornell University

This technical note compares the process for identifying the intersection points of overlapping lines. Simple line drawings are used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

As an example, a simple four-line drawing is created in Manifold.

1. Select the lines you want to intersect.
2. In the transform toolbar, select Intersection Points.

As an example, a simple four line sketch is created in ArcGIS.

Identifying intersection points of overlapping lines in ArcGIS requires 3 steps:

1. On the editor toolbar, click the tool palette dropdown arrow and click the intersection tool.

2. Position the crosshairs over the first segment you want to create an intersection.
with, and click.

A line extends from that segment across the map display so that you can see the first angle used to construct the point of intersection.

3. Position the crosshairs over the second segment and click.

A vertex or point is added at the implied intersection of the two segments.
Repeat as desired for other intersection points.

| Other Considerations: None | Other Considerations: This is a flexible method to selectively choose intersections. The user can also use the topology tools in ArcEditor to apply a more global approach. |
Creating a Polygon from Line Segments

Jerry Brian, Department of Applied Economics and Management, Cornell University
Stephen Shaw, Department of Biological and Environmental Engineering, Cornell University

This technical note compares the process for creating polygons from line segments. Simple line drawings are used to illustrate the process. For ArcGIS, the task assumes that the line segments were created as a feature class within a Geodatabase.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS (ArcCatalog)</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

As an example, a simple line drawing is created in Manifold.

1. Select all lines in the window.
2. In the Transformation Toolbar, select Bounded Areas from the dropdown menu.

This task uses a geodatabase with line features. (If you are starting with a shapefile, create a new geodatabase and export your shapefile as a new feature class to the geodatabase.)

1. In ArcCatalog, navigate to the geodatabase containing the line feature and right click on the data set containing your line feature.
2. In the dropdown menu, select New -> Polygon Feature Class from Lines…
3. Name your new Polygon feature class, and select a cluster tolerance for your line feature class.

Transformation Toolbar
3. Click *apply*. Three polygons are created within the boundaries of the lines.

A new feature class is added to the feature dataset, and is shown in ArcMap:
Correcting Topological Errors

*Eliminating Overlaps, Undershoots, and Dangles*

Jerry Brian, Department of Applied Economics and Management, Cornell University

Stephen Shaw, Department of Biological and Environmental Engineering, Cornell University

This technical note compares the process for finding, and correcting topological errors. A simple line drawing is used to illustrate the process.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
</table>
| Software: Manifold GIS  
Extensions: Surface Tools | Software: ArcGIS (ArcToolbox)  
Extensions: None |

For an example, a polyline line drawing is constructed to border several city blocks. The lines of the shapefile do not cleanly intersect.

Correcting all errors globally would require using the function *Normalize Topology* using the Transform Toolbar.

A second approach allows the user to visit each error:

1. Under Drawing -> Topology Factory,
open the topology factory dialog.

Each error can be visited one at a time and fixed if desired.

With the Fix Topology Error Tool open, a drop down menu provides operations to fix the given error such as “Snap,” “Trim,” or “Extend.”

Other Considerations:

How do I do that in ArcGIS/Manifold
© Arthur J. Lembo, Jr.
Import and Export
Importing database tables, raster data, and vector data
Rebecca L. Loughner, Department of Entomology, Cornell University

This technical note compares the process for importing database tables, raster data, and vector data using both ArcGIS and Manifold GIS. Data for this example includes a digital orthophotograph in Ithaca, New York (TIFF file), and the database and shape file for U.S. counties.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: none</td>
<td>Extensions: none</td>
</tr>
</tbody>
</table>

1. Database tables, raster data, and vector data are all imported under File → Import.

   a) To import database tables, select “Table.”

   ![Manifold Process Image]

   Select the type of file to be imported and the specific file.

   ![ArcGIS Process Image]

   a) In ArcMap right click on the layers label and select Add Data. The imported file is listed under layers, and select the appropriate data set.
The filename will appear in the Properties window. Click on the file name to open a window containing the dataset.

b) To import raster data, right click on the layers label to bring up the Add Data window. Select the file to add.

b) To import raster data, select “Image” or Surface depending upon the format you are interested in.

This will add the raster dataset in the ArcMap window.
Select and open the file as with the database table.

c) To import vector data, select “Drawing.”

Select the file to import and the specific fields to be imported by checking boxes in the dialog window.

c) To import vector data, the add data button will allow you to open shapefiles, coverages, or geodatabases. Other formats will require the use of ArcToolbox.

Open ArcToolbox and select the tool for the type of file that requires conversion to ArcGIS, such as a digital linegraph.

Open the wizard for the particular file conversion and enter the input file and the coverage information (depending on the data file format, the wizard may present a slightly different, yet easy to follow interface).

The data can then be opened in ArcGIS.
Imported files are shown in the Project window in Manifold. Select and open the file like you did with the database table.

2. Recognized file types under database tables, raster data, and vector data include:

a) **Database tables**: CSV, DB, DBF, OLE and ODBC DB tables, HTML, MDB, UDL, WKx, and XLS

b) **Raster data** (Image option in Manifold): BMP, CADRG/CIB, DOQ, ECW, EMF, ENVI IMG, ERDAS IMG, ERMappper ERS, GIF, HDF, JPEG, NITF, PCX, PNG, PPM, SGI, SPOT, SRTM, SUN, TGA, TIFF

c) **Raster data** (surface option in Manifold): ADF, AVHRR, CEOS, SeaWiFS Satellite, CTG, LULC CTG, DAT, SPOT,DDR, LAS, DEM, STDS, DEM GLOBE, GTOPO30, DTED, E00, ENVI, ERDAS IMG, ERMapper, ESRI ASCII Grid, ESRI Fload Grid, GeoSPOT, GRASS, SeaWiFS, ENVI IMG, IDRISI, SDTS SRTM Space Shuttle terrain, Surfer GRD, MapInfo TAB grid files, Generic XYZ

d) **Vector data** (Drawing option in manifold): BNA, CSV, DB, DBF, DGN, DLG, DSN, DWG, DXF, E00, GDF, GML, HTML, IDRISI VCT, LULC GIRAS, ETAK MapAccess, ETAK MapBase, MDB, MFD, MIF, MWS, NTAD, NTF, SDTS, SHP, TAB, TAIF, TIGER/Line, UDL, VMAP, WKx, XLS

**Other Considerations:**

Database table files also may be linked from their original locations rather than imported into the Manifold .map file by going to File → Link → Table. This may

<table>
<thead>
<tr>
<th>Other Considerations:</th>
<th>Other Considerations:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text files may be converted to database format (DBF) in ArcCatalog, or added as event themes in ArcGIS.</td>
<td>Text files may be converted to database format (DBF) in ArcCatalog, or added as event themes in ArcGIS.</td>
</tr>
<tr>
<td>be advantageous if the data file is particularly large or if the file will be modified outside of Manifold.</td>
<td></td>
</tr>
<tr>
<td>--------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Manifold 6.0 also reads Geodatabase (MDB), and OGC WKB databases.</td>
<td></td>
</tr>
</tbody>
</table>
**Data Manipulation and Analysis**

Data manipulation and analysis functions provide the capability to selectively retrieve, transform, restructure, and analyze data.

**Retrieval** options provide the ability to retrieve either graphic features or feature attributes in a variety of ways. **Transformation** includes both coordinate/projection transformations and coordinate adjustments. **Data restructuring** includes the ability to convert vector data to raster data, merge data, compress data, reclassify or rescale data, and contour, triangulate, or grid random or uniformly spaced z-value data sets.

**Analysis** functions differ somewhat depending on whether the internal data structure is raster or vector based. Analysis functions provide the capability to create new maps and related descriptive statistics by reclassifying and combining existing data categories in a variety of ways. Analysis functions also support: replacement of cell values with neighboring cell characteristics (**neighborhood analysis**); defining distance buffers around points, lines and areas (**proximity analysis**); optimum path or route selection (**network analysis**); and generating slope, aspect and profile maps (**terrain analysis**).
Data Retrieval
Dehui Wei, Department of City and Regional Planning, Cornell University

This technical note compares different data-selecting methods in both ArcGIS and Manifold GIS. A vector parcel map representing the City of Ithaca and a raster DEM of the Ithaca East Quadrangle are used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: none</td>
<td>Extensions: none</td>
</tr>
</tbody>
</table>

**Select by Graphic Window:**

1. On the “Selection” toolbar choose the “Select Box” button, and draw a graphic window on top of the “parcels” layer. Parcels overlapping with the window drawn will be selected.

**Other Considerations:**

Manifold can also perform selecting by graphic window on raster data.

**Select by Graphic Window:**

1. Use the “Select Features” button on the “Tools” toolbar and draw a graphic window on top of the polygon map in view window. Polygons overlapping with the window drawn will be selected.

**Other Considerations:**
- Draw a box on the layer in the map window and make a copy by pressing Ctrl+C.

- Right-click in the Project Pane and select “Paste”. A new raster layer will be added.
1. Select the “Create Areas” button then “Insert Box” or “Insert Circle” on “Tools” toolbar and draw a box or a circle on top of the “parcels” layer in “Map” window and select it.

2. On the “Transform” toolbar, select “All Objects in Parcels” ➔ “Select Intersecting” ➔ “Selection in Parcels”.

1. Click “New Rectangle” or “New Circle” button on the “Draw” toolbar and draw a rectangle or a circle on top of the polygon features in the view window.

2. Keep the rectangle or circle selected and go to menu “Selection”, then “Select By Graphics”. Polygons overlapping the rectangle or circle will be selected.
4. Selection options can be changed by choosing different options on “Transform” toolbar.

4. Go “Selections” → “Options…” to change selection options if desired.
Raster Analysis

Select data by area masks

Dehui Wei, Department of City and Regional Planning, Cornell University

This technical note compares the process for clipping out sections of a raster data set using both ArcGIS and Manifold GIS. A digital elevation model for the Ithaca East Quadrangle, and a polygon map representing northeast corner of the quad sheet are used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: Surface Tools</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, both the DEM and polygon map must be loaded into Manifold.

Clipping out the DEM requires three steps:
1. Select the polygon map
2. Under View->Transfer Selection select the individual pixels that fall within the polygon

To perform the analysis, both the DEM and the polygon map must be loaded into ArcMap.

Clipping out the DEM requires two steps:
1. Under the spatial analysis options, set the analysis mask to the polygon map
3. Right click in the project pane to paste the selected features into a new surface.

2. In the raster calculator, select the IEDEM grid and press Evaluate. A new grid will be produced.

Other Considerations:
Alternatively, a user can use the mouse to select any irregular shape they want (as shown below), or use points, lines, areas or another raster dataset to select raster grids. The datasets must reside within the Manifold project file.

Other Considerations:
Alternatively, the user can select any geographic dataset they want, either points, lines, polygons, or another raster dataset.

However, the user cannot use a mouse to draw areas to select, copy, or paste the raster features.

The datasets do not have to exist within the ArcMap project file, but can reside elsewhere on the disk.
Data Restructuring
Convert from raster to vector
Ben Liu, Biological & Environmental Engineering, Cornell University

This technical note compares the process for converting raster data into the vector format. An aquifer map for the Ithaca East Quadrangle is used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold System 6.00</td>
<td>Software: ArcGIS 8.3</td>
</tr>
<tr>
<td>Extensions: none</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

Manifold is not able to perform this procedure for categorical data in a batch mode. However, the Trace Area function on the Tracing toolbar is able to convert features on a one-by-one basis with some manual effort.

A grid must be loaded in ArcMap.

1. In the Spatial Analysis Toolbar, select Convert -> Raster to Features…

2. Select the appropriate field to use for the vector attribute (only one field will be transferred) and the feature type.
The Generalize lines option will smooth lines to avoid jagged edges.

The resulting vector map is shown below.
Convert from vector to raster
Ben Liu, Biological & Environmental Engineering, Cornell University

This technical note compares the process for converting vector/drawings into the raster/surface format. An aquifer map for the Ithaca East Quadrangle is used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold System 6.00 Extensions: none</td>
<td>Software: ArcGIS 8.3 Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

The vector drawing must be loaded in Manifold.

1. In the Tools Menu, select Make Image… (or use hotkey F6).

The resulting image (left) is shown below next to the original raster:

A vector feature must be loaded in ArcMap.

1. In the Spatial Analysis Toolbar, select Convert -> Features to Raster…

2. Select a field to assign the value in the new raster.

A temporary file is created unless a file name and location are specified for the Output raster. The default output is an ESRI GRID, but TIFF or ERDAS...
The user can select the image and copy it as a surface.

IMAGINE formats may be chosen.

The resulting raster map is shown below.
Modify raster cell size by resampling

Ben Liu, Biological & Environmental Engineering, Cornell University

This technical note compares the process for changing cell sizes in a raster/surface. An aquifer map for the Ithaca East Quadrangle is used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold System 6.00</td>
<td>Software: ArcGIS 8.3</td>
</tr>
<tr>
<td>Extensions: none</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

The surface must be loaded in Manifold.

| A grid must be loaded in ArcMap. |

1. In the Surface Menu, select Resize…

2. Select the Method of resampling and the desired resolution of the map:

   ![Resize dialog](image)

   The default Method, bicubic, normally gives the best results for distributed data, such as temperature, while the

   nearest neighbor method is often used for categorical data, such as land cover.

   ![Resample expression](image)

1. In the Spatial Analysis Toolbar, select Raster Calculator…

2. In the main window of Raster Calculator, type in the expression:

   ```
   resample(<grid>, {cellsize}, {method})
   ```

   where

   - `<grid>` is the raster map (required);
   - `{cellsize}` is the desired cell dimension;
   - `{method}` is the resampling algorithm.
nearest neighbor should be chosen for discrete data such as land use (where values must fall within a given set).

In the example, a surface of resolution 255 x 333 was resized to 53 x 70 pixels as shown below. This corresponds to a cell size increase from 42 to 200.

The default resampling algorithm is NEAREST neighbor, but BILINEAR and CUBIC interpolations in addition to extended neighbor SEARCH can be specified (extended information can be found in the software’s Spatial Analyst Functional Reference help).

In the example, raster cell size was increased from 42 to 200 as shown below.

Other Considerations:
Area currently represented by one pixel (Local scale) can be found by right clicking on the surface in the Project Pane and choosing Projection…

Other Considerations:
The area represented by one pixel (cellsize) can be found by right clicking on the raster in the table of contents and choosing Properties…
Data Restructuring

*changing raster values by selected area*

Zachary M. Easton, Department of Biological and Environmental Engineering, Cornell University

This technical note compares the process for changing raster values in a DEM for selected areas using both ArcGIS and Manifold GIS. The data used in this example includes the digital elevation model for the Ithaca East Quadrangle.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS (ArcMap, Arc Catalog)</td>
</tr>
<tr>
<td>Extensions: Surface Tools</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis the DEM is loaded into Manifold.

1. On the tool bar select the type of shape desired, (select touch, shape freeform, box, etc). For this example the freeform tool is used to select the area containing Beebe Lake.

Changing raster values for selected areas involves:

1. Display the grid you want to edit in ArcMap and in Arc Catalog create a new point or polygon theme. This example uses a polygon theme.

2. Click on the new polygon layer in Arc Map, and then in the editor toolbox click start editing, edit polygon. Digitize points or polygons over the individual/groups of cells you want to edit (here we made a new polygon over Beebe Lake).
3. Under the Surface menu select the transform option, and in the transform dialogue box choose selection under scope and select the DEM as the surface.

4. Enter the value (single value or a function) that you wish to change the selected area to.

3. Open the value attribute table and create a "value" column or similar column in the new theme's table with the appropriate replacement cell values.

4. Using Spatial Analyst convert the theme to a grid using the "value" column. Make sure the extent and pixel size of the new grid is the same as the grid you want to edit (DEM).
5. Click on the box “save results as new component” to create new grid. Hit OK to perform calculation.

New DEM is created containing the adjusted values in the area we created the polygon.

5. In the Map Calculator use the "con" request (See ArcGIS Help) to conditionally replace the original grid values with the values in the new grid you've just created. You will need to only replace with the values that are not equal to NULL in the new grid.

```
Con(IsNull(newGrid), (originalGrid, newGrid))
```

The new surface should appear with the adjusted values in place of the original.
How do I do that in ArcGIS/Manifold

48

© Arthur J. Lembo, Jr.
Changing raster values by geographic feature
Zachary M. Easton, Department of Biological and Environmental Engineering, Cornell University

This technical note compares the process for changing raster values in a DEM by a geographic feature in both ArcGIS and Manifold GIS. The data used in this example includes the digital elevation model for the Ithaca East Quadrangle and the wetlands polygon coverage.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: Surface Tools</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, both the DEM and the polygon map (wetlands) must be loaded into Manifold.

To perform the analysis, both the DEM and the polygon map (wetlands) must be loaded into ArcMap.

Changing raster values by geographic feature involves:

1. Open the DEM and the layer with geographic feature in the same map (in this case we will modify the DEM where it intersects with wetlands).

2. Make sure the wetlands base map is the active layer and select (by clicking on it) the layers polygons (wetlands).

We must first clip out the DEM values with the wetland coverage. This requires two steps:

1. Under the spatial analysis options, set the analysis mask to the wetlands map.
3. Under the Drawing menu, select Transfer selection, and in the dialog box make sure that you are modifying the wetlands using the DEM.

4. In the surface transform dialog box, update the selected features in the DEM. In this example, we will multiply the height by 10.

6. The raster will contain adjusted raster values (in this case the original values * 10).

2. In the raster calculator, select the DEM grid and press Evaluate. A new grid will be produced.

3. The wetlands will be clipped from the DEM with the elevation data attached.

4. In the raster calculator select the grid you created above, and apply a value or function to it (in this case we multiplied it by 10).
5. Again open the raster calculator and using the conditional statement combine the two grids.

6. The new surface should appear with the adjusted values in place of the original. In purple are the wetlands that now have an elevation 10 times higher than original.
Reducing Unnecessary Coordinates – Weeding
John Taber, Applied Economics and Management, Cornell University

This technical note compares the process for reducing coordinates within a vector object using ArcGIS and Manifold GIS. A single digitized line is used to illustrate the example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
<tr>
<td>Load the line feature to be edited.</td>
<td>Load the line feature to be edited into ArcGIS.</td>
</tr>
</tbody>
</table>

1. Select Drawing -> Simplify to choose the average distance between vertices

500 meters results in the following generalized line segment:

1. Start an editing session.

2. Under the Advanced editing tools, use the reduce tool (circled below) and enter the maximum allowed error.

First, an example with a 500 foot allowable error.
Whereas 5,000 meters results in:

Whereas 5,000 foot results in:

How do I do that in ArcGIS/Manifold

© Arthur J. Lembo, Jr.
**Smoothing Data to Recover Sinuosity**  
*John Taber, Applied Economics and Management, Cornell University*

This technical note compares the process for smoothing data to recover sinuosity of a line, using ArcGIS and Manifold GIS. A single digitized line is used to illustrate the example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

To smooth lines, select *Spline* from the Transform bar and enter the number of additional points to include on the line.

Start an editing session in ArcGIS.

Under the Advanced editing tools, use the smooth tool (circled below) and enter the maximum allowed error.

The first illustration uses a 50 foot allowable error.
The next illustration shows a 250 foot allowable offset.

Other Considerations:
A trade-off exists between how much the resulting data will resemble a perfectly smooth arc and how accurate it will be compared to the original line.
This technical note compares the process for creating a TIN (Triangulated Irregular Network) from point data using both ArcGIS and Manifold GIS. Elevation points corresponding to the Ithaca East Quadrangle are used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS (ArcMap)</td>
</tr>
<tr>
<td>Extensions: Surface Tools</td>
<td>Extensions: 3D Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, the layer containing the elevation points must be loaded into Manifold.

1. Open the layer, and select all elevation points using Ctrl+A. Copy the points using Ctrl+C.
2. Click the dropdown menu of the Paste tool in the project pane, and select Surface.
3. Click the Height dropdown arrow, and select the attribute for which you want to create a TIN.
4. Click the Method dropdown arrow, and select Triangulation (flat). Specify other desired parameters, and press OK.

To perform the analysis, the layer containing the elevation points must be loaded into ArcMap.

1. Click the 3D Analyst dropdown menu, and point to Create/Modify TIN – Create TIN from Features.
2. Check the box of the layer from which you want to create a TIN.
3. Click the Height source dropdown arrow, and select the attribute for which you want to create a TIN.
4. Specify other desired parameters, and type a name for the Output TIN. Press OK.
Other Considerations:

- The Set corner values to option can be used to interpolate the entire surface using the corner values as anchors.
- The datasets do not have to exist within the ArcMap project file, but can reside elsewhere on the disk.

- The datasets must reside within the Manifold project file.
Kriging from Point Data
Maria Vicenta Valdivia, Cornell University

This technical note compares the process for performing Kriging interpolation from point data using both ArcGIS and Manifold GIS. Elevation points corresponding to the Ithaca East Quadrangle are used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td></td>
</tr>
<tr>
<td>Extensions: Surface Tools (if using the auto-model approach), otherwise none</td>
<td></td>
</tr>
<tr>
<td>Software: ArcGIS (ArcMap)</td>
<td></td>
</tr>
<tr>
<td>Extensions: Spatial Analyst</td>
<td></td>
</tr>
</tbody>
</table>

To perform the analysis, the layer containing the elevation points must be loaded into Manifold.

1. Open the layer, and select all elevation points using Ctrl+A. Copy the points using Ctrl+C.
2. Click the dropdown arrow of the Paste tool in the project pane, and select Surface.
3. Click the Height dropdown arrow, and select the attribute you want to interpolate.
4. Click the Method dropdown arrow, and select Kriging. Specify the number of neighbors, the Kriging model, and other desired parameters. Press OK.

To perform the analysis, the layer containing the elevation points must be loaded into ArcMap.

1. Click the Spatial Analyst dropdown menu, and point to Interpolate to Raster - Kriging.
2. Click the Z value field dropdown arrow, and select the attribute you want to interpolate.
3. Select the Kriging Method and Semivariogram Model.
4. Specify the number of neighbors, and other desired parameters.
5. Type a name for the Output raster, and press OK.
Other Considerations:

- The default *Model - Auto* setting allows Manifold to choose the best Kriging model in every case.
- The *Save error surface as* option allows saving an error surface.
- Processing time increases as more neighbors are included in the interpolation.
- The datasets must reside within the Manifold project file.

Other Considerations:

- Kriging interpolation can also be performed using the *Geostatistical Wizard* tool in the *Geostatistical Analyst* extension. This extension allows for more advanced geostatistical modeling of data.
- Processing time increases as more neighbors are included in the interpolation.
- The datasets do not have to exist within the ArcMap project file, but can reside elsewhere on the disk.
Generate Contour Data from Points

Maria Vicenta Valdivia, Cornell University

This technical note compares the process for generating contour data from points using both ArcGIS and Manifold GIS. Elevation points corresponding to the Ithaca East Quadrangle are used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
</table>
| Software: Manifold GIS  
Extensions: none | Software: ArcGIS (ArcMap)  
Extensions: Spatial Analyst |

To perform the analysis, the layer containing the elevation points must be loaded into Manifold.

1. Open the layer, and select all elevation points using Ctrl+A. Copy the points using Ctrl+C.
2. Click the dropdown menu of the Paste tool in the project pane, and select Surface.
3. Click the Height dropdown arrow, and select the attribute you want to interpolate.
4. Click the Method dropdown arrow, and select the interpolation method (Kriging will be used in this example).
5. Specify the desired parameters, and press OK.

To perform the analysis, the elevation points must be loaded into ArcMap.

1. Click the Spatial Analyst dropdown menu, and point to Interpolate to Raster. Select the interpolation method (Kriging will be used in this example).
2. Click the Z value field dropdown arrow, and select the attribute you want to interpolate.
3. Specify the desired parameters. Type a name for the Output raster, and press OK.
6. Open the interpolated surface, and under Surface tools, select Contours.

7. Click the Create dropdown arrow, and select lines.
8. Erase the default values in the Heights box. Click the Add Sequence button, and type values for Offset and Step. Press OK.

4. Click the Spatial Analyst dropdown menu, and point to Surface Analysis - Contour.

5. Specify the Contour interval and Base
How do I do that in ArcGIS/Manifold

**Other Considerations:**

- Contours cannot be generated directly from data points. An interpolated surface must be created first.
- Contours for specific elevations in a surface can be created clicking the Add button on the Contours dialog box.
- The datasets must reside within the Manifold project file.

**Contour.** Leave Z factor as 1.

6. Type a name in Output features for the output layer. Press OK.

**Other Considerations:**

- Contours cannot be generated directly from data points. An interpolated surface must be created first.
- Alternatively, contours can be created using the 3D Analyst extension, following the process described above.
- Contours for specific locations in a surface can be created using the Create Contours tool on the Spatial Analyst and 3D Analyst toolbar.
- Optionally, a Z factor different than 1 can be used if the z units of the surface are not the same as the x,y units.
• The datasets do not have to exist within the ArcMap project file, but can reside elsewhere on the disk.
Generate Contour Data from Raster

Maria Vicenta Valdivia, Cornell University

This technical note compares the process for generating contours from raster data using both ArcGIS and Manifold GIS. The data used in this example is the DEM (Digital Elevation Model) of the Ithaca East Quadrangle.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS (ArcMap)</td>
</tr>
<tr>
<td>Extensions: Surface Tools</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, the DEM must be loaded into Manifold.

1. Open the DEM, and under Surface tools, select Contours.
2. Click the Create dropdown arrow, and select lines.
3. Erase the default values in the Heights box. Click the Add Sequence button, and type values for Offset and Step. Press OK.
4. Press OK in the Contours dialog box.

To perform the analysis, the DEM must be loaded into ArcMap.

1. Click the Spatial Analyst dropdown menu, point to Surface Analysis - Contour.
2. Specify the Contour interval and Base contour. Leave Z factor as 1.
3. Type a name in Output features for the output layer, and press OK.
Other Considerations:

- Contours for specific elevations in a surface can be created by clicking the Add button on the Contours dialog box.
- Processing time increases as more contour lines are generated.
- The datasets must reside within the Manifold project file.

Other Considerations:

- Alternatively, contours can be created using the 3D Analyst extension, following the process described above.
- Contours for specific locations in a surface can be created using the Create Contours tool on the Spatial Analyst and 3D Analyst toolbar.
- Optionally, a Z factor different than 1 can be used if the z units of the surface are not the same as the x,y units.
- The datasets do not have to exist within the ArcMap project file, but can reside elsewhere on the disk.
**Data Transformation**  
**Mathematical transformation of raster data**  
Zhilin Liu, Department of City and Regional Planning, and Elizabeth Goulet, Department of Entomology, Cornell University

This technical note compares the process of coordinate transformation for raster data using both ArcGIS and Manifold GIS. Spatial transformation is used to convert data from a digitized image or scanned map to real world coordinates. However, it can also be used to convert vector data from one coordinate system to another, or rubbersheet vector data to improve positional fit with other layers. The mathematical adjustment is based on the comparison of coordinates in a set of control points. The data used in this example includes the shapefile of road lines in the Ithaca East Quadrangle (Roadsl.shp) and a scanned map file (Sketch.jpg).

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Software:</strong> Manifold GIS</td>
<td><strong>Software:</strong> ArcGIS</td>
</tr>
<tr>
<td><strong>Extensions:</strong> None</td>
<td><strong>Extensions:</strong> None</td>
</tr>
</tbody>
</table>

### I. Preparing for spatial adjustment

**Manifold Process**

To perform the analysis, both the shapefile and the scanned map must be imported into Manifold.

**Notes:**

Both georegistration and spatial adjustment functions use Control Points tools through the same process in Manifold. It allows users to assign a coordinate system to an image or a scanned map, as well as transform

**ArcGIS process**

To perform the analysis, both the shapefile and the scanned map (JPEG file) must be added into ArcMap.

To georegister the scanned map:

vector data from the current coordinate system to another one.

2. Create two pairs of control points in source and destination layers by zooming between the two layers in the Table of Contents window. It can also be done manually by typing X/Latitude and Y/Longitude coordinates.

II. Start spatial adjustment
1. Under View --> Panes, click Control Points. The Control Point window opens to allow spatial registration and adjustment.

II. Start spatial adjustment function
1. Under View --> Toolbars, click Editor and Spatial Adjustment toolbar to add them into ArcMap.

III. Set up spatial adjustment:
Spatial adjustment in Manifold requires 2 steps:
1. With LC_image (the JPEG file) active, click New Control Point under Control Points toolbar. Create one control point in the LC_image map. Click the Roads.

III. Set up spatial adjustment
Spatial adjustment in ArcMap requires 4 steps:
Create a corresponding control point through the same process.

Repeat the above step to get a minimum of 30 pairs of control points to conduct the rubbersheeting function.

2. Under Control Points toolbar, click Register. Make sure the shapefile is activated. Choose the preferred method then click OK.

2. Set transformation method as rubbersheet: under Spatial Adjustment toolbar --> Adjustment Methods, click Rubbersheet.

3. Create displacement links: here we are adding 30 displacement links, i.e. 30 pairs of control points.

Notes: users may zoom in and out to make control points more precise without deactivating the Links tool.

4. Under Spatial Adjustment toolbar, click
Adjust. This will apply the rubbersheet transformation to Roads – the vector data in this example.

Other considerations:
Three methods of adjustment are offered, including Affine, Numeric, and Similarity. The above example uses Numeric with 30 control points. Affine method requires a minimum of three control points, whereas similarity method requires only two.

Other considerations:
1. Rubbersheeting allows us to correct more chaotic and small-scale warping and shifting of spatial data. It requires many links to “rubbersheet” data through geometric transformation. Alternatively, users can choose Simple adjustment and polynomial adjustment through a similar process.
2. To conduct a simple adjustment, click Transformation-Similarity instead of rubbersheet in Step III-2. It requires a minimum of two displacement links. To conduct polynomial adjustment, users may choose the Transformation-Affine method. This requires a minimum of three displacement links.
Projection definition and coordinate transformation
Elizabeth Goulet, Department of Entomology, and Zhilin Liu, Department of City and Regional Planning, Cornell University

This technical note compares the process for defining a map projection and performing a coordinate transformation using both ArcGIS and Manifold GIS. The map used in this example is a roads shapefile from the Ithaca East Quadrangle.

<table>
<thead>
<tr>
<th>Manifold process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

To perform this process, right click on the map layer in the project window. Select projection.

A Target Projection window will appear. IMPORTANT! Click on the current projection button. A Current Projection window appears.

To perform this process, Arc Toolbox is used.

Open Arc Toolbox -> Data Management Tools -> Projections. Select Define Project Wizard for the appropriate map type. This example uses a shapefile.

In the Define Projection Wizard window, click on the selection folder and navigate to the map you want to project in the Add data window.

Scroll to the desired projection – in this case Universal Transverse Mercator - and select the appropriate zone. NOTE: Check to see if the datum and units are...
How do I do that in ArcGIS/Manifold 71

© Arthur J. Lembo, Jr.

correct in the selection boxes below the projection before selecting the zone. Change if necessary. In this case we change to NAD 1927 mean conus.

Click OK in both the current projection and target projection windows.

the Browse for Coordinate System window, open Projected Coordinate Systems -> UTM, and the folder for the datum you want to use. Now select the UTM zone for your map.

The Spatial Reference Properties window now shows the coordinate system details for the selected projection.

Click OK.

The Define Projection Wizard will now appear with the coordinate information.
To transform a projected map to a different coordinate system, use the same process as for defining projection but do not press the "Current Projection" button.

A Project Wizard box appears. The selection process is the same as in the Define Projection Wizard.

To change a layer from UTM to SPC, select the UTM layer in the Project Wizard. Click next. The wizard now requests an output location for the new file you are creating. In the Select a
destination window, navigate to the output file and name your map.

Save the file, and click Next on the Project Wizard. The wizard will prompt the user to select a coordinate system. The selection process is the same as in Define Projection Wizard.

For SPC, open Projected Coordinates-> State Plane, and select the datum.

For Ithaca East, use NAD1983 datum, and add State Plane New York Central projection. The Spatial Reference Properties window appears with the new coordinate information. The process now finishes the same as in defining a projection.

Other considerations:
The user can check current projection of any layer in its properties. Projection will be latitude/longitude on an undefined map.

ArcMap allows on-the-fly projections.

The user can check current projection of any layer in the properties, under the source tab in the data source window.

The Define Projection Wizard for coverages, grids and TINs allows you to define a coordinate system interactively, or to define the coordinate system for your data to match that of an existing data.

ArcMap allows on-the-fly projections but will not have as much accuracy as using the projection wizard.
Vector Overlay  
**Polygon in polygon overlay**  
*Megan Y. Lew, Cornell University, Dept. of Natural Resources*

This technical note compares the process for overlaying two polygon vector layers in both ArcGIS and Manifold GIS. This example overlays wetland polygons (14 polygons) and aquifer polygons (17 polygons) for the USGS Ithaca East quadrangle in Tompkins County, New York.

<table>
<thead>
<tr>
<th>Manifold GIS Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS 8.x</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

To perform the analysis, load the wetland and aquifer polygon files into a new Project and a new Map.

The overlay is completed by using the Topology Overlay command.

1. Transfer rules must be specified for each attribute table field to be transferred between the two layers. Open both tables. Under the Table menu, select “Design.” A dialogue box will open; specify rules for fields that you want to transfer. (this step may be avoided by setting all the transfer rules to a specific type under the *Tools -* >*Options* menu).

To perform the analysis, load the wetland and aquifer polygon files into ArcMap.

The overlay is completed using the GeoProcessing Wizard.

1. Under the Tools menu, select “GeoProcessing Wizard”.
2. The GeoProcessing Wizard dialogue box will appear. Select “Union two layers”, and click “Next”.
3. Select the wetland layer as the input layer. Select the aquifer layer to be the overlay. Give a name and location to the output shapefile.
2. With the map activated, under the Drawing menu, select Topology Overlay.
3. In the dialogue box that appears, input the source file (wetlands) and the target file (aquifers). Select “Union (areas-areas)” under Method. Click “OK”. The overlay will be completed in the original target file or a new file will be created with the overlay, depending if the “Save results as new component” box is checked.

Other considerations:
- Setting the transfer rules allows users to select the columns they want transferred in the overlay. Also, transferred values from the table can be copied, averaged, summed, etc.
- The output of the overlay can be saved to a new file or completed in the original target file.

4. Click “Finish” and a new shapefile with the overlaid polygons will be created.

Other considerations:
- The Union command in the GeoProcessing Wizard transfers all table columns from one layer to the other. Also, values are copied; users cannot specify to take the average, sum, etc. of numeric values.
- The GeoProcessing Wizard creates a new file with the results of the overlay.
Point in polygon overlay
Megan Y. Lew, Cornell University, Dept. of Natural Resources

This technical note compares the process for overlaying a point and vector polygon layer in both ArcGIS and Manifold GIS. This example uses soil samples (146 points) and a uniform rectangular polygon layer (6 polygons) for a land parcel in Freeville, New York.

<table>
<thead>
<tr>
<th>Manifold GIS Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS Extensions: None</td>
<td>Software: ArcGIS 8.x Extensions: None</td>
</tr>
</tbody>
</table>

To perform the analysis, load the point and polygon layers into a new project and a new map.

The overlay is completed by:

1. Copy and paste one of the soil sample points into the polygon map. This will transfer the attribute table fields from one layer to the other. Delete the soil sample point from the polygon map when the table transfer has completed.
2. Transfer rules must be specified for each attribute transferred between the two layers. Open both tables. Under...

The overlay is completed in one step using a spatial join.

1. In the table of contents, right click with the mouse over the name of the polygon file. Click on “Joins and Relates”, then “Join…”
2. The “Join Data” Dialogue box appears.
   a. Select “Join data from another layer based on spatial location.”
   b. In Question 1 select the soil
the Table menu, select “Design”. A dialogue box will open; specify rules for fields that you want to transfer.

3. Under the Drawing menu, select “Spatial overlay”. In the dialogue box that appears, select the soil sample points as the source and the polygon layer as the target. The method is “points to containing areas”. Click “OK”. The polygon drawing will yield the results of the spatial overlay.

sample point data as the input layer to join to the file.

c. In Question 2 select how the attribute data from the soil sample point layer will be transferred to the polygon layer.

d. In Question 3 give a name to the output file with the completed overlay.

e. Click “OK” and a new file with the overlay will be produced.
### Other considerations:
- Setting the transfer rules allows users to select the columns they want transferred in the overlay. Also, transferred values from the table can be copied, averaged, summed, etc.
- The spatial overlay is completed on the original file. The results of the overlay are not found in a new file. It is best to make a copy of the original file before beginning the overlay process.

### Other considerations:
- All columns from the point file attribute data are transferred to the output file after the join.
- The join command creates a new file with the results of the overlay.
Topological intersection
Megan Y. Lew, Cornell University, Dept. of Natural Resources

This technical note compares the process for intersecting two polygon vector layers in both ArcGIS and Manifold GIS. This example uses wetland polygons (14 polygons) and aquifer polygons (17 polygons) for the Ithaca East USGS quadrangle in Tompkins County, New York.

<table>
<thead>
<tr>
<th>Manifold GIS Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS 6.0</td>
<td>Software: ArcGIS 8.x</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

To perform the analysis wetlands and aquifers are loaded in Manifold.

The intersection is completed by using the Topology Overlay command.

1. Transfer rules must be specified for each attribute table field to be transferred between the two layers (or just set the default to copy/copy). To set the transfer rules, open both tables, and under the Table menu, select “Design”. A dialogue box will open, allowing you to specify the transfer rules for each of the fields.
2. With map activated, under Drawing menu, select Topology Overlay.
3. In the dialogue box that appears, input

The intersection is completed in one step using the GeoProcessing Wizard.

1. Under the Tools menu, select “GeoProcessing Wizard”.
2. The GeoProcessing Wizard dialogue box will appear. Select “Intersect two layers”, and click “Next”.

How do I do that in ArcGIS/Manifold

80
© Arthur J. Lembo, Jr.
the source (wetlands) and target (aquifer) files. Select the method “Identity (areas, lines and points – areas)”. Click “OK”. The intersection will be completed in the original target file or a new file will be created with the overlay, depending if the “Save results as new component” box is checked.

3. Select the aquifer layer as the input layer. Select the wetland layer to be the overlay layer. Give a name and location to the output shapefile.

4. Click “Finish” and a new shapefile with the intersecting polygons will be created.
<table>
<thead>
<tr>
<th>Other considerations:</th>
<th>Other considerations:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Setting the transfer rules allows users to select the columns they want transferred in the overlay. Also, transferred values from the table can be copied, averaged, summed, etc.</td>
<td>• The Intersect command in the GeoProcessing Wizard transfers all table columns from one layer to the other. Also, values are copied; users cannot specify to take the average, sum, etc of numeric values.</td>
</tr>
<tr>
<td>• The output of the overlay can be saved to a new file or completed in the original target file.</td>
<td>• The GeoProcessing Wizard creates a new file with the results of the intersection.</td>
</tr>
</tbody>
</table>
# Line in polygon

Zachary M. Easton, Biological and Environmental Engineering, Cornell University

This technical note compares the process of line in polygon overlay in both ArcGIS and Manifold GIS. The data used in this example includes a watershed and road vector file for Ithaca, NY.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td></td>
</tr>
<tr>
<td>Extensions: Surface Tools</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: Spatial Analyst</td>
<td></td>
</tr>
</tbody>
</table>

To perform this analysis we will need two vector files: one polygon (a watershed) and one line file (roadways).

1. In the transform toolbar select all objects in roads, clip with intersect and all objects in the watershed polygon. Hit apply.

2. Roads are now clipped to the extent of the watershed boundaries. However, they are not contained in the same polygon.

To perform this analysis we will need two shape files: one polygon (a watershed) and one line shape file (roadways). Make them both active in the view.

1. Click the Tools menu and click GeoProcessing Wizard and select Clip one layer based on another. Click next.

2. Click the Input layer dropdown arrow and select a layer to clip—in this case, roads.

3. Click the Polygon overlay layer you want to clip features with—in this case, the
watershed. Click Finish.

4. Before overlay of a line in polygon can be accomplished, we must first make sure that both layers are of the same type (i.e. shapefiles). In Arc toolbox select create personal Geodatabase and create a new data base. Return to Arc Toolbox and select Export form shapefile> shapefile to coverage, and convert the watershed shapefile polygon to a coverage. Repeat this process for the clipped coverage containing the roads clipped to the extent of the watershed.

5. Add these new coverages to the project by selecting the correct file in the new personal geodatabase you have created (double click), and select the arc coverage files.
This technical note compares the process for performing mathematical operations on one raster using both ArcGIS and Manifold GIS. The data used in this example includes the digital elevation model for the Six Mile Creek. Note: the data sets used may not reflect the most appropriate sources to apply these functions, and are only used to illustrate the methods for performing the functions.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: Surface Tools</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, one DEM must be loaded into Manifold.

Calculating Sine, Cosine, and the Exponent of one raster requires 4 steps:
1. Under the Surface Menu, select Transform.
2. In the Formula box, type in ‘Sin’ and opening parentheses. Then double-click on one raster in the Surface box to enter it into the Formula box and type in the closing parentheses. Example: Sin([Nbi Image]).

To perform the analysis, one DEM must be loaded into ArcMap.

Calculating Sine, Cosine, and the Exponent of one raster requires 3 steps:
1. Under the Spatial Analyst toolbar, select the raster calculator, and click the Advanced button.
2. Click on the trigonomic function ‘Sin’
3. Put a check mark where it says ‘Save result as new component’ in order to create a new and separate map.

4. Then click OK. The calculation will automatically be entered in as a new layer, but you will need to double-click on it for it to be displayed. You may want to rename it to identify the new raster calculation properly.

and then double-click on a raster in the Layer box to enter it into the Formula box (to calculate cosine, or the exponent of a raster, click on the trigonometric function ‘Cos’ or the logarithm ‘Exp’, respectively).

3. Then click Evaluate. The calculation will automatically be entered in as a new layer. This calculation is currently in a temporary file. If you want to make it permanent, right click on it and select ‘make permanent’. Follow the steps to save it where you like and rename it.
Mathematical operations on two rasters
Adding, Subtracting, Determining Maximum and Minimum
Jerry Brian, Dept of Applied Economics and Management
Megan Molique, Dept of Crop & Soil Sciences
Cornell University

This technical note compares the process for performing mathematical operations on two rasters using both ArcGIS and Manifold GIS. The data used in this example includes the digital elevation model for the Six Mile Creek. One should note that both systems allow the operations on even more than two rasters.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: Surface Tools</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, two DEM’s representing the same are loaded into Manifold.

Adding or subtracting or determining the min and max of two rasters requires 4 steps:
1. Under the Surface Menu, select Transform.

Adding or subtracting or determining the min and max of two rasters requires 3 steps:
1. Under the Spatial Analyst toolbar, select the raster calculator.
2. Double-click on one raster in the Surface box to enter it into the Formula box. To add, type in a + sign (to subtract, type in a – sign). Then double-click on the other raster.

- To determine Max and Min, in the Transform Dialog box, type in ‘Max’ and opening parentheses. Then double-click on one raster in the Surface box to enter it into the Formula box and type in the closing parentheses. Example: Max([Nbi Image],[Nti Image]). (To calculate Min, replace ‘Max’ with ‘Min’ in the formula.)

- Put a check mark where it says ‘Save result as new component’ in order to create a new and separate map.

- Then click OK. The calculation will automatically be entered in as a new layer, but you will need to double-click on it for it to be displayed. You may want to rename it to identify the new raster calculation properly.

3. Double-click on one raster in the Layer box to enter it into the Formula box. To add, type in a + sign (to subtract, type in a – sign). Then double-click on the other raster. To determine Max, * type in max=max( double click on one raster, type in a comma, and then double click on the other raster and close the parentheses. Example: max=max([nbi],[nti]). To determine Min, replace the word ‘max’ in the formula with ‘min’.

* Note: max= indicates the name of the file that will be created with the calculation. So If you have more than one Max to determine, you may want to be more specific with the name, such as: maxsixmile= max([nbi],[nti]).

4. Then click Evaluate. The calculation will automatically be entered in as a new layer. This calculation is currently in a temporary file. If you want to make it permanent, right click on it and select ‘make permanent’. Follow the steps to save it where you like and rename it.
Neighborhood Functions
Calculating Average, Minimum, Maximum and Most Frequent
Jerry Brian, Dept of Applied Economics and Management
Megan Molique, Dept of Crop & Soil Sciences
Cornell University

This technical note compares the process for performing mathematical operations on one raster using both ArcGIS and Manifold GIS. The data used in this example includes the digital elevation model for the Six Mile Creek.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: Surface Tools (only for Max value)</td>
<td>Extensions: Spatial Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, one DEM is loaded into Manifold. Copy, paste and rename DEM for analysis.

Calculating Average, requires 3 steps:
1. Under the Surface Menu, go to Effects and select Filter.

Calculating Average, Minimum, Maximum, and Most Frequent requires 1 step:
1. Under the Spatial Analyst toolbar, select the Neighborhood Statistics.
   - For input data: browse for a DEM you want to analyze.
   - For the Field, select <Value>, then choose the statistical type you want to determine: Mean, Minimum, Maximum or most frequent.
   - Select preferred neighborhood shape, and set the neighborhood setting accordingly.
   - Choose output cell size and name output raster to preferred file location.
How do I do that in ArcGIS/Manifold

2. Select ‘Low Pass1’ to calculate the mean. Click ‘Apply’ to update the matrix values.

3. The new layer will reflect new DEM with mean values.

Selecting the minimum or maximum value requires the creation of a formula in the Surface -> Transform dialog as follows:
Statistical Function
Calculating Areas, Perimeters and Lengths
John Taber, Applied Economics and Management, Cornell University

This technical note compares the process for calculating areas, perimeters, and lengths of objects using both ArcGIS and Manifold GIS.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

Load the feature to be updated into Manifold.

1. Create an area column (if none exists) in the feature attribute table.
2. Using the Transform toolbar, assign the new column with the Intrinsic value for area.

Updating the perimeter in a feature follows the same process.
Length(ID)

For this example, the area and perimeter fields will be re-created for the Wetlands feature.

1. Open the Attribute Table
2. Select (or add) the Area column
3. Right click on the column and choose calculate values
4. In the field calculator, click on advanced, and enter this code into the Pre-Logic VBA Script Code:
   ```vba
   Dim dblArea as double
   Dim pArea as IArea
   Set pArea = [shape]
   dblArea = pArea.area
   
   Under AREA= (or "your area column" =) enter dblArea.
   
   The Field calculator should now look like this:
   ```
6) Hit “OK”, and the column will be filled with the corresponding area values.

Adding Perimeter values works much the same way, with the following VBA Script Code:

```vba
Dim dblPerimeter as double
Dim pCurve as ICurve
Set pCurve = [shape]
dblPerimeter = pCurve.Length

Under “Perimeter =” enter “dblPerimeter”
```

The code for length is very similar:

```vba
Dim dblLength as double
Dim pCurve as ICurve
Set pCurve = [shape]
dblLength = pCurve.Length

Under “Length =” enter “dblLength”
```
Cross Tabulation of Two Data Categories  
*John Taber, Applied Economics and Management, Cornell University*

This technical note compares the process for creating a cross-tabulation matrix from two vector files using both ArcGIS and Manifold GIS. The data used in this example include two landcover files, one from 1968 and one from 1995.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
</table>
| **Software:** Manifold  
**Extensions:** None | **Software:** ArcGIS  
**Extensions:** Spatial Analyst |

Performing Cross-tabulation in Manifold requires loading the two relevant features into a map.  
1. Start the Topology Overlay tool under “Drawing.”  
2. Select one feature as the target and another as the source, set the method to “Union (areas-areas)” and click “Save result as new component”. This will create a new feature which is the union of the two features to be cross-tabulated.  

3. Create a query as follows:

   ```sql
   transform sum([Area(I)])
   select [Field1] from [Union feature] group by [Field1] pivot [Field2]
   ```

   In this case, Field1 is luse_gen and Field2 is lc, the columns describing land use for the two features in the final merged feature.

To perform a cross tabulation, the user must download and register the *tabulatearea.dll*. The instructions, provided by ESRI to perform this task are as follows:

1. Register DLL from ArcMap:  
   Click Tool/Customize, click button "Add from file" in the Customize dialog, navigate to the file TabulateArea.dll and click OK button. Click Commands tab in Customize dialog, find "SA Sample Tools" category, and then drag the TabulateArea command to a toolbar.  
2. Add the required layers into ArcMap, fill the parameters, then it is ready to run.

The tabulate area command requires that the themes are in raster format. Therefore, under the Spatial Analyst extension, select Convert -> *Features to Raster*, to create a raster dataset for both of the data sets.
This counts the area involved in each possible grouping of land use and creates a confusion matrix.

Under the tabulate Area button, enter both feature datasets:

The two raster datasets are compared, and a resultant cross tabulation table is created.

How do I do that in ArcGIS/Manifold

© Arthur J. Lembo, Jr.
General
Specify distance buffers
Elizabeth Goulet, Department of Entomology, and John Taber, Department of Applied Economics and Management, Cornell University

This technical note compares the process of creating distance buffers around objects in Manifold GIS and ArcGIS. In this example, 500 foot buffers are created around the water features. The data used include water and parcel polygons in Ithaca, New York.

<table>
<thead>
<tr>
<th>Manifold process</th>
<th>Arc GIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

Load a copy of the layer to be buffered (not the original layer) into Manifold.

To buffer all objects in the layer, select the *All Objects* option in the Selection box on the Transform toolbar. Select Buffers from the Operation box menu. Specify buffer distance. Click Apply.

This creates a buffer zone around all objects in the layer extending outward by the given distance and includes the original objects. Units used for the distance value are taken from the projection of the drawing.

Load the map with the feature to be buffered into ArcGIS. Under Tools -> Buffer Wizard, select the layer to buffer.

The next 2 windows in the Wizard allow the user to enter information related to the buffer size.
Other considerations:

A buffer can be created around a single object by selecting it in the layer. Shift + left click allows the user to add more objects. Choosing the (selected objects) option for the layer on the transform toolbar will buffer only the user’s selected objects.

The transform toolbar provides three other buffer zone options.

1. Inner buffer to the inside of features.
2. Border buffer to both inside and outside by the chosen distance.
3. Common buffer transform creates one buffer zone around all of the objects selected.

To change the units of measure, first re-project the drawing into a projection type that has the desired units.

Other Considerations:

It is possible to only buffer selected features of a layer by clicking the “Use only the selected features” option in the first pane of the Buffer Wizard dialogue box.

In addition, features in the layer could be buffered different distances depending on a value in the data table for each feature.

Other options for buffering include multiple buffers, saving all buffer boundaries, and creating buffers inside, outside or on both sides of boundaries. The object can also be included with the boundary.
Polygons within distance of selected features
John Taber, Department of Applied Economics and Management, and Elizabeth Goulet, Department of Entomology, Cornell University

This technical note compares the process of selecting polygons within a specified distance of other objects in Manifold GIS and ArcGIS. The data used are water and parcel polygons in Ithaca, New York.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

A query is used to select polygon features (parcels) in one layer within or beyond a certain distance, or between distances, of features within another layer. The most basic method is to create an SQL query as:

```sql
select * from parcels, water where distance (parcels.id, water.id) < 500 and [water].[Selection (1)] = True
```

Another option is to select the parcels between 100 and 800 feet of the water feature.

Load the parcels shapefile into Manifold to see the selected parcels.

The image below shows the selected parcels along with the query, the query table, and the water layer.

To select the features of a layer within a certain distance of another layer, use the Select by Location tool, under “Selection”. In this example, the features from parcels that are within 500 feet of the water feature are selected. Note that if a 500 foot buffer for the water feature already existed, that buffered feature could be used instead of including the buffering in the selection.
The parcels within 500 feet of the water theme are selected in this image.

<table>
<thead>
<tr>
<th>Other considerations:</th>
<th>Other Considerations:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alternatively, the user can create a buffer around a selected feature, and then intersect the buffer layer with the polygon features to find only the polygons around one specific feature.</td>
<td>You can also use selected features of a theme for buffering instead of the entire theme.</td>
</tr>
</tbody>
</table>
Find nearest features

Elizabeth Goulet, Department of Entomology, and John Taber, Department of Applied Economics and Mangement, Cornell University

This technical note compares the process of finding the nearest features in one vector file to the features in a second vector file using Manifold GIS and ArcGIS. The data used are roads and wetlands in Ithaca, New York.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS, ArcToolBox</td>
</tr>
<tr>
<td>Extensions: None</td>
<td>Extensions: None</td>
</tr>
</tbody>
</table>

Manifold uses query functions to find the nearest feature of one feature class to a feature in another class.

Create a new query in the project window of Manifold.

The first query determines the distance of all features from one class (roads) to all features in another class (wetlands).

ArcGIS uses the JoinData function to find the closest feature in one file to another file. To open the dialog, right click on a theme in the table of contents and select Join.

In the Join Data dialog, select Join data from another layer based on spatial location. When using polygons and lines, the user can select the option to compute the distance from features in one file with features in a second file. A new column is added to the feature table that includes the attributes, and distance to the nearest feature in the other theme.

The second query selects the nearest road to each wetland.
The highlighted wetland, TA-5, is highlighted on both the query table and map below. The closest road ID is in column 1 and the distance is in column 2.

The road table can be opened and the road number selected to identify the closest road to this wetland on the map.

**Other considerations:**
Queries can be used to find the distance between any two feature classes in Manifold. Also, the query may be adapted to include *farthest feature*, or *symmetric feature*.
This technical note compares the process for generating slope and aspect of sections of a raster data set using both ArcGIS and Manifold GIS. This example also creates a 3D visualization of the data. The data used in this example includes the digital elevation model for the Ithaca East Quadrangle.

### Manifold Process

<table>
<thead>
<tr>
<th>Software: Manifold GIS</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extensions: Surface Tools</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td></td>
<td>Extensions: Spatial Analyst and ArcScan</td>
</tr>
</tbody>
</table>

To perform the analysis, the DEM must be loaded into Manifold (where a terrain map is automatically generated).

Determining the slope requires three steps:
1. Select the DEM
2. Under Surface -> Transform
3. In the formula section type "slope" and click on the DEM name, then select OK.

### ArcGIS Process

To perform the analysis, a DEM is loaded into ArcMap.

The spatial analyst toolbar must be added under View -> Toolbars. The spatial analysis must also be activated under Tools -> Extensions.

Determining the slope requires two steps:
1. Using the Spatial Analyst, open Spatial Analyst -> Surface Analysis -> Slope
2. Select the DEM as the input surface, select the appropriate cell size and output location, and then click OK. The
How do I do that in ArcGIS/Manifold

© Arthur J. Lembo, Jr.

The slope (as defined by percent slope) is now generated, and a terrain map is automatically created with it.

A similar procedure can be used to find the aspect of the DEM. Once the DEM is loaded, the aspect can be obtained in three steps:
1. Select the DEM
2. Under Surface -> Transform
3. In the formula section type “aspect,” click on the DEM name, and the hit OK.

The slope is now generated.

A similar procedure can be used to find the aspect of the DEM. Once the DEM is loaded, the aspect can be obtained in two steps:
1. Using the Spatial Analyst, open Spatial Analyst -> Surface Analysis -> Aspect
2. Select the DEM as the input surface, select the appropriate cell size and output location, and then click OK.

The user can also select the output as either percent or degree slope.
The aspect is now generated, and a terrain map is automatically created with it.

Other Considerations:
Manifold can also compute slope and aspect of a dataset without the use of Surface Tools, using the Edit -> Save Mask/Channel menu. Simply select slope or aspect as the feature to save.

The user can easily view and analyze the terrain maps. By pressing the ‘W’ or ‘S’ keys, it is possible to move forward and backward, respectively, along the surface. Also, vector layers may be draped over the terrain for more impressive looking visualizations.

Other Considerations:
A separate program called ArcScene can show the terrain of the data. ArcScene is loaded from the 3D analyst toolbar. Make sure 3D Analyst is activated under Tools -> Extensions.

Select the ArcScene button from the far right of the toolbar to open the program.

Once ArcScene is open, the terrain map can be opened by clicking add data. The user can navigate throughout the dataset using the pan and zoom buttons.
The terrain can also be rotated by using the arrow keys.

To see the 3D view, right-click on the layer, then go to Properties -> Base Heights. Under Height choose *Obtain heights for layer from surface*. Also, you may change the Z Unit Conversion from 1 to 10 for better height distinction.

Now a new terrain is created. Also, vector layers may be draped over the terrain for more impressive looking visualizations.
Identifying Watersheds  
Ya-Wen Lu and Michael Sinkevich Jr., Cornell University

This technical note compares the process for identifying watershed boundaries in a raster data set using ArcGIS. The data used in this example includes the digital elevation model for the Ithaca East Quadrangle.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
</table>
| Software: Manifold GIS  
Extensions: n/a | Software: ArcGIS  
Extensions: Spatial Analyst |

Manifold does not have the functions to perform this type of analysis.  

To perform the analysis, the “filled” DEM, free from gores and spikes, is loaded into ArcMap.

The spatial analyst toolbar must be added under View -> Toolbars. The spatial analysis must also be activated under Tools -> Extensions.

Under the Spatial Analyst, open the Raster Calculator. Using the FlowDirection command and selecting the DEM, an output grid of flow patterns over the landscape is created.
How do I do that in ArcGIS/Manifold

Next, under the Spatial Analyst, open the Raster Calculator. Using the Basin command and selecting the Flow Direction grid, and output grid for watersheds is created.

The flow direction map of Ithaca East.

The basin map for Ithaca East.
Right click the basin layer and choose Properties -> Symbology. Change from Classified to Unique Values.

This results in a map with unique values for each watershed.
Network Functions
Choosing the optimal path through a network
Kathy Mills, Department of Natural Resources, Cornell University

This technical note compares the process for defining an optimal path through a network using both Manifold GIS and ArcGIS. This example specifies an optimal driving path through a road network in the Ithaca East quadrangle.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: Business Tools</td>
<td>Extensions: Network Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, a drawing window or drawing layer in a map window must be open. This drawing must contain lines and at least two points should be chosen between which a route can be selected. Fields in the drawing table should specify the length and speed of travel for each line in the road network.

To generate an optimal route, choose “Drawing” from the main toolbar and select “Optimal Route.” In the command window, fill in fields and units for road length and speed.

To perform this analysis, a file must be contained in a geodatabase and converted to a geometric network within ArcGIS. (See help files: ‘geodatabases’>’creating’ and ‘network feature class’>’creating’.)

Open the network in ArcMap. Right click on the main menu and select “Utility Network Analyst” to open the toolbar associated with this extension. Using the flag/barrier selector tool, designate two points on the network that will serve as the endpoints of a route.

On the Utility Network Analyst toolbar, select “Find path” as the Trace Task and click the solve icon.
The optimal route program selects the fastest route between the two points and highlights this path on the map.

By clicking “Save Report” in the command window, a report with driving directions is generated.

A path between the two points is highlighted on the map.
**Other considerations:**

Manifold also allows the user to choose a visual interface for selecting points between which optimal routes are needed.

In the main toolbar, select “Drawing”-> “Optimal Route (Visual)”

Click on the points between which an optimal path should be determined.

**Other considerations:**

To find the shortest path, weights can be assigned to the junctions of the geometric network. For example, if roads have different speed limits, a speed field could be used to assign weights for determining the shortest path.

The Utility Network Analysis extension in ArcGIS does not provide an option for producing a report with driving directions between the two points.
Defining a drive-time zone  
*Kathy Mills, Department of Natural Resources, Cornell University*

This technical note compares the process for defining a drive-time zone using both Manifold GIS and ArcGIS. This example selects drive-time zones from one location in the Ithaca East quadrangle.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcView</td>
</tr>
<tr>
<td>Extensions: Business Tools</td>
<td>Extensions: Network Analyst</td>
</tr>
</tbody>
</table>

To perform the analysis, a drawing window or drawing layer in a map window must be open. This drawing must contain lines and at least one point that can be used as the center of the zone to be defined. Fields in the drawing table should specify the length and speed of travel for each line in the road network.

To generate a zone around the center point that can be reached within a specified driving time, choose “Drawing” from the main toolbar and select “Drive-Time Zones.” In the command window, fill in fields and units for road length and speed. Also, choose a method for determining the drive-time zone (buffer, hull, or zone), and type in the amount of driving time each zone should encompass. Multiple drive-time zones may be generated at

Enable the Network Analyst Extension, and activate the theme containing the network shapefile. To create a drive time zone about the denoted point, choose “Network” in the main menu and select “Find Service Area.”

How do I do that in ArcGIS/Manifold  
112  
© Arthur J. Lembo, Jr.
In the box that appears, click “Load Sites…” and add the shapefile containing the point that denotes the center of the drive zone.

Click “Properties…” to select the field that represents costs associated with your network. Costs may be defined in a number of ways, including the length along a line and minutes of driving time.

Then specify the extent of the driving zone by double clicking in the cost field of the first wizard and typing in the travel time or distance. Multiple extents may be defined using different cost values; separate values with a space or comma. Click the icon in the upper right to run the analysis.

A polygon and roads therein that represent the distance that could be traveled in each drive zone will be highlighted.
Other considerations:
Manifold also allows the user choose a visual interface for selecting points between which optimal routes are needed.

In the main toolbar, select “Drawing”-> “Optimal Route (Visual)”

Clicking the “Compact Areas” box creates a network with more jagged boundaries to more precisely define the area within the driving zone. Without clicking this box, more areas will be included at the edge of the zone, some of which may overlap streets that are outside the specified travel time or distance.

Click on the points between which an optimal path should be determined.
Geocoding addresses
Kathy Mills, Department of Natural Resources, Cornell University

This technical note compares the process for geocoding addresses using both Manifold GIS and ArcGIS. This example uses an attribute table for roads in the Ithaca East quadrangle as the basis for deriving addresses.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software: Manifold GIS</td>
<td>Software: ArcGIS</td>
</tr>
<tr>
<td>Extensions: Geocoding database</td>
<td>Extensions: none</td>
</tr>
</tbody>
</table>

Addresses stored in a table may be geocoded as long as 4 primary fields are available: address, city, state, zip.

Under **Tables -> Address -> Geocode**, a user can select the appropriate fields, and information they want returned:

An error dialog box will come up to assist the user in identifying errors within the addresses.

User must separately purchase either MapPoint 2004 or the Manifold

ArcGIS provides numerous addressing schemes. This example chooses a simple scheme called “US One Address”.

Within ArcCatalog,
1) Double click on “Geocoding Services.”
2) Double click on “Create new geocoding service.”
3) In the new geocoding service window, scroll down and select “US One Address (GDB).”

4) Direct the geocoding service to the reference file containing the streets for geocoding. The user can then specify the columns of the reference table that define the address information (i.e. street name, city, etc.).
geocoding database. Currently, no facilities exist to geocode user supplied centerlines.

5) Click “OK” and the new geocoding service is created.

In ArcMap,
1. Click on the “find” icon in the toolbar.
2. Select the “Addresses” tab, and locate the appropriate geocoding service. Type in a street name, and click “find.” Addresses on the selected street are identified.

3. Right click on one of the addresses that was located, and click “Flash Candidate Location(s)” to highlight the location on the map.
4. Right clicking on an address also enables the user to zoom to the address and flash the location, add a graphic marker to the map at the location, or set a spatial bookmark for the location.

Other Considerations:

ArcGIS includes many options for geocoding, that are too numerous to mention in this note. Therefore, this note only illustrates one of the simplest methods for geocoding addresses using ArcGIS.
Data Display and Presentation

Data display functions provide the ability to generate both two-dimensional orthographic and three-dimensional perspective displays; symbolize point, line and area features and annotate maps for display on a terminal or hardcopy device.

This technical note compares the processes for displaying and presenting data sets using both ArcGIS and Manifold GIS. The data display and presentation processes include thematically shading polygons, creating map titles, legends, scale bars and north arrows, and creating, moving and editing annotations and labels. Land parcels in Ithaca, New York, are used to illustrate this example.

<table>
<thead>
<tr>
<th>Manifold Process</th>
<th>ArcGIS Process</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Software:</strong> Manifold GIS</td>
<td><strong>Software:</strong> ArcGIS</td>
</tr>
<tr>
<td><strong>Extensions:</strong> None</td>
<td><strong>Extensions:</strong> None</td>
</tr>
</tbody>
</table>

**Thematically Shade Polygons** – selecting polygons based on certain attributes (i.e. parcel size, area, land use, etc.)

To perform this analysis, the parcel data set was loaded into Manifold.

Thematically shading polygons requires 2 steps:

1. Select Area/Polygon Background button. Can designate either one color for all the polygons, or select theme to specify an attribute for polygon shading. Select Theme.

2. Select the field, method and color (palette) for the attribute of interest in the

![Manifold Process](image1)

**Thematically Shade Polygons** - selecting polygons based on certain attributes (i.e. parcel size, area, land use, etc.)

To perform this analysis, parcel layer must be loaded into ArcMap.

Thematically shading polygons requires 3 steps:

1. Double click on the layer of interest in the Table of Contents pane. The layer properties window will open. Select symbology tab.

2. Specify in the field option which attribute for analysis. Also select a color scheme, classifications, and label

![ArcGIS Process](image2)
Facility for creating map titles, legends, scale bars, etc
To perform the analysis, load parcels map into Manifold

Creating map titles, legends and scale bars requires 3 steps:

1. Create a layout of either a surface or a map. Select the layout in the project pane.

2. In create button options above project pane, select “create legend”, “insert textbox”, “insert scale” or “insert north arrow”. Can also add legend, title, north arrow or scale bar from the view drop down menu.

3. Select Enter and polygons should be shaded according to attribute selected.

Facility for creating map titles, legends, scale bars, etc
To perform the analysis, load parcels map into ArcMAP

Creating map titles, legends and scale bars requires 3 steps:

1. Under the view drop down menu, select Layout view. (In order to go back to the data view while working on your layout, select data view from the View pull down menu).

2. Under the Insert drop down menu, select legend, scale bar, north arrow, title, etc.

3. Follow the appropriate prompts for requirements.
3. To specify options for legend (ie color scheme, number of points, etc), select the dataset from which the layout was created from. Follow the steps outlined in thematically shading polygons from above.

Other Considerations:
To delete the legend, scale bar, title or north arrow, right click in the layout view, and select delete from the options.

Add and move annotations – In Manifold, annotations are labels.

Adding and moving annotations/labels can be completed in 3 steps:

1. Select File – Create –> Labels under drop down the item you wish you to create in your layout:
   - Legends – select attributes you would like displayed, enter legend title, border, font size, border color, shadow color, etc.
   - North Arrow – select desired north arrow.
   - Title – enter the title in the text box displayed on the layout.
   - Scale – select desired scale bar.

ArcMAP annotation is editable and easily supports adding individual pieces of text that are not associated with any map feature. This means that if you want to create a few new pieces text
down menu, or create labels from project pane options.

2. Select the data layer and attributes for labeling. Specify text as desired.

3. Drag and drop the label created under data layer (in project pane) into the map (not in a drawing or surface).

and place them where you like on and around your map, then you should use annotation.

Adding and moving annotations can be completed in 5 steps:

1. Right click on a layer in the table of contents pane. Select Properties and labels tab.

2. Select the attribute/field that you would like displayed. Click on OK.

3. Can label each point or place on map individually. Make sure the Draw Toolbar is turned on.

4. Select the new text, new splined text button, callout button, or label button located on the draw toolbar.
Other Considerations:

To Create Labels, can also call function under the new button found in the project pane.

To specify what zoom level the annotations/labels become visible, select view – properties, and specify zoom to the desired level.

Font color, size, angle and style can all be edited by changing the selections in font options above the surface screen.

Other Considerations:

5. Use the mouse to click the location where the text, line, callout box or label will be located. Type in the text string. Hit enter when complete.

As you zoom in and out on your map, the size of your labels will not change. If you want label text size to scale with the map, right-click the data frames and click Set Reference Scale. Font color, size, angle and style can all be edited by changing the selections in the drawing toolbar.

To edit annotation text for a point, double-click on the text and dialogue box will pop up. To move text, click and hold on the text and drag to new location. Store your text in the geodatabase if you want to use the same text in different maps. Store your text in the map document if you only want to use your text on that particular map.